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1.1 Introduction 

Queries are an essential part of database. They are used to extract required data from one or more tables and 

present the result in a datasheet or on a Form or Report. They can be considered as questions asked to a table 

in a database. Access provides a graphical tool known as Query Designer to create queries. Queries are not 

only used to retrieve data from tables, but can also be used to insert, update or append data in tables, to filter 

data, to perform calculations with data,  to summarize data and to automate data management tasks. 

This chapter focuses on creating different types of queries and their different usage. The first part of the 

chapter talks about Sub-queries, in which the criterion for a query is query itself, i.e. writing a que ry within 

query. The next part of the chapter talks about working with Query Wizard and learning how to find unmatched 

data between two tables and to find duplicate rows within a table. We will also learn to create a summari sed 

result out of queries using the crosstab queries. Crosstab queries can be taken as a tabular format of Pivot 

tables. This chapter also introduces the multiple views of the query and how to get query results in the form of 

Pivot Tables or Pivot Charts. 

In addition to the above queries, we will also learn to create a query on multiple tables, specify different join 

types to retrieve the desired result.  We can create joins between the tables using relationship window provided 

by Access, or we can create joins at the query design window. Access also has many functions and operators 

which can be used to create expressions. This chapter discusses how to use these functions to create a new 

column from an existing column. The chapter also highlights some of the advanced queries avai lable in Access 

and illustrates their significance using case studies. 

 

LEARNING OBJECTIVES 

◼ Writing Advanced Queries 

❑ Creating Sub-queries   

❑ Creating Unmatched and Duplicate Queries 

❑ Grouping and Summarizing Records using Criteria 

❑ Summarizing Data using Crosstab Query 

❑ Creating a Pivot Table and a Pivot Chart 

◼ Joining Tables in Queries 

◼ Calculated Fields 
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1.2 Writing Advanced Queries 

Access has the capability to handle far advanced queries than the simple criteria based queries. The queries in 

Access not only allow users to change the existing data, but also to generate summary reports. This section 

discusses few advanced queries handled by Access, such as Sub-queries, Crosstab Queries, Creating 

Unmatched and Duplicate Queries, and also creating PivotTable and PivotChart through queries. 

1.2.1 Creating Sub-queries 

A sub-query is a query nested inside another query. We can use Sub-queries within Select query, Action query 

or within other Sub-queries. Sub-queries in Select statement can be the part of Where clause or having clause 

in Group By query. For Action queries, we can use Sub-queries to change the records which match some 

values in other tables. 

Fig. 1.2.1 shows an example of a sub-query in a Select statement.  

 

SELECT * FROM Products  

WHERE ProductID IN  

(SELECT ProductID FROM OrderDetails WHERE Discount >= .25);   

Fig. 1.2.1. Subquery Example 

This query retrieves all the columns from table Products based on the criteria that the discount on the products 

in the OrderDetails table must be greater than or equal to 25%. Notice that to present the criteria of discount for 

Products, we have used a sub-query in the WHERE clause.  

Points to be noted while writing a sub-query: 

• The sub-query must always be written as an SQL statement. 

• The sub-query is always written in brackets ( ). 

• If we are using the same table for the main query and sub-query, we need to provide aliases (alternate 

names) to the tables.   

• If a sub-query is returning more than one row, the IN, ANY, ALL or EXISTS clause should be used in the 

WHERE statement. 

1.2.1.1 Problem Scenario 

Rohit is an Accountant in Apex Ltd. At the closing of the quarter, he has to check the Invoices for which the 

payments are made in Quarter-I of year 2008. 

Solution 

For the purpose of solving the above requirement, a query is created to retrieve all records from Invoices table 

for which the Payment Date in Payments table lies in Quarter-I i.e. between 1/1/2008 and 4/30/2008. Since we 

do not require any details from the Payments table, we use the table in a sub-query. 
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Steps for retrieving records from table INVOICES 

1. Open the Show Table dialog box, by clicking on Create -> Queries -> Query Design. 

2. Select the Invoice table from Show Table window and click Add, as shown in Fig. 1.2.2. 

 

Fig. 1.2.2: Show Table window 

3. Click Close. 

4. The Query Designer Window appears, as shown in Fig. 1.2.3. 

 

Fig. 1.2.3: Query Designer Window 
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5. Select the fields Invoice Number, Sales Order Number, Type of Invoice, Invoice Date, Source of Order 

 and Payment Terms from table Invoice and drag them to the Columns tab as shown in Fig. 1.2.4. 

 

Fig. 1.2.4: Drag the required columns 

6. Click the Save button  at Quick Access Toolbar to save the query. Type the name of query as 

Invoices Paid Q1 as shown in Fig. 1.2.5. 

 

Fig. 1.2.5: Save the Query 
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Now we create a SQL Statement for sub-query. The SQL Statement for the sub-query can be written directly in 

the criteria clause with the Select syntax or we may create another query using Query Designer and then copy 

the generated SQL. For the current scenario, we use the latter method.  

 

Steps for writing a query to retrieve Invoice Number from Payments where Paid Date is in Quarter-I of 

year 2008 

1. Open the Show Table dialog box, by clicking on Create -> Queries -> Query Design. 

2. Select the Payments table from Show Table window and click Add, as shown in Fig. 1.2.6. 

 

Fig. 1.2.6: Show Table window 

3. Click Close. 

4. Double-click the columns Invoice Number and Date Paid so that they appear in the Columns tab in 

Query Design as shown in Fig. 1.2.7. 
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Fig. 1.2.7: Select Required columns 

5. In the Criteria section of the Date Paid Column, write the criteria BETWEEN #1/1/2008# AND 

#4/30/2008# and clear the Show checkbox. The Query Design window should appear, as shown in Fig. 

1.2.8. 

 

Fig. 1.2.8: Specify the criteria 
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6. Click the Run icon  in Design -> Results to view that the proper result is coming.  

7. Click on SQL View from Design -> Results -> View drop-down to view the SQL statement of the 

query. The SQL statement appears for the query, as shown in Fig. 1.2.9. 

 

Fig. 1.2.9: Query SQL View 

8. Copy the SQL statement and switch to the Query window of Invoices Paid Q1. 

Steps to add a sub-query to Invoices Paid Q1 query  

9. In the Criteria tab of Invoice Number column, type IN() and paste the copied query within the braces. 

The Query window appears, as shown in Fig. 1.2.10. 

 

Fig. 1.2.10: Write subquery in Criteria 
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10. Click the Run icon  in Design -> Results to view that the proper result is coming. 

In a similar manner as demonstrated by an example above, Sub-queries can be used as a SQL statement for 

criteria of Action queries, Group By queries etc. 

NOTE: We can also use Sub-queries as an expression to create a new column as a query result. 

1.2.2 Creating Unmatched and Duplicate Queries 

Query Wizard available in Access can be used to create different types of queries. Along with several different 

queries, it also provides queries to find duplicate records in a table on the basis of one or more fields in a table. 

In a similar manner, we can create Unmatched Query to compare two tables and find the records that do not 

have matching values in given columns. 

1.2.2.1 Unmatched Queries 

Find Unmatched Records Query will examine the data found in two different tables/queries and compare the 

records based on a common field. It will return the records from the first table which do not have matching 

values in second table.  

The easiest way to create Unmatched Query is by using the Find Unmatched Query Wizard. After the wizard 

builds query, we can modify the query's design to add or remove fields, or to modify joins as required.  

Unmatched Query Wizard in Access asks for the names of the two tables to compare, and common field name 

between the tables. The wizard then confirms the fields that we wish to retrieve from the first tab le as a query 

result. Finally, the wizard prompts to enter the query name and creates the query.  

This type of query can help find records that have no corresponding records in other tables. For example, we 

may be looking for products that have not been sold in any order or may be for customers who have not placed 

any orders. 

1.2.2.2 Problem Scenario 

Ankur Mathur, Sales Head of Apex Ltd. wishes to reduce the production of few products. To analy se which 

products should not be produced further, he needs to find out the products which have not been ordered so far.  

Solution 

For the purpose of finding the unmatched products in Sales Item Description, we use Unmatched Query Wizard 

and find out products from Inventory table which do not have a matching Item Number in Sales Item Description 

table. 

Steps for creating Unmatched Query using Query Wizard: 

1. Open the Query Wizard by selecting Query Wizard from Create -> Queries, as indicated in Fig. 

1.2.11.  

 

Fig. 1.2.11: Open Query Wizard 
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2. The New Query window appears, as shown in Fig. 1.2.12. 

 

Fig. 1.2.12: New Query Dialog Box 

3. Select Find Unmatched Query Wizard from the New Query window and click OK, as shown in Fig. 

1.2.13. 

 

Fig. 1.2.13: Select Find Unmatched Query Wizard 

4. The Find Unmatched Query Wizard appears. Select the table Inventory and click Next, as shown in 

Fig. 1.2.14. 
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Fig. 1.2.14: Select Table Inventory 

5. Select the table Sales Item Description from second page of the wizard as we need to compare 

Inventory table to Sales Item Description table, as shown in Fig. 1.2.15. Click Next. 

 

Fig. 1.2.15: Select Table Sales Item Description 

6. Now, we need to mark the common field in both the tables to be compared. For this example, select 

the Item Number in both Inventory and Sales Item Description table and click  button, as 
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shown in Fig. 1.2.16. Click Next to move to next page. 

 

Fig. 1.2.16: Match the common fields between two tables 

7. On the next page in wizard, select the columns that should be the part of query result and click Next. 

In this page, select Item Number, Class, Category, Sub Category, Description, Manufacturer, Model  

and Cost fields as shown in Fig. 1.2.17. Click Next to move to next page. 

 

Fig. 1.2.17: Select the Fields 

 

NOTE: Use  button to move a selected field from Available fields to Selected fields,   
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button to move all fields from Available fields to Selected fields,  button to move selected 

field from Selected fields to Available fields,   button to move all fields from Selected fields 

to Available fields. 

8. Name the Query as “Products without Orders” in the final window that appears and click Finish as 

shown in Fig. 1.2.18. 

 

Fig. 1.2.18: Name the query 

9. The result of the query appears as in datasheet form, indicating the products that do not have an 

order associated with them, as shown in Fig. 1.2.19.  

 

Fig. 1.2.19: Query Result 
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1.2.2.3 Duplicate Queries 

The Duplicate Queries option creates a query that reports which records in a table are duplicated by matching 

one or more fields in the table. The Query Wizard first confirms which fields have to be used to check for 

duplication and then prompts to enter some other fields that  may be a part of query result. Finally, Access 

accepts a name for the query and displays the results as a datasheet.  

This type of query is useful when we have no unique indexes or primary key in the table, or the data for the 

table is imported from a source where we do not have mechanism to check duplicate values.  

1.2.2.4 Problem Scenario 

Varun Gupta, a Chartered Accountant in Apex Ltd., is required to audit the invoices and the payments. While 

tracking the payments he noticed that multiple invoices have been created for a single sales order. To sort out 

the things, he wishes to check all the sales order having duplicate invoices.  

Solution 

Create a Find Duplicate Query for table Invoices based on the field Sales Order Number so that it displays all 

the duplicate invoices created for a single sales order. 

Steps for Finding Duplicate records in the table Invoices 

1. Open the Query Wizard by selecting Query Wizard from Create -> Queries.  

2. Select Find Duplicates Query Wizard from the New Query dialog box and click OK, as shown in Fig. 

1.2.20. 

 

Fig. 1.2.20: Select Find Duplicates Query Wizard 

3. The Find Duplicates Query Wizard appears. Select the table Invoice and click Next as shown in Fig. 

1.2.21. 
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Fig. 1.2.21: Select Table Invoice 

4. Select the column on the basis of which the duplicate records need to be matched and click Next. In this 

scenario, select Sales Order Number as shown in Fig. 1.2.22. Click Next. 

 

Fig. 1.2.22: Select the column for Duplicate values 
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5. Select the columns that should be the part of the query result and click Next. In this dialog box, select 

Invoice Number, Type of Invoice, Invoice Date, Source of Order and Payments Terms, as shown in Fig. 

1.2.23. Click Next. 

 

Fig. 1.2.23: Select the columns for Query Result 

6. Name the Query as “Duplicate Invoices” in the final window that appears and click Finish, as shown in 

Fig. 1.2.24. 

 

Fig. 1.2.24: Name the Query 
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7. The result of the query appears in Datasheet form with all the Sales Order having multiple invoices, as 

shown in Fig. 1.2.25. 

NOTE: We can create Find Duplicate Query by matching records on multiple fields also. This query can also be 

used to find duplicate records in a table by matching records on all the fields (considering that we can match 

only 10 fields at a time). 

 

Fig. 1.2.25: Query Result 

1.2.3 Grouping and summarising Records using Criteria 

Access provides queries that can be used for obtaining the aggregated results instead of individual records. 

These queries may be helpful in retrieving count of records, sum, average, and maximum or minimum of the 

values in a column.  These queries are known as Group By queries or Totals Query. Such queries can return 

the aggregated results from the entire table or the records of the table filtered by a certain criteria.  

1.2.3.1 Grouping and summarising Records  

At times, it is required to retrieve information in tables based on a group of one or more fields. For example, 

total number of contacts from a particular area or a sum of all the payments received in a month. Access 

provides a method to obtain the desired result using queries without the need of any complex programming. It 

calculates the totals using several aggregate functions. 

Access performs grouping of the records by using Totals option available in the Query Tools tab, as shown in 

Fig. 1.2.26. 
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Fig. 1.2.26: Totals option in Design tab 

The Totals option adds a new row in the Query Designer window which enables the application of summary 

functions to columns as indicated in Fig. 1.2.27.  

 

Fig. 1.2.27: Total Row added 

A list of Aggregate Functions that can be used with Totals Query is given in Table 1.2.1. 

FUNCTION NAME EXPLANATION 

Sum() Returns the sum of numeric data for a column or set of values in a column 

Count() Counts the set of values that satisfy the given criteria 

Avg() Returns average of numeric data for a column or set of values in a column 

Max() Returns a maximum value from a set of values 

Min() Returns a minimum value from a set of values 

Var() Returns the variance of values in a column or set of values 

Stdev() Returns a standard deviation for a set of data values 

First() Returns the first value from a list of text values 

Last() Returns the last value from a list of text values 

Table 1.2.1: Aggregate Functions 

1.2.3.2 Problem Scenario 

The Country Head in Apex Ltd. wishes to compute the sales volume of its products. He also would like to see 

the number of orders placed for each product, so that they can focus on products with greater sales volume.  
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Solution: 

Create a Total query that calculates the count of orders placed for each product and arrange them in 

descending order of the counts so as to find the products which are sold more.  

Steps for creating a total query 

1. Open the Query Design window by selecting Query Design from Create -> Queries, as indicated in Fig. 

1.2.28. 

 

Fig. 1.2.28: Opening the Query Design window 

2. Select the Inventory and Sales Item Description tables from Show Table dialog box and click Add, as 

shown in Fig. 1.2.29.  

NOTE: Multiple tables can be selected in the Show Table window by pressing CTRL key and then selecting the 

tables. 

 

Fig. 1.2.29: Show Table window 

3. Click Close. We can see the two tables with a 1:∞ relationship. This relationship has been created while 

creating the database. 
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4. Click the Totals button in the Show/Hide group on the Design tab, as shown as Fig. 1.2.30. 

 

Fig. 1.2.30: Click on Totals button 

5. Select the fields Category and Item Number from Inventory table and drag them to the Columns tab. 

Similarly, select fields Sales Order Number from Sales Item Description table and drag it to Columns tab. 

The Query Window appears as shown in Fig. 1.2.31. 

 

Fig. 1.2.31: Select the required columns 
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6. In the column Sales Order Number, change the Group By function to Count, as shown in Fig. 1.2.32. 

Notice that we have set Group By on columns Category and Item Number, so that the query first groups all the 

items according to their category and then all the items in same category on the basis of Item Number. The 

Count function with Sales Order Number indicates that we wish to compute the count of total Sales Orders for 

a group created.  

 

Fig. 1.2.32: Set the Totals Function 

7. Click Run in Design -> Results to view the results. The result of the query appears, as shown in 

Fig. 1.2.33. 
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Fig. 1.2.33: Query Result 

NOTE: The Query result just shows all the products arranged in group of Category and Item Number and their 

volume sold. To get the products which are sold more, the column CountOfSales Order Number has to be 

arranged in order that it appears from most sold to least sold.  

8. Reopen the query in Design View by clicking Design View from Home -> Views. 

9. In the column Sales Order Number, set the sort order as descending, as shown in Fig. 1.2.34.  
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Fig. 1.2.34: Set the sort order 

10. Click Run in Design -> Results to view the result. The result appears as shown in Fig. 1.2.35. 
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Fig. 1.2.35: Query Results sorted according to sales of Product 

11. Click the Save button  on Quick Access Toolbar to save the query. Type the name of query as 

Product Sales Volume. 

NOTE: Queries are required to be saved for future use if the same result is desired again; it saves the effort 

and time of recreating the query.  

1.2.3.3 Applying Criteria to Records 

A criterion limits the records that are displayed as result, on the basis of values in a field. A criterion in Total 

queries can be created against Group By, Aggregate Total, Non-Aggregate Total fields. For Group By and 

Aggregate Total, criteria can be mentioned using Criteria tab of Query Design window. For the Non-Aggregate 

Total field, the criteria can only be specified using the Where clause instead of Group By or Aggregate function 

in Total tab of Query Design window. 

Using any one, any two, or all three of these criteria, the scope of Total query can be limited to finite criteria.  

1.2.3.4 Problem Scenario 

Considering the problem of retrieving Sales volume of Products as discussed in Section 2.2.3.1, Country Head 

wants to have a look at only the products with at least an order count of three. The management authority also 

thought of maintaining the products which are cheaper and have more sales volume.  

Solution 

Update the Total query Product Sales Volume created above and apply criteria “>=3” on the Sales Order 

Number count to ensure that only the products with at least an order count of three are retrieved as a query 

result. Also, add criteria “<50” to the Cost field of the products so that management can have a view on the 

cheaper products. 
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1. Open the query Product Sales Volume in Design view. To do this, right-click the query and select Design 

View.  

2. In the column Sales Order Number, type “>=3” in the Criteria tab as shown in Fig. 1.2.36. 

 

Fig. 1.2.36: Insert Criteria for Sales Order Number 

3. Click Run  in Design -> Results to view the result. The result of the query appears as shown in Fig. 

1.2.37. 
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. 

Fig. 1.2.37: Query Result for Products having at least 3 Sales Orders 

Now, include only the products which cost less than 50.00 in the query result. Since Cost is a non-aggregate 

field, the criteria for the Cost is included in the Where clause of Total tab.  

4. Double-click the field Cost in the Inventory table so as to include it into the Field tab of Query Design 

window. 

5. Change the Group By function of column Cost to Where clause in Total tab and write “<50” in the Criteria 

tab, as shown in Fig. 1.2.38. 

Note that the Show checkbox is cleared as Cost is a non-aggregate field and not a part of the query 

result. 
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Fig. 1.2.38: Products with cost <50 

6. Click Run  in Design -> Results to view the result of the query, as shown in Fig. 1.2.39. 

 

Fig. 1.2.39: Query Result 
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7. Click Save  at Quick Access Toolbar to save the query.  

1.2.4 Grouping and summarizing Records using a Crosstab Query 

Crosstab query is an excellent analytical tool. It is a special type of query that can be created to describe one 
numerical quantity in terms of two other fields. Crosstab queries are useful for summarizing information, and 
are somewhat similar to pivot tables in MS-Excel.  

For example, we might want to have a table that contains the sales figures of entire inventory for the whole 
year, and the amount of money that is made per product during each month of the year. In this case, a crosstab 
query would be the right way to display the information. 

Access provides an option to create Crosstab query through Query Wizard. Each crosstab query will include 
one or more Row Heading, a single Column Heading and a Value to be displayed at the intersection of row and 
column. 

1.2.4.1 Problem Scenario 

The company Apex Ltd. wishes to revise the credit limit of its customers. For this purpose, Ashish, the PRO 
needs a summary report that indicates the count of orders placed by each customer in every month of last 
financial year i.e. 2011-2012. 

Solution 

To obtain the desired summary report, create a Crosstab query on table Sales Order with month of Sales Date 
as row heading, Customer Number as column heading and count of Sales Order Number as values. We create 
this query using the Query Wizard. 

Steps for creating Crosstab queries 

1. Open the Query Wizard by selecting Query Wizard from Create -> Queries  

2. Select Crosstab Query Wizard from the New Query dialog box and click OK as in Fig. 1.2.40. 

 

Fig. 1.2.40: Select Crosstab Query Wizard 
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3. The Crosstab Query Wizard appears. Select the table Sales Order and click Next as shown in Fig. 

1.2.41. 

 

Fig. 1.2.41: Select Table Sales Order 

4. The next page in Query Wizard confirms the column to be taken as Row Heading. In this window, select 

the column Sales Date as shown in Fig. 1.2.42 and click Next. 

 

Fig. 1.2.42: Select column Sales Date for Row Heading 
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5. Select the column to be taken as Column Heading in the next window of the Query Wizard that appears. 

In this window, select the column Sold to Customer as shown in Fig. 1.2.43 and click Next. 

 

Fig. 1.2.43: Select column Sold to Customer for Column Heading 

6. Next page in the wizard prompts to specify the values that should appear on the intersection of rows and 

columns. Select the column Sales Order Number from the Fields tab and Count from the Functions tab 

in this page, as shown in Fig. 1.2.44. Click Next. 

NOTE: This page has a checkbox Yes, include row sums; which if checked, allows the inclusion of the grand 

total of values in the row as a column in the query result.  
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Fig. 1.2.44: Select Sales Order Number Count as values 

7. Write the name for the query as “Customer-Month wise Sales” in the final window that appears and click 

Finish, as shown in Fig. 1.2.45. We can also choose the default query name that the wizard displays.  

 

Fig. 1.2.45: Name the query 
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8. The result of the query appears in Datasheet form, as shown in Fig. 1.2.46.  

 

Fig. 1.2.46: Query Result 

NOTE: The query result is not as desired as it displays the values on the basis of the Sales Date and not on 

Sales Month. To view these results on the basis of Sales Month, we are required to make changes in the query 

design and change the column Sales Date to the Month (Sales Date) and also provide a criterion that the 

months must be in last financial year. 

Steps to group results on Sales Order Month  

1. Reopen the query in design view by clicking the Design View from Home -> Views.  

2. Click on field Sales Date and write the expression Sales Month: Month ([Sales Date]) in Field tab as 

shown in Fig. 1.2.47. 

NOTE: We can use the function Month Name() to get names of month instead of numbers in query results.  
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Fig. 1.2.47: Change the expression of field Sales Date 

Steps to provide the criteria for last financial year 

1. Double-click the column Sales Date from table Sales Order such that it appears in Field tab. Change 

the value of Total tab to Where and add the expression Between 4/1/2011 AND 3/31/2012 to the 

Criteria tab as shown in Fig. 1.2.48. 

 

Fig. 1.2.48: Provide a criteria to Sales Date column 
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NOTE: The Access query window has changed the criteria expression suitable to match column values.  

2. Click Run  in Design -> Results to view the modified result as shown in Fig.1.2.49. 

 

Fig. 1.2.49: Query Result 

NOTE: The result of the query appears as a 3-dimensional table with Months on rows, Customer No. on 

columns and the Count of orders as values. 

Crosstab Queries are capable of handling much more complex calculations. These queries can be based on 

another query using multiple tables or may use different level of grouping by having more than one row 

heading. Also, Crosstab queries can be created by Query Design by changing the query type to Crosstab. 

1.2.5 Creating a PivotTable and PivotChart 

The powerful tool of MS-Excel PivotTable and PivotChart is also available in Access to summarize data. 

Interactive Pivot Tables and Pivot Charts enable the manipulation of summary data, and therefore can save 

ample time to create multiple queries and reports to achieve the same results.  

1.2.5.1  PivotTable 

A PivotTable is a view in Access Queries that allows summarising and examining data in a datasheet form. It is 

used to group values as rows and columns with a calculated value at the intersection of each row and column. 

A PivotTable can be considered as a modified form of Crosstab queries discussed in the above section. A 

PivotTable is created by dragging fields to the appropriate area on the design screen. Data can also be broken 

down to different levels of detail, such as showing earnings by year, quarter, or month.  

The PivotTable view in a query can be obtained by selecting the PivotTable View from the Views drop-down in 

Home tab as indicated in Fig. 1.2.50.  



 ADVANCE DATABASE CONCEPTS 

36  ADVANCED INFORMATION TECHNOLOGY 

 

Fig. 1.2.50: PivotTable View 

The PivotTable is shown in Fig. 1.2.51. 

 

Fig. 1.2.51: PivotTable 

A PivotTable has four areas for dropping fields whose values are summarized. The description of these areas is 

shown in Table 2.2.2. 
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Drop Area Description 

Filter Area Is used for the fields that are used as a filter for PivotTable 

Column Area 
The fields selected to be displayed as column headings are included in this 

area 

Row Area 
The fields selected to be displayed as row headings are dropped in this 

area 

Totals Or Detail Area 

The field values to be used for calculations or summarization are dragged 

and dropped in this area, and the value is displayed at the intersection of a 

row and column 

Table 1.2.2: Drop Area in Pivot Table 

1.2.5.2 Problem Scenario 

The Head of Sales Department in Apex Ltd. has demanded a Sales Summary report for review. The following 

are the desired requirements: the sales of the products can be viewed in terms of Year, Quarters and Months; 

the report should enable the user to view the products filtered by Category.  

Solution 

To create this Summary report, first a query is created that displays the Products and their Category, Sales 

amount of each product, and also the date on which they were sold. Then to create summary sheet, we create 

a PivotTable view of the query having: 

• Category field as a filter  

• Product field on row  

• Year, Quarter and Month on columns 

• Total Sales (which is computed as Quantity sold into Product cost) displayed as values  

Steps for creating the query to obtain Sales Data  

1. Open the Query Design window, by clicking Create -> Queries -> Query Design. 

2. Select the Inventory, Sales Item Description and Sales Order tables from Show Table window and click 

Add, as shown in Fig. 1.2.52. 
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Fig. 1.2.52: Show Table window 

3. Select the columns Category and Item Number from Inventory Table and drag them to the columns tab. 

Similarly, select column Sales Date from table Sales Order and drag it to the columns tab. The query 

window appears as in Fig. 1.2.53. 

 

Fig. 1.2.53: Select the required columns 
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4. Now to compute the Total Sales of the Product, multiply Quantity * Price and create a new column. Write 

the expression Total Sales: [Quantity]*[Price] in the Field tab of the next column as displayed in Fig. 

1.2.54. 

 

Fig. 1.2.54: Compute Total Sales 

5. Click Run  in Design –> Results to view the query result. The result appears as shown in Fig. 

1.2.55. 

 

Fig. 1.2.55: Query Result 
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Now, we have achieved the desired result from the query. However, the Summary Report through PivotTable is 

required to be created.  

Steps for Creating PivotTable from the query 

1. Open the query in PivotTable View by clicking PivotTable View from Home -> Views, as displayed in Fig. 

1.2.56. 

 

Fig. 1.2.56: Select PivotTable View 

2.  The PivotTable view appears with the field list on right side as displayed in Fig . 1.2.57. 

 

Fig. 1.2.57: PivotTable View 
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NOTE:  If the PivotTable Field List does not appear, obtain the list by clicking Field List from Show/Hide 

group on the Design tab as indicated in Fig. 1.2.58. 

 

Fig. 1.2.58: Field List Button 

3. Select the Category field from PivotTable Field List and drag it to the Drop Filter Fields Here area.  

4. Select the Item Number field from PivotTable Field List and drag it to the Drop Row Fields Here area.  

5. Select the Year by expanding the Sales Date By Month field and drag it to the Drop Column Fields Here 

area. Similarly, select and drag Quarter and Month to the Drop Column Fields Here area. 

6. Select and drag the Total Sales field to the Drop Totals or Detail Fields Here area. The PivotTable 

window should appear as in Fig. 1.2.59. 

 

Fig. 1.2.59: Drag Fields in PivotTable Area 

7. Click Save  at Quick Access Toolbar to save the query. Type the name of the query as “Sales 

Summary Report”. 

If we wish to see the Quarterly sales of all the Products from Personal Watercraft category, the PivotTable 

query is obtained as follows: 
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8. Open the drop-down in Category Filter Area, clear all checkboxes and check the Personal Watercraft and 

click OK as in Fig. 1.2.60. 

 

Fig. 1.2.60: Select Personal Watercraft from Category Filter 

9. Click on the negative sign on Quarter tab so that the months disappear. Also, click on the plus sign with 

Totals to make the Grand Total appear. Make sure that all the plus signs in Item Number Row are clicked 

so as to make the Total Sales value appear. The final query should appear as shown in Fig. 1.2.61. 
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Fig. 1.2.61: Quarterly sales of all the Products from Personal Watercraft category 

1.2.5.3 PivotChart 

A PivotChart is a tool used for graphical analysis of data. In simple terms, PivotChart helps visualize a 

PivotTable, Query or a Form. It can display summarized data in different chart formats and enables data 

analysis. Data can be presented by using different chart formats as required, and unwanted items can be 

hidden from being viewed. 

The PivotChart view in a query can be obtained by selecting the PivotChart View from Home -> Views, as 

indicated in Fig. 1.2.62.  
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Fig. 1.2.62: PivotChart View 

A sample PivotChart indicating sales of a Category of Products in each Quarter in a year is shown in Fig. 

1.2.63. 

 

Fig. 1.2.63: PivotChart View 
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Description of the various headings marked in PivotChart above is given in Table 2.2.3. 

Headings Description 

X-Axis The horizontal axis in PivotChart 

Y-Axis The vertical axis in PivotChart 

Legend A table displaying the color code used for each data series in PivotChart 

Filter Field A field on basis of which filter can be applied on PivotChart.  

Data Field Field values to be shown along the Y-axis. 

Category Field Field values to be shown along the X-axis. 

Series Field Field values that will form the legend of the graph. 

Table 1.2.3: Various fields in PivotChart 

1.2.5.4 Problem Scenario 

Considering the Summary Sales Report discussed in Section 1.2.5.1, a graphical representation of the same 

data is required.  

Solution 

To represent the data graphically, we need to create a PivotChart. For this purpose, we first create a query to 

display Summary Report and then create a PivotChart based on that query. In the Pivot Chart, the fields will be 

placed as: 

• Category as Filter Field 

• Years & Quarters field on X-Axis 

• Total Sales on Y-Axis  

• Item Number as Series Field 

Steps to create a query of Summary Report 

Follow the steps discussed in Section 1.2.5.1 to create a query Sales Summary Report and create another 

query Graph of Sales Summary Report with columns as Category, Item Number, Sales Date and Total Sales 

(Quantity * Price).  

Steps to create a copy of Summary Report 

1. Double-click the Graph of Sales Summary Report query to open it in the Datasheet view. 

2. Open the PivotChart view of the query by selecting PivotChart View from Home -> Views drop-down list. 

The PivotChart view appears as in Fig. 1.2.64. 
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Fig. 1.2.64: PivotChart View 

3. If the Chart Field List is not there, select the Field List option from the Show/Hide group on the Design 

tab.  

4. Select the Category field from Chart Field List and drag it to the Drop Filter Fields Here area. 

5. Select Years by expanding the Sales Date By Month field and drag it to the Drop Category Fields Here 

area. Similarly, select and drag Quarters to the Drop Category Fields Here area. 

6. Select the Item Number field and drag it to the Drop Series Fields Here area.  

7. Select and drag the Total Sales field to the Drop Data Fields Here area. 

8. To display the legend, select Legend from the Show/Hide group on the Design tab, as indicated in Fig. 

1.2.65. 

 

Fig. 1.2.65: Select Legend option 
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9. The PivotChart window should appear, as shown in Fig. 1.2.66. 

 

Fig. 1.2.66: Drag and Drop Fields in PivotChart Area 

NOTE: The Total Sales of few products is much lesser as compared to other products that they are hardly 

visible on data bar. To solve this problem, the axis has to be changed to Logarithmic axis so as to make data 

bars more visible. 

Steps for changing the axis to logarithmic axis 

1. Right-click on any value in Y-axis so the entire scale is selected and select Properties from the menu, as 

shown in Fig. 1.2.67. 
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Fig. 1.2.67: Select properties for Y-Axis 

2. In the Properties window that appears, go to the Scale tab and check Logarithmic Scale checkbox as 

displayed in Fig. 1.2.68. 

 

Fig. 1.2.68: Scale Properties 
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3. Close the Properties window. 

In order to make graph more explanatory, we will provide a name to X-Axis and Y-Axis of the graph. 

Steps for naming Axis in PivotChart 

1. Right-click the Axis Title on X-Axis and select Properties from the menu, as shown in Fig. 1.2.69. 

 

Fig. 1.2.69: Open X-Axis Properties 

2. In the Properties window, go to the Format tab and change the Caption property to Sales Quarter as in 

Fig. 1.2.70. 
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Fig. 1.2.70: Change caption of X-Axis 

3. In a similar manner, change the caption of Y-Axis to Total Sales. The PivotChart appears as in Fig. 1.2.71. 

 

Fig. 1.2.71: Pivot Chart with Axis Captions 



ADVANCED SQL QUERIES  

 ADVANCED INFORMATION TECHNOLOGY 51 

 

Now if we wish to see the chart of quarterly sales of all the products from Truck category for the year 2011, the 

PivotChart will be obtained as follows: 

4. Open the drop-down in the Category Filter area, clear all checkboxes check the Truck checkbox and click 

OK as in Fig. 1.2.72. 

 

Fig. 1.2.72: Select Truck from Category 

5. In a similar manner, select 2011 from Years drop-down in horizontal axis. The resultant chart appears as in 

Fig. 1.2.73 indicating the sale of different items of Truck category, which is maximum in Quarter2 and 

minimum in Quarter4. 
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Fig. 1.2.73: Quarter-wise Truck Sales 

NOTE: Different PivotCharts can be made to represent different kinds of data. Both PivotChart and PivotTable 

can also be made directly on tables rather than making a query first. 

1.3 Joining Tables in Queries 

A Join is a temporary relationship that is created between two tables in a que ry or the relationship window using 

a common field in both the tables having same data type and usually the same name. Joins created in a query 

are temporary and are meant for the current query only. Joining tables in a query is required to view data from 

two or more tables. For example, to retrieve products ordered by each customer, tables Customers, Sales 

Order and Inventory are required to be joined to get the desired output.  

When two or more tables are added to the Query Design window, Access creates Joins between them based 

on the relationships that have been defined in the relationship window. Joins establish the criteria that the data 

must match to be included in the query operations. If the tables are not joined, the query result will match each 

record of one table to every record in another table, resulting in spurious rows. Different types of joins are 

available to get a different set of records as query result.  

There are three types of joins available in Access: inner join, left outer join, and right outer join. 

Inner Join: Returns only those rows from both tables that match on the joining field. 

Left Outer Join: The query returns all of the rows from left table, and also those rows from the right table that 

share a common value on both sides of the join. Since some of the rows in left table of a left outer join will not 

have corresponding rows in right table, some of the fields returned as a query result will be empty when the 

rows do not correspond. 
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Right Outer Join: It is just the opposite of left outer join. The query using right outer join returns all the rows 

from right table, and also those rows from the lef t table that share a common value on both sides of the join. 

1.3.1 Problem Scenario 

The Operations Regional Head of Apex Ltd. is required to produce a report giving the details of the payments 

received. 

For this purpose, two reports are required to be prepared: 

• First report indicating the Invoices for which payments have been made, including the invoice and 

payments detail. 

• Second report displaying a list of all the sales order, their invoices and details of payments, including 

those invoices for which payments have not been received. 

Solution 

To get the desired result, we create two queries: 

First query to fulfill the requirement using inner join between tables Invoice and Payments. 

Second query to achieve the second requirement which includes Sales Order, Invoice and Payments tables 

with an left outer join between Invoice and Payments tables. 

Steps to create the first query - to obtain invoices for which payments have been made 

1. Open the Query Design window, by clicking Create -> Queries -> Query Design. 

2. Select the Invoice and Payments tables from Show Table window and click Add. Click Close. 

3. To join the two tables, click the Invoice Number from Invoice table and drag it to Invoice Number in 

Payments table. The query window appears, as shown in Fig. 1.3.1. 

NOTE:  If the tables are already related through relationship window, the joining line automatically 

appears between the tables.  
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Fig. 1.3.1: Create Relationship between tables 

4. Select the columns Invoice Number, Sales Order Number, Type of Invoice, Invoice Date and Source of 

Order from the table Invoice and drag them to the columns tab. Similarly, select columns Date Paid, How 

Paid, Amount Paid and Amount Alloc from Payments table and drag them to the columns tab. The query 

window appears as shown in Fig. 1.3.2. 

 

Fig. 1.3.2: Add required columns 
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5. Click the Save button  on Quick Access Toolbar to save the query. Type the name of the query as 

Payment Made. 

6. Click the Run icon  in Design -> Results to view the query result displaying invoices with their 

payment details as shown in Fig. 1.3.3. 

 

Fig. 1.3.3: Query Result 

Steps to create the second query - to display list of all the sales order, their invoices and payments 

details, including those invoices for which payments have not been received 

1. Open the Query Design window, by clicking Create -> Queries -> Query Design. 

2. Select the Sales Order, Invoice and Payments table from Show Table window and click Add. Click Close. 

3. To join the tables, click the Sales Order Number from Sales Order table and drag it to the Sales Order 

Number in Invoice table. Similarly, join Invoice and Payments table on Invoice Number field. The query 

window appears as shown in Fig. 1.3.4. 
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Fig. 1.3.4: Join Tables 

4. Select the fields Sales Order Number, Sold to Customer and Sales Date from Sales Order table and drag 

them to the Columns tab. Similarly, select fields Invoice Number, Type of Invoice, Invoice Date, Source of 

Order and Payment Terms from Invoice table and columns Date Paid, How Paid, Amount Paid and 

Amount Alloc from Payments table. The query window appears as in Fig. 1.3.5. 
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Fig. 1.3.5: Select required columns 

5. Click Run  in Design -> Results to view the query result as shown in Fig. 1.3.6.  

 

Fig. 1.3.6: Sales Order with Payments 
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Notice that these query results are showing only the records for which payments have been received. To get 

the records for which the payment are not yet received, the join between Invoice and Payments table has to be 

converted to left outer join.  

Steps to create left outer join between Invoice and Payments tables 

6. Switch to the query design view by clicking Design View in Home -> Views. 

7. Right-click the joining line between Invoice and Payments tables and select Join Properties from the 

menu, or double-click the joining line. The Join Properties window appears, as shown in Fig. 1.3.7. 

 

Fig. 1.3.7: Join Properties dialog box 

8. Select the option 2: Include ALL records from ‘Invoice’ and only those records from ‘Payments’ 

where the joined fields are equal., and click OK. The Join Properties window appears as displayed in 

Fig. 1.3.8. 

 

Fig. 1.3.8: Set the Join Properties to Left Outer Join 
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9. The Join line changes to indicate that it is a left outer join. Notice an arrow pointing towards the Payments 

table as indicated in Fig. 1.3.9. 

 

Fig. 1.3.9: Left Outer Join between Invoice and Payments tables 

10. Click Save  on Quick Access Toolbar to save the query. Type the name of the query as Sales Order 

Details. 

11. Click Run
 

 in Design -> Results to view the query result shown in Fig. 1.3.10. Notice that the Date 

Paid, How Paid, Amount Paid and Amount Alloc fields from table Payments are blank for few records, 

indicating the invoices for which payments have not been received. 
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Fig. 1.3.10: Query Result 

A more complex join can be created among any number of tables and modified accordingly to get the desired 

results. 

1.4 Calculated Fields 

The Access query’s result is not restricted to the fields in tables only, but can display many other computed 

columns known as Calculated Fields. The Calculated fields can be compared to cells containing functions or 

formulas in Excel Worksheet. In Access, these cells can be considered as the columns of the table. 

Normalization forbids tables to have columns whose values can be computed using the existing fields. 

Calculations in a query are recomputed each time the query is run. As such, data is always current. The results 

of the calculations are not stored in a table. A calculated field performs some type of arithmetic calculations on 

one or more fields in a table to come up with a completely new field. For example, if a table has an Order Total 

field and a Tax Rate field, Access can calculate these two fields to find out the Sales Tax for each order as 

[Order Total] * [Tax Rate].  

The calculated fields create new fields in a record by combining the values of other fields in the record. 

Calculated fields can store numeric, date, or text fields for each record using expressions and functions.  

1.4.1 Problem Scenario 

Ramit, an executive in Apex Ltd. is required to produce a report displaying all the sales orders which contains 

the field Total Amount Paid as a sum of Tax, Freight and Other Charges. 

Solution 

As a solution to the above problem, a query has to be created on table Sales Order with a calculated column 

Total Amount Paid computed as a sum of Tax, Freight and Other Charges. 
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Steps for creating query with Calculated Columns 

1. Open the Query Design window, by clicking Create -> Queries -> Query Design. 

2. Select the Sales Order table from Show Table window and click Add. Click Close. 

3. Select the columns Sales Order Number, Sold to Customer, Sales Date, Payment Terms and Shipped via 

from Sales Order table and drag them to the columns tab as displayed in Fig . 1.4.1. 

 

Fig. 1.4.1: Select Required Columns 

4. To create the calculated column, write the expression Total Amount Paid: [Tax] + [Freight] + [Other] in the 

Field tab of the next column as displayed in Fig. 1.4.2. 
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Fig. 1.4.2: Calculated Column - Total Amount Paid 

5. Click Run  in Design -> Results to view the query result. The result is displayed in Fig. 1.4.3. Note 

the calculated column Total Amount Paid in query result. 
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Fig. 1.4.3: Query Result 

6. Save the query as Sales Order Report and close the query window. 

1.5 Summary 

Queries are the heart of every database application. Queries are responsible for converting diffuse data 

contained in tables into information that users can actually use. Without queries, we would have to write a 

complex code for every data extraction and transformation.  

This chapter talks about more complex part of queries . Sub-queries, as the name indicates is a query within 

query and helps us to retrieve data from multiple tables, and can also be used to replace  Joins. The Query 

Wizard can be used to create queries like Find Unmatched and Find Duplicate.  Apart from this, queries can 

generate summary reports using Group By and Crosstab Queries. Queries can be very interactive in terms of 

PivotTables and PivotCharts which can be obtained by just changing the query view.  

Queries can be based on multiple tables using different types of joins. Joins can be Inner Join or Outer Joins. 

Queries provide much more liberty, such as adding newly calculated columns to query result or restrict number 

of rows returned by specifying the criteria. Calculated columns enable us to implement normalization by 

omitting unnecessary columns in the table and introducing them as calculated columns later.  

  



 ADVANCE DATABASE CONCEPTS 

64  ADVANCED INFORMATION TECHNOLOGY 

1.6 Lab Exercises 

1.2.6 Case Study 

For the database Apex Inventory Shipment of Apex Ltd., consider the scenario and provide their solutions.  

1. The company is launching a new sales campaign for its existing customers. For this , the marketing 

department needs the list of customers with the highest credit limit. Create a query using sub-query to 

retrieve this list. 

2. A sales person made a mistake and skipped entering the item description for an order made by the 

customer. Using query, retrieve the sales order information for which the item description has not been 

entered. 

3. For the above exercise, retrieve the information about the customer who has placed the order so that the 

items can be reconfirmed. 

4. The company launched its new office in India and asked the sales executive to interact with various people 

and enter the details of possible customers in a table named Customers_India. The table has the following 

structure: 

Field Name Data type 

Customer Number Text 

Salutation Text 

First Name Text 

Last Name Text 

Company Text 

Phone Text 

Email Text 

Street Text 

City Text 

State Text 

ZIP Code Text 

In the absence of any constraints on the table, the sales team ended up inserting duplicate records of a 

single customer. Write a query to find these duplicate records. (Consider the Customer Number as unique 

for each customer.) 

5. The Finance Head who keeps track of their inventory shipped, requires the report displaying the quantity of 

items shipped every month of year 2011. Create a Totals query displaying the required data.  

6. The company is issuing a discount policy to its customers. For this purpose, the Marketing Regional 

Manager needs a detailed report of the customers. The report should contain Customers Name s on rows 

and Month Name as columns, and count of orders placed by each customer on the intersection cell s of 

rows and columns. 
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7. Create a user interactive report using PivotTable to display payments made by customers. The user should 

be able to filter the customers according to their states and should be able to drill the payments in terms of 

years, quarters, months and days. 

8. Considering the scenario given in the above exercise, create a graphical view using PivotChart indicating 

the total payments received quarter-wise from all the customers from a particular city. User should be able 

to filter the city on the basis of their country. 

9. Create a query containing mailing address list for all the customers with the following field list:  

1 Salutation FirstName Last Name  

2 Company  

3 Street, City  

4 State  

5 Country 

6 Postal Code 

10. Display the list of all customers from New York (State Code – NY), with details of items they have ordered 

and Total Amount to be paid by them. 

1.2.7 Multiple Choice Questions 

1. For the database Apex Inventory Shipment of the Apex Ltd., we wish to retrieve records for customers who 

have not placed any orders yet. What type of query can be used? 

(a) Duplicate Query 

(b) Crosstab Query 

(c) Find Unmatched Query 

(d) Group By query 

2. Considering the database Apex Inventory Shipment of the Apex Ltd., how can we display sales grouped by 

country, state, and customer, all at the same time? 

(a) Use the Sort Descending command 

(b) Use the PivotTable View command 

(c) Use the Find command on specified groups 

(d) All of the above 

3. For the database Apex Inventory Shipment, the number of items for each category is required to be 

computed, which query type is required to be used? 

(a) Select Query 

(b) Group By query 

(c) Crosstab Query 

(d) Duplicate Query 
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4. Considering the scenario in question above, which function should be used with Item Number in query? 

(a) Count 

(b) Compute 

(c) Sum 

(d) Calculate 

5. In the database Apex Inventory Shipment, to see total amount received from Payments table, it should be 

dragged into which area of the PivotTable? 

(a) Drop Column Fields Here 

(b) Drop Row Fields Here 

(c) Drop Totals or Detail Fields Here 

(d) None of the above 

6. Considering the database Apex Inventory Shipment, we wish to get all the sales orders with cash 

payments. What needs to be done to achieve this? 

(a) Create a  sub-query with Sales Order as Payment type 

(b) Create a select query on Sales Order table and write Cash as criteria for Payment Terms 

(c) Create a Group-By query on Payment Terms 

(d) None of the above 

7. From the database Apex Inventory Shipment, we wish to retrieve a report displaying details of all the 

invoices including the payments details (if already made) of the invoices. What type of Join should be used 

in Query window to achieve the desired result? 

(a) Left outer join 

(b) Right outer join 

(c) Default join 

(d) No joins will be used 

8. How can we add a table to the Query Design window? 

(a) Select Create -> Add Table 

(b) Select Database Tools -> Add Table 

(c) Select Design -> Show Table 

(d) Select the table from the Navigation Pane 

9. If we are creating a Crosstab query, the table we are querying must contain what? 

(a) Lots of confusing information 

(b) More than 100 records 
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(c) At least one field 

(d) At least three fields 

10. _______ type of query summarises information in a grid, organized by regions and months. 

(a) An update query 

(b) A parameter query 

(c) An action query 

(d) A Crosstab query 

11. When we double click a query object, we open 

(a) The object in design view 

(b) The object in print preview 

(c) The result of the query 

(d) The underlying table on which the query is based 

12. What is the primary difference between a PivotTable report and a Cross tab query? 

(a) A PivotTable report can contain sums, counts, and averages, while a Cross tab query cannot 

(b) We cannot create a PivotTable from a Crosstab query 

(c) A Crosstab query lets us group similar items, while a PivotTable query does not 

(d) None of the above 

13. In Access, the best types of queries to use for data analysis are: 

(a) Select queries 

(b) Parameter queries 

(c) Action queries 

(d) All of the above 

14.  Which view allows adding tables to the query? 

(a)  Datasheet view 

(b)  PivotTable view 

(c)  PivotChart view 

(d)  Design view 

15. Which type of join in multi-table query permits to view all the records from one table and matching from 

another? 

(a)  Inner Join 

(b)  Outer Join 

(c)  Equi Join 

(d)  Non-Equi Join 
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16.  For the database Apex Inventory Shipment, we need to present a graphical view of the sales volume of 

products. User should have the liberty to view all the products, or products from a particular category. For 

this purpose, a PivotChart is created. Which field should be placed in area Drop Series Fields Here? 

(a) Category 

(b) Total Sales 

(c) Month 

(d) Item Number 

17. For the above question, the area Drop Filter Fields Here should contain _________ field. 

(a) Category 

(b) Item Number 

(c) Years 

(d) Month  

18. To view the results in Datasheet view of the query created, do the following _____________.  

(a)  Press F5 key 

(b) Click Run on Design tab 

(c) Press CTRL + R  

(d) All of the above 

19.  The  option in Design ribbon permits us to create what type of queries? 

(a) Crosstab Queries 

(b) Action Queries 

(c) Parameter Queries 

(d) Group By Queries 

20.  For the database Apex Inventory Shipment, if we wish to delete all the invoices for which the payments 

were made in last quarter of year 2011, what should be done? 

(a) Create a select query and delete records manually 

(b) Create a sub-query with action query 

(c) Create simple action query 

(d) Cannot be done using queries 
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2.1 Introduction 

Forms help to display, add, modify, and delete data. Different features available in Access enable to create 

forms such that it becomes easier for the users to handle data. Access provides various methods to make 

forms handier and simpler. Different controls can be added to a form to enhance their working. Access also 

provides ActiveX controls which are Microsoft control meant for different purposes. A form can be divided into 

pages to increase the readability, or can include a summary section to display grouped data.  

Reports can be considered as the static version of forms. Reports are the best way to present dat a to higher 

authority and communicate the information to the people. They can be customized using header and footers, 

calculated values, and sub-reports to represent linked data. Access also provides the facility to create charts in 
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reports which represents data diagrammatically. Since reports are used for business communication, it must be 

available for everyone.  

2.2 Advanced Form Design 

Forms are an important medium of representing data in Access. Forms are not only used for entering of data, 

but also to view the data in a user friendly manner. Access provides various controls and utility to make the 

forms more presentable. For example, forms can contain unbounded controls, graphics, calculated values, and 

combo boxes.  

2.2.1 Adding Unbound Controls 

An Access Form can contain multiple controls, each having its own significance. These controls can be 

selected from Create tab in Forms ribbon. In general, all the controls are bounded to one field of the table or 

query the form is based on. However, there are few controls which retain the entered value, but are not linked 

with any table fields. These controls can be used for text label d isplay, for controls such as lines and 

rectangles, or for holding unbound OLE objects (such as bitmap pictures or logo) that are  not stored in a table, 

but in the form itself. Unbound controls are also known as variables or memory variables.  

2.2.2 Problem Scenario 

The database Apex Inventory Shipment has a form frmOrders as shown in Fig. 2.2.1, based on table Sales 

Order which keeps track of all the orders placed. The Sales Manager wishes to add a current date on the form, 

so that it becomes easy for the user to keep track of dates.  

 

Fig 2.2.1. frmOrders form 

Solution 

The Database Developer adds an unbounded control, a label to the form and sets its property to store the 

current date. 
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Steps for adding an unbounded control 

1. Right-click the form frmOrders under All Access Objects -> Forms tab. Select Design View from the 

dropdown to open the table in Design View, as shown in Fig. 2.2.2. 

 

Fig 2.2.2. Open the form frmOrders in Design view 

2. Select the Date & Time control  from Design ribbon ->Header/Footer tab. The Date and Time window 

appears, as shown in Fig. 2.2.3 select the date & time format from this window. 
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Fig. 2.2.3: Date and Time window 

3. Click OK to close the window and draw the control on the Form Header portion on the form. The form should 

appear, as shown in Fig. 2.2.4. 

 

Fig. 2.2.4: Date and Time unbounded control added to a form 

NOTE: In a same way, other controls like shapes, logo, etc. can be added to form. The properties of these 

controls can be set to meet user requirements. 

2.2.3 Adding Graphics to Form 

Attractive forms are always a valuable addition. Access makes it easy to add a graphic to the background of a 

form, such as a “watermark” which appear on expensive bond paper. The picture can contain a company logo, 

text, or any other graphic element. The picture is specified by the form’s picture property and can be embedded 
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in the form or linked to an external file. If the picture is linked, the graphic displayed on the form changes any 

time the external file is edited. 

The graphic can be inserted into the form in the following ways:  

1. Import a graphic file (clip art, gif, jpeg, bmp, etc.) directly into the form. 

2. Attach a link to the graphic that opens a website or other database object.  

3. Associate the graphic with an existing macro in the database. 

2.2.4 Problem Scenario 

Consider the frmOrders discussed in section 2.2.1. The Database Developer wants to make it more presentable 

and thought of adding a picture to the background of the form. 

Solution 

The picture can be set as form background using the image control. Select the picture to be added, draw the 

image control and adjust its properties to make image as a background.  

Steps for adding graphics 

1. Right-click the form frmOrders under All Access Objects -> Forms tab. Select Design View from the 

dropdown to open the table in Design View. 

2. Select the insert image button from Design ribbon -> Controls tab and drag it to cover the Details section of 

the form. 

3. The Insert Picture window appears. Browse for the picture to be inserted and click OK to close the window. 

The Insert Picture window is displayed in Fig. 2.2.5. 
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Fig. 2.2.5. Insert Picture window 

 

4. The form after the picture is inserted appears, as shown in Fig. 2.2.6. 
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Fig. 2.2.6: Image inserted in form frmOrders 

5. The picture is required to move to the back of controls. Right-click the picture and select Position -> Send to 

Back from the dropdown, as indicated in Fig. 2.2.7. 

 

Fig. 2.2.7. Send the picture to back of controls 

6. The form appears, as shown in Fig. 2.2.8. 
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Fig. 2.2.8. Form with Graphics 

7.  Select the picture and press F4 to view its properties. In the property sheet, move to format and set the Size 

Mode property of picture to stretch, as shown in Fig 3.2.9. 

 

Fig. 2.2.9. Set the image property 

8. The final form appears, as in Fig. 2.2.10. 
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Fig. 2.2.10. frmOrders with Graphics inserted 

NOTE: While adding a graphic to the form, a link to that graphic can also be created. The link ensures that the 

changes made to original file are also reflected in form.  

2.2.5 Adding Calculated Values 

Access provides many features to give forms enhanced behavior and a modern look. One of the major 

requirements in Accessform that it can be display computed results. These results may be bounded to some 

field in the table or may be unbounded. For example, we may need to display the complete name of the 

customer instead of displaying the first name and last name separately.  

Calculated controls can use any of the existing function or user build function available in Access.  Calculated 

values can also be expressions computed with a combination of other fields and operators. 

2.2.6 Problem Scenario 

Consider the form frmOrders discussed in section 3.2.1. The Manager wishes to add another date in form, 

which may indicate when the order will reach customers. This date can be computed as 15 days after the date 

of shipment. 

Solution  

A textbox is added to the form.This textbox contains calculated value, which is computed as 15 days + date of 

shipment. 

Steps to add calculated values to form 

1. Right-click the form frmOrders under All Access Objects -> Forms tab. Select Design View from the 

dropdown to open the table in Design View. 

2. Select the textbox control  from Design ribbon -> Controls tab and draw it on the details section of the 

form. The form should appear, as in Fig. 2.2.11. 
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Fig. 2.2.11. Insert Textbox in Form 

3. Double-click the label and type Delivery Date instead of Text25. Similarly, double-click the textbox and type 

=DateAdd("d",15,[Ship Date]). The form should appear, as shown in Fig. 2.2.12. 

 

Fig. 2.2.12. Specify values for Textbox control 
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NOTE: The formatting of the new added textbox can be copied from above cells. 

4. Select Form View from Home ribbon -> Views tab to open the form in Form View. Confirm the textbox 

displays the calculated value. 

2.2.7 Adding Combo Boxes 

Combo boxes in Access provide a way of selecting a value from a list. This is quicker than remembering which 

value to type and ensures that the entered value is valid. A combo box is a compact method of presenting a list 

of choices and allows user to enter a value that is not in the list.  

The values in a combo box are displayed by clicking the arrow at the end. In combo box values can be selected 

by clicking it or by typing the first few characters of the value into the text box area of the combo box. If the 

Auto Expand property is set to Yes, the default setting, Accessautomatically fills in the rest of the value. Combo 

box consists of rows of data with one or more columns, which can appear with or without headings. One of the 

columns contains the values to be stored in the field (bound control) or use for other purposes (unbound 

control); the other columns contain explanatory information. 

2.2.8 Problem Scenario 

Consider the form frmOrders created in section 3.2.1.Theexecutives are making many mistakes while typing the 

reference of the customer to which orders are sold. The Sales Manager asked the Database Developer to find 

the solution to this problem. 

Solution 

The Database Developer thought that it will be a good way to add a combo box for the customers. Users will 

have an option to choose the value from the list or type a new value if required, thereby decreasing the typing 

mistakes. 

Steps to add a combo box in Form 

1. Right-click the form and select Design View from the dropdown to open the form in Design View. The form 

appears, as shown in Fig. 2.2.13. 
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Fig. 2.2.13: frmOrders in Design View 

2. Delete the Sale to Customer textbox.  

3. Select the Combo Box control  from Design ribbon -> Controls tab and draw it in the place of Sale to 

Customer textbox. The Combo Box wizard appears, as shown in Fig. 2.2.14. 

 

Fig. 2.2.14. Combo Box wizard 
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4. Select the first option i.e. I want the combo box to look up the values in a table or query  and click Next. 

5. In the Select Table or Query window, select the table option from View tab and choose table Customer 

from the list, as indicated in Fig. 2.2.15. Click Next to continue.  

 

Fig. 2.2.15. Select the required table 

6. In the Select Field window, select field Customer Number from Available field and click on  sign to put 

it into selected fields.  Similarly, add First Name and Last Name to selected field. The window appears, as 

shown in Fig. 2.2.16. Alternatively, the user can double-click the fields to add them to selected field.  

 

Fig. 2.2.16. Add field to Combo Box 
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NOTE: Even if the multiple fields are selected to be displayed in Combo Box, the Primary Key will be stored 

in table or form. 

7. Click Next to continue. In the Sort Order window select Customer Number as 1. This is indicated in Fig. 

2.2.17. 

 

Fig. 2.2.17. Select Customer Number for Sort Order 

8. In the Hide Key Column window, uncheck the Hide Key Column checkbox, as shown in Fig. 2.2.18. Click 

Next to proceed. 

 

Fig. 2.2.18. Uncheck Hide Key Column Option 
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NOTE: Hide Key Column hides the Primary Key to be displayed as a value in combo box, though internally 

only Primary key is stored. 

9. The next window confirms a unique value to be stored in table. Select Customer Number and click Next, as 

indicated in Fig. 2.2.19. 

 

Fig. 2.2.19. Select Field to be stored in Table 

10. In the next window that appears, select the option Store the value in this field and select the value Sale to 

Customer from the dropdown, as indicated in Fig. 2.2.20. 

NOTE: The first option Remember the value for later use is used in case of unbound controls.  

 

Fig. 2.2.20. Select field to store the value 
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11. Click Next to make the Name window appear. Type the name cmbCustomers for the Combo Box and click 

Finish to close the wizard, as indicated in Fig. 2.2.21. 

 

Fig. 2.2.21: Type Name for Combo Box 

12. The Sale to Customer combo box appears on the form, as displayed in Fig. 2.2.22.  

 

Fig. 2.2.22. Combo Box added in form 

13. Set the formatting of the label and combo box to make it more presentable. Open the form in Form View to 

verify the added combo box. The form should appear, as shown in Fig. 2.2.23. 
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Fig. 2.2.23. The Combo Box List appears 

2.3 Make effective use of Forms 

Most databases provide forms for data entry and for viewing data. Access provides few techniques that help 

enhancing the usability of forms, and in turn, the productivity of the users of database. Forms are used by most 

of the users on a regular basis, and hence it is very crucial to make the effective use of forms. Adding more 

capabilities to forms helps to save user time and work, and also present data in a more organised way. Some of 

the extended functionality of the form can be: 

• Adding calendar control on a form 

• Organising information with tab pages 

• Displaying a summary with tab pages 

2.3.1 Displaying a calendar control on a Form 

To make forms more presentable and user friendly, different types of controls can be added to forms. These 

controls can be as simple as controls that are available in the design ribbon -> controls tab, or can be a third 

party ActiveX control. ActiveX controls are usually graphical objects that do not operate as standalone 

solutions, and they run only in the Windows environment. 

Calendar control is one of the most popular ActiveX controls. While working with dates, it is always helpful to 

have a calendar nearby.  If a form contains a date field, it is always good to add a calendar control which 

displays dates graphically and make the form more user-friendly. The calendar control provides properties that 

enable to set and retrieve dates in/from a table.  

2.3.2 Problem Scenario 

Database Designer of Apex Ltd. has designed the frmOrders form to be used for Sales Orders table, as shown 

in Fig. 2.3.1 The Supervisor of the Customer Service Group informs the designer that the people taking orders 
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often need to refer to a calendar to answer customer questions, such as when they will receive a shipment. A 

calendar is necessary so that the customer service employees can take weekends and holidays into account 

when they make an estimate as to when orders will be shipped. 

 

Fig. 2.3.1. frmOrders Form 

Solution 

A Calendar control is added to all the date fields to make the form convenient for the users. The Database 

Developer adds a calendar control for Sales Date and Ship Date for users to pick up date graphically.  

 

Steps to add a Calendar Control 

1. Right-click the frmOrders and select Design View from the dropdown to open the form in Design View, as 

shown in Fig. 2.3.2. 
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Fig. 2.3.2. Open form frmOrders in Design View 

2. From Design ribbon -> Controls tab, click the Insert ActiveX Control Command . 

3. The Insert ActiveX control window appears. SelectCalendar Control 11.0 from the list and click OK, as 

shown in Fig. 2.3.3. 
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Fig. 2.3.3. Select Calendar control 

4. The Calendar control is placed in the upper-left corner of the form. Drag it to the required position. The 

frmOrders after inserting the Calendar control appears, as displayed in Fig. 2.3.4. 
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Fig. 2.3.4: Calendar control inserted on the form 

5. Select the Calendar control and press F4 to open the Property Sheet for the Calendar control  

6. Move to the data tab in property sheet. Click the arrow next to the Control Source property, and choose 

Sales Date from the list, as shown in Fig. 2.3.5. 

 

Fig. 2.3.5. Set the Control Source property 
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 NOTE: The Calendar control has many properties that you can set to create a custom appearance.  

7. To set other properties of Calendar control, click on  button in the Custom property in Other tab. The 

Calendar properties appear, as shown in Fig. 2.3.6. 

 

Fig. 2.3.6. Calendar Properties 

2.3.3 Organising information with Tab Pages 

A Tab control is an Accesscontrol that allows user to create multiple pages in one form. Each page is separated 

by its own tab and becomes active when the user selects a tab. Tab controls are useful for presenting grouped 

information that can be assembled by category. A tab control  has pages, each with a tab of its own. Each tab 

page can contain all types of controls, such as text boxes, combo boxes, images, and even command buttons.  

2.3.4 Problem Scenario 

The Sales Manager asks the Information Analyst to store the information of the customer which could be 

displayed in a friendly manner, such that the customer’s personal details and company details can be viewed 

separately. 

Solution 

The Information Analyst advises the developer to divide the information into separate tab in a form. One tab in 

the form should contain customer contact detail, while the other can contain customer’s company details, and 

third tab can contain customer’s terms with the company.  
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Steps to add tab in a form 

1. On the Create ribbon -> Forms tab, click Blank Form to create a new form, as shown in Fig. 2.3.7. 

 

Fig. 2.3.7: Open a blank Form 

2. From the Field List window, open the plus sign with Customers table and drag the fields Customer Number, 

First Name, Middle Name and Last Name to the form. The form appears, as shown in Fig. 2.3.8. 

 

Fig. 2.3.8. Add Fields to a blank form 

NOTE: If the field list window does not appear, click on Add Existing Field from Design ribbon -> Tools tab. 

3. Click Home ribbon -> Views tab -> View and select Design View from the dropdown to open the form in 

Design View. The form appears in Design View, as shown in Fig. 2.3.9. 

 

Fig. 2.3.9. Form in Design View 
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4. Extend the size of the form as required. Click on tab control  in Design ribbon -> Controls tab and draw 

it into the form. The form appears, as shown in Fig. 2.3.10. 

 

Fig. 2.3.10. Add tab control to a form 

5. Double-click the tab Page28. Property sheet appears. Type the value Personal Details in Name property, 

as shown in Fig. 2.3.11.  

 

Fig. 2.3.11. Change the name of first tab 

6. In a similar manner, change the name of the second tab to Company Details. Right-click the Tab control 

and select Insert Page from the dropdown to add a new tab and change its name to Other Details. The 

form should appear, as in Fig. 2.3.12. 



 DESIGNING FORMS AND REPORTS  

 ADVANCED INFORMATION TECHNOLOGY 93 

 

 

Fig. 2.3.12. Add three tabs to Form 

7. Move to the Personal Details tab, and select the field Street, City, Country, Zip/Postal Code, Phone, Other 

Phone, and Email from the Field List window. The resultant form is displayed in Fig. 2.3.13. 

 

 

Fig. 2.3.13: Add required field to personal Details tab 
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8. In a similar manner, add the fields CompanyName, Company Details and Job Title to the Company Details 

tab and also the fields Credit Limit, Payment Terms, Comments, and Document submitted to the Other 

Details tab. 

9. A tabbed form is prepared. Now the user can navigate between different tabs to view the information 

required. 

10. Save the form as frmCutomers.  

2.3.5 Displaying a Summary of Data in a Form 

Presenting a summary of data can be very useful to users who access database. PivotCharts and PivotTables 

are created in forms to display a summary of data. Pivot Table is used to summarize and analyzes data in a 

form. The idea of Pivot Table is to let users slice and dice the data in any way required at a given moment in 

time. Pivot Table represents the data in spreadsheet form, while Pivot Chart represents the same data in a 

graphical form. Both Pivot Chart and Pivot Table are different views of a form.  

Pivot Table represents the data in tabular form, in which one or more vales are represented in rows, another 

value in columns, and a summarized value at the intersection of row and column. Forms that lend themselves 

to be displayed in PivotTable or PivotChart view provide many ways for users to manipulate data. An example 

of such a form is one that contains information about country, city, salesperson, sales, and date of sale. Such 

form can be used to determine sales by city and salesperson for each month, o r sales in each country for each 

salesperson during the year. 

2.3.6 Problem Scenario 

The Sales Manager wishes to see the summarized data of sales. He requests the Database Developer to 

create a form in such a manner, that it should display the summarized data in terms of cost of Item Sold per 

year, per country. For example, he needs a report displaying summary of the items sold country  wise and state 

wise in year 2008 Quarter-2. 

Solution 

The Database Developer first creates a query based on table Sales Order, Customers, Sales Item Description, 

and Inventory and fetches the required data from it. Once query is created, then a form using pivot table option 

is created over the query. 

Steps for creating a query 

1. Open the Query Design window by clicking Create ribbon ->Queries tab -> Query Design. 

2. Select the tables Customers, Sales Order, Sales Item Description and Inventory table from the Show Table 

window. Click OK to close the window. The Query Design window appears, as shown in Fig. 2.3.14. 
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Fig. 2.3.14. Query Design window 

3. Select Country and State from the Customers table and drag them to the Add Columns tab. Similarly add 

the column Sales Date from Sales Order table and Item Number from Inventory table. Also add a 

calculated column as Total Sale: [Quantity] * [Price]. The resultant query window is displayed in Fig. 2.3.15. 

 

Fig. 2.3.15. The query Design window 

4. Save the query as SummarizedData and run to confirm the results. 

Steps for creating a Pivot Table Form 

1. Select the query SummarizedData under All Access Objects -> Queries tab. From the Create ribbon -> 

Forms tab ->, click the dropdown arrow near More Forms and select Pivot Table from the list, as indicated 

in Fig. 2.3.16. 
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Fig. 2.3.16. Select the Pivot Table option 

2. The Pivot Table window appears along with the field list, as shown in Fig. 2.3.17. 

 

Fig. 2.3.17. The Pivot Table window 

 NOTE: If the Field List window does not appear, click Design ribbon -> Show/Hide tab and Field List. 
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3. Open the plus sign of the field Item Number and drag the field to Drop Row Fields Here. Open the plus sign 

of Country and State drag Country and then State to Drop Column Fields Here. Similarly, open the plus 

sign for Total Sale and drag the column Total Sale to Drop Totals or Detail Fields Here, and open the plus 

sign of Sales Date By Month and drag the fields Years and Quarters to Drop Filter Field Here. The resultant 

Pivot Table window is shown in Fig. 2.3.18. 

 

Fig. 2.3.18. Pivot Table window 

4.  Click the dropdown arrow of Sales Date by Month field. Deselect the Select All option and open the plus 

sign of year 2008, and select Qtr2 from the year 2008, as shown in Figure 2.3.19. 
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Fig. 2.3.19. Select the required year 

5. The Pivot Table window displays the sales made for each item country and state wise in Quarter2 of year 

2008. 

NOTE: Pivot Table gives you a flexibility of selecting the desired data and view the data according to your 

requirements.  

2.4 Advanced Reports 

Reports are one of the best ways to represent data.  Reports can be made more advanced and more user 

friendly to represent the data in a more organized form. The Reports can include customized Headers and 

Footers such as to display the company Logo or the department. Also the calculated controls can be added to 

report to display computed values.  

2.4.1 Creating Customised Headers and Footers 

Reports can include pairs of header and footer sections:  

• Report Header and Footer for printing information at the beginning and end of the report . 

• Page Header and Footer for printing information at the top and bottom of each page . 

• Group Header and Footer for printing information when the group starts or the group ends, if groups exist in 

the report. 

To add a header/footer pair, right-click in the report design and choose Page Header/Footer or Report Header/ 

Footer from the shortcut menu. Page and report headers and footers are added as pairs, while In Group only 

Headers can be added.  
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Controls in the Report Header & Footer section are printed only once at the beginning and the end of the report. 

A common use of a Report Header section is as a cover page or a cover letter , or for presenting information 

that needs to be communicated only once to the user of the report. The Report Footer section can be used to 

display the summarized data of whole report, like author of report, date & time, etc. 

Controls in the Page Header & Footer section are normally printed at the top and bottom of every page. 

Typically, Page Headers serve as column headers in group/total reports; they can also contain a title for the 

report. A Group Header section normally displays the name of the group.  Group Headers immediately precede 

Detail sections. A Group Header is added to the report if any grouping is done in the report. 

Each Header& Footer section in reports can be customized from their traditional look to meet user’s 

requirement. Different controls can be added to header and footer. The textboxes or labels can be used to 

display a user-defined message. Various functions and expression can be used to display summary results an d 

computed data. 

2.4.2 Problem Scenario 

The Database Developer has prepared a report rptCustomers to display all the details of the customers, as 

shown in Fig. 2.4.1. The Zonal Sales Head requires the report to be customized; each page of the report must 

contain the Report Title at the top and date & time at bottom. 

 

Fig. 2.4.1: Report rptCustomers 
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Solution 

The Database Developer adds a Page Header & Footer to the report and customizes the Page Header to hold a 

label with Report Title, and Page Footer to contain the date & Time using Date Time control. 

Steps to customize Page Header & Footer of the Report 

1. Right-click the report rptCustomers under All Access Object -> Reports tab and select Design View from 

the dropdown to open the report in Design View. The Report Design View should appear, as in Fig. 2.4.2. 

 

Fig. 2.4.2: Report rptCustomers Design view 

2. Expand the Page Header section. Select a label control  from Design ribbon -> Controls tab and draw 

it on the Page Header section, as indicated in Fig. 2.4.3. 

 

Fig. 2.4.3. Add Label to Page Header 

 NOTE: If Report Header does not appear right-click the report and select Page Header /Footer to view 

them.   
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3. Type the text Customers into the label and format it according to the requirement, as shown in Fig. 2.4.4. 

 

Fig. 2.4.4. Add Title to Label 

4. In a similar manner, add a Textbox control  to the Page Footer of the report from Design ribbon -> 

Controls tab. The resultant report appears, as shown in Fig. 2.4.5. 

 

Fig. 2.4.5: Add Textbox to the Report 

5. Delete the label of the Textbox and type =Now() in the textbox. The report appears, as shown in Fig. 2.4.6. 
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Fig. 2.4.6. Add Textbox in Page Footer 

6. Right-click the report and deselect Report Header/ Footer to remove the report header and footer. This is 

optional. The report header can contain some different text and can be displayed.  

7. Open the report in Report View format by selecting Report View from Home ribbon -> Views tab to verify 

the data. The report should appear as in Fig. 2.4.7. Note that each page of the report contains the Report 

Title and Date/Time. 

 

Fig. 2.4.7. Report View 
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2.4.3 Adding Calculated Values 

Reports in Access can be modified to display the data as per user requirements. In general , reports contain 

fields from the table, but many times it becomes necessary to add some computed values in reports. These 

computed values may count, sum, or calculate an average of the numeric values in a group created in the 

report. Also, these computed values can be calculated using one or more fields in a table , for example, to 

display the total cost by multiplying quantity and price.  

The calculated values in reports are added using a text box and specifying an expression. The liberty of 

displaying computed values helps to display the reports in a user-friendly format. The calculated values in the 

report can be displayed in two ways: using queries with calculated columns and creating reports based on 

them, or by computing values in the report itself using Expression and Functions. The calculated values in 

queries are displayed as fields in reports which use them. 

2.4.4 Problem scenario 

Consider the report rptCustomers discussed in section 3.4.1.The Sales Head wishes the customer name should 

be displayed as a complete name, not as first name and last name. He requests the Database Developer to 

implement the change. 

Solution 

The Database Developer adds a calculated value that concatenates first name and last name in the report 

rptCustomers and replaces the First Name and Last Name textboxes. 

Steps to add Calculated Values 

1. Right-click the report rptCustomers under All Access Objects -> Reports tab and select Design View from 

the dropdown. The report appears in Design View, as shown in Fig. 2.4.8. 

Fig.2.4.8: report in Design View 

2. Select the First Name and Last Name textboxes and delete them. Add a new Textbox control  from 

Design ribbon -> Controls tab. 

3. Drag the Textbox in place of First Name and Last Name textboxes. The report should appear, as shown in 

Fig. 2.4.9. 
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Fig. 2.4.9. Add Textbox control to Report 

4. Delete the Textbox Label and type the text = [First Name] + “ “ + [Last Name] in the textbox. The report 

window appears, as shown in Fig. 2.4.10. 

 

Fig. 2.4.10. Write the expression in calculated control 

5.  Add a label control  from Design ribbon -> Controls tab in the Page Header tab along with other 

headings. The Report should appear, as in Fig. 2.4.11. 

 

Fig. 2.4.11. Add Label Control to Page Header 
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6. Type text Name in label and format the label accordingly. The Report should appear , as shown in Fig. 

2.4.12. 

 

Fig. 2.4.12: Format the label 

7. Select Report View from Home ribbon -> Views tab to open the report in Report View. The resultant report 

should appear, as in Fig. 2.4.13. 

 

Fig. 2.4.13. Report view 

2.4.5 Sub-Reports 

Sub-Report is a report that is inserted in another report. A sub-report, a complete report in its own right, is 

inserted into another report, called the Main Report. Main Report can be either bound or unbound. A bound 

main report is based on a table or query and its sub-reports contain related information. An unbound main 

report is not based on a table or query, but can serve as a container for one or more sub-reports. A main report 

can include as many sub-reports as necessary. The sub-reports can be added to two hierarchy levels. 
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Sub-Reports are usually an extension of data in main report. For example, the main report can contain details 

about the sales in a year, while the sub-report can show data for sale of each item or charts and graphs 

summarising and illustrating the numbers in the main report. If a sub report is inserted in a bounded main 

report, it should contain some field to link to main report.  

2.4.6 Problem Scenario 

Consider the Report rptCustomersdiscussed in section 3.4.1. The Regional Head notices that the database 

users face a big problem while tracing the orders placed by each customer. He asks the Database Developer to 

create a user-friendly object which can display both the customer’s details and orders placed by the customer. 

Solution 

The Database Developer decides to add a sub report to the report rptCustomers which include details of the 

orders placed by the customers. For this purpose, the table Sales Order is used and the fields Sale to Customer 

from Sales Order and Customer Number from Customers are mapped. 

Steps to add a Sub Report to Main Report 

1. Right-click the report rptCustomers and select Design View from the dropdown to open the report in Design 

View. 

2. In the Design View, expand the Details section. Select the sub-report control  from Design ribbon -> 

Controls tab and draw the control in Details section.  

3. The SubReport Wizard appears, as shown in Fig. 2.4.14. 

 

Fig. 2.4.14. SubReport Wizard 
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4. Select the option Use Existing Tables and Queries and click Next to proceed further, as shown in Fig. 

2.4.15. 

 

Fig. 2.4.15. Select option to use existing table 

5. In the Select Table or Query window, select the table Sales Orders from the list. Select the fields Sales 

Order Number, Sale to Customer, Sales Date, Ship Date from selected field to available field, as shown in 

Fig. 2.4.16. 

 

Fig. 2.4.16. Select required Table 
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6. Click Next to advance. The Link Field window appears. Select Customer Number from Forms/Reports field 

and Sale to Customer from Subforms /Sub reports field.  The Sub Report Wizard appears, as shown in Fig. 

2.4.17. 

 

Fig. 2.4.17. Link fields of main report and sub report 

7. Click Next to proceed to Name of Sub report window. Provide a suitable name to your sub report, and click 

Finish to close the window as indicated in Fig. 2.4.18. 

 

Fig. 2.4.18: Provide a name to the sub report. 
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8. Open the resultant report in Report View by selecting Report View from Home ribbon -> Views tab. Final 

report appears, as shown in Figure 2.4.19. 

 

Fig. 2.4.19. Customers and Orders placed by them 

2.5 Make Reports more effective 

Reports are a way of communicating database information. By customizing reports, the information can be 

presented in the most effective format. A customized report developed by using Access tools can reach a wider 

audience and enable more users to handle them. Different methods to make reports effective can be : 

• including charts in a report 

• printing data in columns 

• canceling the printing of a blank report 

• creating report snapshot 

2.5.1 Including a Chart in a Report 

Chart is a graphical representation of information used to illustrate quantitative relationships. It is a diagram that 

depicts a relationship, often functional, between two sets of numbers or between a set of numbers and a set of 

categories.  

Microsoft Graph is used to chart data from any of the database tables or data stored within other applications. It 

creates graphs in a wide variety of styles, such as bar graphs, pie charts, line charts, and others. Because 

Microsoft Graph is an embedded OLE application, it does not work by itself. As such, it has to be run from 

within Access. In other words, it is dependent on Access. 
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Different Chart Types 

Chart Type Purpose 

Column Chart Used to compare multiple values of categories or differences over a period of time. 

The horizontal axis depicts categories and the vertical axis depicts values.  

Bar Chart Used for the same purposes as a Column Chart. However, the horizontal axis of a Bar 

Chart shows values and the vertical axis shows categories or periods of time. 

Area Chart Used to emphasize differences in individual values to the total , over a period of time. 

Line Chart Used to compare trends over a period of time. 

Pie Chart Used to show the relationship of a part to the whole. It is suitable for depicting one 

data series or data at a point in time. 

 

Charts can be included in reports to illustrate the information more clearly. Charts enhance the data presented 

in reports by summarising the information and illustrating it in easily understandable ways. The reader can 

analyse trends and make comparisons using charting tools. The chart can be linked to a field in the underlying 

table or query. 

2.5.2 Problem Scenario 

The Sales Head wishes to create a summary report. The report should show the quarterly total sales for each 

category. The Sales Head requests the Information Analyst to show a diagrammatic representation of the 

report. 

Solution 

The best way to display the summary report is to create charts to represent the data. The charts can be 

included in a report, and based on a query to show its diagrammatic representation.  

Steps to Include Chart in Report 

1. The Query Sales data represents the summarized data for per quarter sale. The design of the query is 

displayed in Fig. 2.5.1. 
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Fig. 2.5.1. Sales Data Query 

2. Select Report Design from Create ribbon -> Reports tab. A blank report opens. 

3. Select Chart control  from Design ribbon -> Controls tab and draw it on the report. The Chart Wizard 

appears, as shown in Fig. 2.5.2. 

 

Fig. 2.5.2. Chat Wizard 
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4. Select the Queries option, and select Query: Sales Data from the list, as indicated in Fig. 2.5.3. 

 

Fig. 2.5.3. Select Queries Sales Data 

5. Click Next to advance. The Select Field window appears. Select all the fields: Category, Qtr, and Sales, as 

shown in Fig. 2.5.4. 

 

Fig. 2.5.4. Select required fields 
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6. Click Next to proceed. In the Choose Chart Type, select the Column Chart  and click Next.  

7. In Preview Chart window drag field Qtr to Axis, Category to Series and Sales to Data as shown in Fig. 

2.5.5. Click Next to advance. 

 

Fig. 2.5.5. Drag the fields to chart 

8. Specify the title for the chart and select the Display Legend option. Click Finish to close the window. 

9. The resultant chart appears, as shown in Fig. 2.5.6.  

 

Fig. 2.5.6. The Sales Data Report 
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NOTE: The chart object can be modified by right-clicking and selecting Chart Object -> Edit from the dropdown. 

Also, the chart object can be embedded with existing data in the report so that the chart changes with each 

record display. 

2.5.3 Printing Data in Columns 

Reports are a handy tool to represent data. The visibility of the reports makes an impact on how data can be 

viewed. Some of the reports may involve long lists of just a few fields of data—such as a phone or product list. 

These may be best arranged in multiple columns for better readability. 

While working with many databases, it is natural to come across some that consists of long lists of information. 

As a result, printing such data can mean printing a single column on many pages.  

The multiple columns for the report can be set using the Report Page Setup property and setting the number of 

columns to 2 or more, as shown in Fig. 2.5.7. 

 

Fig. 2.5.7. Select multiple columns from Page Setup 

2.5.4 Cancelling the Printing of a Blank Report 

If a report contains no records, the detail area of the report will be blank. While printing reports, it is not be 

advisable to print blank report. Macros can be used to cancel printing of a blank report and thus save time and 

effort. Depending on the availability of data, certain records may be absent in a report and printing a blank 

report would be meaningless.  
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To cancel previewing or printing of a blank report when the underlying query has been run with no records 

returned, the On No Data event of the report is used. 

2.5.5 Problem scenario 

The Database Developer has prepared a report CustOrders, which accepts the customer’sfirst name and 

displays all orders placed by the customer in the current quarter. However, most users while printing the report 

found that the even when the query returns no results, the report is printed. They requested the Database 

Developer to resolve the problem. 

Solution 

The report event On No Data can be used to cancel the printing of report when no data is returned. 

Steps for Canceling the Print 

1. Open the CustOrders Report in Design View. 

2. Press F4 to open the property sheet of report. Make sure that the report is selected in the Selection Type 

textbox. On the Event tab, select the property On No Data, as indicated in Fig. 2.5.8. 

 

Fig. 2.5.8. Property Sheet of Report 

3. Select  button of On No Data property.Choose Builder window appears. Select Macro Builder and click 

OK as shown in Fig. 2.5.9. 
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Fig. 2.5.9. Open Macro Builder 

4. In the Macro Builder window, select Action MsgBox and specify the value of message Arguments as No 

Records Found, Title as Customers Orders, as indicated in Fig. 2.5.10. 

 

Fig. 2.5.10. Specify MsgBox Action 
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4. Specify the second action as CancelEvent and click the Close button to close the Macro window. The 

confirmation message appears, as indicated in Fig. 2.5.11.  

 

Fig. 2.5.11. Confirm to close the macro 

5. Click Yes to save the macro and close the message window. The macro now appears on No Data event.  

6. Open the report and verify that the macro is working. 

2.6 Summary 

Forms and Reports are a crucial part of data representation in Access. Access provides various utilities to make 

Forms and Reports more user-friendly and presentable. Different controls can be added to forms to display the 

logo of the company, date and time, and pictures. Forms also permit the inclusion calculated values and combo 

boxes which make it much easier to handle the controls and present data to user. This control helps make data 

handling easier for the user. Access provides various ActiveX like calendar control to make forms more 

interactive. Sometimes, it is required to display the information on a form in groups. The tab control available 

with Access can be used for this purpose. The popular utility for summarizing data of Pivot Table to summarize 

data is also available in Access. 

Reports represent static data, but are a useful way of communicating. Reports in Access can be customized to 

user’s requirements including its header and footers. Another crucial feature available with reports is sub-

reports, which enable data linking in several tables. Apart from this, we can add charts and calculated controls 

to reports to make them more visible. The properties of reports can be used to avoid printing of blank reports.  

2.7 Lab Exercises 

Considering the Apex Inventory Shipment database of Apex Ltd. Provide a solution to the following problem 

scenarios: 

1. The Sales Manager of the company has demanded a form displaying the details of the orders, containing 

with Items ordered, Shipping Details and Invoice Information. Design the form Order Details as dis played in 

Figure below. Create tabs to represent the data.  
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 On the Order Details Form created in Question1 implement the Question 2 to 7:  

2. In the Order Details form, convert the Customer Textbox to Combo Box which contains Customer Number 

and Company Name. 

3. To make the Order Details form more user-friendly, add a calendar control to the form to select the Order 

Date.  

4. The Sales Manager asked the developer to add a logo of the company the Order Details form as the form 

will be circulated among all divisions.   

5. The database developer needs to make the form more presentable and has to add a picture on the 

background of each tab. Implement the needful. 

6. In the Order Details tab of the form, add a calculated value that calculates the Total Price as Qty * Unit 

Price – Discount as shown in Figure below: 
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7. The Sales Manager of the Company wishes to launch some sales promotional offers. He requested the 

database developer to create a form which should display the summarized count and cost of Orders place d 

by each customer on Quarter and month basis. He should also be able to view the same results for a 

particular category. Create a form containing Summary of Data. 

The developer of Apex Inventory Shipment database needs to create Item Sales report. The rep ort should 

be grouped by Category and then Item and should display quantity and price of Item sold. The report is 

displayed in Figure below: 

 

Implement the Questions 8 – 14 based on the report Item Sales. 

8. Add a calculated control Total Sales on the report that should display the Total Sales as Price * Quantity.  

9. Add a Page Header and Footer on the Report. The header must contain the logo of the company and 

Footer must contain the current Quarter and Month. 

10. Compute the Total Sales for each product in group footer. 

11. Include a pie chart in the Category group footer that should display the ratio of sales of each product in that 

category. The report should look like as in Figure below: 
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12. The details of the Sales of Item were to be presented in the Monthly meeting  as a hardcopy. So the 

Manager asked the executive to get the report into columnar format so that is more readable. Remove the 

Page Headers and the chart, and print the report in two columns.  

13. For the Annual review of the sales, the Vice President demanded a report displaying the product sales by 

month. The reports should display the products from a particular category, which is given by the user. The 

report should represent the data diagrammatically using charts. Create the required Report.  

14. The Sales Manager found that there are few categories which are not produced any more by the company 

but are not discarded in the report. As a result if such category is entered, a blank report gets printed. As a 

report administrator, cancel the printing of the blank report. 

Multiple Choice Questions  

1. The controls that are not linked to any field of the table or query on the form are known as ________.  

(a) ActiveX control 

(b) Unbounded Controls 

(c) Graphics Control 

(d) Bound Controls 

2. The Vice President of the Company wishes to add the image of the company vision statement as a 

background of all the forms. Which control can be used for the purpose? 

(a) Calendar Control 



 DESIGNING FORMS AND REPORTS  

 ADVANCED INFORMATION TECHNOLOGY 121 

 

(b) ActiveX control 

(c) Image Control 

(d) Graphics Control 

3. Which of the Header in reports can be viewed separately from the Footer?  

(a) Page Header 

(b) Group Header 

(c) Report Header 

(d) All of the above 

4. The Manager requested the developer to create a Inventory form in a manner such that the Product’s 

description is stored in one group, the cost and supplier information another group. Which is the best 

control to display the required information? 

(a) Use the Tab Control 

(b) Use SubForms 

(c) Add ActiveX Control 

(d) None of the above 

5. Which property of the form can be used to insert a background image? 

(a) Caption 

(b) Background 

(c) Record Source 

(d) Picture 

6. The Sales Executive while filling the details of the orders placed find it very difficult to type the name of 

each product every time it is ordered. They demanded that the form should provide them a drop down to 

select the product to be ordered. How can we implement the required? 

(a) Using the query in the form 

(b) Using the Combo Box control 

(c) Using a SubForm 

(d) Cannot be done 

7. The Calendar control can be selected from _______________ 

(a) Microsoft Office-> Access Options 

(b) Design -> Controls 

(c) Design -> Controls -> ActiveX controls 

(d) Create -> Forms 
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8. The Regional Sales Head demanded a summary report indicating the monthly sales done by each 

employee in each zone. Which kind of form is best to display the required data?  

(a) Use tabbed browsing 

(b) Insert an Image in form 

(c) Insert SubForm 

(d) Create Pivot Table  

9. To print the multi-columnar report, the number of columns can be set through _________ property.  

(a) Report property sheet 

(b) Page Setup  

(c) Report wizard 

(d) Grouping 

10. The persons from the delivery team found it very annoying that even when the reports contained no data, 

they are printed and they have to search for such reports among all the printed data. They requested the 

developer to find the solution to this problem. Which property of report can be used to implement the 

requirement? 

(a) CancelPrint 

(b) CancelEvent 

(c) Create a macro called On No Data 

(d) Create a macro called On Print 

11. To display the data of the Products and the orders placed for each product in the current month. The 

following feature available in Reports can be used. 

(a) Report Wizard 

(b) Nested Reports 

(c) Grouping 

(d) SubReports 

12. The Regional Head wishes to view the diagrammatic representation of data indicating the sales made by 

each zone in his region. Which feature can help to implement the requirement?  

(a) Graphics  

(b) ActiveX 

(c) Charts 

(d) Pivot Table 

13. To display the list of employees grouped according to first letter of their name, which type of controls can 

be used in reports? 
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(a) Use Calculated values in group 

(b) Add grouping control 

(c) Add Function control 

(d) Add ActiveX control 

14. Which property of the control is used to bind it to a field of a table or a query? 

(a) Data 

(b) Record Source 

(c) Field 

(d) None of the above 

15. Each tab in a tab control is known as _________. 

(a) Page 

(b) Data Tab 

(c) Control Page 

(d) Control 

16. The Sales Manager requested a summary form which should enable him to choose the category and 

display the monthly sale of each product in the category. In the created Pivot Table Form, The category 

field should be placed in which area? 

(a) Drop Row Fields Here 

(b) Drop Column Fields Here 

(c) Drop Totals or Detail Fields Here  

(d) Drop Filter Field Here 

17. A developer created a report displaying the information of customer grouped according to country and 

state. To add a count of customer in each state the count textbox should  be placed in which section of the 

report? 

(a) Page Footer 

(b) Report Footer  

(c) State Group Footer 

(d) Country Group Footer 

18.  The Sub Report in the main report can be inserted to _______________ hierarchy level?  

(a) 7 

(b) 3 

(c) 2 

(d) 4 
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3.1 Introduction 

Expressions in Microsoft Access can be considered similar to formulae in Microsoft Excel. Expressions are a 

combination of operands, operators, functions, and values that are evaluated according to their order of 

precedence. Expressions can be used with tables, queries, forms, reports, and macros. In Access, expressions 

are used to obtain calculated values, provide criteria, and query or supply constraint to table columns. Access 

also provides a powerful user interactive graphical tool to create expressions known as Expression Builder.  

In this chapter, we will discuss how to build criteria expressions in Access. We will also look at using various 

components of an expression for building query criteria. This chapter will also identify various operators 

available in Access. Next, we will discuss the available built-in functions in Access. We will discuss the different 

type of functions and their utilisation. Further, this chapter will cover how to use Expression Builder to create 

expressions using Objects, Functions, Operators, and Identifiers. 

3.2 Using Operands in Criteria Expressions 

Query criteria are the most important part of any query as they permit users to select only the desired records 

from an existing table. An operand is a value on which a calculation is performed. In other words, an operand is 

a data value that gets manipulated in the query expression. Operands can be literals, identifiers, or functions.  

3.2.1 Literals 

A literal is value that is not addressed by any name. It can be typed directly into the criteria expression. In 

Access, literal can be of type number, text, date, or logical value (i.e. True or False). Literals are also referred 

as constants as their values remain static throughout the evaluation of expression.  

Examples of literal:  

“Hello” + “ “ + “Everyone” , Here Hello and Everyone are Text literals  

 [Date] > #1/1/2011#, Here 1/1/2011 (1-Jan-2011) is a Date literal 

CHAPTER 

3 
 

LEARNING OBJECTIVES 

◼ Using operands in Criteria Expressions 

◼ Using built-in functions 

◼ Working with Expression Builder 
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3.2.2 Identifiers 

Identifiers are variables. In Access, identifiers represent field name, table name, or control name. Identifiers are 

a crucial part of expression building as they specify the column to which an expression represents.  While 

creating an expression in Access, identifiers are always represented in square brackets [ ].  

Examples of identifiers used in an expression: 

[Basic Salary] + [Tax]: Where Basic Salary and Tax are identifiers 

3.2.3 Functions 

Functions provide specialised operations to enhance the working of Access. Functions are built -in expressions 

that take an input, perform necessary calculations on it, and return the output.  The input accepted by the 

function is called arguments; a function may have one or more number of arguments. Access provides us 

different functions to work with different type of data, such as Text functions, Date and Time functions, Numeric 

functions, and Mathematical functions. 

For example, a text function Length takes an input string as an argument and returns the length of the string in 

number as: 

Length (“MS Access”) will return 9. 

3.2.3.1 Problem Scenario 

Apex Ltd. is launching a new production unit in “California”, which will also focus on some new products. To 

promote these products a detailed list of all existing customers from “California” (state code CA) is required.  

Solution 

To achieve this, a query displaying Name, Contact Info, and Address of the customers is required. To get only 

the customers from “California”, the value CA in the criteria for the state field needs to be specified.  Here, CA 

is a literal operand and is typed direct in query criteria.    

Steps for creating required query 

1. Click Create ribbon -> Other -> Query Design to open the Query Design window. 

2. Select Customers from Show Table and click Add, as displayed in Fig. 3.2.1. 
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Fig. 3.2.1. Show Table window 

3. Select the columns Salutation, First Name, Middle Name, Last Name, Company, Street City, State, 

Zip/Postal Code Phone, and Email from table Customers and drag them to the columns tab. The Query 

window appears, as shown in Fig. 3.2.2. 

 

Fig. 3.2.2. Select Required Columns 
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Now, we will add criteria to get records from “California”. 

4. In the Criteria tab of field State, write the literal “CA”, as indicated in Fig. 3.2.3. 

 

Fig. 3.2.3. Specify criteria for State 

5. Click Save  in the toolbar to save the query. Type the name of query as “Customers from California”. 

6. Click the Run sign in Design ribbon -> Results to view the results of the query, as shown in Fig. 3.2.4. 

NOTE: Literals are usually combined with operators to form complex expressions for query criteria. 

 

Fig. 3.2.4. Query Results 
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3.3 Using Operators in Criteria Expressions 

Operators make the expression complete. They are special symbols, such as +, -, used with operands to 

perform calculations. Every operator has a specific meaning and a symbol. Operators help create expressions 

with the combination of identifiers and values. Every operator is executed according to its priority. 

For example: In [BasicSalary] + [Tax], “+” is an operator. 

Different types of operators are: 

• Comparison operators 

• Arithmetic operators 

• Miscellaneous operators 

• Compound criteria and logical operators 

3.3.1 Comparison Operators 

Comparison operators, also known as relational operators, define relation between two identifiers or two values 

by comparing them. These operators can be used with Numeric or Date data type. 

Comparison Operators are listed in Table 3.1 

OPERATOR NAME EXPLAINATION 

> Greater Than Num1 >  Num2 returns true if  Num1 is greater than Num2 

< Less Than Num1 <  Num2 returns true if  Num1 is less than Num2 

>= Greater Than Equal 

to 

Num1 >= Num2 returns true if  Num1 is greater than or Equal to Num2 

<= Less Than Equal To Num1 <=  Num2 returns true if  Num1 is less than or equal to Num2 

<> Not Equal To Num1 <>  Num2 returns true if  Num1 is not equal to Num2 

= Equal To Num1 =  Num2 returns true if  Num1 is equal to Num2 

Table 3.1: Comparison Operators 

3.3.2 Arithmetic Operators 

Arithmetic operators, commonly known as mathematical operators, are used with numeric data to perform 

calculations. 
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Arithmetic Operators are displayed in Table 3.2. 

OPERATOR NAME EXPLAINATION 

+ Addition   

- Subtraction  

* Multiplication  

/ Divide  Returns integer as a result of division of integer numbers and 

decimal as a result of division of decimal numbers, that is, 5\2 will 

return 2.5 and 5\2.5 will return 2. 

\ Integer Divide  Returns integer as a result of division, that is, 5\2 will return 2 and 

5\2.5 will return 2. 

^ Exponentiation Computes power, that is, the result of 5^3 is 125. 

Mod Modulo Returns the remainder of the division of two integers, that is, 5/2 

will return 1. 

Table 3.2: Arithmetic Operator 

3.3.3 Miscellaneous operators 

In Access, a special set of operators is used with multiple data types. These operators provide an addit ional 

functionality to create expressions. Some of the miscellaneous operators are – LIKE, Between, IN, Is Null etc. 

3.3.3.1 The LIKE Operator 

The LIKE operator works with text or date data type. LIKE is used to match text patterns in the query criteria. 

This operator uses various wildcards to form different patterns. The various wildcards that can be used with 

LIKE are mentioned in Table 3.3. 

Wildcard Explanation Example 

* Denotes any number of 

characters (0 or more) 

LIKE ‘A*’ will match all the characters 

starting from A 

For example, Accounts, Audit 

? Denotes a single character LIKE ‘B??K’ will match all the text with 

B as first letter, k as last letter and 2 

letters in between. 

For example- Book, Back 

# Denotes a single digit LIKE ‘#ABC’ will match text which 

starts from a digit followed by ABC. 

[xyz] Denotes a set of characters LIKE [ABC]* will match all text starting 

from either A, B, or C. 

Table 3.3: Wildcards with LIKE operators 
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3.3.3.2 The Between… And Operator 

The Between operator is used with Numeric and Date data type to obtain a set of values within a specified 

range of values.  

For Example:  

Between 10 and 20 will give all the values within the range of 10 and 20 including 10 and 20.  

Between #1/1/2011# And #8/1/2011# will return all the dates between 1-Jan-2011 And 1-Aug-2011.  

(Note that dates are included between # and are written in “mm/dd/yyyy” format) .  

3.3.3.3 The IN operator 

The IN operator is used to match a value to a set of values given. This operator can be used with Numeric, 

Text, or Date data types.  

For Example: 

[Month] IN (‘Jan’, ‘Feb’, ‘Apr’, ‘May’) will match all the month values which are either from the specified values.  

3.3.3.4 The IS NULL operator 

The IS NULL operator is used to find the null records in table. We use IS with NULL to indicate all the record 

which are null in the table. Note: Null is not “0” or “blank”.  

For Example: 

[Discount] IS NULL will return all the records with [Discount] value as NULL. 

Similar to IS NULL, IS NOT NULL searches for non-null values.  

For Example: 

[Advance Amount] IS NOT NULL will return all records where [Advance Amount] is not null. 

3.3.4 The Logical Operators 

A logical operator results in expression that returns True or False. These operators are used to combine 

multiple expressions. They are also known as Boolean operators. 

The logical operators are listed in Table 3.4. 

OPERATOR NAME EXPLAINATION 

And Logical And Returns True if both the expressions compared are True 

Or Logical Or Returns True if either of the expressions compared is True 

Eqv Logical Exclusive Nor Return True if either both the expressions are True or both 

the expressions are False 

Xor Logical Exclusive Or Return True if either of the expressions is True 

Not Logical Not Works with a single expression and returns True if the 

expression is False 

Table 3.4: List of Logical Operators 
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3.3.5 Understanding the Operator Precedence 

Access permits to create complex expressions containing multiple operators. To evaluate these expressions, 

Access determines which operator to evaluated first, and then which is next, and so forth according to a 

predetermined order. This order is known as operator precedence. Every operator is assigned a precedence 

order and is calculated in the same order.  

The only exception to this rule is parenthesis (). Parentheses are used to group expressions and override the 

default order of precedence. Operations within parentheses are performed before any operations outside them. 

Within the parenthesis all operators are computed on basis of their precedence.  

Operator precedence is similar to BODMAS order that is followed in algebra. Parenthesis or brackets over here 

perform the same function to change the priority order of operators.  

Note: BODMAS =  

B Brackets first 

O Orders (ie Powers and Square Roots, etc.) 

DM Division and Multiplication (left-to-right) 

AS Addition and Subtraction (left-to-right) 

Operators are first preceded in the order of their category and then within each category each operator has its 

own precedence order. Operators precedence according to their category is displayed in Table 3.5, from the 

highest to the lowest. 

Operator Category Precedence Order 

Arithmetic I 

Comparison II 

Boolean III 

Table 3.5: Operator Precedence according to Category 

Table 3.6 displays precedence of each operator within different categories from the highest to the lowest.  

Category Operator Symbol Precedence Order 

Arithmetic    

 Exponentiation   ^ I 

 Multiplication and/or division (left to right) * , / II 

 Integer division \ III 

 Modulo Mod IV 

 Addition and/or subtraction (left to right) +, - V 
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Comparison    

 Equal = I 

 Not equal <> II 

 Less than < III 

 Greater than > IV 

 Less than or equal to <= V 

 Greater than or equal to >= VI 

    

Logical    

 Not  I 

 And  II 

 Or  III 

 Xor  IV 

 Eqv  V 

 Imp  VI 

Table 3.6: Operator Precedence within Category 

3.3.6 Using Compound Criteria 

Queries can help retrieve data in any form. Queries are usually created on multiple criteria, known as 

compound criteria. 

There are two types of compound criteria - “AND” and “OR.”  

3.3.6.1 AND Criterion 

In AND, compound criteria will return results only if each individual criterion is true.  

For example, if we add criteria to the query from the Customer table as: 

[State] = “CA” AND [Credit Limit] > 500000, it will return customers from California who have credit limit greater 

than 500000. 

The AND criteria in a query designer is specified by writing all the criteria in some row of the Criteria tab, as 

shown in Fig.3.3.1. 
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Fig. 3.3.1. Specifying AND compound criteria 

3.3.6.2 OR Criteria 

The OR compound criteria are used in queries where we need to match either of the criterion specified in query 

criteria. OR returns result even if any criterion is true.  

For example, if we add criteria to the query from the Customer table as: 

[State] = “CA” OR [Credit Limit] > 500000, it will return all customers who are either from California or who have 

credit limit greater than 500000. 

The OR criteria in a query designer is specified by writing all the criteria in different rows of the Criteria tab, as 

shown in Fig. 3.3.2. 
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Fig. 3.3.2: Specifying OR Compound Criteria 
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3.3.6.3 Problem Scenario 

This case study focuses on the operators discussed above and how to use them as a Criteria Expression.  

At the end of a quarter, Country Head of Apex Ltd. wishes to review the following data: 

• A report displaying all sales orders placed in from January to March 2008.  

• All inventory details from the “Car”, “Snowmobile”, and “Boat” categories along with the details of the order 

placed for them. 

• A list of all the products that were sold with a quantity greater than 5, or the price greater than 1000.  

• A contact list for all Customers whose first name starts with A, B, or C.  

Solution 

For creating the query containing the report of Sales Order, the query will be created on the Sales Order table, 

using “Between” and ”And” operator in query criteria. 

The inventory details query will contain the Inventory table and Sales Item Description. The query criteria will be 

based on the IN operator. 

For obtaining the list of products, query needs to be based on Inventory and Sales Item Description containing 

compound criteria. 

To retrieve the contact list of Customers, query will be based on the Customers table and the criteria for the first 

name will contain the LIKE operator.  

Steps for creating query containing the report of Sales Order 

1. Click Create ribbon -> Queries -> Query Design to open the Query Design window. 

2. Select the Sales Order table from the Show Table window and click Add, as shown in Fig. 3.3.3. 

 

Fig. 3.3.3. Show Table window 
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Select all the columns from the Sales Order table and drag them to the Columns tab. The Query window 

appears, as shown in Fig. 3.3.4. 

 

Fig. 3.3.4. Select Required Columns 

3. In the Criteria section of the Sales Date column, write the criteria BETWEEN 1/1/2008 AND 3/31/2008. Set 

the Sort order of column as Ascending, as shown in Fig. 3.3.5. 

NOTE: The Query Builder window formats the date with # sign.  

 

Fig. 3.3.5. Specify Query Criteria 



BUILDING CRITERIA EXPRESSIONS  

 ADVANCED INFORMATION TECHNOLOGY 137 

 

4. Click the Run sign in Design ribbon -> Results to view results, as shown in Fig. 3.3.6.  

 

Fig. 3.3.6. Query Result 

5. Click  on the toolbar to save the query. Type the name of query as “Sales Order QTR1”. 

Steps for creating inventory details query  

1. Click Create ribbon -> Queries -> Query Design to open the Query Design window. 

2. Select the Inventory and Sales Item Description table from the Show Table window and click Add, as 

shown in Fig. 3.3.7. 

 

Fig. 3.3.7: Show Table Window 
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3. Select Item Number, Category, Sub Category, Description, and Model from the Inventory table and drag 

them to the Columns tab. Similarly drag Sales Order Number, Quantity, Unit, and Price. The Query 

window appears, as shown in Fig. 3.3.8. 

 

Fig. 3.3.8: Specify Required Fields 

4. In the Criteria section of the Category column write the criteria IN (Car, Snowmobile, Boat), as shown in 

Fig. 3.3.9. 

 

Fig. 3.3.9: Specify Criteria for Column 
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5. Click  on the toolbar to save the query. Type the name of query as “Inventory Sales”. 

Steps for creating the query to obtain the list of products  

1. Click Create ribbon -> Queries -> Query Design to open the Query Design window. 

2. Select the Inventory and Sales Item Description table from the Show Table window and click Add. 

3. Select Item Number, Category, Sub Category, Description, and Model from the Inventory table and drag 

them to the Columns tab. Similarly, drag Sales Order Number, Quantity, and Price. The Query window 

appears, as shown in Fig. 3.3.10. 

 

Fig. 3.3.10. Specify Required Columns 

4. In the Criteria section of the Quantity column write the criteria > 5. In the next row, write the criteria for 

Price as > 1000. The Query design window should appear as shown in Fig. 3.3.11.  

NOTE: Since this is an OR compound criteria, both the criteria are written in different rows. 
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Fig. 3.3.11. Specify Compound Criteria 

5. Click  on the toolbar to save the query. Type the name of query as “Inventory Sales – Qty Price”. 

6. Click in Design ribbon -> Results to view the results, as shown in Fig. 3.3.12.  

 

Fig. 3.3.12. Query Results 
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Steps for creating query to retrieve the contact list of Customers  

1. Click Create ribbon -> Queries -> Query Design to open the Query Design window. 

2. Select the Customers table from the Show Table window and click Add. 

3. Select Customer Number, First Name, Last Name, Company, City, State, Country, and Phone from 

Customers and drag them to the Columns tab. The Query window appears, as shown in Fig. 3.3.13. 

 

Fig. 3.3.13. Specify Require Fields 

4. In the Criteria section of the First Name column write the criteria LIKE “[ABC]*”. The wildcard [ABC]* with 

operator LIKE specifies that it should match any string starting from A, B, or C.  Also set the sort order of 

the First Name field to Ascending. The Query Design window should appear as shown in Fig. 3.3.14. 
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Fig. 3.3.14. Specify Query Criteria 

5. Click  on the toolbar to save the query. Type the name of query as “Customers Contact List – ABC”. 

6. Click in Design ribbon -> Results to view the results, as shown in Fig. 3.3.15.  

 

Fig. 3.3.15. Query Results 

Many complex Criteria Expressions for a query can be created using the combination of operators and 

operands. Combining multiple criteria and different operators can help get the required data.  

3.4 Using the Built-In Functions 

Built-In Functions provide specialized operations to enhance the working of Access. We can perform 

mathematical, financial, comparative, and other operations using functions.  
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Some useful types of functions available in Access are: 

• Mathematical 

• Date/Time 

• Financial 

• SQL Aggregate 

• Text  

3.4.1 Using Text Functions 

Text functions are used to perform various operations on strings, such as manipulating strings , concatenate the 

string, extracting a portion of string.   

Some useful string functions are listed in Table 3.7. 

FUNCTION NAME EXPLAINATION EXAMPLE 

Left() Returns specified number of 

characters from left of the string 

Left(“Access”,3) will return Acc 

Right() Returns specified number of 

characters from right of the string 

Right(“Access”,3) will return ess 

Mid() Returns specified number of 

characters from the given position in 

string 

Mid(“Access”,2,3) will return 3 characters from 2 

positions, that is, cce 

Len() Returns the length of the given 

string 

Len(“Access”) will return 6 

 

Lcase() Converts the text to lower case Lcase(“ACCESS”) will return access 

Ucase() Converts the text to capital case Ucase(“access”) will return ACCESS 

Instr() Returns the position of first 

occurrence of a string in another 

string  

Instr(“Operations”,”ra”) will return 4 

Trim() Removes leading or trailing spaces 

in a text 

Trim(“  Acc ess    “) will return “Acc ess” 

Replace() Converts a substring from the given 

string into specified string  

Replace(“Account Transactions”,”Account”,”Daily”) 

returns Daily Transactions 

Strcomp() Compares two strings 

Returns  

0 if strings are same. 

1 if first string is greater the second. 

-1 If first string is less than the 

second. 

Strcomp(“Access”,”Access”) returns 0 

 

Strcomp(“Access”,”Training”) returns -1 as 

“Training” is greater than “Access” 

StrReverse() Returns the string in reverse order StrReverse(“access”) returns “ssecca” 

Table 3.7: Text Functions 
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3.4.2 Using Date and Time Functions 

These functions are used to handle Date and Time data. This group contains various functions such as 

extracting a part of date or adding two dates. 

Few of the important Date/Time functions, are shown in Table 3.8. 

FUNCTION NAME EXPLANATION EXAMPLE 

Now() Returns current date and time Now() 

Returns 07/18/2012 12:20:55 

Date() Returns current date Date()_ 

Returns 07/18/2012 

Time() Returns current time Time()_ 

Returns 12:30:15 

DateDiff() Returns difference two dates. The 

interval for difference  can be in terms 

of Days (“d”), months(“m”), Quarter 

(“q”), years(“yyyy”), weeks (“ww”) 

DateDiff (“m”,#7/18/2011#,#12/3/2011#) 

Returns 5 as the difference between two 

dates in terms of months is 5. 

DateAdd() Adds a specified interval to the given 

Date. Intervals in this can be used as 

same in DateDiff 

DateAdd(“q”,1,#1/11/2012#) will return 

4/11/2012  

As a Quarter added to January returns 

April. 

DatePart() Extracts a portion of a date from the 

given date 

DatePart(“ww”,#2/3/2012#) returns 6 

Month() Returns month in integer from the 

given date 

Month(#12/1/2011#) returns 12 

MonthName() Returns name of the month, that is, 

given as an integer 

MonthName(12) returns December 

Year() Returns year from a given date Year(#2/2/2012#) returns 2012 

Table 3.8: Date and Time Functions 

3.4.3 Using Math Functions 

Math functions are used for performing calculations on Numeric data. These functions provide us the property 

of performing various mathematical operations. 
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Some important mathematical functions are listed in Table 3.9. 

FUNCTION 

NAME 

EXPLANATION EXAMPLE 

Abs() Returns the absolute value of a number  Abs (14) returns 14 

Abs(-14) returns 14  

Fix() Returns the nearest integer for a negative number Fix(-125.64) returns -125 

Int() Returns an integer for a specific value Int(23.64) returns 23 

Round() Returns a number rounded to specified number of 

digits 

Round(18.234,2) returns 18.23 

Round(18.246) return 18.25 

Rnd() Returns any generated random number Rnd() returns any Random no. 

Sgn() Returns an integer representing sign of a number -

1 for –ve number 

1  for +ve number 

0  for Zero 

Sgn(-14) returns -1 

Sqr() Returns square root of a number Sqr(16) returns 4 

Log() Returns logarithm of a number  

Table 3.9: Math Function 

3.4.4 Using Financial Functions 

Financial functions are used to perform many standard financial calculations, such as interest rates, annuity or 

loan payments, and depreciation. 

Some extensively used financial functions are listed in Table 3.10. 

FUNCTION 

NAME 

EXPLAINATION EXAMPLE 

DDB() Returns the double-declining balance 

method of depreciation return based on the 

formula: 

Depreciation / period = ((cost  salvage) * 

factor) / life 

DDB(cost, salvage, life, period[, factor]) 

If we calculate depreciation for Rs.5, 000 

computer with a Rs.200 salvage value and 

an estimated useful life of three years for the 

first year. 

DDB(5000,200,3,1)  

FV() Returns the future value of an annuity based 

on periodic, fixed payment and fixed interest 

rate 

FV(Rate, Payment Periods, Payment [, 

Present Value] [, Type]) 

If we calculate Future value for a rate of 8% 

for 10 installments depositing an amount of 

Rs. 200 monthly. FV will be calculated as: 

FV(0.08/12,10,-200) 

PV() Returns the present value of an annuity PV (Rate, Payment Periods, Payment [, 
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based on periodic, fixed payments to be 

paid in future and fixed interest rate 

Future Value] [, Type]) 

To calculate Present value of an annuity that 

will provide 5,000 a year for the next 20 

years at a rate of .0825. We will use: 

PV(.08,5000,20) 

SYD() Returns the sum-of-years depreciation of an 

asset for a specific period 

SYD(Cost Of Asset, Salvage Value, Length 

Of Useful Life, Period) 

To calculate the depreciation charges of a 

building that cost 365820 to build has a 

salvage value of 5390, and an estimated 

useful life of 30 years. We will use function 

SYD as: 

 SYD(365820,5390,15,1) 

PMT() Returns the payment for an annuity based 

on periodic, fixed payment and fixed interest 

rate 

To calculate a payment amount for a 6 

percent loan of 360 months for 110000. The 

formula will be: 

 PMT(.005, 360, -110000) 

RATE() Returns the interest rate per period  Rate (nper, pmt, pv [, fv ] [, type ] ) 

To calculate interest rate on a Rs. 5,000 

loan where monthly payments of  Rs.250 are 

made for 2 years 

Rate(2*12,250,5000) 

Table 3.10: Financial Functions 

3.4.5 Problem Scenario 

The Operations Manager of Apex Ltd. received many complaints from customers about the orders not reaching 

them on time. He wants a report to be submitted for all the orders which were delayed (under normal cycle 

orders must be shipped within 7 days).  

Solution  

The required query will use the tables Sales Order, the criteria will be placed on shipped date using the 

DateDiff () function. 

Steps for creating a query 

1. Click Create ribbon -> Queries -> Query Design to open the Query Design window. 

Select the Sales Order table from the Show Table window and click Add. 

2. Select the columns Sales Order Number, Sold to Customer, Sales Date, Ship Date, Shipped Via . The 

Query window appears, as shown in Fig. 3.4.1. 
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Fig. 3.4.1. Select required column 

Specify the criteria for Shipped Date as DateDiff("d",[Sales Date],[Ship Date])>7. The DateDiff() function 

returns difference between two dates, “d” forces it to return it in terms of days. The query looks like, as shown 

in Fig. 3.4.2. 

 

Fig. 3.4.2. Specify Query criteria using Functions 

 



 ADVANCE DATABASE CONCEPTS 

148  ADVANCED INFORMATION TECHNOLOGY 

3. Click  on the toolbar to save the query. Type the name of query as Orders Delayed. 

4. Click in Design ribbon -> Results to view the results, as shown in Fig. 3.4.3.  

 

Fig. 3.4.3. Query Results 

3.5 Working with Expression Builder 

The Expression Builder tool in Access helps build complex expressions. It contains easy access to access 

names and properties of columns of the tables. Expression Builder also contains a set of predefined functions 

in Access and also some prebuilt expression as to display page numbers. 

The Expression Builder window is shown in Fig. 3.5.1. 

 

Fig. 3.5.1: Expression Builder Window 
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3.5.1 View of Expression Builder  

Expression box - A text box in which expressions are written. Any value from the Operators button or 

Expression Elements can be pasted into Expression Box. 

Operator buttons - Various operators are available in the Operators Buttons tab. We can just click any 

operator to get it in the Expression Box text box. 

 Expression elements – Expression element contains three tabs  

• First one is for the objects in the database like Tables, Queries, Forms, or Reports. 

• Second is for the sub elements of the objects selected in the First tab like fields of the table, containers in 

Reports and Forms. 

• Third is for the properties of the element selected in second tab.  

3.5.2 Complete view of all the three tabs in Expression Elements 

The first tab contains functions, the second contains different types of functions, and the third contains all the 

functions in a particular type. 

Click the Paste button to get any function in Expression Box, as shown in Fig. 3.5.2. 

 

Fig. 3.5.2. Three tabs in Expression Elements 

 



 ADVANCE DATABASE CONCEPTS 

150  ADVANCED INFORMATION TECHNOLOGY 

3.5.3 Problem Scenario 

Consider the case scenario discussed in section 3.3.4 database Apex Inventory Shipment.  The Marketing 

Manager of Apex Ltd., found that there were few orders which were prepared on time, but could not be sent 

because of customer details are not available. By mistake, a sales executive while typing has put a wrong 

customer number. Customer Number general format is XXX-0000, where X represents character and 0 

represents any digit. The executive has inserted five digits instead of four. List the names of all such customers.  

Solution  

For this query, again the Sales Order table needs to be used. The criteria would be formed using the text 

function Len (), length of Customer Number is normally 8 but would be 9 in this case. Expression Builder can be 

used to specify the criteria. 

Steps for second creating query 

1. Click Create ribbon -> Queries -> Query Design to open the Query Design window. 

2. Select the Sales Order table from the Show Table window and click Add. 

3. Select the Sales Order Number Sold to Customer, Sales Date, Ship Date, Shipped Via  columns.  

4. Right-click on the Criteria tab of the Sold to Customer column and select Build from the drop-down, as 

shown in Fig. 3.5.3. The build will open the Expression Builder window. 

 

Fig. 3.5.3. Select build from drop down 

5. The Expression Builder window appears, as shown in Fig. 3.5.4. 
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Fig. 3.5.4. Expression Builder window 

6. The expression in the criteria should be Len ([Sold to Customer]) > 8. To include the length () function, 

select Functions -> Built-In functions from first tab, Text on the second tab, and Len on the third tab from 

Expression Elements in Expression Builder, as displayed in Fig. 3.5.5. 

 

Fig. 3.5.5. Select Len function 
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7. Double Click the Len function to include expression in Expression Box, as shown as in Fig. 3.5.6. 

 

Fig. 3.5.6. Paste the expression 

8. Now the string which is a part of the Len () function must be replaced by field name. To do this select 

Table -> Sales Order from the first tab, Sale to Customer from the second tab in Expression Elements part 

of Expression Builder. 

9. Select the string argument of the Len () function and Double click to Paste the argument in Len() function. 

The column Name (Sale to Customer) will be pasted in place of string, the Expression Builder looks like as 

in Fig. 3.5.7. 
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Fig. 3.5.7. Place the required column as function argument 

10. Now click on > (Greater Than sign) from the Operators tab so that it gets pasted on Expression Box and 

write 3  after that so the Expression Builder window looks like as in Fig. 3.5.8. 

 

Fig. 3.5.8. The Complete expression 
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11. Click OK to save the expression. Note the written expression appears in criteria of the Sale to Customer 

field, as shown in Fig. 3.5.9. 

 

Fig. 3.5.9.  Expression appears in Criteria 

Click  on the toolbar to save the query. Type the name of query as “Sale to customer Criteria”. 

12. Click in Design ribbon -> Results to view the results, as shown in Fig. 3.5.10.  

 

Fig. 3.5.10. Query Results 

The Expression Builder makes it easier to remember function names and also avoids typing error in the name 

of the columns. The operators’ option can be used to place all the available operators in criteria expression.  

3.6 Summary 

This chapter focused on creation of criteria expressions in Access. The different components of the expression 

are – operators, operands, and functions. Operands can be considered as values used for performing 

operations. Operands can be further distinguished as literals, identifiers, and functions. Further, this chapter 

introduced different types of operators as – comparison, arithmetic, logical, and miscellaneous.  

Functions are built in code to help us work better with expressions. There are different types of functions 

available in Access to work with different data types. Various functions available are - Text Function, Date and 
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Time Functions, Math Functions, and Financial Functions.  

Expressions can be written directly or by using an interactive tool Expression Builder to create expression. 

Expression Builder has various tabs as Expression Box, Operator Buttons, and Expression Elements. 

3.7 Lab Exercises 

For Apex Inventory Shipment database of Apex Ltd. Provide a solution to the following problem scenarios: 

1. A sales executive while inserting records in the Sales Order table by mistake inserted the Sales Date with a 

previous year. For instance, instead of 1/2/2012, he typed 1/2/2011. Write an Update query to add 1 year to 

all the dates which were written in previous year. 

2. The Finance manager came to know that there had been a problem in receiving payments that were paid 

through Cheque or Electronic Card. Create a record set displaying all the invoices that were paid through 

Cheque, Master Card, or Visa Card. 

3. For year-end review, the Vice President of the Company needs a report displaying a list of all the 

customers, and value and count of the orders placed by them.  

 (To solve the above query create a Group By query on Customer, Sales Order, and Sales Item Description. 

Calculate the value of orders as Sum of Quantity and Price).  

4. Considering the query in question 3, a customer named James having Customer Number as END -0010 

wishes to pay his entire amount in monthly installments. Company charges an interest rate of 5% for the 

part payments. Calculate the amount that James has to pay as a monthly installment. (Use the PMT 

function). 

5. Display a list of all the orders which have not been shipped. (Check for orders w ith NULL Shipped Date). 

6. A sales person was trying to fetch all the customers from India from city – New Delhi, but he found that the 

city has been typed in many different ways. For instance New Delhi was also written as Delhi, N Delhi, or 

Old Delhi. Find all the records from table Customers which have country as India and contain ‘Delhi’ in city 

name. 

7. The Marketing Manager defined a standard format of creating Customer Code as XXX-0000 where XXX 

are first three letters of Customer’s Company and 0000 is a four digit numeric code for customer. This 

format was not followed by some executives. Find all the customers for whom first three letters of the 

Customer Number does not match first three letters of their Company Name.  

8. It was noticed that in the table Sales Item Description some values for Ship Qty are inserted as negative. 

Write a query to retrieve data having all the values of Ship Qty converted to positive and also the Price 

removing the decimal values. (Use math functions for the purpose).  

9. Display a list of all the inventory items which are to be reordered. (Check all the Inventory which have 

Reorder Point greater than Inventory in Stock + Inventory on Order).  

10. Considering the above query, retrieve a list of all the inventories which have not been ordered from past 

one month. (Make use of DateDiff and Date function) 
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Multiple Choice Questions 

1. For the Apex Inventory Shipment database, a list of orders placed ten months ago or more from the Sales 

Order table needs to be created. What would be appropriate query criteria for the Sales Date field? 

(a) DateValue(DateAdd(“yyyy”,-3,[Sales Date]) > Today() 

(b) >= 3 Months 

(c) Between 3 And 5 

(d) DateAdd("m",3,[Sales Date])<Date() 

2. Which record will be retrieved if the query criteria is < #1/1/11#? 

(a) All values less or more than 1,195 

(b) Value less than 95 characters 

(c) Records with date before 2011 

(d) All of above 

3. The query criteria on Shipped Date for deleting all the records from the Sales Order table which were 

shipped before April 2011 or were never shipped would be ____________? 

(a) ">=#4/1/2011# OR IS NULL 

(b) Month() = April  

(c) IS NULL 

(d) None of the above 

4. For the criteria BETWEEN 1/1/2011 and 12/31/2011, which rows will be displayed as result?  

(a) Display records between the dates 1/2/2011 and 1/1/2012 

(b) Display records between the dates 1/1/2011 and 12/31/2011 

(c) Display records whose dates equaled 1/1/2011 or 12/31/2011 

(d) All of the above 

5. In the criteria expression Total Amount Paid: [Tax] + [Freight] + [Other], which value is an Identifier. 

(a) Total Amount Paid 

(b) [Tax]  

(c) + 

(d) All of the above 

6. A report is needed to be prepared, checking all the orders that are pending to be shipped within one week. 

The criteria expression in Shipped Date can be? 
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(a) > Today() 

(b) < DateAdd(“d”,7,”[Shipped Date]) 

(c) > Date() + 7 

(d) = Now() 

7. The tab in Expression Builder in which we write expressions is known as _____________. 

(a) Expression Elements 

(b) Operator Button 

(c) Expression Box 

(d) Expression Builder window 

8. The criterion for the Category column in the Inventory table is IN (“Truck”, “Boat”, “Car”). This is equivalent 

to: 

(a) [Category] Like “Truck”,”Boat”,”Car” 

(b) [Category] = “Truck”,”Boat”,”Car” 

(c) [Category] = “Truck” AND [Category] = ”Boat” AND [Category] = ”Car”  

(d) [Category] = “Truck” OR [Category] = ”Boat” OR [Category] = ”Car”  

9. Among +, <>, MOD, AND, <= operator which operator has the highest priority. 

(a) + 

(b) MOD 

(c) AND 

(d) <> 

10.  The criteria expression LIKE?a*. 

(a) Will match all text starting from A 

(b) Will match all text ending from A 

(c) Will match all text having second character as A 

(d) Will match all text starting with a digit 

11. Which criteria would be used to find the records where the mode of payment is not known from Payments 

table? 

(a)  [How Paid] IS NULL 

(b) [How Paid] = “” 

(c) NOT IN [How Paid]  

(d) None of the above 
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12. The criteria [Sales Date] > #1/1/2011# XOR [Payment Terms] = “Cheque” will return records only when … 

(a) [Sales Date] is greater than 1-Jan-2011 And [Payment Terms] is “Cheque” 

(b) Either [Sales Date] is greater than 1-Jan-2011 Or [Payment Terms] is “Cheque”, but not both  

(c) [Sales Date] is greater than 1-Jan-2011 Or [Payment Terms] is “Cheque” 

(d) All of the above 

13. Consider the query on the Inventory table: 

 

 This query will return: 

(a) All records from Inventory table 

(b) All records from Inventory table having Quantity in Stock greater than 20 AND Quantity on Order > 

25. 

(c) All records from Inventory table except having Quantity in Stock less than 20 and Quantity on Order 

> 25. 

(d) All records from Inventory table having Quantity in Stock greater than 20 OR Quantity on Order > 25.  

14. The Mid(“Apex Limited”,5,4) function will return 

(a) Apex 

(b) Ted 

(c) Limi 

(d) Apex Limited 

15. The SGN() function is a ____________ type function: 
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(a) Math 

(b) Financial 

(c) Text 

(d) Date & Time 

16. The expression to combine first three characters of Customer First Name and last four characters of Sales 

Order Number placed by customer will be: 

(a) [First Name] + [Sales Order Number] 

(b) [First Name] & [Sales Order Number] 

(c) Left([First Name],3) + Right([Sales Order Number],4) 

(d) Left([First Name]) + Right([Sales Order Number]) 

17. The expression 3\4 will return 

(a) 0.75 

(b) ¾ 

(c) 0 

(d) None of the above 

18. The Instr(4, “XXpXXpXXPXXP" , “P”) function will return 

(a) 3 

(b) 6 

(c) 9 

(d) None 

19. Which of the following is not a Date Time function? 

(a) Today() 

(b) Date() 

(c) Now() 

(d) MonthName() 

20. A query with compound criteria, where both the criteria are written on the same row of two different fields. 

This will be creating_____________ compound criteria? 

(a) OR compound criteria 

(b) AND compound criteria 

(c) XOR compound criteria 

(d) EQV compound criteria 
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4.1 Introduction 

A macro allows you to automate tasks and add functionality to your forms, reports, and controls. Access macros 

let you perform defined actions and add functionality to your forms and reports. Macros in Access can be 

thought of a graphical and a simpler way to do programming. Every macro has a list of actions and arguments 

defined for each action. Macros can be used independently or attached to a form, report, or control events. 

Arguments provided in a macro can restrict, validate, or automate data entry. Microsoft Access has added new 

features to macros to eliminate the need to writing VBA code. 

Switchboards are forms available in Access to present data in the form so that users can focus on using the 

database as intended. A switchboard form presents the user with a limited number of choices for working with 

the application and makes the application easier to use. For example, a switchboard may give choice to open 

the tables, forms, and open or print reports. 

4.2 Simplifying Task with Macros 

In Access, macros can be considered as a simplified version of VBA programming. Macros are used to execute 

any task that can be initiated with the keyboard or the mouse. Macros are written by specifying a list of to 

perform and providing arguments for these actions. Access provides enables macros so that they can automate 

responses to many types of events (events can be change in the data, the opening or closing of a form or a 

report, or even a change of focus from one control to another) without forcing actually using  a programming 

language.  

CHAPTER 

4 
 

LEARNING OBJECTIVES 

◼ Simplifying Task with Macros 

❑ Creating a Macro 

❑ Attaching a Macro 

❑ Restricting Records Using a Condition 

❑ Validating Data Using a Macro 

❑ Automating Data Entry Using a Macro 

◼ Managing Switchboards 

❑ Creating a Database Switchboard 

❑ Modifying a Database Switchboard 

❑ Setting the Startup Options 
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4.2.1 Creating a Macro 

In Access, macros can be created using the Macro Design window. This window can be opened by clicking 

Create → Other → Macro, as shown in Fig. 4.2.1 

 

Fig. 4.2.1 Create New Macro 

The Macro Design window is displayed in Fig. 4.2.2. 

 

Fig. 4.2.2. Macro Designer Window 

In the new Macro Designer for Access, the layout more closely resembles a text editor. Actions and conditional 

statements displayed in a familiar top-down format that is used by programmers. Arguments are displayed 

inline in a dialog box as shown in Figure.4.2.3 
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Fig. 4.2.3: Macro Designer Window 

Adding a new action or conditional statement is simple. Either select it from the actions drop -down list, from a 

right-click menu, or select it from the Action Catalog pane as shown in Fig. 4.2.4 to the right side of the Macro 

Designer. 

 

Fig. 4.2.4: Action Catalog 
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Actions Catalog: Actions are the basic building blocks of macros. MS Access provides a Action Catalog pane 

that contained large list of actions to be chosen, enabling a wide range of commands that can be performed.  

Some of the commonly used actions are: open a report, find a record, display a message box, or apply a filter 

to a form or report. A list of some commonly used actions in macro is displayed in Table 4.2. 

Action Description 

ApplyFilter Applies a filter or query to a table, form, or report. 

CancelEvent Cancels the event that caused the macro to run. 

Close Closes the specified window or the active window, if none is specified. 

CopyObject Copies the specified database object to a different Microsoft Access database or to 

the same database with a new name. 

DeleteObject Deletes the specified object or the object selected in the Database window, if no 

object is specified. 

Echo Hides or shows the results of a macro while it runs. 

FindNext Finds the next record that meets the criteria specified with the most recent 

FindRecord action or the Find dialog box. Use to move successively through 

records that meet the same criteria. 

FindRecord Finds the first or next record that meets the specified criteria. Records can be found 

in the active form or datasheet. 

GoToControl Selects the specified field on the active datasheet or form.  

GoToPage Selects the first control on the specified page of the active form. 

GoToRecord Makes the specified record the current record in a table, form, or query. Use to 

move to the first, last, next, or previous record. 

Maximize Maximizes the active window. 

Minimize Minimizes the active window. 

MoveSize Moves and/or changes the size of the active window. 

MsgBox Displays a message box containing a warning or informational message.  

OpenForm Opens a form in the Form view, Design view, Print Preview, or Datasheet view. 

OpenModule Opens the specified Visual Basic module in the Design view. 

OpenQuery Opens a query in the Datasheet view, Design view, or Print Preview. 

OpenReport Opens a report in the Design view or Print Preview or prints the report immediately. 

OpenTable Opens a table in the Datasheet view, Design view, or Print Preview. 

OutputTo Exports the specified database object to a Microsoft Excel file (.xls), rich -text file 

(.rtf), text file (.txt), or HTML file (.htm). 

PrintOut Prints the active database object. You can print datasheets, reports, forms, and 

modules. 

Quit Quits Microsoft Access. 
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Rename Renames the specified object. 

Requery Forces a re-query of a specific control on the active database object.  

Restore Restores a maximized or minimized window to its previous size. 

RunApp Starts another program, such as Microsoft Excel or Word. 

RunCode Runs a Visual Basic Function procedure. 

RunCommand Runs a command from Microsoft Access's menus. For example, File Save. 

RunMacro Runs a macro. 

RunSQL Runs the specified SQL statement for an action query. 

Save Saves the specified object or the active object, if none is specified.  

SelectObject Selects a specified database object. You can then run an action that applies to that 

object. 

SendObject Sends the specified database objects as an attachment in an e-mail. 

SetValue Sets the value for a control, field, or property on a form or report.  

SetWarnings Turns all system messages on or off. This has the same effect as clicking OK or Yes 

in each message box. 

StopAllMacros Stops all currently running macros. 

StopMacro Stops the currently running macro. Use to stop a macro when a certain condition is 

met. 

TransferDatabase Imports or exports data to or from the current database from or to another database.  

TransferSpreadsheet Imports data from a spreadsheet file into the current database or exports data from 

the current database into a spreadsheet file. 

TransferText Imports data from a text file into the current database or exports data from the 

current database into a text file. 

Table 4.1: Macro Actions 

4.2.1.1 Problem Scenario 

Kanika Mathur, a sales executive in Apex Ltd. is required to send a detailed report of all the orders that have 

been placed today to the Sales Head every evening in a form of an Excel sheet, also the same sheet also has 

to be uploaded in a shared folder for delivery to check. She thought to automate the process of transferring 

records so as to save the efforts required. 

Solution 

As a solution to the above problem, create a macro that transfers the table Orders into Excel and stores it in a 

shared folder using the TransferSpreadSheet Action. Then, use Send Object Action to mail it to the Sales Head.  

Steps for creating the macro 

1. Open Macro Designer. Click Create → Macro & Code → Macro. 
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2. Click AddNew Action drop-down box → Select ExportWithFormatting.Note that the 

ExportWithFormatting option will also be available in Action Catalog. The Macro Designer window 

appears, as shown in Fig. 4.2.5. 

 

 

 

 

 

 

 

 

 

 

 

 

 

Fig. 4.2.5 : Select Export with Formatting Action 

3. When we select an action that needs more than one argument, it would appear, followed by a box for each 

argument as shown in Fig. 4.2.6. 

 

Fig. 4.2.6 : Box for each argument and type necessary values 

Object Type  : Table 

Object Name :  Orders 

Output Format :  Excel Workbook (*.xlsx) 
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Output File :  C:\Desktop\Order.xlsx 

NOTE: Output File Name should include the complete absolute path of the shared folder. Macro Designer 

appears, as shown in Fig. 4.2.6.   

4. Select the next action in the Query Designer window as EmailDatabaseObject and specify Action 

Arguments, as shown below in Fig. 4.2.5: 

5. Fig. 4.4: Action SendObject 

Object Type :   Table 

Object Name :   Orders 

Output Format : Excel Workbook (*.xlsx) 

To :    SalesHead@Apex.com <email of Sales Head> 

Cc : 

Bcc : 

Subject :  <Subject line for the mail> 

Message Text :  <Message to be sent along with attachment>  

Edit Message :   No (Select Yes to edit message before sending> 

Template File :  <template file for output to be generated> 

NOTE:  The EmailDatabaseObject action can only be used if the Outlook is configured and is open. The 

To, Cc, Bcc, Subject, Message Text options can be set according to the requirement.  

6. Click Quick Access → . The window prompts for the name of the macro, write the name of macros as 

MailCurrentOrders and click OK. Close the Macro Design window. 

7. Double-click the Macro Name under the Macro option in the All Access Objects tab to execute it.  

 

Fig. 4.2.7: EmailDatabaseObject Macro 

All Macros are saved automatically in default name. 

mailto:SalesHead@Apex.com
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Macro Builder can use many actions in a single macro or create multiple macros in one macro designer by 

using macro names. Macro can also be assigned shortcut keys using the AutoKeys macro. 

4.2.2 Attaching a Macro 

A macro can be attached to an event of a control, a form, or a report. Macros are used to provide an added 

functionality to Access Objects. Macros can automate responses to many types of events without using a 

programming language. Events are the property of a form or a control. Macros are always attached to one 

event or another to perform some action. To view the events for a control, open its Property window and move 

to the Events tab as shown in Fig. 4.2.8. For example, if a button on a form is required to print a report, a macro 

which opens a report in print preview from can be attached to click event of the button.  Access permits to 

create macros embedded to the control or attach an existing macro to events. 

 

Fig. 4.2.8: Events in Form Properties 
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4.2.2.1 Problem Scenario 

Consider the problem scenario discussed in section 4.2.1. Now the same functionality is required to be added 

to the Orders form. This means that the Orders form should have a button that enables the user to export and 

mail the table. 

Solution 

Consider the form frmOrders which is based on Orders table, as shown in Fig. 4.2.9. 

 

Fig. 4.2.9: Orders Form 
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Now, add a button on the form and attach a macro to the click event of the button. Macro is the same as 

created in section 4.2.9 and exports and mails the list. 

1. Open the Orders form in the Design view. To do this, right-click the form and select Design View from the 

list. 

2. To add a button to the form, select Design -> Controls → button to be added and draw it on the form, as 

shown in Fig. 4.2.10. Cancel the Command Button wizard that appears.  

 

Fig. 4.2.10: Draw the button on the form 

NOTE: The Command Button wizard may not appear if Use Control -> Controls in Design is not selected.  

 

Fig. 4.2.11: Use Control Wizards option 
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3. Open the control properties by selecting the Command button and press F4. Alternatively, select Property 

Sheet from Design -> Tools, as shown in Fig. 4.2.12.  

 

Fig. 4.2.12: Select Property Sheet 

4. The Property window appears as shown in Fig. 4.2.13. 

 

Fig. 4.2.13: Property Sheet for Button 

5. In the Format tab of Property Sheet, set the value of the Caption property to Export And Mail as shown in 

Fig. 4.2.14. 
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Fig. 4.2.14: Set Caption Property 

6. In the Event tab of the Property Sheet, set the value of the On Click event. To do this, click  to open 

the list and select MailCurrentOrders, as shown in Fig. 4.2.15. 

 

Fig. 4.2.15: Set the On Click event Property 

NOTE: A macro embedded to the control can also be created, by clicking on  button and selecting Macro 

Builder from the Choose Builder window that appears, as shown in Fig. 4.2.16. 

Command24 
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Fig. 4.2.16: Create an embedded Macro 

7. The form appears as shown in Fig. 4.2.17; the macro will be executed on clicking the Export And Mail 

button. 

 

Fig. 4.2.17: Click Button to execute the Macro 

Command24 
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Multiple macros can be created in a single Macro Designer window by giving each macro a different name and 

can be attached to an event of form or control by specifying their name.  

4.2.3 Restricting Records using a Condition 

A macro condition is an expression that enables a macro to perform certain tasks only if a specific situation 

exists. When a condition is used in a macro, the macro performs a defined set of tasks depending on whether 

the expression returns the True or False value. When the expression returns True, all the act ions are 

performed. When the expression returns False, none of the actions are performed. Conditions can be entered 

in the Conditions column of the Macro Builder window. A single condition can control more than one action.  

4.2.3.1 The Where Condition 

The Where condition filters and selects records in reports or forms and their underlying tables or queries. This 

condition is applicable as an argument for the macro actions OpenForm and OpenReport. The Where condition 

is an Action Argument for macro actions such as OpenForm or OpenReport. For example, the Where condition 

specified for an OpenForm action can be used to compare and display matching records from two related 

forms.  

4.2.3.2 Problem Scenario 

In the Database Apex Inventory Shipment, as an enhancement to the Orders form created in Section 4.2.2, the 

Manager wishes to see the details of the Customer who has placed the order.  

Solution 

As a solution to the above requirement, a command button will be added to the form. On the click event of the 

command, a macro will be created that displays the Customers form restricted to the Customer Number for the 

order. 

For the purpose of displaying the customer information the frmCustomers form is created based on the 

Customers table, as shown in Fig. 4.2.18. 

 

Fig. 4.2.18: Form frmCustomers 



 ADVANCE DATABASE CONCEPTS 

174  ADVANCED INFORMATION TECHNOLOGY 

Steps for adding a button to frmOrders 

1. Open the frmOrders form in Design view. To do this, right-click the frmOrders form under the All Access 

Objects tab and select Design View from the list. The form opens in Design View, as shown in Fig. 4.2.19. 

 

Fig. 4.2.19: Open form frmOrders in Design View 

2. To add a button to the form, select the button from Design -> Controls and draw it on the form, as shown 

in Fig. 4.2.20. Cancel the Command Button wizard that appears.  
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Fig. 4.2.20: Draw Command Button on Form 

3. Open the control properties by selecting the Command button and pressing F4. Set the value of Caption 

property as View Customer Details, as shown in Fig. 4.2.21. 
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Fig. 4.2.21: Set Caption Property 

Steps for embedding a macro to On Click event of the command button 

4. In the Event tab of Property Sheet, set the value of the On Click event. To do this, click  next to the On 

Click property. The Choose Builder window appears, as shown in Fig. 4.2.22. 
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Fig. 4.2.22: Open the Choose Builder window 

5. In the Choose Builder window, select Macro Builder from the list and click OK. The Macro Designer 

window appears, as shown in Fig. 4.2.23(A). 
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Fig. 4.2.23(A): Macro Designer window 

6. In the Add New Actions Dropdown list, select the OpenForm Action from the list.  Set the value of Action 

arguments as shown in Fig 4.2.23(B): 

 

Fig 4.2.23(B): Fill the arguments of OpenForm Action 
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 Form Name  :   Customers 

 View :   Form 

 Filter Name :   

 Where Condition : [Customer Number]=[Forms]![Orders]![Sold to Customer] 

 Data Mode :   Yes 

 Window Mode :   

7. Click Design -> Close -> Close, as shown in Fig. 4.2.24(A). 

 

Fig. 4.2.24(A): Close the macro 

8. A message box appears prompts to save the macro created, as shown in Fig. 4.2.25(B). Click Yes to save 

the macro. 

 

Fig. 4.2.25(B): Confirm to save the macro 
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9. The created macro gets embedded in the Property window and is shown in the On Click property. The 

Property Sheet appears, as shown in Fig. 4.2.26. 

 

Fig. 4.2.26: Property Sheet 

10. To check the macro, open the frmOrders form in Form View and click the View Customer Details button. 

This should display the frmCustomers form only with the record of current customer, as indicated in 

Fig. 4.2.27. 

 

Fig. 4.2.27: Customer Records restricted by Orders form. 
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4.2.4. Validating Data using a Macro 

Microsoft Access provides a variety of ways to control how data is entered in a dat abase. For example, the data 

that a user can enter into a field can be limited to a range of values or to the format in which it must be entered.  

The validations can be defined at the table level by specifying table properties or the validation can be don e at 

the form level. To validate data entry in a form, the properties of the controls may be used or alternatively all 

these validations can be defined using macros. Macros provide a good flexibility to place complex validation. 

Macros are useful for validating records when: 

• Validation rule is to be applied on multiple fields in the form or to same field in different forms.  

• To display customized error messages for different types of errors in the field.  

• Instead of Validation Rule, it must be just a warning message.  

• The validation involves references to controls on other forms or contains a function.  

Table 4.2 lists some control events on which macro can be attached for Data Validation.  

Event Property When the Macro Will Execute 

Before Update  Before the entered data is updated. 

After Update  After the entered data is updated. 

Before Insert  After you type in a new record. 

On Delete  In response to a deletion request, but before the record is 

deleted. 

Table 4.2: Event Property 

Table 4.3 lists some macro actions that can be used as a response to validation.  

Action Use Action To 

Cancel Event  Prevents a user from posting a new record unless certain 

conditions are met. 

GoToControl  Specifies where on the form the insertion point is to be placed. 

MsgBox  Displays a custom message box. 

Table 4.3: Macro Actions for Data Validation 

4.2.4.1 Problem Scenario 

Consider the frmOrders form created in Section 4.2.2. Rahul Sharma, the database developer in Apex Ltd. is 

asked to place a check on the Item Number field. It is to be ensured that Item Number should not be left blank.  
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Solution 

 To solve the above problem, a macro will be embedded on the Click event property of the Save Command 

Button. This macro will check if the Item Number is blank and will display a message accordingly. 

Steps for Validating Item Number 

1. Open the frmOrders form in Design View. To do this right-click the frmOrders form under the All Access 

Objects tab and select Design View from the list.  

2. Add a button to the form by selecting the button from Design -> Controls and draw it on the form. Cancel 

the Command Button wizard that appears.  

3. Open the control properties by selecting the Command button and pressing F4. Set the value of the 

Caption property as Save, as shown in Fig. 4.2.28. 

 

Fig. 4.2.28: Set the caption property as Save. 

4. In the Event tab of Property Sheet, set the value of the On Click event. To do this, click  to the right 

side of the On Click property and open the Choose Builder window.  

5. Select Macro Builder from the list in the Choose Builder window, as shown in Fig. 4.2.29. Click the OK 

button. 
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Fig. 4.2.29: Open Macro Builder 

6. In the Macro Designer window that appears, add the conditions from selecting If from Add New Action 

Menu as displayed in Fig. 4.2.30. 

 

Fig. 4.2.30: Add Condition 

7. In the Condition Argument textbox of the Macro Designer type the text [Item Number] IS NULL, this 

condition checks whether the Item Number value is blank. 

8. In the Add New Action Dropdown, select the CancelEvent action from the list. The Query Designer window 

appears, as shown in Fig. 4.2.31. 
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Fig. 4.2.32: Specify Condition & Action 

9. In the next row, type … in the Condition tab. In the Action tab, select MsgBox from the list and specify 

Action Arguments as: 

Message    :  Item Number cannot be left Blank 

Beep   :  Yes 

Type   :  Warning? 

Title   :  Validate 

10. In the next row, type … in the Condition tab. In the Action tab, select GoToControl from the list and specify 

Action Arguments: 

Control Name  :  Item Number  

     The Macro Designer window appears, as shown in Fig. 4.2.33. 

 

Fig. 4.2.33: Specify GoToControl Action 

11. Click Design -> Close -> Close, as shown in Fig. 4.2.34. 
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Fig. 4.2.35: Click Close to save and close the macro 

12. A message box appears prompting to save the macro created, as displayed in Fig. 4.2.36. Click Yes to 

save the macro. 

 

Fig. 4.2.36: Confirm to Save the macro 

Note that the created macro gets embedded in the Property window and is shown in the On Click property. 

Property Sheet appears, as shown in Fig. 4.2.37. 

 

Fig. 4.2.37: Property Sheet 
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13. To check the macro, open the frmOrders form in Form View and enter a new record with the values, as 

shown in Fig. 4.2.38. 

 

Fig. 4.2.38: Enter a New Record 

14. Click the Save button to save the record. Since the Item Number field is left blank the macro gets 

executed and the message is displayed, as shown in Fig. 4.2.39. 

 

Fig. 4.2.39: Macro Executes 
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Note that the multiple conditions and their post actions can be specified in the same macro; specifying the 

validation rule for other fields also.  

4.2.5. Automating Data Entry Using a Macro 

Macros can be used to avoid errors and save time during data entry by automating the data entry process. 

Instead of having users type in the same data over and over for each record with the possibility of invalid data 

being entered, a macro can automate data entry. Microsoft Access Macros can be used to speed up the 

process of data entry. While automating the entry of data, it can be ensured that the possibility of errors in 

database data is minimized, which can have an impact on the accuracy of the data available for reports and 

queries.  

Macros can also be used for data entry where the value to be entered is dependent on value of other fields. For 

Example, a macro can be created to enter the total cost of an order if the unit price and quantity to be ordered 

of an item is provided.   

Table 4.4 lists the common events that can be used for Automating Data Entry. 

Event Property  When the Macro Will Be Executed 

On Enter  Upon arriving on a control, but before the control has 

focus. 

Before Update  Before the control data is updated. 

After Update  After the changed control data is updated. 

On Exit  Upon leaving a control, but before the focus is removed. 

Table 4.4: Event for Automating Data Entry 

Table 4.5 specifies macro action used for Automating Data Entry. 

Action Description 

SetLocalVar Enters a value automatically in a field. The field name and the 

value that needs to be entered in the field are mentioned as 

arguments. You need to enter the arguments in the Action 

Arguments pane for this action. 

GoToControl Specifies the field where the insertion point needs to be 

moved after a value. 

Table 4.5: Macro Actions for Automating Data Entry 

4.2.5.1 Problem Scenario 

 In the frmOrders form discussed in section 4.2.2, the Operational Manager wishes to see the total cost of the 

order, which would be computed as Quantity ordered * price of an Item. 
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Solution 

A text box as Total Order Cost is added to the form, and a macro is created on the Exit event of price to 

compute the total cost of an order. This macro first checks the value of Quantity is not null and then computes 

Total Cost. 

Steps for creating a macro to automate data entry 

1. Open the frmOrders form in the Design view. Add a TextBox to a form, select the TextBox control from 

Design -> Controls and draw it on the form, as shown in Fig. 4.2.40. 

Note that the TextBox also creates a label on the form so as the label to the Text value can be specified. 

 

Fig. 4.2.40: Draw the TextBox on form 
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2. Double-click the label and write the text Total Cost. Change the format of the label to match it with other 

controls. In this case, set the format as “Times New Roman, size 12, Bold”. The Form Design window 

appears, as shown in Fig. 4.2.41. 

 

Fig. 4.2.41: Specify the text as Total Cost 

3. Open the control properties by selecting TextBox and pressing F4. In the All tab of Property Sheet, set the 

value of the Name property as “Total Cost”, as shown in Fig. 4.2.42. 
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Fig. 4.2.42: Set the Name property 

4. In the Event tab of Property Sheet, set the value of the On Click event. To do this, click  to the right 

side of the On Click property and open the Choose Builder window.  

5. Select Macro Builder from the list in the Choose Builder window, as shown in Fig. 4.2.43. Click the OK 

button. 

 

Fig. 4.2.43: Open Macro Builder 

6. In the Macro Designer window, add the Conditions tab by selecting Condition from Design -> Show/Hide. 
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7. In the Condition tab of the Macro Designer type the text [Quantity] Is Not Null, this condition checks if the 

Quantity value is blank. 

8. In the Action drop down, select the SetLocalVar action from the list. Set the value of Action arguments as: 

Name :  Name of the local Vatriable 

Expression :  [Quantity] * [Price] 

      The Query Designer window appears, as shown in Fig. 4.2.44. 

 

Fig. 4.2.44: The Macro Designer window 

9. Click Design -> Close -> Close to save and close the macro. A message box appears prompting to save 

the macro created, as displayed in Fig. 4.2.36. Click Yes to save the macro. 

 

Fig. 4.2.45: Click Yes to save the macro 

10. The created macro gets embedded in the On Exit event property of the Price TextBox control. Property 

Sheet appears, as shown in Fig. 4.2.46. 
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Fig. 4.2.46: Property Sheet 

11. Open the frmOrders form in Form View and enter a new record with the values, as shown in Fig. 4.2.47.  

 

Fig. 4.2.47 : Insert a new record in frmOrders 
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12. As you enter the value for price and move to the next textbox, the On Exit event of the Price control gets 

executed and the total cost is calculated, as shown as Fig. 4.2.48. 

 

Fig. 4.2.48: Automated Data Entry for Total Cost 

4.3 Managing Switchboards 

A switchboard is a Microsoft Office Access form that facilitates navigation in Access and access to different 

parts of an application. It functions as an interface between the user and the application. A switchboard is 

similar to the Ribbon of the Access application. It provides users with direct access to the specific functions of 

the application and acts as an interface between the user and the application.  

Switchboard contains command buttons that execute specified actions. These buttons can be programmed to 

open forms, reports, queries. Each button on the switchboard triggers some action within the database or leads 

to another switchboard form. Switchboard forms are an invaluable way to keep users focused on using the 

database as intended. 

A switchboard form presents the user with a limited number of choices for working with the application and 

makes the application easier and user specific to use. The user’s login information can determine which of a 
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number of switchboard forms to use. For instance, a manager with a higher level of privileges may be given a 

form with more options than a clerical worker would be given. 

4.3.1. Creating a Database Switchboard 

The Switchboard Manager is a dialog box that allows creating a switchboard for an Access database. It lists the 

switchboards currently available in a database and provides an option to create new ones. In each switchboard, 

command buttons can be added, deleted, or edited. The command buttons can be configured for accessing 

forms, reports, macros, or functions in the database. Switchboard Manager only allows a maximum of eight 

command buttons on a switchboard. The operations that the command button on switchboard can perform are 

listed in Table 4.6. 

Command Action performed 

Go to Switchboard Opens a secondary switchboard. 

Open Form in Add Mode Opens a form in a mode that only allows new records to be added.  

Open form in Edit Mode Opens a form in a mode that allows any record to be added or edited.  

Open Report Opens a report in Print Preview. 

Design Application Opens the Switchboard Manager. 

Exit Application Closes the current database. 

Run Macro Runs a macro. 

Run Code Runs a Visual Basic function. 

Table 4.6: Different Commands that Switchboard can perform 

When a switchboard is created with Switchboard Manager, Access creates the Switchboard Items table that 

describes what the display text and action performed by the buttons on the Switchboard form. 

4.3.1.1 Problem Scenario 

Employees of Apex Ltd. need to keep updating the company database frequently for various reasons. However, 

employees are confused over the interface that appears when the application is started. The application 

developer wishes to resolve this confusion by providing a clear and concise environment in which users can 

reduce the amount of time spent figuring out how to obtain the information they are looking for. 

Solution 

To resolve the problem of navigation in the database, a Switchboard form that contains buttons to open the 

Customers and Inventory tables and the frmOrders form needs to be created. 

Since switchboard is not capable of opening the tables directly through the Command button, so we have 

created macros to open the Customers and Inventory tables named as MacroCust and MacroInvent 

respectively. The structure of macros is displayed in Fig. 4.3.1. 

javascript:AppendPopup(this,'AcMacro_1_1')
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Fig. 4.3.1: Macro to open Customers and Inventory table 

NOTE: Notice that both the MacroCust and MacroInvent macros are created in the same Macro Designer 

window using the Macro Name property. 

Steps for Adding Switchboard in Access 

The Switchboard Manager is still available in Access, but it's not included in the Database Utilities Ribbon as in 

Access 2007 and 2003. You have to launch it as doing the following steps  as shown in Fig.4.3.2: 

Step 1: First click the File tab and Options button, then we will get into Access Options window; 

Step 2: Click the Quick Access Toolbar at left bar; 

Step 3: In the Choose commands from drop down box, select the Commands Not in the Ribbon item; 

Step 4: Select the Switchboard Manager item in the command list box; 

Step 4: Click the Add button; 

Step 6: At last click the Ok button at the bottom. 
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Fig. 4.3.2: Open Switchboard Manager in MS Access 

Steps for creating Switchboard in Access: 

On the New tab, in the Ribbon, click Switchboard Manager, as shown in Fig. 4.3.3. 

 

Fig. 4.3.3: Switchboard Manager 

NOTE: If the database does not contain any switchboard, a message box as indicated in Fig. 4.3.4 appears 

confirming to create a new Switchboard. 
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Fig. 4.3.4: Confirming New Switchboard 

1. The Switchboard Manager Dialog box appears. Click New to create a Switchboard. Switchboard Manager 

is displayed as in Fig. 4.3.5. 

 

Fig. 4.3.5: Switchboard Manager Dialog box 

NOTE: Instead of creating a new Switchboard, the default created switchboard can also be used. 

2. In the Create New dialog box, in the Switchboard Page Name text box, enter User Switchboard and then 

click OK to create a sub-switchboard with that name, as shown in Fig. 4.3.6. 
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Fig. 4.3.6: Create New Dialog Box 

3. In the Switchboard Manager dialog box, in the Switchboard Pages section, verify that User Switchboard is 

selected and click Edit, as displayed in Fig. 4.3.7. 

 

Fig. 4.3.7: Edit the switchboard to add buttons 

4. In the Edit Switchboard Page dialog box, click New to add buttons to Switchboard. The Edit Switchboard 

Item dialog box appears, as shown in Fig. 4.3.8. 
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Fig. 4.3.8: Create a New Button 

5. In the Edit Switchboard Item dialog box, in the Text field, type Customers as name of the button.   

6. From the Command list, select Run Macro. 

7. From the Form list, select MacroOpenTable.MacroCust and click OK. The Edit Switchboard window 

appears, as shown in Fig. 4.3.9. 

 

Fig. 4.3.9: Provide details of the button 

8. Click OK to close the Edit Switchboard window, the created button appears in Items on the Switchboard 

tab, as shown in Fig. 4.3.10. 
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Fig. 4.3.10: Customers Button 

9. Repeat steps 4 - 8 to add another button to the form which opens the Inventory table. The final Edit 

Switchboard window appears, as shown in Fig. 4.3.11. 

 

Fig. 4.3.11: Create Button Inventory 

Steps to add frmOrders form to the Switchboard 

10. In the Edit Switchboard Page dialog box, click New to add buttons to Switchboard. The Edit Switchboard 

Item dialog box appears. 
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11. In the Edit Switchboard Item dialog box, in the Text field, type Orders as name of the button.  From the 

Command list, select Open Form in Add Mode. 

12. From the Form list, select frmOrders and click OK. The Edit Switchboard window appears, as shown in 

Fig. 4.3.12. 

 

Fig. 4.3.12: Create Orders Button 

13. The final Edit Switchboard window appears, as shown in Fig. 4.3.13. Click Close to close the Edit 

Switchboard window. 

 

Fig. 4.3.13: Final Edit Switchboard window 
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14. The Switchboard Manager window appears. Select User Switchboard and click the Make Default button. 

This option will set the User Switchboard as default switchboard. The Switchboard Manager window 

appears, as shown in Fig. 4.3.14. 

 

Fig. 4.3.14: Make User Switchboard as Default Switchboard 

NOTE: Notice that Switchboard Manager has created a new table Switchboard Items and a new form 

Switchboard. 

15. To test the switchboard created, double-click Switchboard under All Access Objects -> Forms to launch 

the User Switchboard window. The switchboard form appears, as shown in Fig. 4.3.15 

 

Fig. 4.3.15: User Switchboard  
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4.3.2 Modify a Database Switchboard 

A switchboard created using Switchboard Manager can display only the default settings for the elements on the 

switchboard. Switchboards can be made more handy and effective by modifying the properties of a 

switchboard. Access provides different features to customize a switchboard. 

A Database Switchboard can be modified in the Design view using the Property Sheet pane. The VB Editor can 

also be used for making switchboard modifications. Switchboard can be modified by changing its design, 

moving controls, adding text, modifying text properties, adding graphics, and changing the control properties. 

To add or delete buttons to Switchboard, the Edit option in Switchboard Manager is used. 

4.3.2.1 Problem Scenario 

The developer noticed that the switchboard created in section 4.3.15 is not giving a professional look. He 

wishes to add the company logo to the switchboard. In addition, he wants to add a new button to the 

switchboard which will help the user to create an excel copy of data and mail it to the manager. 

Solution  

To add a company logo to the switchboard, modify the switchboard in the Design view. To add a new button to 

the switchboard, use the Edit option in Switchboard Manager. Create a command button to execute the macro 

MailCurrentOrders created in section 4.2.1. 

Steps for adding a company logo to Switchboard 

1. Right-click the switchboard under All Access Objects -> Forms and select the Design view from the list to 

open the switchboard in the Design view. The switchboard appears, as shown in Fig. 4.3.16.  

 

Fig. 4.3.16: Open Switchboard in Design View 
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2. Click Design -> Controls -> logo button and browse to the logo image, as shown in Fig. 4.3.17. 

 

Fig. 4.3.17: Form Design Tools View 

 

Fig. 4.3.18: Print the desired logo 

3. The logo appears in the Switchboard form, as displayed in Fig. 4.3.19. 
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Fig. 4.3.19: The Switchboard form with logo. 

Steps to customize the text in Label 

1. Select the Apex Inventory Shipment label and press F4 to open the Property window.  

2. Set the value of caption property as Inventory Shipment Data. The Caption property is visible under the 

Format tab. The Property window appears, as shown in Fig. 4.3.20.  

 

Fig. 4.3.21: Change Caption of the label 

3. Save the Switchboard form and open it in the Form view to view the changes made. The Switchboard 

form appears, as shown in Fig. 4.3.22. 



 ADVANCE DATABASE CONCEPTS 

206  ADVANCED INFORMATION TECHNOLOGY 

 

Fig. 4.3.22: Switchboard Form 

Steps for adding a new button to the Switchboard Form 

4. On the New Tab or where the Switchboard Manager in your tab, New Tab, click Switchboard Manager. 

5.  The Switchboard Manager Dialog box appears. Select User Switchboard and click Edit to edit the 

switchboard, as shown in Fig. 4.3.23. 

 

Fig. 4.3.23: Edit the Switchboard User Switchboard 
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6. Edit Switchboard Page appears. Click New to create a button, as shown in Fig. 4.3.24. 

 

Fig. 4.3.24: Create a new button 

7. In the Edit Switchboard Item dialog box that appears as a result, in the Text field, enter Mail and Create 

Excel copy.   

8. From the Command list, select Run Macro. 

9. From the Form list, select MailCurrentOrders and click OK. The Edit Switchboard window appears, as 

shown in Fig. 4.3.25. 

 

Fig. 4.3.25: Add a button to run macro MailCurrentOrders 

10. Click OK to close the Edit Switchboard window, the button appears in Items on the Switchboard tab, as 

shown in Fig. 4.3.26. 
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Fig. 4.3.26: Button appears in Edit Switchboard window 

11. Close the Edit Switchboard window and the Switchboard Manager window. 

12. To test the switchboard created, double-click Switchboard under All Access Objects -> Forms to launch 

the User Switchboard window. The switchboard form appears, as shown in Fig. 4.3.27. 

 

Fig. 4.3.27: Switchboard Form 

4.3.3 Setting the Startup Options 

Since most database users do not require direct access to the entire application, the switchboard can be used 

as a means to direct the user only to the objects specific to their job role. To make a switchboard appear while 

opening the database so as to make the application more convenient set the startup option of the database. 

Displaying the switchboard at startup helps to implement a level of security by hiding the key elements of the 

interface from the user. This allows users to access the database objec ts relevant to their tasks. 
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4.3.3.1 Problem Scenario 

The Country Head of Apex Ltd., desired that the database Apex Inventory Shipment should be more users 

friendly. This means that users should not waste time navigating through various objects. The applica tion 

should guide the user provide only the required functionality.  

Solution 

The Switchboard form has already made the application user friendly, with a difference that user needs to open 

the application search switchboard among the forms and then execute it.  This is time -consuming a long 

process and user may be confused with various options and forms available. To avoid this, set the switchboard 

form at the Startup option so that as and when the user opens the application the Switchboard form should 

appear and user may select the required task from it.  

Steps to set the switchboard form at startup 

1. Open the Apex Inventory Shipment database and click . 

2. Select Access Options from the list, as shown in Fig. 4.3.28. 

 

Fig. 4.3.28: Open Access Options 

3. The Access Options window appears select Current Database from the left tab, as shown in Fig. 4.3.29. 
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Fig. 4.3.29: Select Current Database 

4. Go to Application Options, click  in the Display form and select Switchboard from the list that appears, 

as shown in Fig. 4.3.30. 
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Fig. 4.3.30. Select Switchboard for Display Form option 

5. Click OK to close the window. 

6. To test the startup option, close and reopen the database. The Switchboard form should display 

automatically. 

NOTE: Other than switchboard, any other form can also be set as a database startup option. So it helps to 

create a login form or a switchboard form and launch it at the startup of database. 

4.4 Summary 

Macros can be created from simple to complex with one or multiple actions. Macro can be executed as a 

separate object or can be attached to an event property of form, controls, or reports. The attached macros are 

executed when the event occurs. Macro can also be useful in restricting the number of records to retrieve using 

the Where clause available with certain actions. Using macro names, can help one macro object hold many 

macros. Conditions can also be specified with macros to validate the data entry. Macros can also be embedded 

with the control so that it is stored in the control and moves around with the control.  

Switchboards can help to navigate between the various database objects easily and manage data more 

effectively. The switchboard is essentially a steering wheel for users to find their way through the functions and 

forms that are available in the application. The switchboard is used as a navigation form, using buttons to 

display other forms. Switchboards are created using Switchboard Manager. A Switchboard Manager creates a 
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switchboard form and a switchboard items table automatically. Switchboards can be set as database startup 

options so they should be displayed as the database is opened and can guide the user through proper options.  

4.5 Lab Exercises 

Consider the Apex Inventory Shipment database of Apex Ltd. Provide a solution to below problems. 

1. The executive from California has sent the details of all the Orders received today as an Excel 2007 (.xlsx) 

file named Orders_CA. Create a macro to convert the file to Access table and append the records to the 

Orders table.  

 (NOTE: To append the records, create a query and execute it through macros.) 

2. The executive in the Operations department are using the frmOrders form to view the orders placed. They 

want a functionality that the orders should be displayed only for the given period and the date should be 

accepted each time when they open the form. Create a macro to fulfill the requirement. (Use the Where 

clause) 

3. The operations manager is facing a problem in checking whether the Items ordered are available or not. He 

wishes to have a button on frmOrders which should display the details of the Items requested in Order. 

Create a button on frmOrders and attach a macro to get desired functionality.  

4. A form was created to track Inventory, as shown in the Fig. below. Attach a macro to the Calculate button 

that should make an auto entry to the field Order and Available. The order field should be set to Yes if sum 

of Quantity in Stock and Quantity on Order is less than Reorder Point. The Available Point should be set to 

Yes if the sum of Quantity in Stock and Quantity on Order is greater than Quantity ordered in Orders table.  

 

Inventory Form 
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5. Consider the Inventory form created in previous example, create a macro to ensure that Category and Sub 

Category of an Item should not be left blank and Quantity on Order should not be less than Reorder 

Quantity. Display customized message if the validation is not followed.  

6. The operations manager wishes to have the application customized for the users of Operations 

department. The operations manager asked the developer to create a switchboard form that should contain 

the link to open Inventory table, also it should display the Sales Orders along with their Invoices. Create a 

switchboard for the purpose.  

7. Modify the above created switchboard so as when users selects inventory  option another switchboard must 

be opened. This switchboard gives user option to display the entire Inventory, Inventory from a particular 

category and Items for which Quantity in Stock is more than 100. 

8. Set the Switchboard created in Question No. 6 to the startup option of database so that it opens 

automatically as user opens the database. 

9. Add a button to the Inventory form created in Question 4. The button should display all the orders from 

Sales Order Description table that were placed for the particular item. The item must be the item that is 

displayed currently in the form. (Attach a macro to the button for the purpose). 

10. Edit the switchboard in Question No. 7. Add a button to the switchboard that should open the Inventory 

form.  
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Simplifying Advanced Transactions 
in Tally 

 

Tally provides with exceptional capabilities that simplifies the way to manage all the critical aspects of 
business such as interest calculations, handling forex transactions, bill of materials, manufacturing process, 
job work and many more, all these business requirements can be easily maintained using Tally. Let us now 
understand business benefit of each feature in detail. 

1.1 Interest Calculation 

 
1.1.1 Introduction 

Interest is a legitimate return on money invested and chargeable in the business world on loans and on delayed 
payments. Interest can be calculated based on simple interest or compound interest.  

 Simple Interest: Simple Interest is a quick method of calculating the interest charged. It will be fixed 
throughout the period. 

 Compound Interest: Compound Interest is the interest on interest. 

Business Scenario 

Emerald-Shine Makers started a company with a capital of ₹ 5,00,000, in April 2019. Company is into 
manufacturing and trading business, they manufacture and trade the stock items such as DDL Laptops and 
other electronic gadgets like DLL smart phones, Cameras, electronic cookers etc. 

Emerald-Shine Makers transacts business on cash and credit basis, To have a control on debts and faster 
closure of credit transactions, It is advised by an auditor to fix the credit period for all the customers, which in 
turn helps raising fund and liquidity on time. If a customer doesn’t make a payment within the credit period, then 
the customer must make a payment along with the interest. 

Activity: Create a company with the following details: 

LEARNING OBJECTIVES 
 Understanding of simple & compound interest 
 Maintaining interest calculation in Tally 
 Calculating interest based on simple interest  
 Calculating interest based on compound interest  

 Bringing the interest amount in the books of accounts 

 Viewing of interest calculation reports 

CHAPTER 

1 
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Company Name: Emerald-Shine Makers 

Address: No. 198, 6th Cross, Vinayakanagar, Bengaluru -560078 

Financial year beginning from: 01-04-2019 

1.1.2 Activating Interest Calculations 

To activate the Interest Calculation feature,  

1. Go to Gateway of Tally > Press F11: Features > F1: Accounts>Set the option Activate interest 
calculation? and Use advanced parameters? to Yes and save the screen 

1.1.3 Calculating Simple Interest  

In Tally, we can calculate simple interest on Outstanding Balance and on outstanding bills/invoices/ 
transactions. 

Activity:  

 Create the ledger SBI Bank under Bank Accounts and Proprietors Capital under Capital Account.  

 Record a journal entry for introducing capital of ₹5,00,000 to business as shown in table 1.1.1, to record 
click F12: Configure from Journal and enable the option Allow cash accounts in journal vouchers? 

Particulars L.F Dr. Cr. 

SBI Bank _________________ Dr.  5,00,000  
To, Proprietors Capital A/c   5,00,000 

(Being cash invested by the proprietor)    

Table 1.1.1  

Illustration 1: Configuration of interest in advance parameters and recording of sales transaction 

Date Particulars 

01-04-2019 Voucher: Purchase  

Purchased the following stock item on credit from Mufti Solutions with 30 days of 
credit period and the supplier invoice number is PUR/001. If the payment is not made 
within 30 days, then from thereafter the rate of interest is 10% per 30 day a Month. 

Name of Stock Item Quantity Rate/Nos. Amount 

DDL Laptops 10 Nos ₹ 15,000 ₹ 1,50,000 
 

Table 1.1.2  

To record the transaction in the books of accounts follow the steps: 
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Step 1: Creation of Accounting Masters 

1. Go to Gateway of Tally>Accounts Info> Ledgers >Create> Mufti Solutions under Sundry Creditors> 
Enable Maintain balance bill- by-bill? and Activate interest calculation? >Fill in the Interest Parameters 
screen as shown in the figure 1.1.1 

The Interest Parameters screen appears as shown in the figure 1.1.1: 

     

Figure 1.1.1 Interest Parameters Screen 

Note: 

 In the Interest Parameters screen, set Calculate Interest Transaction-by-Transaction to Yes.  This 
option should be disabled when we don’t require to calculate interest for all transactions based on the 
parameters defined in the master 

 Set the option Override parameters for each Transaction to Yes, by enabling this option, the interest 
amount, interest style and interest balances defined in the ledger master can be over- ridden during 
voucher entry 

 Set the option Override advance parameter to Yes, in order to override the advance interest parameter 
like applicability, calculate from option, while recording the transaction 

 Specify the Rate as 10% for a 30-Day Month on all balances 

 Interest Balances: This parameter will allow us to choose the calculation of interest either on Debit 
Balances or on Credit Balances. We can choose to include both for interest calculation by selecting All 
Balances. 

 Select Applicability as Past Due Date 

 Applicability: This parameter allows us to choose the period of interest calculation. On selecting 
Always, interest will be calculated as on voucher date of entry. If Past Due Date is selected, then the 
interest calculation will happen after credit days. 

 Calculate From: This parameter allows us to define floating rates of interest by defining different rates 
of interest for different periods. For example, from 10 to 15 days from voucher entry the rate of interest 
can be 5% and from 16 to 20 days the rate of interest can be 6%. There are four different ways of 
providing floating rates, by Date of Applicability, by Date Specified During Entry, Due Date of 
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Invoice/Ref, or by Effective Date of transaction. For example: If calculate from is selected as Due 
date of invoice/Ref, then the interest will get calculated after due date or credit days, in this case 
select Due date of invoice/Ref. 

 Rounding: We can choose to apply either upward, normal or downward rounding as required. In this 
case we have selected Not Applicable. 

2. Press Enter and save the party ledger creation screen 

Purchase Ledger 

Purchase A/c 

Against the Field Name Action to be Performed 

Name Enter as Purchase A/c 

Under Select as Purchase Accounts 

Inventory values are affected? Set to Yes 

Activate interest calculation? Set to No 

Table 1.1.3 

Step 2: Creation of Inventory Master 

Stock Item 

Go to Gateway of Tally > Inventory Info. > Stock Items > Create 

DDL Laptops 

Against the Field Name Action to be Performed 

Name Enter as DDL Laptops 

Under Select as Primary 

Units Nos (Bring the cursor in the unit’s field and press Alt+C to create it) 

Table 1.1.4 

Step 3: Recording Purchase Transaction  

1. To record the purchase transaction, go to Gateway of Tally >Accounting Vouchers >F9: Purchase> 
F2: Date>01-04-2019, enter the Supplier invoice no as PUR/001> Date appears automatically, select 
Party A/c name as Mufti Solutions, Purchase ledger as Purchase A/c > Under Name of Item> Select 
DDL Laptops and enter the Quantity as 10Nos, Rate as ₹ 15,000. 

2. In the Bill-wise Detail screen enter the Type of Ref. as New Ref. and in the name column, enter as 
PUR/001. Enter the Due Date, or Credit Days as 30 days, and the amount will be captured 
automatically 

3. Press Enter, Interest Parameters screen appears as we have enabled to override the interest 
parameters in party ledger 
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 The Interest Parameter screen appears as shown in the figure 1.1.2: 

 

Figure 1.1.2 Interest Parameters Screen-Sales Voucher 

4. In the Interest Parameters screen the details are captured from the ledger master. We can make 
changes even here. 

5. Press Ctrl+A to accept Interest Parameters screen. 

The Completed Purchase Voucher appears as shown in the figure 1.1.3 

 

Figure 1.1.3 Purchase Voucher Creation Screen 

6. Accept the entry. 

Note: If we did not make payment on or before 01-05-2019 (Within credit period), then interest will calculate 
from 02-05-2019. 

Consider Emerald-Shine Makers delayed in making the payment to Mufti Solutions. 

1.1.4 To Bring the Calculated Interest in the Books of Accounts 

We have set the interest parameters for ledger accounts. The calculated interest amounts must be recorded 
using debit notes and credit notes with voucher classes to bring the interest amount in the books of accounts. 
Debit notes are used for interest receivable and credit notes for interest payable. 

In Tally, interest is calculated on simple or compound basis and hence separate classes should be used for 
them. 



 ADVANCED ERP CONCEPTS 

222  ADVANCED INFORMATION TECHNOLOGY 

Illustration 2: Checking of Interest payable amount and bringing the same in the books of accounts 

Date Particulars 

31-05-2019 Voucher: Credit Note 

Emerald-Shine Makers bought interest payable amount in the books of accounts.  

Table 1.1.5 

Let us find out the interest payable amount to Mufti Solutions as on 31-05-2019 and bring the interest amount 
in the books of accounts. 

Step 1: Checking of Ledger Interest Report in Tally  

To view interest calculated on Mufti Solutions,  

1. Go to Gateway of Tally > Display > Statements of Accounts > Interest Calculations > Ledger > 
Select Mufti Solutions, Change the period from 01-04-2019 to 31-05-2019>Click ALT+F1 for Detailed view 

The Ledger Interest screen appears as shown in the figure 1.1.4 

 

Figure 1.1.4 Ledger Interest Screen 

Note: In the Ledger Interest report, we can see that the interest is calculated on ₹ 1,50,000 i.e. from 2.05.2019 
to 31.05.2019 for 30 days at 10% 

Let us now create voucher class for simple interest calculation. 

Voucher class for both simple and compound interest can be created from the same credit note voucher type 
alteration screen in Tally. 

Step 1: Creating Voucher Class 

1. Go to Gateway of Tally > Accounts Info. > Voucher Types > Alter > Credit Note 

2. Press Ctrl+End button to place the cursor in Name of Class field>Type Simple Interest and press 
Enter> Enable the option Use Class for Interest Accounting? to calculate the interest in simple interest 
formula  

The Voucher Type Class screen appears as shown in the figure 1.1.5: 

 

Figure 1.1.5 Voucher Type Class Screen 
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Note: In case if the interest to be calculated based on Compound Interest Formula, then the below option 
Amounts to be treated as Compound Interest? need to be enabled by creating a new voucher class for 
Compound Interest. 

3. Accept the voucher type and return to the Gateway of Tally 

Step 2: Creation of Interest Ledgers 

Interest Paid and Received ledgers are required to create for bringing the interest amount in the books of 
accounts. 

Interest Paid 

Against the Field Name Action to be Performed 

Name Enter as Interest Paid 

Under Select Indirect Expenses 

Activate Interest Calculation? Set to No 

Table 1.1.6  

Activity: Create Interest Received ledger under Indirect Incomes 

Step 3: Recording credit note for bringing the interest amount in the books of accounts. 

1. Go to Gateway of Tally > press F11: Features > F1: Accounts and enable the option Use debit and 
credit notes and save Accounting Features screen. 

2. Go to Gateway of Tally > Accounting Vouchers > Ctrl+F8: Credit Note> select the class>Simple 
Interest>Press F2: Date: 31-05-2019, enter Original invoice no and Original invoice Dt. 

3. Credit the party ledger, Mufti Solutions, to get the Interest Details for screen which contains the list 
of interest bills as shown in figure 1.1.6 

 

The Interest Details screen appears as shown in the figure 1.1.6: 

 

Figure 1.1.6 Interest Details screen 

4. Select the Bill, then select as end of list and press enter, Party Details screen appears accept the 
screen, Interest amount will get calculated automatically, press enter to get the bill wise details screen 
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5. Select New Ref, enter the name as Interest P1 

The Bill-wise Details screen appears as shown in the figure 1.1.7: 

 

Figure 1.1.7 Bill-wise Details screen 

6. Next, we will get the Interest Parameter screen, accept it as it is 

7. Debit the Interest Paid ledger. 

The Credit Note Voucher appears as shown in the figure 1.1.8: 

 

Figure 1.1.8 Booking Interest through Credit Note Voucher Class 

8. Accept the entry. 

Step 4: Check the outstanding report of Mufti Solutions  

1. Go to Gateway of Tally > Display > Statements of Accounts > Outstandings > Ledger > select 
Mufti Solutions  

The Outstandings Report appears as shown in the figure 1.1.9: 

 

Figure 1.1.9 Ledger Outstandings Report Screen 

Observation: The report displays the outstanding amount to Mufti Solutions and interest payable as per the 
date and reference no. Being goods purchased on credit and interest payable for delay in payment to Mufti 
Solutions is ₹ 1,65,000. 

Illustration 3: Recording of payment voucher along with interest amount  
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Date Particulars 

31-05-2019 Voucher: Payment 

Emerald-Shine Makers made a payment of ₹ 1,65,000 to Mufti Solutions with 
interest through SBI Bank  

Table 1.1.7  

To record the transaction in the books of accounts follow the steps:  

1. Go to Gateway of Tally > Accounting Vouchers > press F5: Payment > Select SBI Bank in Account 
field Under Particulars select party ledger Mufti Solutions, Bill-wise Details screen appears, fill in the details 
as shown in figure 1.1.10, and save the entry. 

The Bill wise Details screen appears as shown in the figure 1.1.10: 

 

Figure 1.1.10 Bill wise Details Screen. 

The Payment Voucher appears as shown in the figure 1.1.11: 

 
Figure 1.1.11 Payment Voucher Screen 

Note: Once after recording the payment entry check the Mufti Solutions ledger interest report, we will not get 
the interest details because there is no pending bill from Mufti Solutions. 

1.1.5 Calculating Compound Interest  

Emerald-Shine Makers sold DDL Laptops to Blue Ray Solutions and calculates interest based on compound 
interest formula, In Tally we can also calculate interest in compound interest formula. 
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Illustration 4: Calculating interest based on compound interest formula. 

Date Particulars 

01-05-2019 Voucher: Sales 

Emerald-Shine Makers made a credit sale with reference number SAL/001 to Blue Ray 
Solutions and allowed 30 days credit period. If the payment is not made within 30 days, 
then from thereafter the rate of interest is 8% per 30-day a month 

Name of Stock Item Quantity Rate/Nos. Amount 

DDL Laptops 10 Nos ₹20,000 ₹ 2,00,000 
 

Table 1.1.8 

To record the transaction in the books of accounts follow the steps: 

Step 1: Creation of Accounting Masters 

Activity:  

1. Create Blue Ray Solutions under Sundry Debtors, enable Activate interest calculation? option and 
set the interest parameter. (Make sure to enter Interest Rate as 8% and Interest Style as 30-Day a 
Month) 

2. Create ledger as Sales A/c under Sales Accounts (do not activate interest calculation to this ledger)  

Step 2: Recording of Sales Transaction 

1. To record sales transaction, go to Gateway of Tally>Accounting Vouchers> F8: Sales > Date: 1-5-
2019 enter Reference no: as SAL/001, select Party A/c name as Blue Ray Solutions, Sales Ledger as 
Sales A/c, under Name of Item field select DDL Laptops enter the Quantity as 10 Nos, Rate as ₹ 
20,000  

2. In the Bill-wise Detail screen select the Type of Ref. as New Ref. and in the name column, enter as 
SAL/001. Enter the Due Date, or Credit Days as 30 days, and the amount will be captured 
automatically 

3. Press Enter, Interest Parameters screen appears, press Ctrl+A to accept Interest Parameters screen 

The Completed Sales Voucher appears as shown in the figure 1.1.12 

 

Figure 1.1.12 Sales Voucher Creation Screen 

4. Accept the entry. 
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Note: Once after recording the sales entry if the receipt is not made within the credit days, then Blue Ray 
Solutions needs to pay the total amount along with the interest amount. 

Blue Ray Solution delayed in making the payment within the credit days and now they are liable to pay interest 
to Emerald-Shine Makers 

Step 3: Recording debit note to bring the calculated interest amount in the books of accounts 

1. Let us first check the interest receivable amount as on 30-06-2019, Go to Gateway of Tally > Display > 
Statements of Accounts > Interest Calculations > select Interest Receivable > press F2: Period and 
enter as 01-05-2019 to 30-06-2019, press enter to drill down on Current Assets and Sundry Debtors  

 The Interest Receivable report appears as shown in the figure 1.1.13: 

 
Figure 1.1.13 Interest Receivable Report 

 Observation: In Figure 1.1.13 you can observe that the interest receivable amount is displaying as ₹ 
16,000. 

 Activity: Alter the debit note voucher and configure the following details: 

 Under Name of Class – Enter as Compound Interest  

 Enable the following options in Voucher Type Class screen 

o Use Class for Interest Accounting? 

o Amounts to be treated as Compound Interest? 

2. Next step is to bring the details of interest receivable amount in the books of accounts. 

3. Go to Gateway of Tally > Accounting Vouchers > press F9: Debit Note> In Class field, select 
Compound Interest> Press F2: Date 30-06-2019 enter Original invoice no and Dt. 

4. Debit the party ledger, Blue Ray Solutions, to get the Interest Details screen which contains the list of 
interest bills, select the bill with number SAL/001 (Bill wise details will  not appear for compound interest 
amount separately, as the amounts are auto debited to the selected bills) 

5. Press enter, Party Details screen appears accept the screen,  

6. Credit Interest Received Ledger interest amount will get calculated automatically, press enter and save 
the entry. 

Once after recording the debit note the amount will reflect in the books of accounts, to check go to Balance 
Sheet report > press Enter on Current Assets 

The Group Summary report appears as shown in the figure 1.1.14: 
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Figure 1.1.14 Group Summary Report 

We can observe that the interest receivable amount is reflecting in the books of accounts. 

Check the interest receivable report for the period 01-07-2019 to 31-07-2019 

1. Go to Gateway of Tally > Display > Statements of Accounts > Interest Calculations > Interest 
Receivable> press F2: Period and enter 01-07-2019 to 31-07-2019> press Enter on Current Assets and 
Sundry Debtors 

The Interest Receivable report appears as shown in the figure 1.1.15: 

 

Figure 1.1.15 Interest Receivable Report 

Observation: Observe the Closing Balance Column, the amount is displaying as ₹ 2, 16,000, this amount is 
inclusive of interest amount of the previous period i.e., ₹ 16,000 is the interest amount which is added in the 
total transaction value of ₹2,00,000 

Activity: Recording the receipt voucher along with interest amount  

Date Particulars 

30-06-2019 Voucher: Receipt 

Emerald-Shine Makers received a payment of ₹ 2,16,000 from Blue Ray Solutions 
with interest to SBI Bank A/c. 

Table 1.1.9  

1.1.6 Interest Calculation Reports 

To check the interest calculation report, follow the steps, 

Go to Gateway of Tally > Display > Statements of Accounts > Interest Calculation 

Interest Receivable Report: It displays the details of interest receivable by the Company. 

Interest Payable Report: It displays the details of interest payable by the company to its supplier or vendor. 

Ledger: It displays the interest calculated based on the ledgers (Payable or receivables) 
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Group: It displays the list of all accounts and sub-groups belonging to the selected group and displays the 
current balance in each account or sub-group and the total interest. The Cr in the interest amount should not be 
confused to mean an Income. It only means that it is payable and is a liability. 

Conclusion 

In this chapter we have activated interest calculation feature and calculated interest automatically in Tally. We 
have also learnt to calculate interest in simple and compound method with different styles such as 30- Day 
Month, 365-Day Year etc. 

1.2 Multi-Currency 

 
1.2.1 Introduction 

Due to the globalisation of business, many organisations have found the necessity to work with more than one 
currency. In this case, transactions are also recorded in currencies other than the home currency. 

At times you need to record the transaction in the foreign currency itself when you maintain the balance of the 
concerned account in foreign currency. 

Multi-currency feature in Tally allows you to: 

 Record transactions with different currencies by allowing you to specify and change the currency rate of 
exchange  

 Maintain the balance of the specified account in a foreign currency 

 The home currency, in which the books of accounts are maintained will be addressed as ‘Base 
currency’. Base currency is specified during company creation. 

Business Scenario 

Emerald-Shine Makers are also engaged in exporting and importing of DLL Camera’s to foreign countries. 
Company exports DLL Camera’s to Power Electronics (US), Since the transactions are between more than one 
country, it is required to maintain multiple currencies and record the transactions. Let us now see how Emerald-
Shine Makers maintain these requirements in Tally. 

LEARNING OBJECTIVES 
 Create and maintain multi currencies 
 Adjust forex gain/loss 

 Viewing of financial reports in base and foreign currencies 
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Activity:  

Date Particulars 

01-07-2019 Voucher: Purchase 

Purchased the following items from Best Electronics with Supplier invoice no PUR/002 

Name of Item Quantity Rate Amount 

DLL Cameras  30 Nos ₹ 10,000/Nos ₹ 3,00,000 
 

Table 1.2.1 

 Create Best Electronics ledger under Sundry Creditors. 

 Create stock item as DLL Cameras with Units as Nos. 

1.2.2 Enabling Multi-Currency 

To enable multicurrency feature in Tally 

1. Go to Gateway of Tally > press F11: Features > F1: Accounts>Set Enable multi-currency? to 
Yes>accept Accounting Features screen 

1.2.3 Creating Foreign Currency 

To create a Foreign Currency, 

1. Go to Gateway of Tally > Accounts Info. > Currencies > Create> Create the currency as shown in 
figure 1.2.1 

 The Currency Creation screen appears as shown in the figure 1.2.1: 

 

Figure 1.2.1 Currency Creation Screen 

2. Enter the Symbol as $. (Short cut key is Shift+4) 
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3. Enter the name of the currency in Formal Name as US Dollar 

4. Enter the number of decimal places for the currency in Number of decimal places  

5. Tally has two formats for displaying amount, viz., in millions. 1000000 (one followed by six zeroes) in 
millions format would appear as 1,000,000  

6. Select the required parameter in Show Amounts in Millions field. If you select No, the amounts will not 
appear in million, i.e., it will appear as 10,00,000  

7. Set Suffix symbol to amount to Yes for the symbol to appear after the amount. Set it to No, for the 
symbol to be prefixed to the amount 

8. Add space between amounts and symbol? to Yes to apply a space between amount and symbol 

9. Enter the Word representing amount after decimal.  

10. Enter the No. of decimal places for amounts in words. This number should be equal to or lesser than 
the number specified in Number of Decimal Places field 

11. Press Enter to Save the screen 

1.2.4 Altering Currencies and Defining of Rates of Exchange 

You can modify or delete a currency master using the Alter option. You can also set Rates of Exchange for 
specific dates while altering a currency. 

To alter a Currency, 

1. Go to Gateway of Tally > Accounts Info. > Currencies > Alter>Select $  

2. In the Currency Alteration screen that appears, enter the Rate of exchange for Standard, Selling and 
Buying rates as per figure 1.2.2 

The Currency Alteration screen appears as shown in figure 1.2.2: 

 

Figure 1.2.2 Currency Alteration Screen 

Understanding Exchange Rates 

Standard Rate of Exchange is the rate at which a foreign currency is traded in the market. 

Selling Rate is the rate at which the bank buys currency from a customer. This rate is used while invoicing or 
receiving money. 
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Buying Rate is the rate at which the bank sells the currency. This rate is used when purchasing or paying 
money in terms of a foreign currency. 

1.2.5 Voucher Entry using Foreign Currency (On the basis of Realization) 

A realization foreign transaction is nothing but a transaction which is realized. For Example, the forex gain/loss 
occurs from the difference in exchange rates defined at the time of sales and receipt voucher. 

Illustration 1: Recording sales voucher with dollar currency and corresponding receipt transaction.  

Date Particulars 

01-07-2019 Voucher: Sales 
Exported the following goods to Power Electronics (US) at the exchange rate of ₹ 69/$ with 
Reference number SAL/002. 

Name of Item Quantity Rate Amount 

DLL Cameras  10 Nos $200/Nos $ 20,000 
 

05-07-2019 Voucher: Receipt 
Power Electronics made full payment against the sales reference no. SAL/002. There was an 
increase in exchange rate and the rate was ₹ 70/$. 

Table 1.2.2 

To record the transaction in the books of accounts follow the steps:  

Step 1: Creation of Accounting Masters 

1. Create Power Electronics ledger under Sundry Debtors, select the currency as ₹, enable the option 
Maintain balances bill-by-bill? and save the ledger. 

2. Create Sales - Export ledger under Sales Accounts, select the currency as ₹ 

Step 2: Record Sales Transaction for Exports 

1. Go to Gateway of Tally > Accounting Vouchers> F8: Sales> press F2: Date>01-07-2019 

2. Enter Reference no: SAL/002> select Power Electronics under Party A/c name >  select Sales 
ledger as >Sales – Export> select Name of Item >as DLL Cameras >Enter the Quantity as 10 Nos. 
Rate as $ 200, on entering the rate in foreign currency, the Forex Rate of Exchange screen appears 
as shown in figure 1.2.3 

Note: In the Forex Rate of Exchange screen we can enter the exchange rate while recording the entry. 

The Forex Rate of Exchange appears as shown in the figure 1.2.3: 

 

Figure 1.2.3 Forex Rate of Exchange Screen 
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3. The selling rate specified earlier in figure 1.2.2 is captured here by default, press enter to accept, Bill 
wise Details screen appears, select New Ref, enter the name as SAL/002 and accept the screen as it 
is. 

The completed Sales Voucher Creation appear as shown in the figure 1.2.4: 

 

Figure 1.2.4 Completed Sales Voucher Screen 

 Observation: we can observe the calculation of the sale value is in base currency and the same base 
currency value will get updated in the financial reports. 

 Note: While you are billing for foreign currency ensure to provide the currency, symbol followed by rate 
in Rate field. Any rate without symbol will be considered as base currency. 

4. Press Ctrl+A to accept the voucher 

Step 3: Recording of Receipt Voucher 

1. Go to Gateway of Tally> Accounting Vouchers > F6: Receipt > F2: Date: 05-07-2019> select SBI 
Bank ledger in Account Field > Under Particulars >Select Power Electronics> Select Agst Ref> 
Select the Bill from Pending Bills  

2. By default, the Rate of exchange field sets the previous exchange rate i.e. ₹ 69/$, Change the Rate of 
Exchange to ₹ 70/$, save the screen and accept the entry. 

The Forex Rate of Exchange screen appears enter the details as shown in figure 1.2.5: 

 

Figure 1.2.5 Forex Rate of Exchange Screen 

Observation: During the sale of material, the total cost was ₹ 1,38,000. However, due to an increase in the 
rate of exchange, the total value has increased to ₹ 1,40,000.  Hence, this difference in amount will be reflected 
as the Unadjusted Forex Gain/Loss. 

Let us view the Unadjusted Forex Gain/Loss details in Balance Sheet report. 

1. Go to Gateway of Tally > Balance Sheet> Unadjusted forex gain/loss of ₹ 2,000 appears under the 
Liabilities side.  
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The Balance Sheet report with unadjusted forex gain/loss details appears as shown in figure 1.2.6 

 

Figure 1.2.6 Balance Sheet showing Unadjusted Forex Gain/Loss 

Ledger Outstanding Report 

We can also check the forex gain/loss details from ledger outstandings report 

1. Go to Gateway of Tally > Display > Statements of Accounts > Outstandings> Ledger > select – 
Power Electronics > click Alt+F1: Detailed 

The Ledger Outstanding report appears as shown in figure 1.2.7 

 

Figure 1.2.7 Ledger Outstanding Report with Forex Gain or Loss Details 

1.2.6 Adjusting Forex Gain/Loss 

A Journal entry must be made at the end of the accounting period for writing-off the gain/loss to the Profit & 
Loss account. 

Illustration 2: Recording of journal voucher in order to write-off the forex gain/loss to the profit/loss 
account 

Date Particulars 

31-07-2019 Voucher: Journal 

Written-off the unadjusted forex gain/loss of ₹2,000, which was reflecting in balance sheet. 

Table 1.2.3 

Step 1: Creation of Accounting Masters 

1. Create Forex Gain/Loss ledger under Indirect Incomes> Select Currency as ₹ 

Step 2: Creation of Journal Voucher Class  

1. Go to Gateway of Tally > Accounts Info. > Voucher Types >Alter>Journal> In the field Name of 
Class, type Forex Gain/Loss and follow the steps in figure 1.2.8 
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The Forex Voucher Type Class screen appears as shown in figure 1.2.8: 

 

Figure 1.2.8 Voucher Class Creation Screen 

2. Accept the voucher type alteration screen. 

Step 3: Recording of Journal Voucher 

1. Go to Gateway of Tally > Accounting Vouchers > press F7: Journal>Select Forex Gain/Loss as the 
voucher class > F2: Date: 31-07-2019> In Account field the Forex Gain/Loss ledger will be selected by 
default> Under Particulars select Power Electronics > Bill-wise Details screen appears, select the 
particular bill  

The Bill-wise Details screen appears as shown in the figure 1.2.9: 

 

Figure 1.2.9 Adjusting Forex Gain or Loss 

2. Accept the Bill-wise Details screen and save the entry. 

After Forex adjustment, check the Balance Sheet report 

Observation: Now that the forex adjustment has been completed, the Balance Sheet doesn’t show any 
unadjusted forex gain/loss. The amount of ₹ 2,000 will be transferred to Profit & Loss A/c under indirect 
income head. 

To check Profit & Loss Account report, go to Gateway of Tally > Profit & Loss A/c, check that the amount of 
₹ 2,000 will appear in Indirect Income head> Press enter to view Group summary 

The Group Summary from Profit & Loss A/c appears as shown in figure 1.2.10: 
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Figure 1.2.10 Group Summary 

1.2.7 Voucher Entry using Foreign Currency (On the basis of Un-Realized Transactions) 

An unrealised foreign transaction is nothing but a transaction which is not realized i.e., purchase or sales is 
done but payments are not made/received. 

During sales and purchase transactions, the rate of exchange prevailing to the day is considered for recording 
transactions. As purchase and sales are done on different dates, there are chances of variation in the rate of 
exchange. The variable rate of exchange amount is reflected/called as Unadjusted Forex Gain/Loss. 

Emerald-Shine Makers received multiple orders from Power Electronics.  

Activity: 

Illustration 3: Recording of sales transactions with different rate of exchange 

Date Particulars 

1-08-2019 Voucher: Sales 

Exported the following goods to Power Electronics at an exchange rate of ₹ 70/$ with 
reference number SAL/003 by selecting Sales-Export ledger. 

Name of Item Quantity Rate Amount 

DLL Cameras 5 Nos $200/Nos $ 1,000 
 

10-08-2019 Voucher: Sales 

Exported the following goods to Power Electronics at an exchange rate of ₹ 71/$ with 
reference number SAL/004 

Name of Item Quantity Rate Amount 

DLL Cameras 5 Nos $200/Nos $ 1,000 
 

Table 1.2.4 

Hint: While recording the sales transaction change the Rate of Exchange as per the illustrations. 

After recording the entry let us check the balance sheet values in base currency and dollar currency. 

1.2.8 Reports 

Balance Sheet 

In Tally, we can view the financial reports such as Balance Sheet, Profit and Loss A/c and Trail Balance in 
multicurrency. 
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To view balance sheet in base currency and dollar currency 

1. Go to Gateway of Tally > Balance Sheet>F2: Period and enter the required period>Press Alt+C: New 
Column, to add column> Enter the details as shown in the figure 1.2.11: 

The Select Column Details screen appears as shown in the figure 1.2.11: 

 

Figure 1.2.11 Select Column Details Screen  

The Balance Sheet screen appears as shown in figure 1.2.12: 

 

Figure 1.2.12 Balance Sheet in Multi Currency 

Note: Check the Unadjusted Forex Gain/Loss reflecting under current assets account head. This is appearing 
because of the variation in the forex exchange rate. 

Activity:  

1. Similarly, let us check the Profit & Loss account report in base and dollar currency. 

2. Check the Balance Sheet and adjust the Forex Gain/Loss by passing a Journal entry using the 
voucher class created earlier, for the month of August- select both the bills with the bill name SAL/003 
and SAL/004. 

Ledger Vouchers 

In Tally we can check the forex transactions details from the ledger voucher reports.  

To view only the forex related transactions, 
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1. Go to Gateway of Tally > Display > Account Books > Ledger > Power Electronics > Enter> Press 
F12: Configure > Enable > Show Forex details also and Show Forex Transactions only to Yes 

 The Configuration screen appears as shown in the figure 1.2.13: 

 

Figure 1.2.13 Configuration to see Forex Transactions only 

2. Change the period to 01-07-2019 to 31-08-2019 

The Ledger Vouchers report appears as shown in the figure 1.2.14: 

 

Figure 1.2.14 Ledger Vouchers with Forex 

To view the details of date-wise selling and buying rate of exchange,  

1. Go to Gateway of Tally >Accounts Info>Currencies>Alter>Select $ 

The Currency Alteration screen with Date-wise selling and buying rate of exchange report appears as 
shown in the figure 1.2.15: 

 

Figure 1.2.15 Date-wise selling and buying rate of exchange 

Conclusion 

In this chapter, we have learned to create multiple currencies and define the different forex exchange rate and 
recorded realized and unrealized forex transactions, we have also learned to generate the balance sheet in 
base currency as well as in foreign currency. 
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1.3 Bill of Materials and Manufacturing Process 

 
1.3.1 Introduction 

Inventory is an asset that is intended to be sold or consumed to produce finished products in the ordinary 
course of business.  

In accounting, inventory is typically broken down into three stages, which are: 

Raw materials: Includes materials intended to be consumed to produce finished goods. 

Work-in-process: Includes items that are in the midst of the production process, and which are not yet in a 
state ready for sale to customers. 

Finished goods: Includes goods ready for sale to customers. May be termed merchandise in a retail 
environment where items are bought from suppliers in a state ready for sale. 

Manufacturing Processes is the process of conversion of raw materials/components into finished goods. A Bill 
of Materials is a list of constituent items along with quantity details that can be allotted for the manufacture of 
a certain product, by-product or likewise. This facilitates immediate reduction in stock of the item 
automatically and it saves time by automatically allocating the components while recording Manufacturing 
entry. This process of listing the items that make up another item is made possible in Tally by enabling the Bill 
of Materials feature. 

Business Scenario 

Emerald-Shine Makers received an order for DLL MacBook, the company should now start the manufacturing 
and assembling of DDL MacBook for this the company maintains Bill of Materials and records manufacturing 
journals using the BoM. 

1.3.2 Activating of Bill of Materials 

To activate Bill of Materials, 

1. Go to Gateway of Tally > F12: Configure > Accts/Inventory Info>Set Enable component list details 
(Bill of Materials)? to Yes 

Note: The same option can be enabled in stock item by pressing F12: Configure 

1.3.3 Auto Listing of Components Using Bill of Materials 

Bill of Materials (BoM) is created only for those items that are being assembled in-house. Therefore, you 

LEARNING OBJECTIVES 
 Understanding of Bill of Materials 

 Creation of manufacturing journal voucher 
 Accounting of manufacturing entry in Tally 
 Recording stock journal voucher 
 Checking of reports like cost estimation and transfer analysis 
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need to specify a BoM at the time of creating a Stock Item or while altering the stock item. For trading items, 
you do not need a BoM. 

After activating Bill of Materials, we can define components while creating finished good. 

Illustration 1: Listing of Components using Bill of Materials in Finished goods. 

The following is the list of components which will be used to manufacture 1 unit of DDL MacBook 

List of Components Units used for manufacturing 1 DDL MacBook 

Display Screen 1 Nos 

Hard Disk Drive 1 Nos 

Internal Battery 1 Nos 

Keyboard 1 Nos 

Table 1.3.1 

To define the list of components using Bill of Materials in Tally, follow the procedure: 

1. Creation of Inventory Masters 

Stock Groups 

To create from Gateway of Tally > Inventory Info > Stock Groups > Create 

Against the Field Action to be Performed 

Name Enter as Raw Materials 

Under Select as Primary 

Should quantities of items be added? Set to Yes 

Table 1.3.2 

Activity: Similarly create the stock group by name Finished Goods under Primary and set yes to “Should 
quantities of items to be added” 

Stock Item – Raw Material/Components 

To create from Gateway of Tally > Inventory Info > Stock Items > Under Multi Stock Items > Select Create 
> Select Raw Materials, then create all the stock items at one go as shown in table 1.3.1 under Raw Materials 

Stock Item - Finished Goods 

Let us create the stock item DDL MacBook 

1. To create from Gateway of Tally > Inventory Info > Stock Items > Create>DDL MacBook In Under 
field, select group as Finished Goods>Select Units as Nos Enable the option Set components (BOM), the 
BoM List screen appears> Enter the Name of BOM as DDL Silver MacBook> press Enter  Stock Item 
components (BoM) screen appears where we can define the details of components. 
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2. Enter the Unit of manufacture as 1 >Press F12: Configure and set the option Define Type of 
Components for BoM to Yes, you will get the Type of Item column to select the component type 

Note: In some of the manufacturing processes along with the Finished Goods, Co-Products or By-Products or 
Scrap may be produced. We can define the Stock Item Type by enabling the option Define Type of 
Components for BoM 

3. Enter the components name one by one as shown in the figure 1.3.1 

The Stock Item Components (BoM) screen of DDL MacBook appears as shown in the figure 1.3.1: 

 

Figure 1.3.1 Stock Item Components (BoM) 

4. After listing all the components as shown in the figure 1.3.1, select End of List and save the Stock Item 
Creation screen as it is. 

The purpose of creating a bill of material is to enable the auto consumption of the materials in the ratio 
specified when the product is manufactured. Tally allows us to use a Manufacturing Journal to enter the 
goods manufactured with the bill of materials. 

Note: Tally supports multiple BoM creation and copying of one BoM details to another. Ctrl+C: Copy BoM 
option will be highlighted, if more than one BoM is created. 

1.3.4 Accounting of Manufacturing Process  

Manufacturing Journal is the place where the manufactured inventory is accounted and recorded since it is 
not a default voucher type, new voucher type must be created in Tally, for accounting manufacturing process. 
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Illustration 2: Record purchase of raw materials and manufacturing the finished product. 

Date Particulars 

1-09-2019 Purchase the following components from Comfort Traders on credit and store it in Jayanagar 
Storehouse with reference number PUR/003 

Name of the Stock Item Quantity Rate per (₹) Amount (₹) 

Display Screen 100 ₹ 10,000/Nos. ₹ 10,00,000 

Hard Disk Drive 100 ₹ 8,000/Nos. ₹ 8,00,000 

Internal Battery 100 ₹ 5,000/Nos. ₹ 5,00,000 

Keyboard 100 ₹ 2,000/Nos. ₹ 2,00,000 
 

Table 1.3.3 

To record the transaction, first ensure that the required ledgers are created. 

Step 1: Activation and Creation of Godown 

1. Go to Gateway of Tally > Press F11: Features > F2: Inventory >Set the option Maintain multiple 
Godowns to Yes, and save the Inventory Features screen 

2. Go to Gateway of Tally > Inventory Info. > Godowns > Create > Enter the Name as Jayanagar 
Storehouse and save the Godown. 

Step 2: Creation of Manufacturing Journal Voucher Type 

To create a new Manufacturing Journal voucher type, follow the steps: 

1. Go to Gateway of Tally > Accounts Info. > Voucher Types > Create> Enter the name as 
Manufacturing Journal >Under Stock Journal (by doing this the manufacturing journal voucher type 
will inherit the properties of predefined stock journal voucher type)> Set Use as Manufacturing Journal 
to Yes and save the voucher type. 

Activity:  

1. Create the ledger Comfort Traders under Sundry Creditors 

2. Record the purchase transaction of Illustration 2, by selecting the godown as Jayanagar Storehouse. 

Observation: Once after recording the transaction go to Gateway of Tally > Stock Summary > Press Enter 
on Raw Materials, we will get the details of purchased stock. 

The Stock Summary with Raw Materials appears as shown in the figure 1.3.2: 
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Figure 1.3.2 Stock Summary with Raw Materials 

Illustration 3: Recording of manufacturing journal for converting raw materials in to finished goods 

Date Particulars 

02-09-2019 As per the order received for 50 Quantity of DLL MacBook, manufactured 50 Quantity 
of DLL MacBook. 

While Manufacturing following expenses/cost were incurred. 

 Labour Charges – ₹ 10,000 

 Packing Charges – ₹ 8,000 

Table 1.3.4 

Activity: Create Labour Charges and Packing Charges ledgers under Direct Expenses Group 

Recording of Manufacturing Journal Voucher 

1. Go to Gateway of Tally >Inventory Vouchers > Press ALT+F7 > Select Manufacturing Journal > 
Press F2: Date: 02-09-2019 

2. In the Name of product field select DDL MacBook (Finished Goods) 

3. The Name of BOM & Components (Consumption) details will get captured automatically, if required one 
can change the Name of BOM by pressing Backspace 

4. In Godown field select Jayanagar Storehouse, this is location where a finished goods will be stored 
after manufacturing > In Qty field enter the quantity to be manufactured. (50 Nos) Once after providing 
the quantity details the Quantity, Rate and Amount will get captured automatically for component. 

5. Under Components (Consumption) column enter the godown details as Jayanagar Storehouse (As 
we have stored the raw materials in Jayanagar Storehouse)> Under Co-Product/By-Product/Scrap 
select End of List (While manufacturing  if scrap or co-products or by-products are produced then need 
to select the same under this field) 

6. Under Type of Additional Cost select the expenses incurred while manufacturing like Labour Charges 
and Packing Charges as ₹ 10,000 and ₹ 8,000 and save the entry. 

The Completed Manufacturing Journal Voucher appears as shown in the figure 1.3.3: 
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Figure 1.3.3 Manufacturing Journal Voucher Screen 

Observation: Once the labour Charge and Packing charge is added the effective rate of primary item 
increases to ₹ 25,360/Nos. In this price the labour charge and packing charge is added. 

Activity: Once after recording the manufacturing journal entry, go to Gateway of Tally > Stock Summary, 
here you will get the finished goods quantity as 50. This is the quantity which we have manufactured. 

Note: To view the items with zero balance, click F12: Configure and enable show all items (inc. zero 
balance) 

The Stock Summary with Finished goods appears as shown in the figure 1.3.4: 

 

Figure 1.3.4 Stock Summary with Finished goods 
Activity: 

Date Particulars 

11-09-2019 Sold the following stock items to Pruthvi Traders on credit from Jayanagar Storehouse with 
reference number SAL/005 

Name of the stock item Quantity Rate per (₹) Amount (₹) 

DDL MacBook 10 ₹ 30,000/Nos. ₹ 3,00,000 

Hint: Create Pruthvi Traders under Sundry Debtors. 

Table 1.3.5 
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1.3.5 Transferring of Goods from Storehouse to Main Location 

Emerald-Shine Makers transferred 20 Qty of DDL MacBook from Jayanagar Storehouse to Main Location as 
they are expecting sales in Head office. 

Stock Journal voucher is used to transfer the goods from one location to another. 

Illustration 4: Recording Stock Journal voucher to transfer materials from one location to another 

Date Particulars 
11-09-2019 Transferred 20 Quantity of DDL MacBook from Jayanagar Storehouse to Main 

Location   

Table 1.3.6 

To transfer the goods from one location to another, follow the steps: 

1. Go to Gateway of Tally > Inventory Vouchers > Press Alt+F7 > Select Stock Journal> Under Source 
(Consumption) field select DDL MacBook > Select Godown as Jayanagar Storehouse, Enter 
Quantity as 20 and the Rate and Amount will get captured automatically 

2. In Destination (Production) field select DDL MacBook > Select Godown as Main Location, Enter 
Quantity as 20 and the Rate and Amount will get captured automatically> save the entry 

The Completed Stock Journal Voucher appears as shown in the figure 1.3.5: 

 

Figure 1.3.5 Stock Journal Voucher Screen – Destination (Production) 

1.3.6 Copying the components of a BOM to Another Bill of Material of a Stock Item 

Emerald-Shine Makers received an order for customization of DDL MacBook with external speakers, company 
wants to manufacture the next set of production with additional Raw material external speakers. Tally helps in 
simplifying the manufacturing process by copying the components of BOM from one to another BOM. 

Let us check how this copy of BOM works in Tally: 

Activity: Create the stock item as Speakers under the Stock group Raw Materials  

1. To copy from Gateway of Tally>Inventory Info>Stock Items>Alter>Select DDL MacBook>Enable the 
option Alter components (BOM)?, the BoM List screen appears>Press Lower Arrow key to create 
additional BOM , Enter the Name of BOM as DDL MacBook(Speaker)> press Enter  Stock Item 
components (BoM) screen appears  

2. Click Ctrl+C: Copy BoM, Copy BoM Details screen appears, Select Stock Item as DDL MacBook and 
Component of BoM as DDL Silver MacBook, the components get copied from other BOM 
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3. Enter the Unit of manufacture as 1 > and add the additional components along with godown, in this 
case it is Speakers. 

Note: As we have created new BOM for the stock item DDL MacBook, on selecting New BOM while recording 
Manufacturing Journal the changes gets updated. 

1.3.7 Reports 

Once after recording the transactions like purchase, manufacturing journal, sales and stock journal let 
us check the how these transactions are reflected instantly on reports like Stock Journal Register, 
Transfer Analysis, Godown Summary and Cost estimation. 

1.3.7.1 Stock Transfers 

Stock Transfers/Stock Journal Register displays the list of all the Stock Journal Vouchers used in Tally to make 
stock adjustments. 

Transactions recorded in manufacturing journal voucher will reflect the details in Stock journal register. 

To view stock transfer register, go to Gateway of Tally > Display > Inventory Books> Stock Transfers> 
Enter on September month  

The Voucher Register screen with Stock journal and Manufacturing journal appears as shown in the figure 
1.3.6: 

 

Figure 1.3.6 Stock Journal Voucher Register 

1.3.7.2 Transfer Analysis 

When using different Stock Journals types to record different transactions, Transfer Analysis gives the 
movement details for each type of Stock Journal. 

This report displays information about the Items which are transacted in the Stock Journal Voucher. Generally, 
in the Stock Journal Voucher, Movement of Goods, Manufacture of Goods or Inter-Godown Transfer is 
recorded. 

To view the Stock Transfer analysis for any Stock Journal Voucher Type: 

From Gateway of Tally> Display > Inventory Books > Movement Analysis >Transfer Analysis > Select 
Manufacturing Journal, from the List of Voucher Type. 

The Transfer Analysis Report is displayed as shown in the figure 1.3.7: 
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Figure 1.3.7 Transfer Analysis Report 

Activity: Similarly check the other reports falling under the Movement Analysis Report. 

1.3.7.3 Cost Estimation 

Cost Estimation is a statement that gives the value of the cost incurred in the manufacturing of finished 
goods. To view the cost estimation of a finished product, select the relevant Stock Group which will display the 
stock consumption details and cost thereof for each of the stock items falling under that Group. 

Cost estimation helps in fixing the selling price of the final product after charging appropriate overheads and 
allowing certain margin for profits. It also helps in drawing conclusions regarding the cost of production and in 
determining the necessity to introduce cost reduction techniques in order to improve the manufacturing 
process. 

To view Cost Estimation report, follow the steps: 

Go to Gateway of Tally > Display > Statements of Inventory > Cost Estimation > Select Finished Goods 
(Stock Group)  

The Item Estimates report appears as shown in the figure 1.3.8: 

  

Figure 1.3.8 Item Estimates Report 

Note: 

 From the report of figure 1.3.8, press F6: Component-wise to view Components-wise Item 
Estimates details. 

 Press F5: Show All BOM to view the details all BOM created in Tally. 

Conclusion 

In this chapter, we have learnt about manufacturing process and how the same is handled with ease in Tally, 
with the use of Bill of Materials. We have seen how BoM automates the allocation of components while 
recording manufacturing journal voucher and, we have seen how additional cost incurred while manufacturing 
can be added to the cost of finished goods. 
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1.4 Job Work with Sub-Contracting 

 

1.4.1 Introduction 

Job Work refers to the process of placing orders to job workers for manufacturing certain semi-finished or 
finished goods. 

Job Work also involves tracking of dispatched raw materials, received raw materials, and analysing the 
variance quantity for the effective execution of manufacturing process at the job work location. During Job 
Work Order processing, it is critical to identify, estimate and accumulate the additional cost involved at every 
job level. 

Business Scenario 

Emerald-Shine Makers also undertakes manufacturing as well as outsource the manufacturing of electronic 
cookers to job workers with the required specifications, they want to maintain their books of accounts using Job 
Work related transactions and reports in Tally. 

1.4.2 Enabling Job Order Processing 

To enable job order processing in Tally, 

1. Go to Gateway of Tally > F11: Features > F2: Inventory >Set the option Enable job order 
processing? to Yes 

Note: On enabling Enable job order processing option, the options Maintain multiple Godowns and Use 
material In and out vouchers option will be set to Yes automatically 

In this case we have already enabled Maintain multiple Godowns  

The Inventory Features sub screen appears as shown in the figure 1.4.1 

LEARNING OBJECTIVES 
 Handling of job work order processes  
 Recording the consumption of materials 
 Identifying and ascertaining of additional cost involved in job works 
 Ascertaining stock lying in third parties godown(s) and third-party stock lying in our godown(s) 
 Generating job work in order & job work out order reports 
 Compare and analyse various job work transactions 
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Figure 1.4.1 Inventory Features Screen 

1.4.3 Voucher Type Set Up  

Voucher Type Set up for Job Work Out Order needs to be configured for the voucher types, 

 Material In: It is used to record the material transfer in. 

 Material Out: It is used to record the material transfer out. 

However, for the purpose of recording transactions for Job Work (Job Work Out), Material In and Material Out 
voucher types are required to be configured in the following ways: 

Step 1: Altering Material In Voucher Type. 

Go to Gateway of Tally > Inventory Info. > Voucher Types > Alter> Select Material In voucher type> Set 
Use for job work to Yes> Set Use for Job Work In to No>Set Allow consumption to Yes and save the 
voucher type. 

Step 2: Altering Material Out Voucher Type 

Go to Gateway of Tally > Inventory Info. > Voucher Types > Alter>Select Material Out voucher type> Set 
Use for job work to Yes> Set Use for Job Work In to No and save the voucher type. 

Voucher Type Set up for Job Work In Order, 

For Job Work In process, new voucher types have to be created for Material In and Material Out.  

Step 1: Create a new voucher type as Material In (Raw Materials). 

Go to Gateway of Tally > Accounts/Inventory Info. > Voucher Types > Create> create as Material In (Raw 
Materials)> Select type of voucher> as Material In, Set the option Use for job work and Use for Job Work 
In to Yes> Set Allow consumptions to No and save the voucher type. 
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Step 2: Create a new voucher type as Material Out (Finished Goods). 

Go to Gateway of Tally > Accounts/Inventory Info. > Voucher Types > Create> Material Out (Finished 
Goods)> under> Material Out >Set the option Use for job work and Use for Job Work In to Yes and save the 
voucher type. 

1.4.4 Job Order Processing 

As discussed earlier, the job work order processing involves placing of orders to job worker(s) or undertaking 
orders from clients (principal) for the manufacture of a specified item(s). Further, it allows tracking the 
additional costs, materials transfers and materials consumption during the manufacturing process at job work 
locations. 

In Tally, the job order processing comprises of the following processes: 

 Job Work Out Order 

 Job Work In Order 

Job Work Out Order: Job work out order process takes place when a company places or outsources its part 
of work to the third party called as Job Worker. 

Business Scenario 

Emerald-Shine Makers has placed a job work out order for manufacturing electronic cookers to Madan 
Manufacturing Co. The raw materials for manufacturing electronic cookers are purchased by Emerald-Shine 
Makers. and are transferred to Madan Manufacturing Co. 

Date Particulars 

1-10-2019 Voucher: Purchase 

Purchase the following components from Global Corporation and the goods were stored in 
Component Godown with reference number PUR/004 

Name of the Stock Item Quantity  Rate per (₹) Amount (₹) 

Aluminium Supplies 5,000 20/kg. 1,00,000 

Bakelite Handle Knob 2,000 10/Nos. 20,000 

Rubber Gaskets 2,000 5/Nos. 10,000 

Micro Switch 1,000 100/Nos. 1,00,000 
 

Table 1.4.1 
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Date Particulars 

5-10-2019 Voucher: Job Work Out Order 
Emerald-Shine Makers placed a job work out order with Madan Manufacturing Co., for 
manufacturing of the following stock items with order number 1/MMC 

Name of the Stock 
Item 

Quantity  Rate per (₹) Amount (₹) 

Electronic Cooker 100 1,200 1,20,000 

To manufacture 1 Nos. of electronic cooker, the following components are consumed. 

Name of Stock Item Quantity Consumed 

Aluminium Supplies 5 Kgs 

Bakelite Handle Knob 2 Nos 

Rubber Gaskets 2 Nos 

Micro Switch 1 Nos 

The stock is maintained in separate Godown for job work purpose. The raw materials are stored 
in Component Godown and the finished goods are stored in Finished Goods Godown. 

Table 1.4.2 

Date Particulars 

05-10-2019 Voucher: Material Out 

Emerald-Shine Makers transferred the following components to Madan Manufacturing. Co., for 
manufacturing electronic cookers with reference number MO1. A separate Job Worker Godown 
was maintained to track the job work activities. 

Name of the Stock Item Quantity Rate per (₹) Amount (₹) 

Aluminium Supplies 500 20/kg. 10,000 

Bakelite Handle Knob 200 10/Nos. 2,000 

Rubber Gaskets 200 5/Nos. 1,000 

Micro Switch 100 100/Nos. 10,000 
 

Table 1.4.3 

Date Particulars 

15-10-2019 Voucher: Material In 

Emerald-Shine Makers received the following finished goods from Madan Manufacturing Co 
with reference number MI1. The goods are stored in Finished Goods Godown. 

Name of the Stock Item Quantity Rate per (₹) Amount (₹) 

Electronic Cooker 100 1,200 1,20,000 
 

Table 1.4.4 
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Date Particulars 

17-10-2019 Voucher: Purchase Voucher 

Emerald-Shine Makers booked the job work charges payable to Madan Manufacturing Co. 
and on the same day made a payment of ₹ 1,30,000 towards job work charges with 
reference number JWC/005. 

Table 1.4.5 

Date Particulars 

17-10-2019 Voucher: Payment Voucher 

Made a payment of ₹ 1,30,000 to Madan Manufacturing Co. towards job work charges. 

Table 1.4.6 

To record the transaction in the books of accounts follow the steps: 

Step 1: Creation of Accounting Masters 

Activity:  

1. Create Madan Manufacturing Co. under Sundry Creditors 

2. Global Corporation under Sundry Creditors 

Step 2: Creation of Inventory Masters 

Activity:  

1. Create the Godowns as per Table 1.4.7 

Godown Name Under Our stock with 
third party 

Third party stock 
with us 

Component Godown Primary No No 

Finished Goods Godown Primary No No 

Job Worker Godown (Madan Manufacturing Co.) Primary Yes No 

Table 1.4.7 

Note: Job Worker Godown is created to keep track of the stock item lying in the job worker godown. 
When the option Our stock with third party is set to Yes, then the Third party stock with us option will be 
automatically skipped. 

2. Create the Stock Group as Finished Product (E.C) (for electronic cookers) and Components enable 
the option Should quantities of items be added in both the stock group. 

3. Create Units as Kgs. 

4. Create the stock items (Components) as per Table 1.4.8 from Multiple Stock Item Creation screen. 
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Name of Stock Item Stock Group Unit of Measure 

Aluminium Supplies Components Kgs 

Bakelite Handle Knob Components Nos 

Rubber Gaskets Components Nos 

Micro Switch Components Nos 

Table 1.4.8 

5. Create the stock item Finished Product Electronic Cooker as per Table 1.4.9 

Name of Stock Item Stock Group Unit of Measure Set Components (BOM) 

Electronic Cooker  Finished Product (E.C) Nos. Yes 

Table 1.4.9 

Once after enabling the option Set Components (BOM), BOM list appears. Provide BOM name as Standard 
and enter Unit of Manufacture as 1 and fill in the Stock Item Components screen as shown in figure 1.4.2 and 
save the stock item creation screen. 

 

Figure 1.4.2 Stock Item Components BoM Screen 

Step 3: Record Purchase of Raw Materials 

Activity: Record the Purchase Voucher as per Table 1.4.1 by selecting the godown as Component godown. 

Once after recording the purchase entry, go to Gateway of Tally > Stock Summary > press Enter on 
Components > Press Alt+F1: Detailed to view the components in component godown. 

Step 4: Record Job Work Out Order Voucher 

1. Go to Gateway of Tally > Order Vouchers> Press Alt+J for Job Work Out Order>Press F2: Date and 
enter as 05-10-2019 

2. In Party A/c Name field, select Madan Manufacturing Co. (The job worker ledger on whom the job 
workout order is raised) 
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3. In Party Details screen, specify Dispatch Details, Process Instruction. i.e. Duration of Process and 
Nature of Processing to be carried out as shown in figure 1.4.3 

 

Figure 1.4.3 Party Details Screen 

4. Save the Party Details screen>In Order no. field, enter the job work out order number as 1/MMC> 
Under Name of Item field select the finished Product i.e., Electronic Cooker ( finished goods to be 
manufactured by the job worker) press Enter to view Stock Item Allocations screen 

 Set Track Components to Yes – This option is enabled if the principal manufacturer wants to track the 
raw materials used in the manufacturing of finished goods retain the setting as Yes 

 In the Due on field specify the date on which the delivery of finished goods is due. (In this case Emerald-
Shine Makers has accepted the manufacturing duration of 15 days. Hence the 100 Nos of electronic 
cooker will be due on 20-10-2019.) 

 In the Godown field select the Finished Goods Godown where the finished goods will be stored on 
receipt of the same from the job worker 

 In Quantity field, specify the quantity of finished goods to be received from the job worker. (Specify 100 
Nos as the quantity and press enter from quantity field to view the Components Allocation for screen) 

 In Components Allocation for screen under Fill Components using: the BOM created for the finished 
goods which will be displayed by default. 

The completed Components Allocation screen appears as shown in the figure 1.4.4: 
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Figure 1.4.4 Components Allocation Screen 

Note: In Component Allocation screen, the components are allocated automatically because of BOM. If BOM 
is not created, then the component allocation must be done manually. 

5. Press Enter to save the Components Allocation screen 

6. Enter the rate and amount in the Stock Item Allocation screen as shown in figure 1.4.4 

The Stock Item Allocation screen appears as shown in figure 1.4.5: 

 

Figure 1.4.5 Stock Item Allocation 

7. Accept the screen. 

The completed Job Work Out Order Voucher appears as shown in the figure 1.4.6: 

 

Figure 1.4.6 Job Work Out Order Voucher 
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8. Press Ctrl+A to accept 

Once after recording the job work out voucher the transaction will get updated in Job Work Out Reports, to 
check go to Gateway of Tally > Display > Job Work Out Reports > Select Order Outstandings > Orders> 
press ALT+ F1: Detailed  

The Job Orders Summary report appears as shown in the figure 1.4.7: 

 

Figure 1.4.7 Job Orders Summary Screen 

Observation: In Job Order Summary, we are getting the details of job work out ordered quantity details along 
with the balance quantity.  

Press Alt+C: Components, from Job Orders Summary screen to get the Components Order Summary 
details. 

Observation: In Components Order Summary report we will get the details of the components which are 
pending to be issued to the job worker. 

Step 5: Issue of Raw Materials to Job Worker 

1. Go to Gateway of Tally > Inventory Vouchers > press Ctrl+J for Material Out>under the list of voucher 
types, select the default Material Out voucher type> F2: Date: 05-10-2019 and provide reference no as MO 1 

2. In Party A/c Name field, select Madan Manufacturing Co. (The Job Worker ledger for whom the Job 
Work out order is raised) 

3. Press Enter to view Order Details and Party Details screen>under Order Details, in Order no(s) field 
select 1/MMC dated 05-10-2019 with Order Type – Component Issue Order as the job order from the list of 
orders (towards which the raw materials are transferred), in Date & Time of Issue field, by default the voucher 
date and system time will be displayed, accept Party Details screen. 

4. In Destination Godown field, select Job Worker Godown as the godown to where the stock is 
transferred (Our Stock with third party option need to be enabled in the godown)>Under Name of Item, the 
stock items will be auto-filled based on the job order selected 

The completed Material Out voucher appears as shown in the figure 1.4.8: 
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Figure 1.4.8 Material Out Voucher 

5. Accept the Entry. 

Activity:  

 Once after recording the material out entry, go to Gateway of Tally > Display > Job Work Out Reports 
>Order Outstandings> Components, you can observe that the report is blank because the raw 
materials are supplied to the job worker for manufacturing the finished goods. In order to view the 
cleared job orders, press F12: Configure and set the option Show Cleared Job Orders to Yes. 

 Go to Gateway of Tally > Stock Summary > press Ctrl+G: Godown Type and select the Type of 
Values as Our stock with third party> Select Components Group you will get list of stock items.  
observe that once after recording material out voucher the same stock is available in different godowns 
with different quantities. 

Step 6: Receipt of Finished Goods 

1. Go to Gateway of Tally > Inventory Vouchers > Press Ctrl+W for Material In> select the default 
Material In voucher type> Press F2: Date and change the date to 15-10-2019 and enter reference no as MI 
1>In Party A/c Name field, select Madan Manufacturing Co. (The Job Worker ledger from whom the Finished 
Goods are received) 

2. Press Enter to view Order Details and Party Details screen> In Order Details, under order no(s) field 
select 1/MMC dated 5-10-2019 with Order Type – Material Receipt Order as the job order from the list of 
orders (towards which the finished goods are received) 

Note: Party’s Document Details captures the details automatically based on the details provided in Job Work 
Out Order. 

3. In Consumption Godown field, select Job Worker Godown as the Godown from where the 
components/raw materials are consumed> In Name of Item, the stock item electronic cooker will be auto filled 
based on the Job Order selected 

4. Press Enter to view the Stock Item Allocations screen, set the following details in Item Allocation for 
sub screen 

 Set the option Consider as Primary Item to Yes (If you want to track the cost of raw materials 
consumed to the primary item. Here the cost of raw materials consumed in this voucher is tracked 
against Electronic Cooker) 



 ADVANCED ERP CONCEPTS 

258  ADVANCED INFORMATION TECHNOLOGY 

 In BoM Name field select Standard and press Enter 

 The Order No., Godown, Quantity, Rate and amount of the item will be displayed. Accept the default 
details 

The completed Material In voucher appears as shown in the figure 1.4.9: 

 

Figure 1.4.9 Material In voucher 

Note: The option Enter consumption details by default will be set to Yes (Auto) and it indicates that the 
consumption of raw materials to manufacture the finished goods in Auto Consumption (Cursor will skip this 
field). 

5. Accept the screen 

Activity: Check the Job Work Out Order outstanding report, the report will be blank because once after 
receiving the total finished goods from job worker, the same will be cleared from the Order Outstanding report. 

Step 7: Booking of Job Work Charges 

Activity: Create the Job Work Charges ledger under Direct Expenses group. 

1. Go to Gateway of Tally > Accounting Vouchers > press F9: Purchase 

2. Press F2: Date to change the date to 17-10-2017 

3. Press Alt+I: Accounting Invoice, if the voucher is in item invoice mode. 

Note: If the voucher is in voucher mode, then press Ctrl+V: As Invoice and then press Alt+I: Accounting 
Invoice 

4. Enter the Supplier Invoice no. as JWC/005, Date appears automatically. 

5. In Party A/c name field select Madan Manufacturing Co. 

6. Under Particulars select Job Work Charges ledger and enter the amount as ₹ 1,30,000 

7. Select the Type of Ref. as New Ref. with the same value and press Enter and accept the screen. 

The completed Purchase Voucher appears as shown in the figure 1.4.10: 
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Figure 1.4.10 Purchase Voucher 

8. Press Ctrl+A to accept 

Once after recording the Purchase voucher, the entry will be automatically updated in Profit and Loss 
Account and Balance Sheet. 

Step 8: Record Payment to Job Worker against Purchase Consideration 

1. Go to Gateway of Tally > Accounting Vouchers > press F5: Payment> Under Account field, select 
SBI Bank> Under Particulars, select Madan Manufacturing Co. (Job worker) 

2. In the Bill wise Details screen, select Agst Ref and Track the bill with bill number JWC/005 and save 
the entry. 

Once after recording the payment entry the Job work out order process is completed. 

1.4.5 Job Work Out Reports 

In Tally, Job work out reports gives the details of following information: 

 Order Outstandings 

 Job Work Registers 

 Stock 

 Job Work Analysis 

To view the Job Work Out Order Reports, Go to Gateway of Tally > Display > Job Work Out Reports 

The Job Work Out Reports Menu appears as shown in the figure 1.4.11: 

 

Figure 1.4.11 Job Work Out Report 
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In the previous section we have learnt about the Order Outstanding report and checked the details of order 
pending to be received from job worker and components which were pending to be sent from our end 
(company). 

Now let us check the capability of other job work out reports available in Tally 

Job Work Registers 

To view the Job Work Registers, Go to Gateway of Tally > Display > Job Work Out Reports > Job Work 
Registers 

The Job Work Registers Menu appears as shown in the figure 1.4.12: 

 

Figure 1.4.12 Job Work Registers Menu 

They are four types of reports under Job work registers: 

 Job Work Out Orders Books 

 Material Out Register 

 Material In Register 

 Material Movement Register 

Job Work Out Orders Books: This report displays all the job work out order vouchers recorded in the books.  

Observation: In Voucher Register report we are getting the details of list of all the job work out order 
vouchers recorded for the particular month. We can check the report for any period by using the key Alt+F2: 
Period. 

Material Out register: This report displays all the material out vouchers recorded to account the transfer of 
material to the job workers location. 

Observation: In the Material Out Register, we will get the details of material out voucher using which raw 
materials are sent to job worker for manufacturing processes. 
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Material In Register: displays all the material in vouchers recorded to account the receipt of finished goods 
from the job worker location.  

Observation: In Material In Register, we will get the details of finished goods receipt details, which was 
recorded using material in voucher in Tally. 

Material Movement Register: It displays the details of movement of material (raw materials and finished 
goods) 

Observation: Material Movement Register, displays the details of overall movement of finished goods and raw 
materials. 

This completes the explanation of Job work register reports available in Tally, next let us check the stock and 
job work analysis reports. 

Stock: It display the details of stock lying with the job workers and provides the ageing analysis of stock lying 
with the job worker. 

From Stock Menu we can check the following two reports 

 With Job Worker: This report displays the details of stock lying with the job worker. To view the stock 
With Job Worker report, go to Gateway of Tally > Display > Job Work Out Reports > Stock > With 
Job Worker > press F5 (To get the party wise detail) 

 Ageing Analysis: It displays the details of period (i.e. for how many days) has the stock been lying with 
the job worker 

To view the Stock Ageing Analysis report, go to Gateway of Tally > Display > Job Work Out Reports > 
Stock > Ageing Analysis > select Primary from the List of Stock Groups for which the ageing analysis report 
is to be viewed. 

Job Work Analysis Report: It report gives the information of any variance in the issue of raw materials (issued 
more) and receipt of finished goods/scrap/by-products/co-products. These reports can be used to analyse 
reasons for variances. 

In Job Work Analysis Menu, we are getting the following two report: 

 Issue Variance: It displays the details of variance in the raw material/components issued against the 
ordered quantity of the Job Work Out Order. The report also displays the variance quantity and the 
percentage of variance. 

To view the Stock Issue Variance report, go to Gateway of Tally >Display > Job Work Out Reports > Job 
Work Analysis > Issue Variance > press Alt+F1 for detailed view. 

 Receipt Variance: It displays the details of variance in the finished goods/scrap/co-product/by-product 
received against the ordered quantity of the Job Work Out Order. 

Activity: Go to Gateway of Tally >Display > Job Work Out Reports > Job Work Analysis > Receipt 
Variance.  

Observation: As there is no variance the report will show blank. 
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1.4.6 Job Work In Order Processing  

Job work in order process will take place when a company receives a job work from the third party. In this case 
Emerald-Shine Makers, will act as a Job Worker. In this section we will see the different types of transactions 
involved in Job Wok In Order Processing. 

Job Work In Order process in Tally allows the job worker to record receipt of Job Order from the principal 
company. 

Job Work In Order in Tally allows: 

 Raising an order for material (finished goods) to be dispatched after the completion of the job process 

 Defining the BOM for the finished goods during voucher entry 

 Flexibility to capture information on material required to be received from the principal company 

Business Scenario 

To understand Job Work In Order processing, let us consider that Emerald-Shine Makers has received a Job 
Work In Order for manufacturing Electronic Cookers from Sunshine Industries. The raw materials for 
manufacturing the electronic cookers are received by Emerald-Shine Makers from Sunshine Industries. 

Illustration 2: Handling job work in order processing in Tally 

Date Particulars 

20-10-2019 Voucher: Job Work In Order 

Emerald-Shine Makers Received a Job Work In Order from Sunshine Industries for 
manufacturing the following goods with order no 1/SI 

Name of the Stock 
Item 

Quantity  Rate per (₹) Amount (₹) 

Electronic Cooker 50 1,200 60,000 

To manufacture 1 Nos. of electronic cooker, the following components are consumed. 

Name of Stock Item Quantity Consumed 

Aluminium Supplies 5 Kgs 

Bakelite Handle Knob 2 Nos 

Rubber Gaskets 2 Nos 

Micro Switch 1 Nos 

The stock is maintained in separate godown for job work purpose. The raw materials and the 
finished goods are stored in Sunshine Godown i.e. Third Party godown. 

Table 1.4.10 
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Date Particulars 

22-10-2019 

 

 

 

 

 

 

 

 

Voucher: Material In 

Emerald-Shine Makers received the following components from Sunshine Industries for 
manufacturing electronic cookers with reference number SI/1. A separate Job Worker 
Godown is maintained to track the job work activities 

Name of the Stock Item Quantity  Rate per (₹) Amount (₹) 

Aluminium Supplies 250 20/kg. 5,000 

Bakelite Handle Knob 100 10/Nos. 1,000 

Rubber Gaskets 100 5/Nos. 500 

Micro Switch 50 100/Nos. 5,000 
 

Table 1.4.11 

Date Particulars 

22-10-2019 Voucher: Manufacturing Journal 

Emerald-Shine Makers manufactured 50 electronic cookers using the raw materials 
received from Sunshine Industries that are stored in Sunshine Godown. 

Table 1.4.12 

Date Particulars 

26-10-2019 Voucher: Material Out 

Emerald-Shine Makers delivered the following finished goods to Sunshine Industries with 
reference number MO/SI1. The goods are stored in Sunshine Godown. 

Name of the Stock Item Quantity Rate per (₹) Amount (₹) 

Electronic Cooker 50 1,200 60,000 
 

Table 1.4.13 

Date Particulars 

27-10-2019 Voucher: Sales Voucher 

Emerald-Shine Makers Booked the income of ₹ 60,000 in the sales invoice from Sunshine 
Industries for the job work rendered with reference number JWC/006. 

Table 1.4.14 

Date Particulars 

27-10-2019 Voucher: Receipt Voucher 
Received ₹ 60,000 from Sunshine Industries for the job work rendered. 

Table 1.4.15 
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To record the transaction in the books of accounts follow the steps given: 

Step 1: Creation of Accounting Masters 

Activity:  

1. Create Sunshine Industries under Sundry Debtors 

Step 2: Creation of Inventory Masters 

Godown Name Under Our stock with third party Third party stock with us 

Sunshine Godown Primary No Yes 

Table 1.4.16 

Step 3: Recording Job Work In Order 

Activity: Record Job Work In Order as shown in the Table 1.4.10, (Provide despatch details as per your 
requirement) with job work order number as 1/SI select the godown as Sunshine Godown in Stock item 
Allocations screen as well as in Component Allocations screen. 

Note: While recording Job Work In Order, the finished good quantity will appear as negative stock, this is 
because currently we do not have stock balance in Sunshine Godown.  

After recording the Job Work In Order voucher, the entry will be automatically updated in Job Work In 
Reports.  

To check, go to Gateway of Tally > Display > Job Work In Reports> Order Outstanding > Orders > press 
Alt+F1: Detailed 

Step 4: Recording Material In Voucher 

Activity: Record Material In Voucher by selecting Material In (Raw Materials) as shown in the Table 1.4.11, 
with reference number as SI/1, track the Job work In order. 

Hint: In Source Godown field, select Not Applicable as the components are being received from the principal 
manufacturer. Store the materials received in Sunshine Godown(Third Party Godown). 

Once after receiving the components from the third party the stock balance will not impact our books of 
accounts.  

To check the details of third party stock with us,  

1. Go to Gateway of Tally > Stock Summary > press Ctrl+G: Godown Type 

2. Under Type of Values select Third party stock with us 

Step 5: Manufacturing of Finished Goods 

Activity: Record the Manufacturing Journal entry as shown in the figure 1.4.13 
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Figure 1.4.13 Manufacturing Journal Voucher 

Note: Change the Godown to Sunshine Godown manually for all components as shown in the figure 1.4.13 

Activity: Check third party stock with us details 

 Go to Gateway of Tally > Stock Summary > press Ctrl+G: Godown Type 

 Under Type of Values select Third party stock with us 

 The report will display the stock balance of electronic cooker stock item, because the components are 
consumed, and it is converted into finished goods. 

Once the finished goods are manufactured, next step is to dispatch the goods to the third party (Sunshine 
Industries) 

Step 6: Dispatching Finished Goods to Manufacturer (Sunshine Industries) 

Activity: Record Material Out entry as per table 1.4.13 by selecting the voucher type Material Out (Finished 
Goods) with Reference No MO/SI (Track the Material Dispatch Order number). 

Hint: In Destination Godown field, select as Not Applicable as the stock is being transferred to the Principal 
Manufacturer 

Step 7: Booking of Income Details (Job Work Charge) 

Book the Income as shown in figure 1.4.14 

Activity: Create a ledger Job Work Charges Income under Direct Incomes. 

The completed Sales Voucher appears as shown in the figure 1.4.14: 

 

Figure 1.4.14 Sales Voucher 
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Step 8: Recording receipt from Sunshine Industries against the Job Work Rendered 

Record the Receipt entry as shown in the figure 1.4.15 

The Receipt Voucher screen appears as shown in the figure 1.4.15: 

 

Figure 1.4.15 Receipt Voucher 

1.4.7 Job Work In Order Reports 

In Tally, job work in reports gives the details of following information: 

 Order Outstanding 

 Job work register 

 Stock 

 Job Work Analysis 

Activity: Check all the Job Work In Reports and understand the behaviour of the reports. 

Conclusion  

In this chapter, we have learnt about different types of job work processing like job work out order processing 
and job work in order processing and, we have checked how the reports are generated instantly once the 
transactions are accounted in Tally. 

The management can easily track the inflow and outflow of components and finished goods which aids in 
decision making for a company. 

1.5 Price Levels and Price Lists 

 

1.5.1 Introduction 

A Price List refers to a list of items maintained by an organisation along with their price details. It is generally 
used by organisations which deals in multiple products. 

Price Lists are maintained in various structures for different types of buyers (customers), viz., Wholesalers, 

LEARNING OBJECTIVES 
 Create and maintain price levels and price lists 
 Use price lists while passing invoice  
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Dealers, Retailers, etc. It is structured based on the classification of buyers and is referred at the time of 
making sales. Whenever the sales price changes (on the basis of time), the changes are reflected in the Price 
List also. In case of bulk sales, discounts can also be given to the buyers. 

Tally permits you to create any number of Price lists & Price levels, based on the Stock Group and Stock 
Category to match the required structure. 

Business Scenario 

Emerald-Shine Makers manufactures and trades DLL Smartphones and they sell the goods to wholesalers and 
retailers at different prices to each level of customers, company wants to fix the price of the products for 
different kinds of buyers based on time period and size of order also, the discount rate varies based on the 
size of the order. These requirements can be easily maintained using pricelist feature of Tally  

Let us now see how Tally handles such a situation through the Price List feature. 

1.5.2 Activating Price Lists and Defining of Price Levels 

We can define the classification of buyers like wholesalers, retailers etc. in the Price Level and prices of the 
stock item can be defined in the Price List. 

Illustration 1: Defining price levels for different buyers 

Pass the following transaction in the books of Emerald-Shine Makers 

Date Particulars 

01-11-2019 Emerald-Shine Makers wants to define price levels for its buyer Classification like: 

 Wholesale Price Level 

 Retail Price Level 

Table 1.5.1 

To maintain the price levels in the books of accounts, first ensure that the required configurations are made in 
Tally 

Follow the steps to create the Price Levels (Classification of Buyers) in Tally. 

Activation of Price List, and Defining the Price level: 

1. Go to Gateway of Tally > Click>F11: Features> F2: Inventory 

2. Set the option Use multiple price levels to Yes. (This option will be accessible only if the feature 
Enable invoicing is set to Yes.) 

3. Press enter and the Company Price Levels screen will appear. 

4. Define the price levels as: 

 Retail Price Level-1 

 Wholesale Price Level-1 
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The Price Levels Screen appears as shown in the figure 1.5.1: 

 

Figure 1.5.1 Company Price Levels Screen 

5. Accept the screen and save the Inventory Features. 

1.5.3 Creation of Price List 

In this section, we will learn how to define price list for different stock items. 

Illustration 2: Defining price list for different stock items of the company in Tally 

Emerald-Shine Makers for the Month of November-2019 

Wholesale Price Level-1 

Stock Group Name of the Stock Item Number of Quantities Rate Discount Rate 

  From Less than   

Mobile Phones DLL - GEN_1 
Basic Phone 

 10 5000 -- 

  10 20 5000 1% 

  20 above 5000 5% 

      

Mobile Phones DLL - GEN_4 
Smart Phone 

 10 10,000 1% 

  10 20 10,000 5% 

  20 above 9,500 5% 

      

Mobile Phones DLL - GEN_5 
Smart Phone 

 10 15,000 1% 

  10 20 14,000 -- 

  20 above 14,000 5% 

Table 1.5.2 Wholesale Price Level-1 Price List 
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Retail Price Level-1 for the month of November 

Stock Group Name of the Stock Item Quantities Rate Discount Rate 

  From: Less than   

Mobile Phones DLL - GEN_1 
Basic Phone 

 5 6,000 -- 

  5 10 6,000 5% 

  10 15 5,500 1% 

  15 above 5,500 5% 

      

Mobile Phones DLL - GEN_4 
Smart Phone 

 5 12,000 1% 

  5 10 12,000 5% 

  10 15 11,500 -- 

  15 above 11,500 10% 

      

Mobile Phones DLL - GEN_5 
Smart Phone 

 5 16,000 1% 

  5 10 16,000 5% 

  10 15 15,500 5% 

  15 above 15,000 10% 

Table 1.5.3 Retail Price Level-1 Price List 

To maintain the price levels in the books of accounts, first ensure that the required masters are created. 

Step 1: Creation of Inventory Masters  

Activity: 

1. Create Stock Group as Mobile Phones  

2. Create Stock Items as shown in the table 1.5.4 

DLL - GEN_1 Basic Phone 

Against the Field Action to be Performed 

Name Enter as DLL - GEN_1 Basic Phone 

Under Select Mobile Phones 

Units Select Nos 

Note: Minimum one stock item must be created in Tally to enable the Price List option. 

Table 1.5.4  
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Activity: Similarly, create two items listed under the stock group Mobile Phones  

 DLL - GEN_4 Smart Phone 

 DLL - GEN_5 Smart Phone          

Step 2: Creation of Price List 

Price List 

To create price list, follow the steps: 

1. Go to Gateway of Tally > Inventory Info. > Price List 

2. In Stock Group Name, select Mobile Phones from List of Stock Groups 

3. Select Wholesale Price Level-1 in Price Level and specify Applicable From date 01-11-2019 

4. Under Particulars, select the applicable stock items, refer the Table 1.5.2 Wholesale Price Level-1 
Price List and fill the details 

 

Figure 1.5.2 Defining Wholesale Price Level-1 Price List details 

5. Accept the screen 

Activity: 

 Similarly, create the price list for Retail Price Level-1 as on 01-11-2019, refer Table 1.5.3 Retail Price 
Level-1. 
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 Additionally, enable the feature Use separate discount column in invoices from Gateway of Tally > 
F11: Features> F2: Inventory (This is enabled to record the transaction with discount details) 

1.5.4 Using Price List 

The following illustrations will demonstrate how price lists can be used in a sales invoice. 

Illustration 3: Recording Sale Voucher 

Date Particulars 

1-11-2019 Voucher: Purchase the following stock item from Mani Electronics with Supplier invoice no 
as PUR/006 

Name of Stock Item Quantity Rate per (₹) Amount (₹) 

DLL - GEN_1 Basic Phone 50 Nos 4,500/ Nos 2,25,000 

DLL - GEN_4 Smart Phone 50 Nos 8,500/ Nos 4,25,000 

DLL - GEN_5 Smart Phone 50 Nos 13,000/ Nos 6,50,000 
 

05-11-2019 Voucher: Sales 

Emerald-Shine Makers sold the following mobile phones to Magnum Stores at Wholesale 
Price Level-1 price with reference number SAL/007. 

Name of Stock Item Quantity Rate per (₹) Discount Amount (₹) 

DLL - GEN_1 Basic Phone 15 Nos 5,000/ Nos 1% 74,250 
 

Table 1.5.5 

To record the transactions of table 1.5.5, in the books of accounts, first ensure that the required masters are 
created in Tally. 

Step 1:  Recording Purchase Invoice 

Activity: Create Mani Electronics under Sundry Creditors and record the purchase transaction in item 
invoice mode. 

Hint: Select the godown as Main Location, for item invoice mode click ALT+I: Item Invoice. 

Step 2: Recording Sales Invoice 

Activity: Create Magnum Stores ledger under Sundry Debtors, select Price level applicable as Wholesale 
Price Level-1 

1. Go to Gateway of Tally > Accounting Vouchers > F8: Sales>Press F2: Date and change the date to 
05-11-2019>Enter the Reference no.: SAL/007> select party as Magnum Stores, Price level appears 
automatically 

2. Select Sales A/c in Sales ledger field. 

3. Select the stock item DLL - GEN_1 Basic Phone, Godown as Main Location and enter quantity as 15 
Nos. 
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4. Rate and Discount automatically appear as ₹ 5,000 and 1% respectively 

(As the required price level is selected in the ledger master of Magnum Stores) 

The Sales Voucher appears as shown in the figure 1.5.3 

 

Figure 1.5.3 Sales Invoice Screen 

5. Save the entry. 

Observation: 

 In the sales invoice as shown in figure 1.5.3, we can observe how the rate and discount 
appeared automatically, this is because we have defined the price list details for all the stock 
items. 

 Tally provides you the flexibility to select items with and without the Price List in the same 
invoice. 

Activity: Record the following transaction  

Date Particulars 
06-11-2016 Sold the following stock item to Variety Infocom at Retail Price with Reference number 

SAL/008 
Hint: Create the party Variety Infocom and select the pricing level as Retail Price Level-1 
 

Name of Stock Item Quantity Rate per (₹) Discount Amount (₹) 
DLL - GEN_1 Basic Phone 10 Nos 5,500/Nos 1% 54,450 

Table 1.5.6 

1.5.5 Revise Price List 

The price of stock items varies from time to time, the price may increase or decrease based on the market 
condition, then as per the latest prices of stock items. The price list defined in Tally can be revised. 

Illustration 4: Revising of price list in Tally 

10-11-2019 Revise Price List  

 Emerald-Shine Makers wants to revise the Wholesale Price Level-1 price list as the rate 
of stock items are increased by ₹ 100.00 and the discount rate is fixed. 

Table 1.5.7 
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To Revise the Price List, follow the steps: 

1. Go to Gate way of Tally > Inventory Info. > Price List 

2. Press Alt+R: Revise Price 

3. Enter the Stock Group Name as Mobile Phones 

4. Select the Price level as Wholesale Price Level-1 

5. Enter the Applicable From Date as 10-11-2019 

6. Enter the details as shown in the figure 1.5.4: 

The Price List screen appears as shown in the figure 1.5.4: 

 

Figure 1.5.4 Revision of Price List Screen 

7. In the Revise Price field select Increase by amount (Because the price is increased by ₹100)> 
Enter the Amount as ₹ 100 

Note: If the price is decreased, select decrease by amount or percentage, if the prices are increased, then 
select Increase by amount , if no variation in the price ,select as Not applicable (Not applicable can be 
selected when there is a change in the discount rate only) 

8. In the Revise Discount field select as Not Applicable> Revise Price updated Message appears 

9. Press Enter from the Price List screen, you will get the Price List with revised rates save the screen 

The Price List with Revised Price screen appears as shown in the figure 1.5.5 

 

Figure 1.5.5 Price List with Revised Price Screen 
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Observation: On the left-hand side in the under-rate column, you are getting the revise price of all the stock 
items (It is increased by ₹ 100) 

After revising the price for stock items let us record the sales transaction with revised price list in Tally 

Illustration 5: Recording sales voucher with revised price list in Tally 

Date Particulars 

15-11-2018 Voucher: Sales 
Sold the following phones to Magnum Stores at Wholesale PL-1 price with Reference no: 
SAL/009 
 

Name of Stock Item Quantity Rate per (₹) Discount Amount (₹) 

DLL - GEN_1 Basic Phone 20 Nos 5,100/Nos 5% 96,900 

Table 1.5.8 

Record the sales invoice as shown in figure 1.5.6 and observe the prices as per the revised price list. 

The Sales Voucher screen appears as shown in the figure 1.5.6 

 

Figure 1.5.6 Sales Invoice with Revised Price 

Activity:  Go to Gateway of Tally > Display > Statements of inventory > Stock query > select DLL- 
GEN_1 Basic Phone >Press F7, to view the price list details and then press F10: Show Latest Price, to get 
the latest price list. 

Conclusion 

In this chapter, we have learnt how to define the different types of price levels for an organisation using Tally 
application. Apart from different price levels, we have learnt how price list for multiple stock items are defined 
from the single screen and how these details reflect while recording sales transactions. 

1.6 Tally Audit 

 
 

LEARNING OBJECTIVES 
 Enable Tally Audit 

 View Tally Audit Monthly Register 
 View Voucher type wise, Master wise and User wise audit statistics details 
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1.6.1 Introduction 

Audit is an important function of any business organisation; it denotes that the business has true and fair 
transactions during the year. Tally has an in-built feature: Tally Audit, which enables the auditor to perform an 
audit or track changes that affect the integrity of a transaction. Changes made to Date, Ledger Masters and 
Amounts in the voucher are reflected in the Tally Audit Listings. 

Business Scenario 

Due to Increase in the volume of business transactions, Emerald-Shine Makers has appointed an accountant 
and two data entry operators; the accounting ledger and inventory masters will be created by the accountant 
and the day-to-day transactions will be recorded in Tally by the data entry operators.  

Their roles are: 

Data Operator 1 - To record Purchase and Payment Transactions in Tally 

Data Operator 2 - To record Sales and Receipt Transactions in Tally 

Emerald-Shine Makers wants to track the day to day activities of the business transactions such as masters 
and entry creations, to facilitate these requirements Emerald- Shine Makers decided to use Tally Audit feature. 

1.6.2 Enabling Tally Audit Feature  

Tally audit feature can be enabled in company creation or alteration screen, since we have already created the 
company let us enable the Tally audit feature in the company alteration screen. 

To enable Tally Audit Features, follow the steps: 

1. Go to Gateway of Tally > press Alt+F3: Comp Info > Alter 

2. In the Company Alteration screen, set Use security control to Yes 

3. Enter the administrator’s name in Name of Administrator field as admin 

4. Enter the password as admin9999 

 Tally displays the strength of the password entered depending on the combination - Alphabets, 
Numbers & Special Characters. 

 Repeat the password for the purpose of confirmation. 

5. Set the option Use Tally Audit Features to Yes 

The Security Control in the company alteration screen appears as shown in figure 1.6.1: 



 ADVANCED ERP CONCEPTS 

276  ADVANCED INFORMATION TECHNOLOGY 

 

Figure 1.6.1 Security Control in Company Alteration screen 

6. On saving the company alteration screen, it will ask for Reload Company, Click Yes> and enter the 
“Name of User” and “Password”, company gets re-loaded 

Note: Use Tally audit features will be available in company creation/alteration screen, only if the option 
“Security Control is enabled”. 

1.6.3 Create User Level Security 

To create User Level Security, follow the steps: 

Step 1: Creating Security Levels for Data Operator 1 

1. Go to Gateway of Tally > Alt+F3: Company Info. > Security Control> Select Types of Security, The 
Default List of Security Levels such as Data Entry, Tally.Net User and Tally.Net Auditor appears, press 
Lower arrow key to enter the name as Data Operator 1 

2.  Select Data Entry in Use Basic Facilities of field 

Note: By Selecting Use Basic Facilities of as Data entry, the newly created security level will inherit the 
facilities of Data entry, which are pre-defined in Tally.  

3. Enter disallow and allow the facilities as shown in figure 1.6.2 and save the screen. 
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Figure 1.6.2 Security Level Screen 

Activity: Similarly, create the following security levels for Data Operator 2 

• Activities which are Disallowed: Purchase and Payment 

• Activities which are Allowed: Sales and Receipt 

The completed Security Level screen appears as shown in the figure 1.6.3: 

 

Figure 1.6.3 Completed Security Level Screen 

Step 2 Creation of Users and Assigning Password for Each User 

1. Go to Gateway of Tally > Alt+F3: Company Info. > Security Control>Users and Passwords 

2. Select the newly created Security Level, enter the Username enter the required Password for the Users. 

Activity:  

1. Provide the username as DO1 and password as DO1 for Data Operator 1 

2. Similarly provide username as DO2 and password as DO2 for Data Operator 2 

The Users for Company screen appears as shown in the figure 1.6.4: 
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Figure 1.6.4 Users for Company Screen 

1.6.4 Creating of master’s by Administrator and Recording of Transactions by the Users 

In this section we will learn to login to the same company with different users and perform the day to day 
activities in Tally 

Illustration 1: Recording of transaction with different user levels 

Record the following transaction from user ID DO1 

Date Particulars 

01-12-2019 Voucher: Purchase 
Purchased the following stock items from Brahma Traders with reference number 
PUR/007 

Name of Stock Item Quantity Rate (₹) Amount 

DDL Laptops 10 15,000 1,50,000 
 

05-12-2019 Voucher: Payment 
Made payment of ₹ 1,50,000 to Brahma Traders through SBI Bank 

Record the following transaction from User ID DO2 

Date  Particulars 

06-12-2019 Voucher: Sales 
Sold the following stock items to Mital Traders 

Name of Stock Item Quantity Rate  Amount 

DDL Laptops 5 20,000 1,00,000 
 

06-12-2019 Voucher: Receipt 
Received ₹ 1,00,000 from Mital Traders 

Table: 1.6.1 

Create the required Masters and record the given transactions using the respective I.Ds 

Step 1: Creation of Accounting Masters  

Masters need to be created in Admin login as we have not provided the permissions to create masters for the 
user ID’s 

Activity: Create Brahma Traders under Sundry Creditors and Mital Traders under Sundry Debtors. 
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Step 2: logout the Company from the Administration level. 

Go to Gateway of Tally>Alt+F3>Shut Company  

1.6.5 Login from User ID 

To login the company from user ID, follow the steps given below 

Step 1: Login to Emerald-Shine Makers using User ID i.e., DO 1 and password as shown in the figure 1.6.5 

 

Figure 1.6.5 Company Login Screen 

Step 2: Recording Purchase Transaction 

1. Go to Gateway of Tally > Accounting Vouchers > F9: Purchase> F2: Date -01-12-2019> Enter 
Supplier invoice no. as PUR/007 and the Date will be captured automatically 

2. In the Party A/c name field select as Brahma Traders> select Purchase ledger 

3. Select the Name of Stock Item as DDL Laptops, Godown as Main Location 

4. Enter the Quantity as 10 Nos, Rate as ₹ 15,000 and the amount will be captured automatically 

5. Accept the Bill-wise details screen, 

The Purchase Invoice screen appears as shown in figure 1.6.6: 

 

Figure 1.6.6 Purchase Voucher Screen 

Activity:  

 Record the following transaction from User ID DO1 

Date Particulars 

05-12-2019 Voucher: Payment 
Made payment of ₹ 1,50,000 to Brahma Traders through SBI Bank 

Table: 1.6.2 

 Record the following transaction from User ID DO2 
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Hint: Log out from the company and login as DO2  

Date  Particulars 

06-12-2019 Voucher: Sales 
Sold the following stock items to Mital Traders with reference number SAL/010 (Price list 
is not applicable) 
Hint: Select Main Location Godown for making sales. 

Name of Stock Item Quantity Rate (₹) Amount 

DDL Laptops 5 20,000 1,00,000 
 

06-12-2019 Voucher: Receipt 
Received a cheque of ₹ 1,00,000 from Mital Traders 

Table: 1.6.3 

1.6.6 Audit Listing for Voucher Types 

To display the Tally Audit statistics for voucher types, 

1. Close/Shut the company which is opened with user I.D 

2. Open the company with Admin I.D to check the report. 

2. Go to Gateway of Tally > Display > Statements of Accounts > Tally Audit>Select Voucher Type, to 
get the audit statistics details 

The Audit Statistics with voucher types appears as shown in figure 1.6.7: 

 

Figure 1.6.7 Audit Statistics 

To view voucher types with no entries, 

1. Press F12: Configure from the figure 1.6.7, 

2. Set Show Voucher Type having no entries to Yes and accept it 

Note: To view Parent Voucher Types wise entered or altered transactions, Press F12 from figure 1.6.7 and 
Set Sort by default voucher to Yes to display the list of voucher types based on the alphabetical order of 
parent voucher types 

Activity: Press F12 from the figure 1.6.7 and set the option Show Cancelled and Deleted Count Separately? 
to Yes, to display the Modified, Cancelled and Deleted voucher’s count separately in columnar format 
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1.6.7 Voucher Auditing 

Tally Audit feature is a quick auditing of vouchers and masters from the administrator of the company. After 
recording the transactions, the administrator will audit/check the vouchers and masters. After the vouchers are 
audited, any changes made in the audited vouchers will be recorded in Tally 

Other than the voucher auditing feature, Tally also provides a powerful tool to perform the statutory audit of 
Tally data by auditors 

This feature can be accessed from Gateway of Tally >Audit and Compliance, only if security control feature 
is enabled for the company. 

The Audit and Compliance tool consists of 4 menus which are used in conducting statutory audit such as 

1. Audit Documentation 

2. Audit and Analysis 

3. Audit Journals 

4. Financial Statements  

Let us now understand the voucher auditing feature which is quick auditing of vouchers and masters by 
administrator of the company. 

To audit Voucher, 

1. Go to Gateway of Tally > Display > Statements of Accounts > Tally Audit > Voucher Types 

2. Click F5: Show All Vch or Press F5 for displaying the vouchers of the Company for auditing 

The Tally Audit Listing appears as shown in the figure 1.6.8 

 

Figure 1.6.8 Tally Audit listing 
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3. On verification of the transactions, click F7: Accept One to accept each transaction one by one or click 
F7: Accept All to accept all the transactions. Once accepted, the transactions will be removed from the Tally 
Audit Listing Details. 

Alternatively, the administrator can take a hard copy of the Tally Audit Listing, verify the transactions manually 
and accept them. 

Business Scenario 

Data Operator 2 altered the receipt entry which is recorded as on 06-12-2019 and changed the date to 07-12-
2019. 

Activity: Open the company with DO2 user I.D and change the date, once after the changes are made, open 
the company with administrator I.D and check the following altered details. 

To view the name of the person who has entered or altered a voucher, 

1. Go to Gateway of Tally > Display > Statements of Accounts > Tally Audit > Voucher Types > F5  

2. Press F12: Configure from Tally Audit Listing screen 

3. Set Show Entered/Altered By to Yes 

The F12 Configuration screen appears as shown in figure 1.6.9: 

 

Figure 1.6.9 Configuration Screen 

4. Accept the screen 

The Tally Audit Listing screen appears as shown in figure 1.6.10: 
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Figure 1.6.10 Tally Audit Listing with Entered or Altered Details 

Note: Change the period, if multiple vouchers are selected for auditing. 

To sort deleted, modified, or cancelled voucher, 

Press F12: Configure from the Tally Audit Listing screen and select the required User Action from the list 

 

Figure 1.6.11 Configurations screen 

 Altered: This option allows you to view and audit all the audited Altered vouchers consisting of all 
Modified, Cancelled and Deleted vouchers. 

 Cancelled: This option allows you to view and audit only the audited Cancelled vouchers. 

 Deleted: This option allows you to view and audit only the audited Deleted vouchers. 

 Entered: This option allows you to view and audit only the audited entered Vouchers 

 Modified: This option allows you to view and audit only the Modified vouchers where Date, Amount, 
Ledger Masters are being altered in the audited Modified vouchers. 

1.6.8 Tally Audit Statistics for Masters 

Tally Audit Statistics for Master displays the details of Accounting Master with Entered and Altered details. 
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To view Audit Statistics for Masters,  

Go to Gateway of Tally > Display > Statements of Accounts > Tally Audit > Masters  

The Audit Statistics – Master- Wise screen appears as shown in figure 1.6.12: 

 

Figure 1.6.12 User Statistics Screen 

Tally Audit Listing 

On drilling down from the Master-wise report, the Tally Audit Listing for the List of Entered/Altered Ledgers 
appears as shown in figure 1.6.13: 

 

Figure 1.6.13 Master-Wise Audit Statistics Report 

1.6.9 Audit Listing for Users 

Audit Listing for Users contain the details of User Type and user wise Modified, Cancelled and deleted count 

To view Tally audit statistics for Users, 

1. Go to Gateway of Tally > Display > Statements of Accounts > Tally Audit > Users 

2. Press F12 and enable the options Show users having no entries and Show Cancelled and Deleted 
Count Separately 

The Audit Statistics User-Wise screen appears as shown in figure 1.6.14:  
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Figure 1.6.14 Audit Listing for Users 

Along with username, user type is also shown. The total count of entered & modified voucher for a user 
includes the count of masters and vouchers. 

Conclusion 

In this chapter we have learnt to configure tally audit feature and understood the role of security control feature 
in Tally. We have also learnt to configure security levels for different users and assign the rights to them. 
Tracking of audited transactions i.e., if any changes are done after auditing the voucher in Tally, then the same 
can be checked in Tally Audit report. 



 

 
 
TSS Features and Capabilities 

 
Tally Software Services (TSS) is a set of capabilities that helps to add value to Tally. With TSS feature 
capabilities, we can have a central consolidation of all branch office data over secure servers, access the 
company data remotely, instant support from within Tally etc. are the additional features of TSS. 

2.1 Remote Access 

 
Tally.NET is a framework which works in the background and provides a broad range of services using the 
internet. 

Using Tally.NET, a user can access a company’s data from a remote location using the Tally installed at that 
location to record the transactions remotely and viewing of reports. similarly, a practicing-chartered accountant 
working with Tally auditor’s license can look over the client’s Tally data remotely from his office. 

At the client’s place, the administrator must create remote users with the permission to access or audit data 
from a remote location and assign controls based on their security level for the required company only. The 
remote user accessing the company data acts as a client to Tally.NET. 

2.1.1 Overview of Tally.Net Features 

TSS provides the following list of useful features: 

 Connect companies from Tally 

 Create and maintain remote users  

 Synchronization of data (via Tally.NET)  

 Use online help and support capability from within Tally or the browser  

Business Scenario 

Emerald-Shine Makers has expanded the business and started a branch office in Delhi location, due to this 
proprietor of the company had to frequently visit Delhi branch for business meetings, during business meetings 
the proprietor wanted to access the Tally data and view his books of accounts as well record the entries for 
expenses incurred.   

LEARNING OBJECTIVES 
 Configuration of Tally Software Services  
 Creation of Tally.NET users and specifying security levels 

 Accessing data from a remote location 

CHAPTER 

2 
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Also in few cases due to busy schedule the auditor of the company Emerald-Shine Makers were unable to visit 
the company for auditing the data, due to which auditor suggested to use the remote access feature of Tally, by 
doing this the company data could be accessed remotely by the proprietor, auditor and staffs if the  required 
access is provided.   

2.1.2 Configuring TSS Features 

Let us load the company Emerald-Shine Makers, after loading follow the steps. 

Note: Security control feature should be enabled in the company to access the data remotely. (We have 
already enabled security control for this company) 

1. Go to Gateway of Tally > F11: Features  

The Company Features screen appears as shown in the figure 2.1.1: 

 

Figure 2.1.1 Company Feature Screen 

2. Select TSS Features or click F4: TSS, to view the TSS Features screen 

3. In the Connection Details section 

 Connect name: The user can enter a connect name for the company to be connected as per his 
requirements or retain the company name mentioned in the company master. 

 Name of contact person: Specify the name of the contact person. 

 Contact number: Specify the contact number. 

4. In the Configuration for Remote Access section 

 Allow company to connect: Set this option to Yes to establish a connection with the Tally. NET 
server.  
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 Connect company on loading: Set this option to Yes, when the user requires the company to be 
connected to Tally.NET server on loading the data, in this case let it remain No. 

5. In SMS Access Details section 

 Enable SMS access: Set this option to Yes if accessing company’s data via SMS is required, in 
this case let it remain No. 

 Company name for SMS: Enter the company’s name to be used for SMS query 

The completed TSS Feature screen appears as shown in the figure 2.1.2: 

 

Figure 2.1.2 Setting up TSS Features Screen 

2.1.3 Creating Tally.NET User 

After configuring TSS Feature in Tally, let us create the Tally.NET Users and allow them to access the data 
remotely.  

Administrator will have the rights to create the users, once after creating the Tally.NET Users, the user will be 
able to work on the company data remotely based on the rights assigned to the user. 

To create a Tally.NET User, 

1. Go to Gateway of Tally > click K: Control Centre or press Ctrl+K  

2. The Tally.NET User login screen will appear. Enter the Account ID in Your Tally.NET ID field and 
password in Your Tally.NET Password field. The password is the same which is sent by e-mail to the 
email address provided while activating Tally 

The Tally.NET User Login screen appears as follows: 
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Figure 2.1.3 Remote Tally.NET User Login Screen 

3. Press enter Control Centre screen appears as shown in figure 2.1.4: 

The Control Centre screen appears as shown in figure 2.1.4: 

 

Figure 2.1.4 Control Centre Screen 

4. Select User Management and press enter  

5. In User Management screen 

 Select Owner from the List of Security Level  

 Enter the required Email ID in Tally.NET ID field.  

 Set Tally.Net User to Yes   

The User Management screen appears as shown in the figure 2.1.5: 
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Figure 2.1.5 User Management Screen 

Note: In case of single user license one user (1 e mail id) can be configured for remote access, and for 
multiuser license 10 active Tally.Net user can be configured. 

6. Accept the screen and come to Gateway of Tally by logging out from control centre. 

Note: The Tally.NET users created here receive their password through e-mail provided as Tally.Net ID 
mentioned here and it must be valid e-mail IDs. 

2.1.4 Creating Security Controls for Tally.NET User 

By default, the Tally.NET User’s security levels is set as Data Entry, thereby having restricted access only to 
the company data. However, the administrator can change the access controls of Tally.NET User based on the 
requirement. Any user created under these Security Levels requires Tally.NET authentication to access data. 

To create security controls for a Tally.NET User,  

1. Go to Gateway of Tally > Alt+F3 > Security Control  

2. Select Types of Security 

3. The Security Levels for company appears as shown in figure 2.1.6: 

The Security Levels screen appears as shown in the figure 2.1.6: 

 

Figure 2.1.6 Security Levels Screen 
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4. Select Tally.NET User 

5. In the Security Levels for Tally.NET User screen 

 By default, Tally.NET User appears in Name of security level field 

 Use Basic Facilities of field, Data Entry is pre-set by default, administrator can change this based 
on the requirement 

 Days allowed for Back Dated vouchers is set as 0 by default 

 Cut-off date for Back Dated vouchers is kept blank  

 Set the option Set/Alter rules for Print Before Save to No 

 Allow company to connect, set it to Yes, by enabling this option, we are allowing security level to 
connect the company for remote access using Tally.NET Server  

 By default, Use Tally.NET Authentication is set to Yes. The user classified under this security 
level can login remotely with Tally.NET User capabilities 

6. In Disallow the following Facilities 

 Select the required access control from the Type of Access  

 Select the required List of Reports/Facility to be disallowed based on the access control 

7. In Allow the following Facilities 

 Select the required List of Reports/ Facility and select End of List from the Type of Access 

The Security Levels screen appears as shown in the figure 2.1.7: 

 

Figure 2.1.7 Security Levels Defining Rights 
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8. Press Ctrl+A twice to save the access controls for Tally.NET User 

2.1.5 Authorizing Tally.NET User 

Based on business requirements, the administrator can authorize users under Tally.NET User.  

Go to Gateway of Tally > F3: Company Info. > Security Control > Users and Passwords 

In the Users for Company screen, follow the steps: 

1. Under Security Level field, press lower arrow key and select Tally.NET User from Security Level below 
Data Operator 2  

2. In Username field type the required Email ID which was assign as Tally.Net ID 

3. By default, the Password (if any) field is blank and cannot be provided for Tally.NET User 

4. Set Allow Remote Access to Yes if the Tally.NET User requires to access it remotely  

5. Allow Local TDL Files is set to No, if the admin does not want the additional TDLs to be executed 
remotely for the selected remote user  

6. Set Yes to Allow SMS Access if required  

The complete Users for Company screen appear as follows  

 

Figure 2.1.8 List of Users of Company 

7. Accept the screen 

2.1.6 Connect Company on Tally.NET 

In order to connect a company to Tally.NET Server for remote access,  

1. Click F4: Connect or press F4 from Gateway of Tally 

2. A message will be displayed indicating that the company is connected successfully in the calculator 
pane: 

The Gateway of Tally screen with Tally.NET User connection details appears as shown in the figure 2.9: 

 

Figure 2.1.9 Connection Successful Notification 
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2.1.7 Remote Login 

The users classified under Tally.NET User can access data from a remote location by providing the remote user 
Login ID and Password while Tally is running in Licensed or Educational mode.  

1. Open Tally from the remote location. 

2. In the Company Info menu, select Login as Remote User  

The Company Info Menu screen appears as shown in the figure 2.1.10: 

 

Figure 2.1.10 Company Info Screen 

3. Provide the configured Email-ID in Your Tally.NET ID field and Password in Your Tally.NET Password 
field 

The Tally.NET User Login screen with remote login appears as shown in the figure 2.1.11: 

 

Figure 2.1.11 Login as Remote Tally.NET User 

On successful authentication, a remote session is created on Tally.NET which remains valid till the user logs 
out. A unique identification number is assigned to the remote session created. The remote user can work on 
only one company at a time.  

In List of Remote Companies screen, select the required company from the List of Companies to connect. 

The List of Remote Companies screen appears as shown in figure 2.1.12: 
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Figure 2.1.12 List of Remote Companies Screen 

Once after selecting the required company from the list of remote companies then the following screen will 
appear. 

The Gateway of Tally screen appears as shown in the figure 2.1.13: 

 

Figure 2.1.13 Remote login Gateway of Tally Screen 

Note: It is mandatory to enable Security Control for the company to avail TSS Features in Tally. We can logout 
the remotely connected company from Company Info screen by clicking on the option Remote User Logout. 

2.2. Data Synchronization 
When a business has more than one office, we might need to consolidate the data from all the branches in one 
place, every day or every week based on our preference. With Tally’s Data Synchronization feature this 
requirement can be easily met. Synchronization can be done over Tally.NET or a private network and can be 
initiated by either the server or the client. 

Data Synchronization in Tally 

1. Online Synchronization: In this type of synchronisation, the client and the server companies are 
connected live through Tally.NET Server, or a private network. 

 Sync using Tally.NET Server 

 Sync through Private Network (also referred as Direct/IP Sync) 
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2. On demand Synchronization: In this type of synchronization, the client and the server companies need 
not be online at the same time. Data is synchronized using Tally.NET Server. 

Business Scenario 

Emerald-Shine Makers have its head office at Bengaluru and branch office at Delhi. The Head office needs to 
communicate with the branch office to know the status of the branch transactions and update those 
transactions in the Head Office. This can be done by Data Synchronization. Let us Consider the Head Office 
Emerald-Shine Makers as the Server and the Branch Office Emerald-Shine Makers Delhi as the Client. 

Activity: Create the following company for the financial year 2019-20 and enable security control feature. 

 Emerald-Shine Makers Delhi Branch 

 Location: Delhi 

 Enable the option Use security control?  

Step 1: Configuration of Synchronisation using Tally.Net Server. 

Load the company Emerald-Shine Makers, 

1. Go to Gateway of Tally > F12: Configure > Advanced Configuration.  

2. In the Advanced Configuration screen, under Client/Server Configuration section, 

 Set the option Tally is acting as to Server to run Tally as Synchronization Server 

 Specify the required port number (e.g. 9000) in the Port field 

3. Select Connection Configuration section: 

 Set the duration in seconds for Connection Timeout (in seconds) field. The server disconnects 
when it does not receive any response from the client within the specified duration, let us not set 
Connection Timeout. 

 Set the option Connect to Tally.NET Servers running on Non-HTTP port to Yes, to avoid 
frequent disconnection from TSS or when receiving the error 16004 - frequently 

 Set the option Use absolute URL for HTTP Actions to Yes, this will enable the proxy server to 
communicate the complete URL, by default this option is set to No 

4. Select Log Configuration section: 

 Set the option Enable Sync Logging (SockReq.log) to Yes, to generate a Log file which contains 
information about the synchronised vouchers. This file resides in the folder where Tally is installed 

 Set the option Truncate previous log before Syncing to Yes, to overwrite the contents of the 
current log file generated earlier 

 Set the option Enable HTTP Log (tallyhttp.log) to Yes, to login all SOAP and HTTP Post 
request/response in the login file residing in the default Tally folder 

 Set the option Enable detailed Log (tally.imp) to Yes, to generate tally.imp log file containing 
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details of the operation 

 Tab down to Tally.Net Server Proxy Configuration section: (in case you are using proxy server 
for internet connection) 

 Set Use proxy for connecting to Tally.NET Server to Yes, if internet is connected through the 
proxy server, In this case let it be No. 

 Enter the required URL/IP Address and the port number in the Specify URL/IP address and port 
for proxy server field 

 Set Authentication proxy server to Yes to verify the username and password. 

o Enter the required username in the Username field 

o Enter the password in the Password field 

The completed Advanced Configuration screen appears as shown in figure 2.2.1: 
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Figure 2.2.1 Configuring Tally as Server 

Note:  

1. Tally will prompt you to restart for the changes to have effect, click Yes and restart. 

2. Company Login screen appears, enter Name of User and Password to login. 

Tally will restart, and in the information panel, we will be able to view configuration as server, as shown in figure 
2.2.2: 

 

Figure 2.2.2 Information Panel of Server 

Step 2: Configure Tally.NET Features on Server 

1. Go to Gateway of Tally > F11: Features > F4: TSS 

Note: We have already configured Tally.Net Features for the company Emerald-Shine Makers during remote 
access process. 

The completed TSS Feature screen of server appears as shown in figure 2.2.3: 

 

Figure 2.2.3 TSS Features screen 

Step 3: Connect Server Company to Tally.NET 

During the Data Synchronization it is essential that the Server Company be connected to Tally.NET server. To 
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connect the server company to Tally.NET, follow the steps: 

1. Go to Gateway of Tally > click F4: Connect or Press F4 

2. Select the required Company to be connected for Synchronization using TSS from the List of Companies  

On successfully connecting to Tally.NET server, the connection status displayed in the calculator panel is as 
shown in figure 2.2.4: 

 

Figure 2.2.4 Calculator Panel of Server 

Step 4: Configure Client for Synchronisation 

To configure the client company for synchronization, follow the steps: 

1. Load the company Emerald-Shine Makers Delhi Branch in the client location 

Configure the client company for synchronization as shown in the figure 2.2.5  
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Figure 2.2.5 Configuring Tally as Client 

2. Press Enter to save setting for Synchronization (Client), for the changes made. 

Note:  

1. Tally will prompt you to restart for the changes to have effect, click Yes and restart. 

2. Company Login screen appears, enter Name of User and Password to login. 

Tally will restart, and in the information panel, we will be able to view configuration as Client, as shown in figure 
2.2.6: 

 

Figure 2.2.6 Information Panel of Client 

Step 5: Creating a Synch Rule on Client 

To set the client rule for master, 

1. Go to Gateway of Tally > Import of Data > Synchronization > Client Rules > Create, create the client 
rule as follows 

The Client Rule Creation screen appears as shown in figure 2.2.7: 

 

Figure 2.2.7 Advance configuration screen 

Note: On enabling the option Use On-demand sync? we can synchronize the data across multiple points, 
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send or receive data from a central location without the need of being in an always connected mode. 

2. Enable Set/alter advanced configurations? to change advanced configurations for sync rule in client 
company. The advanced configurations are separately set for Receive Data and Send Data options 

Advanced Configuration for Send Data 

Set the Advanced Configuration screen as shown in figure 2.2.8: 

 

Figure 2.2.8 Advance configuration screen 

Creation of Client Rule for Transaction  

1. Go to Gateway of Tally > Import of Data > Synchronization > Client Rules > Create 

Set the Client Rule Creation screen as shown in figure 2.2.9: 

 

Figure 2.2.9 Client Rule Creation screen 

2. On Selecting the Direction of sync as Both, Synchronization Types screen appears as shown in the 
figure 2.2.10 accept it as it is. 
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Figure 2.2.10 Synchronization Types 

3. Enable Set/alter advanced configurations? option 

The Advanced Configuration screen for both (receive & send) appears as shown in figure 2.2.11: 

 

Figure 2.2.11 Advance configuration screen 

4. Accept the screen and client rule. 

Activity: Record the following transactions in the books of Emerald-Shine Makers Delhi Branch. 

Date Particulars 

10-12-2019 Voucher: Receipt 
Received ₹ 2,00,000 from a Hari Traders vide cheque no 000009 
and deposited the same in SBI Bank (Advance Reference with 
reference number Adv-R-001) 

15-12-2019 Voucher: Payment 
Made payment of ₹ 90,000 to Deepak Suppliers vide SBI Bank cheque no.000002. 
(Advance Reference with reference number Adv-P-001) 

Table: 2.2.1 
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Hint: Create the masters such as Hari Traders, Deepak Suppliers and SBI Bank in Delhi Branch to record 
the transaction. 

Sending Sync Rule 

After creating a sync rule, you must perform synchronization to send the rule to Tally.NET Server. To send sync 
rule, 

1. Go to Gateway of Tally >F4: Connect  

2. From Gateway of Tally select Import of Data > Synchronization 

 Select Synchronise All to send all rules 

 Select Synchronise Selected to send selected rule 

3. Press Enter to start synchronization to send the rule 

 Note: We can alter the Sync Rule created in Tally, by following the steps: 

 Go to Gateway of Tally > Import of Data > Synchronization > Client Rules/Server Rules > 
Alter 

 Select the rule from the List of Rules 

 Alter the details, and Accept the screen 

 Access the Rule Info. for masters and transactions by pressing Alter on the right button bar 

Step 6: Activating Synch Rule on Server  

Follow the steps in the server location, Emerald-Shine Makers 

Go to Gateway of Tally > Import of Data > Synchronisation > Server Rules > Activate 

The Select Item screen appears as shown in figure 2.2.12: 

 

Figure 2.2.12 Selection of rule screen 

4. Select the Master rule from the List of Rules 

The Rule Type tells you if the rule you are selecting is a masters or transactions rule. 

Activating Master Rule 

The Server Rule Alteration screen appears as shown in figure 2.2.13: 



 TSS FEATURES AND CAPABILITIES  

 ADVANCED INFORMATION TECHNOLOGY 303 

 

Figure 2.2.13 Activation of Rule 

Note: Set Set/alter advanced configurations? to Yes to change the advanced configuration. You can 
specify advanced configurations for send masters or receive masters.  

Activating Transaction Rule 

The Server Rule Alteration screen appears as shown in figure 2.2.14: 

 

Figure 2.2.14 Activation of transaction rule 

Note: Enable Set/alter advanced configurations? to Yes and to change the advanced configuration. 
You can specify advanced configurations for receive data, send data or both. 

Step 7: Synchronisation of Data  

This step must be followed in client and server location, where the transfer of data is required. 

1. Go to Gateway of Tally > Import of Data > Synchronization 

 Select Synchronise All to synchronise data for all the client rules created 
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 Select Synchronise Selected to synchronise data for selected rule 

2. Press Enter to start data synchronization 

After data synchronisation, a message appears in the server system’s calculator pane, as shown in 
figure 2.2.15: 

 

Figure 2.2.15 Data Synchronisation Message 

Alternatively, you can synchronise data on the Gateway of Tally using the following buttons: 

 O: Synchronise: Press Alt + O to synchronise data for all sync rules 

 Y: Sync Selected: Press Alt + Y to synchronise selected sync rules 

The Synchronise All option is used to perform synchronisation, and to send and accept the sync rule 
created by the client. 

Observation: Once after synchronising the data in client and server location, open the server company, 
here it is Emerald-Shine Makers, and go to daybook report enter the full period and check the 
transactions.  The transactions which were recorded in the client (Emerald-Shine Makers Delhi 
Branch) are transferred to server company i.e., Emerald- Shine Makers. 

Conclusion 

In this chapter we have learnt to access the data remotely using Remote Access feature and synchronized the 
data between branch to head office using Synchronization feature of Tally. 

 



 

 
 
E-Filing 

 
Electronic filing is the process of filing tax returns for TDS, TCS, GST, IT etc. using internet and tax preparation 
software that has been approved by the tax authority. 

3.1 Tax Deducted at Source 

 
3.1.1 Introduction 

TDS stands for Tax Deducted at Source. The concept of TDS was introduced in the Income Tax Act, 1961, 
with the objective of deducting the tax on an income, at the source of the income. It is one of the methods of 
collecting Income Tax, which ensures regular flow of revenue to the Government. 

3.1.2 Setting up TDS in Tally  

The TDS module in Tally is integrated with financial accounts and takes care of all the TDS and e-TDS 
requirements of your business, right from voucher entry to report generation. Tally completely automates your 
TDS management - accurately computes tax to be deducted at source, the TDS payable amount, and 
generates TDS payment challans, TDS Certificates, Statutory Returns, and other related MIS reports.  

Its e-TDS features further assist you to file your mandatory tax returns in electronic format as specified by the 
Income Tax Department. It helps in minimizing error-prone entry of information, incorrect remittances and 
provides accounting for interest and penalties (if any) for smooth and effective functioning of your business. 

As per section 194J (Notification 21/2012), tax is applicable on a software product when it is purchased directly 
from a producer (first level of purchase), and not applicable (exempt) when it is purchased from a dealer 
(subsequent purchase). Exempt purchase must be reported separately in TDS returns Form 26Q. 

In this section we will learn to record the purchase of software transactions in Tally 

Business Scenario 

Comfort Enterprises started a company with a capital of ₹ 10,00,000, in April 2019. The company is into 

LEARNING OBJECTIVES 
 Deducting TDS on Rent on Machinery, Purchase of Software and Commission and Brokerage 

expenses 
 Rectification of errors in TDS reports 
 Generating TDS Challan 

 Generating TDS return 

 Filing e-return 

CHAPTER 

3 
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timber manufacturing. They have branches in 3 locations Delhi, Mumbai, and Chennai.  They have taken a 
logging machinery on rental basis for business purpose.  The amount of rent is ₹ 3,00,000 which is above the 
exemption limit. Hence, they must deduct TDS on rental expenses, let us now see how Comfort Enterprises 
maintains its books of accounts in Tally. 

Activity:  

 Create the following company in Tally: 

Company Name: Comfort Enterprises 

Address: No: 16/56, Raheja Building, Bangalore 560031 

State: Karnataka 

Financial Year: 01-04-2019 to 31-03-2020 

 Create the ledger Kotak Bank under Bank Accounts and Proprietors Capital under Capital Account.  

 Record a Journal entry or Receipt entry for introducing capital of ₹ 10,00,000 to business as shown in 
table 3.1.1  

Particulars L.F Dr. Cr. 

Kotak Bank _________________ Dr.  10,00,000  
To, Proprietors Capital A/c   10,00,000 

(Being cash invested by the proprietor)    

Table 3.1.1 

3.1.2.1 Activating TDS for the Company 

To activate TDS feature for Comfort Enterprises, follow the steps: 

1. Go to Gateway of Tally> F11: Features >F3: Statutory> set the options Tax Deducted at Source 
(TDS) and Set/alter TDS details to Yes 

2. On enabling Set/alter TDS details, TDS Deductor Details screen appears, fill in the Company TDS 
Deductor Details. 

Illustration 1: Booking of rental expenses on equipment’s, which attracts TDS 

30-07-2019 
 
 

Voucher: Journal 
Comfort Enterprises booked rental expenses of ₹ 3,00,000, on Machinery against Quick 
Agency. Since the Rent on Machinery expenses is ₹ 3, 00,000 TDS must be deducted 
while booking the expense 

30-07-2019 
 
 

Voucher: Payment 
Made a payment of remaining amount of ₹ 2,94,000 to Quick Agency vide cheque number 
000001 dated 30-07-2019. 

Table 3.1.2 
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Let us now record the transactions in Tally. 

The applicable Income Tax rates for payment of Rent on Plant & Machinery to Company Resident - 
Deductee Type is 2%. 

Step 1: Creation of TDS Nature of Payments, 

 Go to Gateway of Tally > Accounts Info. > Statutory Info. > TDS Nature of Pymts > Create > Enter 
the Name or Press Ctrl+C: Helper and select the Nature of Payment as Rent of Plant, Machinery Or 
Equipment> enter the Rate as 2% and Threshold/exemption limit as ₹ 2,40,000 accept the TDS 
Nature of Payment Creation screen. 

Step 2: Creation of Account Group and Enabling TDS at Group Level 

Accounting Master Creation 

Account Group- Rent Expenses (Machinery) 

 Go to Gateway of Tally > Accounts Info. > Groups > Create> enter the name as Rent Expenses 
(Machinery)>under Indirect Expenses> enable Set/Alter TDS details > select Nature of Payment as 
Rent of Plant, Machinery Or Equipment and accept Group Creation screen. 

Step 3: Creation of Accounting Masters 

To book the expense in the books of Comfort Enterprises, first ensure that the required ledgers are created in 
Tally. 

Rent on Machinery 

 Go to Gateway of Tally >Accounts Info.>Ledgers> Create > create Rent on Machinery under Rent 
Expenses (Machinery) > select Is TDS applicable as Applicable and select Nature of Payment as 
Undefined (as we have already defined the Nature of Payment in Accounting Group)save the ledger. 

Quick Agency 

 Go to Gateway of Tally >Accounts Info.>Ledgers> Create > create Quick Agency under Sundry 
Creditors > set Is TDS Deductable to Yes, select Deductee type as Company- Resident, set Deduct 
TDS in Same Voucher to Yes, select Nature of Payments enter PAN/IT No. and save the ledger. 

TDS on Rent of Machinery 

 Go to Gateway of Tally >Accounts Info.>Ledgers> Create > create TDS on Rent of Machinery under 
Duties and Taxes > select Type of duty/tax as TDS select Nature of payment as Rent of Plant, 
Machinery Or Equipment and save the ledger. 

Step 4: Recording Journal Voucher to book Expenses and Deduct TDS 

1. Go to Gateway of Tally > Accounting Vouchers > F7: Journal 

2. Click F2: Date to set the date to 30-7-2019 

3. Debit the Rent on Machinery expense ledger 

4. Enter 3,00,000 in the amount field 
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5. Credit Quick Agencies, you will get the Bill-wise Details screen, enter the following details: 

 Select Type of Ref as New Ref 

 Name – Let it be as it is i.e., 2 

 Due Date - Do not enter any details 

 Amount – Amount ₹ 3,00,000 will get captured automatically 

 Press Enter. The amount after TDS deduction will appear in the Amount field automatically 

 Again, select Type of Ref as New Ref   

 Name – Let it be as it is i.e., 2 

 Due Date - Do not enter any details 

 Amount – Amount ₹ 6,000 will get captured automatically 

6. Credit the ledger TDS on Rent of Machinery (Tax ledger). 

7. The TDS amount ₹ 6,000 will capture automatically.  

8. Press Enter 

9. Enter Narration, in the Narration field 

The Journal Voucher Screen appears as shown in the figure 3.1.1: 

 

Figure 3.1.1 Journal Voucher Screen 

10. Press Enter to accept the entry. 

Step 5: Making Payment to Party 

To record a Payment Voucher, follow the steps: 

1. Go to Gateway of Tally > Accounting Vouchers > F5: Payment> date appears as 30-07-2019 > select 
Kotak Bank in Account field, under Particulars field, select Quick Agency, Bill-wise Details screen appears, 
select Agst Ref and track the bill with Name 2 and press entry amount appears automatically. 

The completed Payment Voucher Creation screen appears as shown in Figure 3.1.2: 
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Figure 3.1.2 Payment Voucher Screen 

2. Accept the Entry. 

After recording the transaction, the entry will be automatically updated in the Balance Sheet and Profit & Loss 
Account. 

Observation: Go to Gateway of Tally > Display > Account Books > Ledger > Select TDS on Rent of 
Machinery. You should get the amount as ₹ 6,000 (This amount is payable to the government). 

Business Scenario 

Comfort Shelters has purchased software to its branches, to maintain the books of accounts. The company 
deducted TDS on the same and made a payment to the government. 

Let us now see how this is handled in Tally. 

Illustration 2: Recording of purchase of software transaction which attracts TDS 

Date Particulars 

01-08-2019  Voucher: Purchase 

Comfort Shelters purchased the software directly from producer Sky High Solutions at 
₹ 50,000 and TDS @ 10% is deducted. 

05-08-2019 Voucher: Payment 

Made a payment of remaining amount of ₹ 45,000 to Quick Agency vide cheque number 
000003 dated 31-08-2019. 

Table 3.1.3 

To record the transaction in the books of accounts, follow the steps: 

Step 1: Creation of TDS Nature of Payment 

Go to Gateway of Tally > Accounts Info. > Statutory Info. > TDS Nature of Pymts > Create >enter the 
Name or Press Ctrl+C and select the Nature of Payment as Payment \Royalty on Acquisition of Software 
U/s 194J> enter the Rate as 10% and Threshold/exemption limit as ₹ 30,000 accept the TDS Nature of 
Payment Creation screen. 

Step 2: Creation of Accounting Masters 

To record the purchase vouchers in the books of Comfort Enterprises, first ensure that the required ledgers 
are created in Tally. 
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Purchase of Software 

 Go to Gateway of Tally >Accounts Info.>Ledgers> Create > create Purchase of Software under 
Fixed Assets> select Is TDS Deductable? as Yes, enable the option Treat as TDS Expenses? and 
select Nature of Payment as Payment\Royalty on Acquisition of Software U/s 194J and save the 
ledger. 

Sky High Solutions  

 Go to Gateway of Tally >Accounts Info.>Ledgers> Create > create Sky High Solutions under Sundry 
Creditors > set Is TDS Deductable to Yes, select Deductee type as Company- Resident, set Deduct 
TDS in Same Voucher to Yes, select Nature of Payment enter PAN/IT No. and save the ledger. 

TDS on Software 

 Go to Gateway of Tally >Accounts Info.>Ledgers> Create > create TDS on Software under Duties 
and Taxes > select Type of duty/tax as TDS select Nature of payment as Payment/Royalty on 
Acquisition of Software U/s 194J and save the ledger. 

Step 3: Recording of Purchase Transaction 

1. Go to Gateway of Tally > Accounting Vouchers > F9: Purchase  

2. Press F2: Date and change the date to 01-08-2019 

3. The purchase voucher will be in Item Invoice Mode, press Alt+I, to change it to Account Invoice mode  

4. Enter the Supplier invoice no. as SS/1 and Date captures the Invoice Date by default. 

5. In the Party A/c name field select Sky High Solutions 

6. Under Particulars field select Purchase of Software ledger 

7. Enter the amount as ₹ 50,000 and press Enter 

8. Select TDS on Software ledger (Tax ledger) and the TDS amount ₹ -5,000 will get deducted 
automatically (the amount will have a negative sign) 

9. You will get the Bill-wise Details screen, enter the following details: 

 Select Type of Ref as New Ref 

 Name – Let it be as it is i.e., SS/1 

 Due Date - Do not enter any details 

 In the Amount field – Amount ₹ 50,000 will get captured automatically 

 Press Enter. The amount after TDS deduction will appear in the Amount field automatically 

 Again, select Type of Ref as New Ref   

 Name – Let it be as it is i.e., SS/1 

 Due Date - Do not enter any details 
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 In the Amount field – Amount ₹ 5,000 will get captured automatically 

 Select End of List and press Enter to go back to the voucher creation screen 

10. Enter the Narration 

11. Press Alt+A: Tax Analysis in order to view the TDS calculation; press Alt+F1, to view the Tax Analysis 
in detailed mode 

The Tax Analysis screen appears as shown in the figure 3.1.3: 

 

Figure 3.1.3 Tax Analysis Screen 

12. Press Esc to go back to the Voucher Creation screen and press Enter 

The Purchase Voucher Creation screen appears as shown in the figure 3.1.4: 

 

Figure 3.1.4 Purchase Voucher Creation Screen 

13. Accept the Entry. 

Step 4: Making Payment to Party 

To record a Payment Voucher, follow the steps: 

1. Go to Gateway of Tally > Accounting Vouchers > F5: Payment> press F2: Date and provide as 05-08-
2019 > select Kotak Bank in Account field, under Particulars field, select Sky High Solutions, Bill-wise 
Details screen appears, select Agst Ref and track the bill with Name SS/1 and press entry amount appears 
automatically. 

The completed Payment Voucher Creation screen appears as shown in Figure 3.1.5: 

 

Figure 3.1.5 Payment Voucher Screen 
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2. Accept the Entry. 

Illustration: 3 Booking expenses on Commission Expenses 

Date Particulars 

15-08-2019 

 

Voucher: Journal 

Comfort Enterprises incurred commission expenses of ₹1,20,000 for services taken from a 
Business Consultancy Mayur Agency. 

Table 3.1.4 

Step 1: Creation of Accounting Masters  

Activity:   

1. Create TDS Nature of Payment as Commission Or Brokerage, mention the rate as 5% and exemption 
limit as ₹ 15,000 

2. Create Commission Expenses ledger under Indirect Expenses, set Is TDS applicable as Applicable 
and select the Nature of Payment as Commission Or Brokerage. 

3. Create Mayur Agency under Sundry Creditors, set Is TDS Deductable as Yes, select Deductee type as 
Company- Resident, enable Deduct TDS in Same Voucher, do not enter the PAN No accept the 
ledger. 

4. Create TDS on Commission Duty ledger. 

Step 2: Recording Journal Voucher to book Expenses and Deduct TDS 

1. Go to Gateway of Tally > Accounting Vouchers > F7: Journal 

2. Click F2: Date to set the date to 15-8-2019 

3. Debit the Commission Expenses ledger 

4. Enter ₹ 1,20,000 in the amount field 

5. Credit Mayur Agencies, you will get the Bill-wise Details screen, enter the following details: 

 Select Type of Ref as New Ref 

 Name – Let it be as it is i.e., 3 

 Due Date - Do not enter any details 

 Amount – Amount ₹ 1,20,000 will get captured automatically 

 Press Enter. The amount after TDS deduction will appear in the Amount field automatically 

 Again, select Type of Ref as New Ref   

 Name – Let it be as it is i.e., 3 

 Due Date - Do not enter any details 
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 Amount – Amount ₹ 24,000 will get captured automatically 

6. Credit the ledger TDS on Commission (Tax ledger). 

7. The TDS amount ₹ 24,000 will capture automatically.  

8. Press Enter 

9. Enter Narration, in the Narration field 

The Journal Voucher Screen appears as shown in the figure 3.1.6: 

 

Figure 3.1.6 Journal Voucher Screen 

10. Press Enter to accept the entry. 

Rectification of errors in TDS returns  

To resolve the exception and generate TDS report, follow the steps: 

1.  Go to Gateway of Tally > Display > Statutory Reports > TDS Reports > Form 26Q 

The Form 26 Q appears as shown in figure 3.1.7: 

 

Figure 3.1.7 Form 26 Q 

2. Select Uncertain Transactions 

The Summary of Exception appears as shown in figure 3.1.8: 
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Figure 3.1.8 Summary of Exception 

3. Press enter on PAN not available for party 

The Ledgers with Exceptions appears as shown in figure 3.1.9: 

 

Figure 3.1.9 Ledgers with Exceptions screen 

4. Enter the PAN No and Applicable From date and accept the screen. 

5. Press Esc to return to Form 26 Q report. 

The Form 26 Q after resolving the exception appears as shown in the figure 3.1.10: 

 

Figure 3.1.10 Form 26 Q - Exception Resolved 
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In Figure 3.3.10, we can observe that the Balance Deductable is appearing as (-)18,000, this is because TDS 
was deducted at 20% instead of 5% as PAN was not available. Press enter Deduction Details screen appears 
as shown in figure 3.1.11 

The Deduction Details screen appears as shown in the figure 3.1.11: 

 

Figure 3.1.11 Deduction Details screen  

Drill down (Press Enter thrice) and alter the transaction as shown in the figure 3.1.12  

 

Figure 3.1.12 Journal Voucher Alteration screen 

Note: As per the TDS rate for Commission, we have altered the TDS amount to ₹ 6,000 instead of ₹ 24,000 in 
the transaction, you can either alter the existing transaction or delete the old entry and record a new entry. After 
this step observe Form 26 Q the Balance Deductable will disappear. 

Activity: Record a Payment voucher as on 20-08-2019  

20-08-2019 

 

 

Voucher: Payment 

Made a payment of remaining amount of ₹1,14,000 to Mayur Agency. vide cheque no: 
000003 dated 20-08-2019 

Table 3.1.5 

3.1.3 Payment of TDS 

As per the income tax act, corporate & non- corporate entities (deductor) making payments (specified under 
income tax act) to third parties (deductee) are required to deduct tax at source at the prescribed rates on such 
payments.  

The TDS so deducted should be deposited to the credit of the central government within one week from the last 
day of the month in which the deduction is made. This is deposited into any of the designated branches of 
banks authorized to collect taxes on behalf of the government accompanied by income tax challan ITNS 281.  
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Illustration 4: Recording of TDS payment to government and printing of challan ITNS 281.  

Date Particulars 

30-09-2019 Comfort Enterprises, paid ₹ 17,000 to the government towards TDS on all expenses from 
01-07-2019 to 30-09-2019, vide Kotak cheque number 000010 dated 30-09-2019 

 

Table 3.1.6 

To record the transactions in the books of accounts, follow the steps: 

Step 1: Check the TDS Balance Payable Amount 

1. Go to Gateway of Tally > Display > Statutory Reports > TDS Reports > Form 26Q 

2. Press Alt+F2: Period and enter the period as 1-7-2019 to 30-9-2019 

The Form 26Q appears as shown in the figure 3.1.13: 

 

Figure 3.1.13 Form 26Q 

Observation: In the form 26Q, we can observe that the balance payable is displaying the total amount which is 
deducted by the company and payable to the government. 

Step 2: Recording of Payment Voucher from Form 26Q 

1. From form 26Q, press Alt+S: Stat Payment 

2. Enter the required details in Stat Payment Details screen as follows  

The Stat Payment Details screen appears as shown in the figure 3.1.14: 
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Figure 3.1.14 Stat Payment Details Screen 

3. Select the Kotak Bank ledger, we will get the payment voucher screen. 

4. Press F2: Date and change the date to 30-09-2019 

5. Enter the bank details in the bank allocation screen 

The Payment Voucher appears as shown in the figure 3.1.15: 

 

Figure 3.1.15 Payment Voucher Screen 

6. Accept the screen 

Note: We can record the payment voucher even from Accounting Vouchers menu available in Gateway of 
Tally. 

Once after recording the transaction in Tally Check form 26Q report under Payment Details section. 
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The Form 26Q after making a TDS payment appears as shown in figure 3.1.16: 

 

Figure 3.1.16 Form 26Q – After TDS Payment 

Observation: In form 26Q, we can observe that the TDS payment voucher appears under the head Not 
Included Transactions and still the balance payable is showing the payable amount as 17,000. To include 
TDS payment voucher, we need to reconcile it. 

The following step will explain to reconcile the payment voucher in Tally 

3.1.4 Payment Challan Reconciliation  

As per the income tax act, the details of payment of TDS are required to be furnished in the TDS certificate 
issued to the deductee. For this purpose, the challan details containing the information with respect to bank 
challan no. & date, bank name, BSR code etc., are required to be specified. Tally allows us to enter all the 
required information as specified by the statutes, by using the challan reconciliation facility, if these details are 
not previously furnished while recording the payment voucher.  

1. Go to Gateway of Tally > Display > Statutory Reports > TDS Reports > Challan Reconciliation 

 The Challan Reconciliation Report screen appears as shown in the figure 3.1.17: 

 

Figure 3.1.17 Challan Reconciliation Report 

2. Press F5: Reconcile Challan 

3. Press Alt+S: Set Challan Details, enter the details as shown in figure 3.1.18 

The Set Challan Details screen appears as shown in the figure 3.1.18: 
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Figure 3.1.18 Set Challan Details Screen 

4. Press Enter to go back to the TDS Challan Reconciliation screen 

The completed TDS Challan Reconciliation screen appears as shown in the figure 3.1.19: 

 

Figure 3.1.19 TDS Challan Reconciliation 

5. Press Enter to accept 

Once after reconciliation check the form 26Q report 

The Payment Details section of Form 26Q after reconciliation appears as shown in the figure 3.1.20: 

 

Figure 3.1.20 Form 26Q - After reconciliation 

Observation: Once after reconciling, the balance payable is showing nil balance and the Total Paid amount is 
shown as 17,000. And also, the payment voucher is reflecting under the head Included Transactions. 

Activity: Take a print of the ITNS Challan 281 by following the given procedure 

1. Go to daybook and select the payment voucher recorded on 30-09-2019 
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2. Press Alt+P from the Payment Voucher Alteration screen to view the Voucher Printing screen  

3. In the Voucher Printing screen,  

 Ensure Print as TDS Challan is set to Yes  

3.1.5 E-Return 

With the automation of collection, compilation and processing of TDS returns, the ITD notified electronic filing of 
returns of Tax Deducted at Source in the Scheme 2003.  

Generating Form 26Q and Filing e-Return.  

Form 26Q is a quarterly return for deduction of tax in respect of payments (other than salary) made to 
residents.  

To file the e-Return, go to Gateway of Tally > Display > Statutory Reports > TDS Reports > Form 26Q and 
follow the given steps 

Step 1: Resolve the Exceptions or Uncertain Transactions if any, 

Check for any Uncertain Transaction and resolve if any, we have already resolved exceptions  

Step 2: Save the Form 26Q return 

Once after resolving the exception, next step is to save the return,  

1. Click F6: Save button from the Form 26Q report 

Note: If you try to save the return with uncertain transactions, you will get the popup message which reads as 
“There are still unsolved exception for the period. The tax values may not be correct if all exceptions are not 
solved. Do you really want to save without resolving?” 

2. Once after saving the voucher, the details of the saved return can be viewed in Return Transaction 
Book 

Activity: Generate Return Transaction book, go to Gateway of Tally > Display > Statutory reports >TDS 
reports > select Return Transaction Book 

Note: Once after saving the return, if we make any changes in the TDS voucher then the return will come for 
recompute, we can either overwrite the previous return with the existing one or save a revised one. The saved 
return will be available in the return transaction book where you will get the details of return along with the 
modification details. 

Step 3: Exporting the Form 26 Q 

1. Go to Gateway of Tally > Display > Statutory Reports > TDS Reports > Form 26Q 

2. Press Ctrl+E: e-Return, to export the file 

The Export Report screen appears as shown in the figure 3.1.21: 
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Figure 3.1.21 Export Report Screen 

3. Enter the details as shown in the figure 3.1.21 and press Enter to export the file in selected format 

The Exported File appears as shown in figure 3.1.22: 

 

Figure 3.1.22: Exported File 

Step 4: Validate TDS returns with File Validation Utility 

The exported file (Form 26Q) is required to be validated with the File Validation Utility (a freely downloadable 
utility tool from NSDL website)  

FVU is a program developed by NSDL, which is used to ascertain whether the e-TDS return file contains any 
format level error(s).  

After you have prepared your e-TDS return you can check/verify the same by using the File Validation Utility 
(FVU). This utility is freely downloadable from the NSDL-TIN website.  

When you pass e-TDS return through FVU, it generates an 'error/response file'. If there are no errors in the e-
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TDS return file, error / response, the file will display the control totals. If there are errors, the error/response file 
will display the error location and error code along with the error code description. In case you find any error, 
you can rectify it and pass the e-TDS return file again through the FVU till you get an error-free file, after file 
gets generated without error upload the return to the website. 

To file TDS return, open the file validation utility (downloaded from NSDL website) and follow the steps: 

1. Open the file validation utility tool. 

2. Based on the returns being filed, you can browse and select 26Q or 27Q returns .txt file exported from 
Tally in the field TDS/TCS Input File Name with Path.  

3. Browse and select the challan status inquiry .csi file downloaded from TIN website in the field Challan 
Input File Name with Path. 

4. Enter the location to save the validation error file in the field Error/Upload & Statistics Report File 
Path. 

5. Click Validate.  

6. Click OK to close the messages displayed after validation.  

7. Print the Form 27A created by the validation tool. 

8. Submit the Form 27A and 26Q or 27Q returns .txt file (soft copy) at TIN-FC or upload on NSDL website. 

Note: In case the validation is not successful, results are updated in the error report file. Rectify these errors in 
the data and re-generate the 26Q or 27Q returns text file for validation.  

Form 27 Q 

Form 27Q is a quarterly return for deduction of tax in respect of payments made (other than salary) to non-
residents. In Tally, we can also record the transactions related to Non- Residents and generate the required 
form. 

To generate Form 27Q, follow the given steps: 

Go to Gateway of Tally > Display > Statutory Reports > TDS Reports > Form 27Q and follow the steps: 

1. Resolve the Exceptions or Uncertain Transactions  

2. Save the Form 27Q return 

3. Press Ctrl+E and export the file  

4. Exporting Form 27 Q and validate TDS returns with File Validation Utility 

5. After validating upload, the return to the government website  

Conclusion 

In this chapter, we have learnt to record the TDS transactions for Nature of Payments like rent on machinery, 
purchase of software and commission and brokerage. we have seen how TDS payments can be made in Tally 
without much manual work and learnt to rectify uncertain transactions, also understood the process of e-filing 
from Tally. 
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3.2 Tax Collected at Source 

 
3.2.1 Introduction  

Tax Collected at Source (TCS) is tax collected from the source (transaction) by the seller (collector) from the 
buyer (collectee/ payee), for goods traded u/s 206C (1) of the Income Tax Act, 1961. It is collected when 
accrued or when paid, whichever occurs earlier. It is prescribed for any business or trade dealing with alcoholic 
drinks, forest produce, scrap, etc. It also includes lease, license or contract related to parking lots, toll plaza, 
mines and quarry, etc., as defined in Section 206C of the Income Tax Act, 1961. The following brief description 
covers the applicability of the Act. 

3.2.1.1 Basic Concepts of TCS 

TCS Nature of Goods 

The following table describes the Nature of Goods covered under TCS and the rate applied as shown: 

Sl. No Nature of Goods TCS Rate 

1           Alcoholic liquor for Human Consumption 1% 

2 Any Other Forest Produce (Not Being Tendu Leaves & Forest Timber) 2.5% 

3 Bullion or Jewellery (If consideration exceeds ₹ 2,00,000) 1% 

4 Minerals, Being Coal or Lignite or Iron Ore 1% 

5 Scrap* 1% 

6 Tendu Leaves 5% 

7 Timber Obtained by Any Mode Other Than Forest Lease 2.5% 

8 Timber Obtained Under Forest Lease 2.5% 

9 Sale of any goods in cash exceeding ₹ 2 lakhs 1% 

10 Sale of any cars (both new & old) if sales is above ₹ 10 lakhs 1% 

11 Sale of Motor Vehicle (if the value exceeds the threshold limit of ₹10, 00,000.) 1% 

12  Sale in Cash of Any Goods (Other Than Bullion/Jewellery) – (if the value 
exceeds) the threshold limit of   ₹ 2,00,000.) 

1% 

13 Providing of Any Services (Other Than Ch-XVII-B) – (if the value exceeds the 
threshold limit of ₹ 2,00,000. ) 

1% 

Table 3.2.1 

LEARNING OBJECTIVES 
 Understand basics concepts of TCS 

 Enabling TCS in Tally 
 Create masters necessary for TCS transactions 
 Record TCS transactions 

 Generate TCS reports and challans from Tally 
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Note: Scrap means waste. The residual matter or any damaged materials arise and caused during 
manufacturing the finished units which cannot be useful in any further use. 

Seller 

A seller can refer to any one of the following: 

 The Central Government 

 A State Government 

 Any Local Authority 

 Corporation or Authority established by or under a Central, State or Provincial Act 

 Any Company 

 Firm 

 Co-operative Society 

It also includes Individuals or Hindu Undivided Family (HUF) running businesses or professions. The total 
sales, or turnovers of these businesses must exceed the monetary limits specified under Clause (a) or Clause 
(b) of Section 44AB of Tax Audit of Income Tax Act, 1961. This must be done during the financial year 
immediately preceding the financial year in which the goods of the nature specified above are sold. 

Buyer 

A Buyer is a person who has the right to receive or obtain goods specified above by means of a sale, auction, 
tender, or any other mode. A buyer does not include: 

 A public sector company, the central government, a state government, an embassy, a high commission, 
legation, commission, consulate and the trade representation of a foreign state and a club; or 

 A buyer in the retail sale of such goods purchased by him for personal consumption 

TCS on Contracts, License and Leases 

According to Sec 206C (1C), other than a public sector company (licensee or lessee), every person while 
dealing with another person for business who in whole or in part, either: 

 Grants a lease or license 

 Enters a contract 

 Transfers any right or interest 

Time and Mode of Payment of TCS to the Government Account 

The tax collected is to be paid to the Central Government within one week of the last day of the month in which 
the tax was collected. This payment is made in any branch of Reserve Bank of India (RBI), State Bank of India 
(SBI), or any other authorized bank. The payment is made accompanied by Income Tax challan 281. If the tax 
is collected on behalf of the Government, then the amount can be paid without the Income Tax challan. 



E-FILING  

 ADVANCED INFORMATION TECHNOLOGY 325 

Credit for Tax Collected at Source 

The amount collected on behalf of a person and paid under Section 206C (3) to the Central Government and 
specified in the second provision to sub-section (5) shall be deemed as payment of tax. Credit shall be given for 
that amount, for the assessment year in which such income is assessable without the production of a 
certificate. 

TCS Returns 

To ensure proper checks on the collections (TCS) and subsequent credit taken by the collectee/payee, the 
collectors are required to file their TCS returns with the Income Tax Department. The TCS returns contain the 
following information in the form prescribed by the Income Tax Department: 

 Collector details (the TAN, name, address) 

 The bank where the tax is deposited (like the amount, challan identification number) 

 The collectee details (the PAN, name, amount paid, Tax Collected at Source) 

Forms and Periodicity 

The revised forms for e-TCS returns and their periodicity, prescribed under income tax laws are as follows: 

Form Periodicity Due Date 

     Form 27D                    Annual Annual return of collection of tax under Section 
206C of Income Tax Act, 1961, filed on or before 
30th June, immediately after the financial year. 

 Form 27EQ Quarterly On or before 15th July 15th October 15th January and 
15th May 

Form 27E Annual On or before 30th June, immediately after the 
financial year. 

Form 27B Annual/Quarterly Filed in physical form with each return i.e., Form 
27E and Form 27EQ 

Table 3.2.2 

Business Scenario 

Comfort Enterprises deals with timber that is obtained from forest lease, as it is subjected to TCS 2.5%. The 
company collects TCS and remits the same to the government. The company also sells goods at lower and nil 
rate. 

Let us maintain TCS in Tally, 

3.2.2 Setting up TCS in Company  

Tally’s simple yet powerful TCS feature enables you to record transactions related to Tax Collection at Source 
with ease. 

Follow the steps given, to enable TCS in Tally for Comfort Enterprises 
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To Enable TCS, 

1. Go to Gateway of Tally > F11: Features > F3: Statutory 

2. Set the option Enable Tax Collected at Source (TCS) and Set/alter TCS details to Yes 

3. We have already provided Company TCS Collector Details, Enable the option Set/alter details of 
person responsible and enter Person Responsible Details  

4. Accept the screen and save the Statutory and Taxation screen 

Illustration 1: Recording Sales Transaction with TCS 

Date Particulars 

01-10-2019 Comfort Enterprises sold the following stock item to Krish Timber Traders. Timber 
attracts TCS @ 2.5% with reference CE/1. 

Name of Stock Item Quantity  Rate/MT Amount 

Timber 10 ₹ 8,000 ₹ 80,000 
 

Table 3.2.3 

To record the above transaction in the books of accounts, follow the steps: 

Step 1: Create TCS Nature of Goods 

 Go to Gateway of Tally > Accounts Info. > Statutory Info. > TCS Nature of Goods > Create or press 
Ctrl+C: Helper, to get predefined List of Nature of Goods>Select Timber Obtained Under Forest 
Lease>Enter the Rate as 2.50%>Enter Rate, if PAN not available as 5%>Enter the 
Threshold/exemption Limit if applicable and press Enter to save the TCS Nature of Goods. 

Note: There is no threshold limit for Timber obtained under forest lease. 

The completed TCS Nature of Goods appears as shown in figure 3.2.1 

 

Figure 3.2.1 Completed TCS nature of Goods Screen 

Note:  

 Press F12 Configuration from the TCS Nature of Goods and enable the option Allow rate details for 
others to Yes, in order to define the TCS rate for Individual/HUF and others. 
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 When we are selling the goods to customers who may or may not have PAN. In this case we can define 
the TCS rates for customers with or without PAN for each TCS Nature of Goods, in Rate if PAN Not 
available field 

Step 2: Creation of Accounting Master 

Krish Timber Traders 

 Go to Gateway of Tally >Accounts Info.>Ledgers> Create > create Krish Timber Traders under 
Sundry Debtors > set Is TCS Applicable? to Yes, select Buyer/Lessee Type as Company- Resident, 
and enter PAN/IT No. and save the ledger. 

Sales 

 Go to Gateway of Tally >Accounts Info.>Ledgers> Create > create Sales under Sales Account > 
select Is TCS Applicable? as Applicable and select Nature of Goods as Timber Obtained Under 
Forest Lease. 

TCS Duty  

 Go to Gateway of Tally >Accounts Info.>Ledgers> Create > create TCS Duty under Duties and 
Taxes > select Type of duty/tax as TCS select Nature of goods/contract/license/lease as Timber 
Obtained Under Forest Lease. 

Step 3: Creation of Inventory Master  

 Go to Gateway of Tally >Inventory Info.>Stock Items > Create. 

Timber 

Against the Field Action to be Performed 

Name Enter as Timber  

Under Select as Primary 

Units Select as MT (Create UOM) using Alt+C 

Is TCS Applicable? Select as Applicable 

Nature of Goods Select as Timber Obtained Under Forest Lease 

Table 3.2.4 

Activity: Record the purchase entry mentioned in table 3.2.5 by creating the ledger Crystal Timber Traders 
under Sundry Creditors and Purchase ledger. 

Date Particulars 

01-10-2019 Comfort Enterprises purchased the following stock item from Crystal Timber Traders, with 
PUR/002 item value is inclusive of TCS. 

Name of Stock Item Quantity  Rate/MT Amount 

Timber 100 ₹7,000 ₹7,00,000 
 

Table 3.2.5 
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Step 4: Recording Sales of TCS Goods 

1. Go to Gateway of Tally > Accounting Vouchers > F8: Sales 

2. Press F2: Date and change the date to 01-10-2019 

3. Ensure it is in Item Invoice mode, enter Reference no as CE/1 

4. In the Party A/c name field, select Krish Timber Traders and select the Sales ledger 

5. In the Name of Item field, select Timber 

6. Enter 10 in the Quantity field and ₹ 8,000 in the Rate field. The Amount will be automatically calculated 
and captured  

7. Select the TCS Duty ledger and press enter 

8. To view the Tax Analysis, press Alt+A and then click Alt+F1 for Detailed view 

 The Tax Analysis screen appears as shown in figure 3.2.2: 

 

Figure 3.2.2 Tax Analysis Screen 

9. Press Esc from tax analysis screen, to go back to the voucher creation screen 

 The completed Sales Invoice appears as shown in figure 3.2.3: 

 

Figure 3.2.3 Completed Sales Invoice Screen 

10. Press Ctrl+A to accept 

3.2.2.1 Sales of TCS Goods at Lower Rate 

Where the Assessing Officer is satisfied that the total income of the buyer justifies the collection of tax at any 
lower rate than the relevant rate specified in Section 206C (1), Buyer (or licensee or lessee) will be allowed a 
lower rate of TCS on an application made by the buyer (or licensee or lessee) under sub-section (9) of Section 
206C in Form No. 13. 
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The certificate granted shall be valid for the assessment year specified and is valid only for the person named 
therein. In Tally, the user can record and compute TCS on transactions, on which a lower rate of collection is 
applicable. 

Illustration 2: Accounting sale of TCS goods at lower rate 

Date Particulars 

06-10-2019 Voucher: Sales 
Comfort Enterprises sold the following stock item to Jai Timbers At a lower rate of TCS 
1.5% with reference number CE/2. 

Name of Stock Item Quantity  Rate/MT Amount 

Timber 5 ₹8,000 ₹40,000 
 

Table 3.2.6 

To record the above transaction in the books of accounts, follow the steps given: 

Step 1: Creation of Accounting Masters 

Jai Timber  

 Go to Gateway of Tally >Accounts Info.>Ledgers> Create > create Jai Timbers under Sundry 
Debtors > click F12: Configure to enable the option Allow advanced entries in TDS/TCS master?, set 
Is TCS applicable to Yes, select Buyer/Lessee Type as Company- Resident, enable Use advanced 
configurations for TCS? and set the option Set/alter zero/lower rate for collection to Yes and provide 
the details as shown in the figure 3.2.4 and enter PAN/IT No. and save the ledger. 

The Zero/Lower Collection Details screen appears as shown in figure 3.2.4: 

 

Figure 3.2.4 Zero/Lower Collection Details Screen 

Step 2: Recording Sales Invoice 

1. Go to Gateway of Tally > Accounting Vouchers > F8: Sales 

2. Press F2: Date and change the date to 06-10-2019, enter Reference no as CE/2 

3. In the Party A/c name field, select Jai Timbers, select the Sales ledger 

4. In the Name of Item field, select Timber 

5. Enter 5/MT in the Quantity field and ₹ 8000 in the Rate field. The amount will be automatically 
calculated and captured 

6. Select the TCS Duty ledger and press Enter 
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7. To view the Tax Analysis, press Alt+A and then press Alt+F1 

The Tax Analysis screen appears as shown in the figure 3.2.5: 

 

Figure 3.2.5 Tax Analysis Screen 

Note: We can observe that the TCS is calculated @ 1.5% as we have entered zero/Lower Collection Details.  

8. Press Esc from the Tax Analysis to go back to the voucher creation screen 

The Sales Invoice appears as shown in the figure 3.2.6: 

 

Figure 3.2.6 Completed Sales Invoice Screen 

9. Press Ctrl+A to accept 

Once after recording the Sales transaction with lower rate of TCS the sales transaction is reflected in the TCS 
reports available in Tally. 

3.2.2.2 Sales of TCS Goods at Nil Rate 

In case, the goods referred in Section 206C (1) are to be utilized for the purposes of manufacturing, processing 
or producing articles or things and not for trading purposes, the buyer can get the approval for TCS @ Nil Rate 
by submitting a declaration in Form No. 27C. 

Such certificate shall be valid only for the person named therein and to claim the benefit of Nil Rate, the 
declaration should be furnished to the person responsible for collecting tax. 

Activity: Create the required masters and record the following transaction: 
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Illustration 3: Recording of TCS transaction at Nil Rate. 

Date Particulars 

15-10-2019 Comfort Enterprises sold the following stock item to Jyoti Timber Works with reference 
number CE/3. The TCS applicable is Nil, as Jyoti Timber Works are using the timber for 
manufacturing. 

Name of Item Quantity Rate Amount 

Timber 5 ₹ 8,000/MT ₹ 40,000 
 

Table 3.2.7 

Hint:  

1. Create the ledger Jyoti Timber Works ,Select Buyer/Lessee type as Association of Persons  enable 
Use advanced configurations for TCS? and set the option Set/alter zero/lower rate for collection to 
Yes and provide the details and rate of TCS as 0%, Do not enter PAN/IT No. and save the ledger. 

2. Record the sales transaction without selecting the TCS Duty ledger. 

3.2.3 Rectification of errors in TDS returns  

To resolve the exception and generate TDS report, follow the steps: 

1.  Go to Gateway of Tally > Display > Statutory Reports > TCS Reports > Form 27 EQ 

The Form 27 EQ appears as shown in figure 3.2.7: 

Fig
ure 3.2.7 Form 27 EQ 

2. Select Uncertain Transactions and resolve the exception. 

Note: Here we have resolved the exception only for Not providing the PAN, all other exceptions if any would be 
listed here, which can be resolved from Summary of Exceptions screen.  

The Form 27 EQ after resolving the exception appears as shown in the figure 3.2.8: 
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Figure 3.2.8 Form 27 EQ - Exception Resolved 

In Figure 3.2.8, we can observe that the TCS Collected is ₹ 2,600 which needs to be paid to the department. 

3.2.4 Payment of TCS 

In Tally, we can record the payment of TCS collected to government in a payment invoice using the stat 
payment button. 

Illustration 4: Recording payment of TCS collected to the department 

Date Particulars 

19-10-2019 Voucher: Payment 
Comfort Enterprises made a payment of TCS duty towards Timber Obtained Under Forest 
Lease to the government vide Kotak Bank cheque no. 000012. TCS collected on amount of  
₹ 2, 600. 

Table 3.2.8 

To record the transaction in the books of accounts follow the steps:  

Step 1: Recording Payment Voucher using Stat Payment 

1. Go to Gateway of Tally > Accounting Vouchers > F5: Payment 

2. Press F2: Date and change the date to 19-10-2019 

3. Press Alt+S or click S: Stat Payment 

4. Select TCS in the Type of Tax field 

5. Period from 1-10-2019 to 31-10-2019 

6. Collected till date 19-10-2019 

7. Section 206C 

8. Nature of Goods Timber Obtained Under Forest Lease 

9. Collectee status Company 
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10. Residential status Resident 

11. Select Kotak Bank 

The Statutory Payment screen appears as shown in figure 3.2.9: 

 

Figure 3.2.9 Payment of TCS 

12. Accept the entry 

Step 2: Print Challan ITNS 281 

To print the Challan, 

1. Press Page Up to go back to Payment Voucher or go to Display> Daybook> and open the payment entry. 

2. Press Alt+P from the Payment Voucher to view the Voucher Printing screen 

3. In the Voucher Printing screen, 

 Ensure Print as TCS Challan is set to Yes or else press backspace to fill all the details 

4. Press Enter to print 

The printed TCS Challan appears as shown in figure 3.2.10: 
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Figure 3.2.10 ITNS 281 Tax Challan 
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3.2.5 TCS Reports 

TCS reports in Tally are extensive. Statutory reports are integrated, making it convenient to print and file 
reports in government prescribed formats. Additionally, a wide range of reports such as reconciliation reports 
and display reports are available. These reports provide information and help in managing TCS issues with 
ease. 

3.2.5.1 Form 27EQ 

As per the Income Tax Act, 1961, every corporate and government entity responsible for collection of tax at 
source should furnish TCS returns containing details of collectee(s) and challan details relating to deposit of tax 
with the Income Tax Department. Form 27EQ is the quarterly return statement for TCS.  The due dates for filing 

returns are July 15th, October 15th, January 15th, and for the last quarter, it is May 15th.. 

The Form 27EQ report in Tally assists you in generating accurate returns to be filed. 

The report can be drilled down to the voucher entry level to display complete information of each transaction. 

To generate the Form 27EQ, 

1. Go to Gateway of Tally > Display > Statutory Reports > TCS Reports > Form 27EQ 

2. Click F1: Detailed 

The Form 27 EQ statistics of voucher appears as shown in figure 3.2.11: 

 

Figure 3.2.11 Form 27EQ 

Total Number of Vouchers 

This displays the total number of transactions which are considered for the generation of Form 27 EQ. Press 
Enter on Total Number of Transactions to view the Statistics of Vouchers. 
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Included Transactions: 

Transactions that will be considered as Included for generating Form 27EQ: 

 Sales entries in the current period, with TCS collection 

 Entries recorded in Debit Note/Journal voucher for increase in sales value and/or TCS value 

 Entries for payments received in advance from collectee 

 TCS adjustment entries 

 Entries accounting for TCS reversals and TCS deduction w.r.t escalations and de-escalations 

 TCS ‘book entries’ for collections made by or on behalf of the Government 

Excluded Transactions: 

These are transactions that do not carry the TCS details that are requisite to generate Form 27EQ, and hence 
will be excluded while generating the form. Transactions that will be considered as Excluded for generating 
Form 27EQ: 

 All entries where TCS is not applied  

 Entries recorded using any of the following Voucher Types: 

o Payment 

o Contra 

o Inventory Vouchers 

o Order Vouchers 

o Debit Note (entries with no TCS implications) 

o Credit Note (entries with no TCS implications) 

o Vouchers marked as Optional 

o Reversing Journal 

o Memorandum Vouchers 

o Payroll Vouchers 

o Journal Vouchers recorded with adjustment entries not related to TCS 

Press Enter on Excluded Voucher Details to view the Excluded Voucher Details. 

Uncertain Transactions 

It displays the complete list of information gaps found in transactions. Until these details are specified, either in 
masters or transactions, the transaction cannot be considered for filing returns. It consists of two broad 
categories, 

 Master Related Exceptions 

 Transactions Related Exceptions 
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All the transactions which are displayed here require the user’s intervention to provide the appropriate details. 
Provision to completely exclude uncertain transactions is also made available. Hence, any transaction which 
has information gaps but is not required to be shown in the quarterly return, can be moved to Excluded 
Transactions. 

Collection Details 

Details of all TCS entries are listed here under two heads: 

 Collection at Normal Rate 

 Collection at Zero Rate 

Payment Details 

This will contain the statistics of all TCS payments (deemed or actual) that exist in the data till date. This will 
not contain any of the payment entries that are not related to the current period. Any payment entries other that 
TCS payment entry will not appear here. 

Included Transactions 

All the TCS payment to department till date, which is applicable for the report period, will be listed as Included 
Transactions under this section. 

Not Included Transactions 

Payment transactions that may possibly be TCS payments, but cannot be ascertained due to missing 
information, will be listed here. Transactions will be listed here under the following circumstances: 

 The Duty Type has not been set for the duty ledger 

 The type of TCS Payment is not available. That is, whether the payment is made towards Late Fee, 
Interest, Income Tax, Surcharge, Education Cess, Secondary Education Cess, or Other Payments. 

 Details of the bank where the payment has been made, is unavailable 

 The period for which the payment is made, is not available 

 The payment entry has not been linked to a deduction entry 

 The payment amount has not been rounded off. As per rules, TCS payments need to be rounded off 
figures. 

Activity: Reconcile Challan from Challan Reconciliation report.  

3.2.5.2 Saving Form 27EQ 

After resolving the required exceptions, the changes made can be saved. 

To save the Form 27EQ, 

1. Go to Gateway of Tally > Display > Statutory Reports > TCS Reports > Form 27EQ>Press F6 to save 

2. Once after saving the Form 27 EQ, you can export the form 27 EQ. 
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Exporting the Form 

On saving the form, e-filing of the returns can be done from Form 27EQ. 

To export Form 27EQ 

1. Click Ctrl+E: e-Return from Form 27EQ 

The Exporting eTCS Forms screen appears as shown in figure 3.2.12: 

 

Figure 3.2.12 TCS Export Screen 

You can view the text file as shown in figure 3.2.13: 

 

Figure 3.2.13 Text File 

2. After exporting eTCS form, a text file will be created under Tally folder namely Tally.txt 
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3. Now Tally text file should be validate through NSDL file validation utility.  

4. After successfully validating the file we can submit validated file to govt. portal 

3.2.5.3 Return Transaction Book 

The Return Transaction Book displays the list of saved returns. Each time the form is modified and saved; the 
details are displayed as a separate row in return transaction book. 

To view Return Transaction Book, From Gateway of Tally > Display > Statutory Reports > TCS Reports > 
Return Transaction Book 

The Return Transaction Book screen appears as in figure 3.2.14: 

 

Figure 3.2.14 Return Transaction Book 

To generate the return, which was saved, select the required row and press enter. 

3.2.5.4 Recompute, Overwrite and Save Corrected Return 

In Tally, we have the option to modify the details once after saving the form 27 EQ and then save the revised 
return with the changes made. 

Recompute  

This option will be displayed in the report if we have made any changes in the TCS transactions which belongs 
to the saved return period. 

Activity: Alter the payment of TCS entry and change the date to 21-10-2019. 

Let us check Form 27 EQ once after altering the payment of TCS entry in Tally. 

The Form 27 EQ appears as shown in figure in 3.2.15: 
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Figure 3.2.15 form 27 EQ 

The message ‘(The return values might have been changed, press F5 to recompute)’ appears with a new 
section comprising details of: 

 Modified Masters: If the duty ledger is not selected in invoice, this row will not show transaction count. 

 Modified Vouchers: This row displays the total count of vouchers which are Created, Altered, Cancelled 
and Deleted. Press Enter to display the Summary of Modified Vouchers. As shown in figure 3.33. 

To view the list of transactions captured against each modification type, 

1. Press Enter on the Created or Altered or Cancelled or Deleted vouchers row in which the transaction 
count is displayed. 

2. Press Enter to display the voucher alteration screen 

3. To include the changes made into the report and recalculate the values, click F5: Recompute. Once the 
values are recomputed, the section displayed for modified masters and transactions will not appear. 

In the figure 3.2.15, we can observe that Modified Vouchers displays 1 voucher, press enter Summary of 
Modified Vouchers screen, press Enter on the Altered Vouchers field you will get the screen as shown in 
figure 3.2.16: 

The Summary of Modified Voucher appears in figure 3.2.16: 

 

Figure 3.2.16 Summary of Modified Voucher Screen 
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Observation: In the figure 3.2.16, we can observe the current voucher status details i.e., we have changed the 
date of payment of TCS entry to 21-10-2019. 

To recompute the changes made after saving the return press F5: Recompute from Form 27 EQ.  

Overwrite 

By using this option, we can overwrite the existing form 27 EQ return. 

On recomputing the values of modified transactions, the Form 27EQ report displays: 

1. Two buttons, F6: Overwrite and F7: Save as Revised if all exceptions are resolved and Uncertain 
Transactions count is zero 

2. One button, F6: Overwrite if Uncertain Transactions count is NOT zero 

To overwrite the recomputed information on the existing return, 

1. From Form 27 EQ, click F6: Overwrite. The message appears as Do you want to Overwrite the 
Existing Return?  

2. Press Enter or Y to accept and overwrite the data with modified details. 

Note: If required, we can save the return as revised by following the below given procedure. 

Save as Revised 

To save the recomputed valued as revised return without overwriting the information, click F7: Save as 
Revised button. This button appears only if the Uncertain Transactions count of Form 27EQ is zero. 

To save modified values as revised return, 

1. Click F7: Save as Revised button. The message appears as Do you want to Save the Revised 
Returns? 

2. Press Enter or Y to Accept and Save the Revised Return 

Activity: Once after modifying the return and overwriting it, the details can be checked in Return Transaction 
Book. In this report we will get the modified details i.e., if the return is modified and overwritten, then Is 
Modified field will display as Yes 

Conclusion 

In this chapter we have learnt about Tax Collected at Source (TCS), also we have learnt to record the TCS 
transactions like recording sales at normal, lower and TCS rates, making payment of TCS to department, 
generating TCS Reports and filing e-TCS return in Tally. 
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3.3 Payroll and Income Tax 

 
3.3.1 Introduction  

The term payroll refers to a series of accounting transactions involved in the process of paying employees for 
the services rendered after taking all the statutory and non-statutory deductions into account, in conformance 
with the terms of employment, company policy and the law of the land. 

Business Scenario 

Future Technologies Pvt. Ltd. is engaged in the sales of business software and services. company was 
started with a capital of ₹ 10,00,000, in April 2019. 

company wants to maintain payroll of their employees in Tally. It is based at Bengaluru with the following two 
major departments: 

 Sales Department 

 Administration Department 

Activity:  

1. Create the following Company  

 Company Name: Future Technologies Pvt. Ltd. 

 Address: #52, 5th Main Road, Garden Tech Park, Bengaluru- 560051 

 Financial Year: 01-04-2019 

2. Create the ledger Kotak Bank under Bank Accounts and Proprietors Capital under Capital Account.  

3. Record a Receipt entry for introducing capital of ₹ 10,00,000 as on 01-04-2019 to business as shown 
below 

Particulars L.F Dr. Cr. 

Kotak Bank _________________ Dr.  10,00,000  
To, Proprietors Capital A/c   10,00,000 

(Being cash invested by the proprietor)    

Table 3.3.1 

LEARNING OBJECTIVES 
 Creation of Basic Pay heads and Statutory Deduction Pay heads. 
 Maintenance of Attendance. 
 Defining Salary Details and Processing of Salary.  
 Income Tax configurations such as Declaration of Incomes, Previous Employer Income Details etc. 

 Payroll and Statutory Reports such as Pay Slip, Pay Sheet, Payment Advice, Income Tax 
Computation and Form 16 etc. 
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3.3.2 Activate Payroll 

To activate Payroll in Tally, follow the steps given below: 

1. Go to Gateway of Tally > F11: Features> press F1: Accounts>set Maintain payroll to Yes and set 
Maintain more than one payroll or cost category to Yes>accept Accounting Features screen. 

2. Press F3: Statutory >set Enable payroll statutory? to Yes and Set/alter payroll statutory details? to 
Yes, enter Payroll Statutory Details as shown in the figure 3.3.1 

The Completed Payroll Statutory Details screen appears as shown in figure 3.3.1: 

 

Figure 3.3.1 Payroll Statutory Details 

3. Accept the Payroll Statutory Details screen. 

 



 ADVANCED ERP CONCEPTS 

344  ADVANCED INFORMATION TECHNOLOGY 

3.3.3 Processing Payroll in Tally 

Tally’s payroll features require minimal effort for accurate payroll processing. It takes five easy steps to process 
payroll and generate pay slip in Tally.  

The salary of Future Technologies Pvt. Ltd. employees can be processed in the following five steps. 

 

3.3.4 Employee Setup 

The Employee master is used to record the employee information. In Tally, the following employee masters can 
be created: 

 Employee Category Master 

 Employee Group Master 

 Employee Master 

Employee Group Master 

Businesses with multiple departments, divisions, functions or activities may create the required employee 
groups and classify individual employees under a specified group.  

In this case, we will create employee group as departments such as Sales Department and Administration 
Department. 

Step 1: Creation of Employee Group  

Go to Gateway of Tally > Payroll Info. > Employee Groups > Create> select Category as Primary Cost 
Category >Enter the name as Sales Department >Under Primary >Set the option Define salary details to 
No>Accept the screen 

Activity: Create the employee group for Administration Department under Primary. 

Employee Master 

The Employee Master is used to record all employee- related information. 

Creation of Employee Masters 

1. Go to Gateway of Tally > Payroll Info. > Employees > Create (under Single Employee), create the 
employee Rajesh Jain Under Sales Department as shown in the figure 3.3.2 

2. Click F12: Configure and Set Provide passport and visa details to Yes and Provide contract details 
to Yes to get expat details in employee creation.  
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The Employee Creation Screen appears as shown in the figure 3.3.2 

 

Figure 3.3.2 Employee Creation Screen 

 

3. Accept the screen 

Note:  

 The date of resignation/retirement option will be available only on the employee alteration screen. After 
you enter the date of resignation/retirement, you can also select a reason for leaving. 

 By enabling the option Provide bank details to Yes, we can provide the bank information like, account 
number, IFS code, MICR code, bank name and branch- It is mandatory for generating payment advice. 

Activity: Create the employee Ajay Dutt under Administration Department as shown in figure 3.3.3 
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Figure 3.3.3 Employee Creation Screen 

3.3.5 Creation of Payroll Units 

The salary paid to an employee is computed based on work done by an employee, which is measured in terms 
of time or quantity. In Tally, work done can be quantified using the Payroll Unit. 

A payroll unit is like unit of measure used in the inventory module. We can create simple as well as compound 
payroll units measured on attendance/production types such as time, work or quantity. 

Simple Unit Creation 

Go to Gateway of Tally > Payroll Info. > Units (Work) > Create 

Hours 

Against the field Action to be performed 

Type Let it be as it is 

Symbol Enter Hrs. 

Formal name Enter Hours 

Number of decimal places Enter 0 

Table 3.3.2 

Activity: Create a simple unit as Minutes, with the unit symbol as Mins and formal name as Minutes. 

Compound Unit Creation 

Go to Gateway of Tally > Payroll Info. > Units (Work) > Create > press Backspace 
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Hours of 60 Minutes 

Against the field Action to be performed 

Type Select Compound 

First unit Enter Hrs. 

Conversion Enter 60 

Second unit Select Mins 

Table 3.3.3 

3.3.6 Attendance/Production Types 

An Attendance/Production Type is used to record the attendance and production data. Based on the various 
components (pay head), we may need to define multiple attendance/production types.  

Examples for attendance types are days present or absent, and examples of production types are hours 
worked, or number of pieces produced. 

The Attendance/Production Type may be: 

 Attendance/Leave with Pay: should be used to record positive attendance and leave with pay. For 
example: Present, Sick Leave, etc. 

 Leave without Pay: should be used to record negative attendance. For example: Absent, Leave without 
Pay etc. 

 Production type: should be used to record the production details. For example: Piece Production, 
Overtime Hours, etc. 

 User Defined Calendar Type: should be used to create user defined calendar which can be later used 
to specify the variable number of days for each month. For example: 25 days in January, 24 days in 
February, 26 days in March, etc. 

Attendance Type Creation 

1. Go to Gateway of Tally > Payroll Info. > Attendance/Production Types > Create 

Create as Present Under Primary, select Attendance type as Attendance/Leave with Pay. 

The Completed Present Attendance Type Creation screen appears as per shown in the figure 3.3.4: 
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Figure 3.3.4 Attendance/Production Type Creation Screen 

2. Accept the screen 

Activity: Create the following Attendance Type 

Absent 

Against the field Action to be performed 

Name  Enter Absent 

Under Select Primary 

Attendance Type Select Leave Without Pay 

Table 3.3.4 

Production Type Creation 

Go to Gateway of Tally > Payroll Info. > Attendance/Production Types > Create 

Overtime 

Against the field Action to be performed 

Name Enter Overtime 

Under Select Primary 

Attendance Type Select Production 

Unit Hrs. of 60 Min. 

Table 3.3.5 

3.3.7 Creation of Pay Heads 

The salary components constituting an employee’s pay structure is called a Pay Head. Pay Heads may be 
broadly considered as earnings and deductions from an employee’s point of view.  
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The essential pay heads required to be created to process the salaries of the employees of Future 
Technologies Pvt. Ltd. includes, 

 Basic Pay  

 House Rent Allowance 

 Conveyance  

 Overtime  

The Payroll Statutory deduction pay heads required are  

 Employees PF Deduction @12% 

 Employers EPS Contribution @8.33% 

 Employers EPF Contribution @3.67% 

 EDLI Contribution@0.50% 

 PF Admin Charges@0.50% 

 Employees ESI Deduction @1.75% 

 Employers ESI Contribution @4.75% 

 Professional Tax  

 Income Tax 

Let us now see how these pay heads are created in Tally. 

Creation of Pay heads 

1. Basic Pay 

Go to Gateway of Tally > Payroll Info. > Pay Heads > Create 

Basic Pay 

Against the Field Action to be Performed 

Pay head type Select Earnings for Employees 

Income type Select Fixed 

Under Select Indirect Expenses 

Affect net salary Select Yes 

Name to be displayed in payslip Basic Pay appears by default, accept the same 

Use for calculation of gratuity Select No 

Set/Alter Income Tax Details Set to No 

Calculation type Select On Attendance 
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Attendance/leave with pay Select Present 

Calculation period Select Months 

Basis of calculation (per day) Select As per Calendar Period 

Rounding Method Select Normal Rounding 

Limit Enter 1 

Table 3.3.6 

The Completed Basic Pay Head Creation screen appears as per shown in the figure 3.3.5: 

 

Figure 3.3.5 Pay Head Creation Screen - Basic Pay 

Accept the Pay head. 

2. House Rent Allowance 

House Rent Allowance 

Against the Field Action to be Performed 

Pay head type Select as Earnings for Employees 

Income type Select as Fixed 

Under Select as Indirect Expenses 

Affect net salary Set to Yes 

Name to be displayed in payslip Enter as HRA 

Use for calculation of gratuity Set as No 
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Set/Alter Income Tax Details Set to No 

Calculation type Select As Computed Value 

Calculation period Months will be selected as default 

Rounding Method Select Normal Rounding 

Limit Enter as 1 

Compute Select as On Specified Formula 

Compute on Specified Formula 

Function Add Pay Head appears as default 

Pay Head Select Basic Pay 

Effective From Enter 01-04-2019 

Slab Type Select Percentage 

Value Basis Enter 40% 

Table 3.3.7 

The Computation Information for House Rent Allowance Pay head appears as shown in the figure 3.3.6: 

 

Figure 3.3.6 Computation Information - HRA 

3. Conveyance 

Conveyance 

Against the Field Action to be Performed 

Pay head type Select Earnings for Employees 

Income type Select Fixed 

Under Select Indirect Expenses 

Affect net salary Select Yes 

Name to be displayed in payslip Conveyance 

Use for calculation of gratuity Select No 

Set/Alter Income Tax Details Set to No 
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Calculation type Select Flat Rate 

Calculation period Select Months 

Rounding Method Select Normal Rounding 

Limit Enter 1 

Table 3.3.8 

4. Overtime 

Overtime 

Against the Field Action to be Performed 

Pay head type Select Earnings for Employees 

Income type Select Variable 

Under Select Indirect Expenses 

Affect net salary Select Yes 

Name to be displayed in payslip Overtime 

Use for calculation of gratuity Select No 

Set/Alter Income Tax Details Set to No 

Calculation Type Select On Production 

Production Type Select Overtime 

Rounding Method Select Normal Rounding 

Limit Enter 1 

Table 3.3.9 

3.3.8 Payroll Statutory Deduction Pay heads 

Provident Fund is a benefit scheme for salaried individuals created by the government. It is not only tax saving 
instrument, but it also provides security and stability to the employee and his family as well. Both the employers 
and employees make equal monthly contributions to this fund under various accounts. Employer and 
Employee Contributions are equal in PF which is 12%. This means 12% contribution from employee and 12% 
contribution from employer. Company contribution is split into two parts i.e. 8.33% on family pension fund and 
3.67 % on employee provident fund 
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Creation of Statutory Pay Heads 

1. Employees PF Deduction@12% 

Employees PF Deduction@12% 

Against the Field Action to be Performed 

Pay head type Select Employees’ Statutory Deductions 

Statutory pay type Select PF Account (A/c No. 1) 

Under Select Current Liabilities 

Affect net salary Select Yes 

Name to be displayed in payslip Employee’s PF Deduction@12% 

Rounding Method Select Normal Rounding 

Limit Enter 1 

Compute Select On Specified Formula 

Compute on Specified Formula 

Function Add Pay Head appears as default 

Pay Head Select Basic Pay 

Effective From Enter 01-04-2019 

Slab Type Select Percentage 

Value Basis Enter 12% 

Table 3.3.10 

2. Employers EPS Contribution@8.33% 

Employers EPS Contribution@8.33% 

Against the Field Action to be Performed 

Pay head type Select Employer’s Statutory Contributions 

Statutory pay type Select EPS Account (A/c No. 10) 

Under Select Indirect Expenses 

Affect net salary Select No 

Rounding Method Select Normal Rounding 

Limit Enter 1 

Compute Select On Specified Formula 

Compute on Specified Formula 

Function Add Pay Head appears as default 

Pay Head Select Basic Pay 

Effective From Enter 01-04-2019 

Amount Up To Enter 15,000 

Slab Type Select Percentage 
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Value Basis Enter 8.33% 

Amount greater Than By default it will be taken as 15,000 

Amount Up To Leave it blank 

Slab type Select Value 

Value basis Mention the amount as ₹ 1,250 

Table 3.3.11 

The Computation Information for Employers EPS Contribution@8.33%Pay head appears as shown in the 
figure 3.3.7: 

 

Figure 3.3.7 Computation Information - Employers EPS Contribution@8.33% 

3. Employers EPF Contribution@3.67% 

Employers EPF Contribution@3.67% 

Against the Field Action to be Performed 

Pay head type Select Employer’s Statutory Contributions 

Statutory pay type Select PF Account (A/c No. 1) 

Under Select Indirect Expenses 

Affect net salary Select No 

Rounding Method Select Normal Rounding 

Limit Enter 1 

Compute Select On Specified Formula 

Add Pay Head: Employees PF Deduction@12% 

Subtract Pay head: Employer’s EPS@8.33% 

Compute on Specified Formula 

Slab Type Select Percentage 

Value basis Enter 100% 

Table 3.3.12 
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The Computation on Specified formula for Employers EPF Contribution@ 3.67% screen appears as shown 
in the figure 3.3.8: 

 

Figure 3.3.8 Computation on Specified formula for Employers EPF Contribution@ 3.67% 

EDLI: Employee Deposit Linked Insurance is a scheme which is amended in the year 1976. It is insurance on 
PF deposit. This scheme pays a lump sum payment to the insured nominated beneficiary in the event of death 
due to accident or illness. 

All employees who join employee provident scheme are covered by EDLI Scheme and the EDLI Contribution 
rate is 0.5%. EDLI Contribution will be calculated on PF gross (PF gross refers to the value of pay heads used 
for A/c. No. 1 (employee PF@12%) pay head.) 

Administrative charges: These are the charges collected by the government in order to maintain the PF and 
EDLI account. It’s a charge paid by the employers to maintain the PF and EDLI account. 

Employer PF administrative charges and EDLI contribution are calculated based on the PF gross at 0.50% each 
as per the latest changes. 

4. EDLI Contribution@0.50% 

EDLI Contribution@0.50% 

Against the Field Action to be Performed 

Pay head type Select Employer’s Other Charges 

Statutory pay type Select EDLI Contribution (A/c No.21) 

Under Select Current Liabilities 

Affect net salary Select No 

Calculation type By default, it will take As Computed Value 

Calculation Period By default, it will take as Months 

Computation Info 

Compute By default, it will take as On PF Gross. 

Effective From Enter 01-04-2019 

Amount Upto Leave it Blank 

Slab Type Select Percentage 

Value Basis Enter 0.50% 

Table 3.3.13 
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5. PF Admin Charges@0.50% 

PF Admin Charges@0.50% 

Against the Field Action to be Performed 

Pay head type Select Employer’s Other Charges 

Statutory pay type Select Admin Charges (A/c No.2) 

Under Select Current Liabilities 

Affect net salary Select No 

Calculation type By default, it will take As Computed Value 

Calculation Period By default, it will take as Months 

Computation Info 

Compute By default, it will take as On PF Gross. 

Effective From Enter 01-04-2019 

Amount Upto Leave it Blank 

Slab Type Select Percentage 

Value Basis Enter 0.50% 

Table 3.3.14 

Employee State Insurance is a health insurance scheme can be used for your medical treatment. For all 
employees earning ₹ 21,000 or less per month as wages.  The employer's share of contribution is 4.75% of 
gross salary and employee's share is 1.75% of the gross salary. Thus, in respect of each of the employee, 
6.50% of the wages (including overtime allowance) is to be paid as contribution to scheme. This fund is 
managed by the ESI Corporation (ESIC) according to rules and regulations, which oversees the provision of 
medical and cash benefits to the employees and their family through its large network of branch offices, 
dispensaries and hospitals. 

Note: The Employees’ State Insurance Corporation (ESIC) increased the monthly wage threshold to ₹ 
21,000, from ₹ 15,000, for coverage under its health insurance scheme effective from 01.01.2017 

In order to process ESI in Tally, the following pay heads must be created: 

 Employee ESI deduction 

 Employer ESI contribution 
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6. Employees ESI Deduction@1.75% 

Employees ESI Deduction@1.75% 

Against the Field Action to be Performed 

Pay head type Select Employees’ Statutory Deductions 

Statutory pay type Select Employee State Insurance 

Under Select Current Liabilities 

Affect net salary Select Yes 

Name to be displayed in payslip Employees ESI Deduction@1.75% 

Rounding Method Select Normal Rounding 

Limit  Set as 1 

Compute Select On Specified Formula 

Add all the Earnings Pay Heads on which ESI need to 
be calculated. 

Add Pay Head: Basic Pay 

Add Pay Head: House Rent Allowance 

Add Pay Head: Conveyance 

Effective From 01-04-2019 

Slab Value Enter 1.75% 

Table 3.3.15 

7. Employers ESI Contribution@4.75% 

Employers ESI Contribution@4.75% 

Against the Field 

 

Action to be Performed 

Pay head type Select Employers’ Statutory Contributions 

Statutory pay type Select Employee State Insurance 

Under Select Indirect Expenses 

Affect net salary Select No 

Rounding Method Select Normal Rounding 

Limit  Set as 1 

Compute Select On Specified Formula 

Add all the Earnings Pay Heads on which ESI need to 
be calculated. 

Add Pay Head: Basic Pay 
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Add Pay Head: House Rent Allowance 

Add Pay Head: Conveyance 

Effective From 01-04-2019 

Slab Value Enter 4.75% 

Table 3.3.16 

Professional Tax is charged by respective municipal corporations and most of the states in India charge this 
tax. The tax is deducted by the employer every month and remitted to the municipal corporation and it is 
mandatory like income tax. 

Professional tax is a tax levied by the various state governments of India on salaried individuals, working in 
government or non-government entities, or in practice of any profession 

8. Professional Tax  

Professional Tax 

Against the Field Action to be Performed 

Pay head type Select Employees’ Statutory Deductions 

Statutory pay type Select Professional Tax 

Registration Number Enter KA/PT8983 

Under Select Current Liabilities 

Affect net salary Select Yes  

Name to be displayed in payslip Professional Tax 

Calculation type As Computed Value 

Calculation period Months 

Rounding Method Select Normal Rounding 

Limit Enter 1 

Compute Select On Current Earnings Total 

Table 3.3.17 

Enter the Computation information as shown in figure 3.3.9 

The Computation Information for Professional Tax Pay Head appears as shown in the figure 3.3.9: 
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Figure 3.3.9 Computation Information for Professional Tax Pay Head 

9. Income Tax 

Income tax is the levied on personal income. Income tax is a tax payable, at enacted by the union budget 
(finance act) for every assessment year on the total income earned in the previous year by every person. 

Income Tax 

Income Tax 

Against the Field Action to be Performed 

Pay head type Select Employees’ Statutory Deductions 

Statutory pay type Select Income Tax 

Under Select Current Liabilities 

Affect net salary Select Yes 

Name to be displayed in payslip Income Tax 

Calculation type As Per Income Tax Slab 

Calculation period Select Months 

Rounding Method Upward Rounding will be selected by default 

Limit 1 will be selected by default 

Table 3.3.18 

3.3.9 Defining Salary Details for an Employee 

The pay structure for an employee can be defined in Tally using the Salary Details option. 

1. Go to Gateway of Tally > Payroll Info. > Salary Details > Define > Select Rajesh Jain 
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2. Specify the details referring to the table: 3.3.19 

Salary Details for Rajesh Jain 

Against the Field Action to be Performed 

Effective From Enter 01-04-2019 

Salary Structure Details for Rajesh Jain 

Pay Head Rate Per 

Basic Pay 42,000 Months 

House Rent Allowance As Computed Value  As Computed Value  

Conveyance 2,500 Months 

Overtime 300 Hrs 

Employees PF Deduction@12% As Computed Value  As Computed Value 

Employers EPS Contribution@8.33% As Computed Value As Computed Value 

Employers EPF Contribution@3.67% As Computed Value As Computed Value 

Employees ESI Deduction@1.75% As Computed Value As Computed Value 

Employers ESI Contribution@4.75% As Computed Value As Computed Value 

Professional Tax  As Computed Value As Computed Value 

Income Tax As Per Income Tax Slab  

Table 3.3.19 

Note: The Pay Head Type, Calculation Type and Computed On columns will display information based on the 
Pay Head selected. Either based on percentage for specified formulas or amounts for flat rate as configured in 
the pay head. 

The Completed Salary Details Screen appears as shown in the figure 3.3.10: 

 

Figure 3.3.10 Salary Details of Rajesh Jain 

Accept the salary details screen  
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Activity:  Define salary details for the employee Ajay Dutt (Administration Department) by referring the table 
3.3.20 

Salary Details for Ajay Dutt 

Against the Field Action to be Performed 

Effective From Enter 01-04-2019 

Salary Structure Details for Ajay Dutt 

Pay Head Rate Per 

Basic Pay 12,000 Months 

House Rent Allowance As Computed Value  As Computed Value  

Conveyance 2,500 Months 

Overtime 200 Hrs 

Employees PF Deduction@12% As Computed Value  As Computed Value 

Employers EPS Contribution@8.33% As Computed Value As Computed Value 

Employers EPF Contribution@3.67% As Computed Value As Computed Value 

Employees ESI Deduction@1.75% As Computed Value As Computed Value 

Employers ESI Contribution@4.75% As Computed Value As Computed Value 

Professional Tax  As Computed Value As Computed Value 

Income Tax As Per Income Tax Slab  

Table 3.3.20 

Note:  

 You can also copy salary details from one employee to another or from one employee group to an 
employee. In the pay head field, the Start Type list displays three options namely, Copy from Employee, 
Copy from Employee Group, and Start Afresh. 

 Copy from employee option will appear if the option “Allow Copy From Employee” in F12 Salary Details 
Configuration is set to Yes from salary details alteration screen. 

3.3.10 Providing Income Tax details 

As per Income Tax Act of 1961, all persons who are considered as an assesse and when their income 
exceeds the maximum exemption in the prescribed limit the income tax will be levied at the prescribed rates 
according to finance act. 

The Income Tax Details menu provides various master setup/configurations required for the successful income 
tax computation. 

To view the income tax details menu, 

1. Go to Gateway of Tally > Payroll Info. >Income Tax Details 

The Income Tax Details Menu appears as shown in the figure 3.3.11: 
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Figure 3.3.11 Income Tax Details Menu 

3.3.10.1 Pay Head Configuration 

The Pay Head Configuration screen allows the user to configure the pay heads with the income tax 
components as specified by the income tax department.  

The Pay Head Configurations screen appears as shown in the figure 3.3.12: 

Fig
ure 3.3.12 Pay Head Configuration Screen 

1. Press enter on Basic Pay to configure/re-configure the same for income tax 

2. In the Income Tax Configuration screen, 

 The name of the pay head will appear by default 

 The master type field displays whether it is a pay head or a ledger for easy identification of user 

 Select the proper income tax component for correct tax computation from the list of income tax 
components 

 Select the appropriate tax calculation basis from On Projection  

 Set the option deduct TDS across Period to No, to deduct the entire TDS in the same month. Set it 
to Yes to spread the TDS deduction across the remaining period. 
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Note:  

 On Projected Value: Will take the pay head/ledger value from salary details projected for 12 months 
even though there are no payroll vouchers passed. 

 On Actual Value: Will take the pay head value only based on payroll vouchers. If the payroll vouchers 
are passed then only the values will be taken in consideration. 

The Income Tax Configurations screen appears as shown in the figure 3.3.13: 

 

Figure 3.3.13 Income Tax Configuration 

Similarly, configure all other pay heads to the respective income tax components referring the below table. 

Pay Head Configuration 

Name of Pay Head Income Tax Component 

Conveyance Transport Allowance 

Employees PF Deduction @12% Employee Provident Fund (EPF) 

House Rent Allowance House Rent Allowance 

Overtime Other Earnings/Allowances (Fully Taxable) 

Professional Tax Professional Tax (Tax on Employment) 

 Tax Calculation Basis select as On Projected Value by default 
 Deduct TDS across Period as Yes 

Table 3.3.21 

3.3.10.1.1 Declarations 

As per the Income Tax Act, while computing the taxable income, the following are deducted from the gross 
salary for the employees. 

Exemptions: As per Section 10, there are certain allowances which are exempted from income tax such as 
HRA, LTA, transport allowance, children education allowance and children hostel expenditure allowance. 

Deductions Under Chapter VI-A: As per Chapter VI-A of Income Tax, the following deductions are allowed 
while computing the taxable income: 
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Investments (U/s 80C, 80CCF, 80CCG, etc.): Under Section 80C, 80CCF, 80CCG, etc. certain investments 
are allowed as deduction (based on a ceiling) for the computation of taxable income. 

Others (U/s 80D, 80DD, 80E, etc.): Under Section 80D, 80DD, 80E etc., certain other expenses are also 
deducted before arriving at taxable amount such as Mediclaim, interest paid on higher education loan, etc. 

Define Income Tax Declarations 

The employee can provide the exemption and deduction details to the employer and these details can be 
entered in the system as employee declaration by following the process given below: 

1. Go to Gateway of Tally > Payroll Info. > Income Tax Details > Declarations> select House Rent 
Allowance or press ALT+R: House Rent Allowance and press Enter>select group > Sales 
Department 

 In House Rent Declaration screen, 

 Specify the date from which the rent is paid in the effective from field 

 In Rent Declared amount field, specify the amount which is declared by the employee 

 In Rent Proof Amount field, specify the amount for which the rent proof has been provided by the 
employee 

 In Place of Residence, select Metro or Non-Metro based on the city 

 Enter the Name of Landlord and PAN of Landlord 

 Note: Name and PAN of the landlord are mandatory if the rent declared for the year is more than 1 lakh. 

The completed House Rent Declaration screen appears as shown in the figure 3.3.14: 

 

Figure 3.3.14 House Rent Declaration Screen 

Leave Travel Assistance 

Leave Travel Assistance is also exempted U/s 10 of Income Tax from the gross salary for the computation of 
income tax. Travel Concession provided in connection with proceeding on leave to any place in India. 

Note: To declare Leave Travel Assistance, pay head must be created as earnings to employee, in this case it 
is not required to declare. 

Declaring Transport Allowance 

Conveyance Allowance is renamed as Transport Allowance. It is also exempted U/s 10 of income tax from 
the gross salary for the computation of income tax. Transport allowance is provided for travelling expenses 
incurred between residence and place of duty. 
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1. In the Income Tax Declaration screen, press ALT + A for Transport Allowance OR press Enter>Select 
employee as Rajesh Jain 

2. In the Transport Allowance screen, 

 Specify the date from which the transport allowance is applicable in the Effective From field 

 Select the Employee Status as Others and save the screen 

Declaring Children Education Allowance 

Children Education Allowance is also exempted U/s 10 of Income Tax. An assesse can avail children 
education allowance benefit up to a maximum of two children. 

Note: To declare Children Education Allowance, pay head must be created as earnings to employee, in this 
case it is not required to declare. 

Declaring Children Hostel Expenditure Allowance 

Children Hostel Expenditure Allowance is also exempted U/s 10 of Income Tax. An assesse can avail 
children hostel expenditure allowance benefit up to a maximum of two Children. 

Note: To declare Children Education Allowance, pay head must be created as earnings to employee, in this 
case it is not required to declare. 

Income Declared by Employee - Single Employee Multi Component 

Under this head, you can define employee(s) declarations & proofs/eligible amount for the other incomes like 
house property, other sources and interest on housing loan if self-occupied. 

Deductions Under Chapter VI-A 

Investments (U/s 80C, 80CCF, 80CCG, etc.) 

Similar like declaring other incomes explained in the previous sections, declaring the Investments  

U/s 80C, 80CCF, 80CCG, etc. can be declared using either ALT+S for single employee multi component or 
ALT+M for multi employee’s single component. 

Activity: Declare the investments U/s 80C, 80CCF, 80CCG, etc., for the employee Rajesh Jain as shown in the 
tables 3.3.23 

Insurance Premium 80C 

Employee Effective From Annual Amount (Both Declared & Proof/Eligible) 

Rajesh Jain 01-04-2019 ₹ 20,000 

Table 3.3.22 

Others (U/s 80D, 80DD, 80E, etc.) 

Declaring the Investments U/s 80D, 80DD, 80E etc. can be declared using either ALT+T for Single 
Employee Multi Component or ALT+O for Multi Employees Single Component. 
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Note: Declared and Proof/Eligible value can be the same in the above given example. In this case it is not 
required to declare. 

3.3.10.1.2 Override Exemption Value 

The Override Exemption Value allows the user to override either the Income Amount or Exemption 
Amount. 

When income amount is overridden for any allowance, the voucher value will not be considered for income tax 
computation and the value specified in the override screen will be considered for the income tax.  

3.3.10.1.3 Override Tax Value 

The override tax value allows the user to override the tax amount which will be deducted as income tax in each 
month. It also provides the facility to specify the required period to override the income tax amount. 

3.3.10.1.4 Tax Configuration 

The tax configuration screen allows the user to make all the necessary income tax related configuration 
changes from one single screen. 

The Tax Configuration screen allows the users to configure the following: 

 Salary as per provisions contained in Sec 17(1) 

 Details of Perquisites Sec 17(2) (As Per Form 12BA) 

 Details of Profits shared in lieu of salary Sec 17(3) (As Per Form 12BA)  

 Details of Allowances exempted U/s 10 

 Deductions U/s 16 

 Other Income Declared by Employees 

 Deductions Under Chapter VI-A 

 Details of Reliefs granted 

 Tax Deduction details 

To view the tax configuration screen, 

Go to Gateway of Tally > Payroll Info. > Income Tax Details > Tax Configurations. Press Enter and provide 
the declarations, exemptions etc. 

Salary as per provisions contained in Sec 17(1) 

The pay heads and ledgers can be configured to select the appropriate income tax component, tax calculation 
basis and deduct TDS across Period as explained earlier during pay head creation. It includes all earnings pay 
head components (either based on actuals or projected) 

Value of Perquisites U/s 17(2) (as per Form 12BA) 

Perquisites are Non-monetary benefits given to employee, if any recovered from employee which are taxable 
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1. In Tax Configuration screen select Value of Perquisites u/s 17(2), Income Tax Allowance Setup 
screen appears, select Perquisites Details (Form 12BA) - Single Employee 

2.  Select Rajesh Jain from the List of Employees/Group 

3. In the employee Perquisites screen, specify the details as shown considering the below example on club 
expenses and free meals for employee Rajesh Jain 

Perquisites for Employee – Rajesh Jain 

Nature of 
Perquisites 

Effective 
From 

Value of Perquisites 

Computed Value 

Amount of 
Perquisite 

Chargeable to Tax 

Amount on Which 
Tax Paid  

by Employer 

Club Expenses 01-04-2019 ₹ 10,000 ₹ 10,000 ₹ 10,000 

Free Meals 01-04-2019 ₹ 2,000 ₹ 2,000 ₹ 2,000 

Table 3.3.23 

The completed employee Perquisites screen appears as shown in the figure 3.3.15: 

 

Figure 3.3.15 Perquisites 

Profits in lieu of Salary u/s 17(3) (as per Form 12BA):  Includes any compensation paid to the employees in 
connection with termination, modification of terms of employment, amount paid prior to employment which is 
taxable. 

Allowance to the extent exempted U/s 10  

The user can enter the declaration details for the selected allowance similar to income tax declaration which is 
exempted from income tax. The below mentioned allowances are commonly used by assesse for claiming 
exemption U/s 10 

 Allowance for Transport Employee 

 Children education allowance 

 Children Hostel Expenditure Allowance 

 Conveyance Allowance 

 House Rent Allowance 

 Leave Travel Allowance 
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 Medical Reimbursement 

 Transport Allowance 

Deduction U/s 16 

Entertainment Allowance and Professional Tax falls U/s 16 which is exempted from income tax. 

Entertainment Allowance - Entertainment allowance specially granted to an employee who is in receipt of 
salary from government. 

Professional Tax - Tax on employment calculate as per slab state wise paid to income tax department. 

Other Income Declared by Employees 

To enter the details of Other Income Declared by Employees, 

1. In the tax configuration screen, select Other Income (House Property/Other Source)/ Interest on 
Housing Loan) 

2. Select the required employee from the List of Employees 

3. The declarations made earlier will be listed here for that employee 

Deductions under Chapter VI-A- Investments 

To add Investment declarations for all employees, select Multi Employee Single Component and follow the 
process explained in Investments - Multi Employee Single Component under income tax declarations. 

To add Investment declarations for each employee one by one, select Single Employee Multi Component and 
follow the process explained in Investments - Single Employee Multi Component under income tax 
declarations. 

Relief (U/s 89, 90 & 91) 

The special reliefs granted to some employees due to the dual taxation system are also allowed as Relief U/s 
89,90 and 91 and is reduced from the Taxable Income based on the type of agreement with the other country. 

2. Tax Deducted by Previous Employer - The user can select the required employee and enter the tax details 
of the previous deductor (previous employer) in this screen. 

3. Tax Deducted Other Than Salary - The user can select the required employee and enter the tax deducted 
other than salary as applicable. 

4. Self-Assessment Tax Declared by Employee - The user can select the required employee and enter the 
tax details for self-assessment tax declared as applicable. 

3.3.10.1.5 Previous Employer Details 

For successful computation of income tax and Form16 generation, the previous employer income and tax 
payment details are necessary for the employees who joined the organization in the middle of the year. 
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To understand this better, let us consider that Rajesh Jain worked for company called Great Enterprises 
before he joined Future Technologies Pvt. Ltd. 

The previous salary details as provided by Rajesh Jain can be entered in Tally. To specify the previous 
employer’s income/exemption details, 

1. Go to Gateway of Tally > Payroll Info. > Income Tax Details > Previous Employer Details> Income/ 
Exemption Details 

2. Select Rajesh Jain from the List of Employees and press Enter 

3. Specify the particulars of the salary as shown in the figure 3.3.16: 

 

Figure 3.3.16 Previous Employer Income Details 

To specify the previous employer’s tax deducted/paid details, 

1. Go to Gateway of Tally > Payroll Info. > Income Tax Details > Previous Employer Details > Tax 
Deducted/ Paid Details 

2. Select Rajesh Jain from the List of Employees and press Enter 

3. Specify the Previous Employer and Tax payment details as shown in the figure 3.3.17: 

 

Figure 3.3.17 Tax Deducted by Previous Employee 

3.3.11 Salary Processing 

Salary process comprise of the following Vouchers: 

 Recording of attendance voucher 

 Processing the salary payable 

 Processing PF Payable  

 Processing ESI Payable  

 Process PF Admin Charges 
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 Payment of salary 

Activity:  

 Create the Pay heads Salary Payable, PF Payable, ESI Payable under Current Liabilities as shown in 
the figure 3.3.18 

 

Figure 3.3.18 Salary Payable Payhead 

Step 1: Recording of Attendance Voucher 

To process the salary, firstly we require to calculate the attendance of the employees. Attendance voucher 
allows you to enter attendance, overtime, leave or production details.  

1. Go to Gateway of Tally > Payroll Vouchers > Press Ctrl+F5: Attendance 

2. Click F2: Date or press F2 and change the date to 30-04-2019 

3. Record the attendance voucher for the employees with overtime as shown in the figure 3.3.19: 

 

Figure 3.3.19 Attendance Voucher Screen 

4. Accept the screen 

Step 2: Process Salary 

The salary can be directly paid from the payroll vouchers or the payroll vouchers can be used to create the 
liability and the salary can be paid using the payment voucher. Before we make the payment of the salary using 
a payment voucher, we must calculate the salary. 

To process the salary of the employee, 

1. Go to Gateway of Tally > Payroll Vouchers > Ctrl+F4: Payroll >Date: 30-4-2019 
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2. Press Alt+A for Payroll Autofill 

3. Select Process for Salary, Declared Value 

4. Enter the From and To dates 01-4-2019 to 30-4-2019 

5. Select Primary Cost Category as the Employee Category 

6. Select Employees/Group as All Items (we can also process the salary employee wise or department 
wise if required) 

7. Select Sort by as Employee Name 

8. Select Payroll/Bank/Cash Ledger as Salary Payable  

The Payroll Autofill screen appears as shown in the figure 3.3.20: 

 

Figure 3.3.20 Auto fill screen for Salary Payable 

The Payroll Voucher Creation for Salary appears as shown in the figure 3.3.21: 

 

Figure 3.3.21 Payroll Voucher for Salary payable 

9. Accept the entry. 



 ADVANCED ERP CONCEPTS 

372  ADVANCED INFORMATION TECHNOLOGY 

Observations: In Figure 3.3.20, we can observe that for employee Ajay Dutt Income Tax is not calculated as 
Income Tax is not applicable for his income, whereas for the employee Rajesh Jain Employee ESI Deduction is 
not applicable as the salary is more than ESI limit(₹ 21,000). But Income Tax is applicable. 

Step 3: Process the Statutory Pay Heads 

Provident Fund 

Let us process Employer Contribution towards provident fund in Tally. The following illustration shows how PF 
is processed for the employee 

To process the Provident Fund of the employees, 

Go to Gateway of Tally > Payroll Vouchers> Press CTRL+F4 for Payroll Voucher> Date: 30-4-2019 

1. Press ALT+A for Payroll Auto Fill 

2. Select PF Contribution in Process for field 

3. Enter the From and To date as 01-4-2019 to 30-4-2019 

4. Select Primary Cost Category as the Employee Category 

5. Select Employee/Group as All Items 

6. Select sort by as Employee name 

7. Select PF Payable from the List of Ledger Account 

The Payroll Voucher Creation for PF Payable appears as shown in the figure 3.3.22: 

 

Figure 3.3.22 PF Contribution Voucher Creation 

Employee State Insurance 

Let us process Employer Contribution towards employee state insurance in Tally.  

The following illustration shows how ESI is processed, To process the Employee State Insurance,  

Go to Gateway of Tally > Payroll Vouchers> Press CTRL+F4 for Payroll Voucher>Date: 30-4-2019 

1. Press ALT+A for Payroll Auto Fill 

2. Select ESI Contribution in Process for field 

3. Enter the From and To date as 01-4-2019 to 30-4-2019 
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4. Select Primary Cost Category as Employee Category 

5. Select Employee/Group as Ajay Dutt 

6. Select sort by as Employee Name 

7. Select ESI Payable from the List of Ledger Accounts 

The Payroll Voucher Creation screen for ESI payable appears as shown in the figure 3.3.23: 

  

Figure 3.3.23 Payroll Voucher -ESI Payable 

8. Accept the screen 

Note: It is not required to process ESI for Rajesh Jain as the salary is more than ESI limit (₹ 21,000). 

PF Admin Charges 

Activity: Create the Ledger PF Admin Charges under Indirect Expenses, do not enable Use For Payroll? 
option in the ledger. 

To process the Employer PF Admin Charges, 

1. Go to Gateway of Tally > Accounting Vouchers >Press F7: Journal>Date: 30-4-2019 

2. Press CTRL+O for Other Charges Auto Fill   

3. In the Other Charges Auto Fill screen, enter the From and To date as 01-4-2019 to 30-4-2019 

4. Select Primary Cost Category in the Employee Category field 

5. Select Employee group All Items for the Employee/Group 

6. Select PF Admin Charges in the Expense Ledger field 

7. In Admin Charges (A/c No.2), select PF Admin Charges@0.50% 

8. In EDLI Contribution (A/c No.21), select EDLI Contribution@0.50% 

9. In EDLI Admin Charges (A/c No.22), select Not Applicable  

The Other Charges Auto Fill screen appears as shown in the figure 3.3.24: 
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Figure 3.3.24 Other Charges Auto Fill 

10. The Admin Charges will be calculated for all the employees automatically. 

The completed Journal Voucher appears as shown in the figure 3.3.25: 

 

Figure 3.3.25 Journal Voucher-Other Charges 

11. Accept the screen 

Step 4: Salary Payment 

To make the Salary Payment to employees, 

1. Go to Gateway of Tally > Accounting Vouchers > F5: Payment>Date :30-4-2019>press Alt+A for 
Payment Autofill 

2. Process for Salary Payment 

3. Enter the From and To date 01-4-2019 to 30-4-2019 

4. Enter the Voucher Date as 30-4-2019 

5. Select Primary Cost Category as the Employee Category 

6. Select All Items from the List of Employees/Group  

7. Select Payroll Ledger as Salary Payable 
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8. Select Kotak Bank ledger from the List of Ledger Accounts 

9. Set the option “Use Mode of Payment/Transaction Type” to No 

10. Accept the Bank Allocations screen 

The Completed Accounting Voucher Creation Screen for Salary Payment appears as shown in the figure 
3.3.26: 

 

Figure 3.3.26 Salary Payment 

11. Accept the entry  

Step 5: Provident Fund Payment to PF department 

To record the payment of PF, 

1. Go to Gateway of Tally > Accounting Vouchers > F5: Payment>Date: 30-4-2019 

2. Press ALT+A for Payroll Auto Fill 

3. Select PF Challan in Process for field 

4. Enter the From and To dates as 01-4-2019 to 30-4-2019 

5. Enter the Voucher Date as 30-4-2019 

6. Select Primary Cost Category as the Employee Category 

7. Select All Items from the List of Employees/Group in the Employee/Group field 

8. Select PF Payable in the Payroll Ledger field from the List of Ledger Accounts 

9. Select Kotak Bank as Bank/Cash Ledger from the List of Ledger Accounts 

10. Set Provide Details to No  

11. Enter the Narration  

The completed payment voucher for Provident Fund Payment appears as shown in the figure 3.3.27 
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Figure 3.3.27 Payment for PF 

12. Accept the screen 

Note: While making PF payment to department, it includes employees’ deduction, employer’s contribution and 
employers’ other charges. 

Generating PF Challan 

PF Challans can be generated from Tally which is used for department deposits. To Print PF Challan, 

1. Go to Gateway of Tally> Display> Day Book > Open PF Payment Voucher >Press Alt+P > Enable the 
option Print challan > Accept the Screen 

Step 6: ESI Payment  

Employee State Insurance Payment 

Activity: Record a payment voucher for the ESI contribution by selecting Process for as ESI Challan for Ajay 
Dutt selecting using auto fill option on 30-4-2019 and provide the required payment details. 

Note: ESI challans can be generated from Tally, Go to > ESI Payment voucher >press Alt+P > enable the 
option Print challan. You will be able to generate ESI challans which can be used for department deposits. 

Step 7: Professional Tax Payment 

Activity: Record a payment voucher for the professional tax by selecting Process for as Professional Tax 
Payment for all employees using auto fill option on 30-4-2019 and provide the required payment details. 

Step 8: Payment of Income Tax to Department. 

Income Tax value which is captured while processing salary must be paid to income tax department. To make 
the income tax Payment, 
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1. Go to Gateway of Tally > Accounting Vouchers > F5: Payment> Date: 30-4-2019 

2. Press ALT+A for Payroll Autofill 

3. Process for Income Tax Challan 

4. Enter the From and To dates as 1-4-2019 to 30-4-2019 

5. Enter the Voucher Date as 30-4-2019 

6. Select Primary Cost Category as the Employee Category 

7. Select Rajesh Jain from the List of Employees/Group 

8. Select Payroll ledger as Income Tax. 

9. Select Kotak Bank ledger from the List of Ledger Accounts 

10. Set Provide Details to Yes and provide the necessary details  

The Income Tax Payment voucher appears as shown in the figure 3.3.28: 

 

Figure 3.3.28 Income Tax Payment 

Generating Income Tax Challan 

Income Tax Challans can be generated from Tally, which is used for Income Tax department deposits. To 
Print Income Tax Challan, 

1. Go to Gateway of Tally> Display> Day Book > Open Income Tax Payment Voucher >Press Alt+P > 
Enable the option Print Challan > Accept the Screen 

3.3.12 Payroll Reports 

To view the Payroll Reports, follow the procedure shown below: 

1. Go to Gateway of Tally > Display > Payroll Reports 

Payroll Reports menu consists of reports such as Statements of Payroll, Attendance Sheet, Attendance 
Register, Expat Reports and Statutory Reports. 

Statements of Payroll 

Statements of Payroll consists of reports like Pay Slip, Pay Sheet, Payroll Statement, Payment Advice, Payroll 
Register, Employee Profile, Employee Head Count, Employee Pay Head Breakup and Pay Head Employee 
Breakup. 
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Pay Slip 

Pay Slip is a document issued to an employee that lists each component of earnings and deductions, and the 
net amount paid to an employee for a given pay period. It provides details on how the net amount has been 
arrived at. 

To view Pay Slip, go to Gateway of Tally > Display > Payroll Reports > Statements of Payroll >Pay Slip> 
Single Pay Slip> Rajesh Jain or required employee. 

The Pay Slip Screen appears as shown in the figure 3.3.29: 

 

Figure 3.3.29 Pay Slip 

Tally also provides the option to print or email the pay slips for all the employees.  

Pay Sheet 

Pay Sheet contains all earnings and deduction details for a given month or period with several options to re-
configure the appearance of rows and columns.  

To view the pay sheet, 

1. Go to Gateway of Tally > Display > Payroll Reports > Statements of Payroll > Pay Sheet 

2. In the Employee Filters screen, In the Name of Category field select All Items     ,                                                                                                                       

3. In the Name of Employee Group select All Items from the List of Employees/Groups to view Pay 
Sheet. 

Payroll Statement 

Payroll Statement report allows you to generate the report for a specific Pay Head/Ledger. 
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1. Go to Gateway of Tally > Display > Payroll Reports > Statements of Payroll > Payroll Statement 

2. In the Select Item screen, select the Basic Pay from the List of Pay Heads 

3. Press F12: Configure and enable the option “Show Employee By Categories & Groups” and save the 
configuration screen 

Payroll Advice 

The Payment Advice report is used to generate Payment Advice/Bank Transfer letters to transfer salary 
amount from a specific bank account to the respective bank accounts of the employees based on the salary 
payment voucher. 

For more details refer to salary payment section. 

1. Go to Gateway of Tally > Display > Payroll Reports > Statements of Payroll > Payment Advice, 
provide the details to print the report. 

The Payment Advice appears as shown in the figure 3.3.30: 

 

Figure 3.3.30 Payment Advice 

Payroll Register 

The Payroll Register is a month-wise transaction summary report displaying payroll vouchers, similar to the 
statistics report in the accounting module. Though the register primarily displays payroll vouchers, you can 
however add new columns for any other voucher type. The user can drill down to the voucher level from this 
report. 
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Attendance Reports 

The following Attendance/Production related reports can be generated in Tally: 

 Attendance Sheet 

 Attendance Register 

3.3.13 Payroll Statutory Reports 

Provident Fund Reports 

To view the Provident Fund reports, 

1. Go to Gateway of Tally > Display > Payroll Reports > Statutory Reports > Provident Fund 

The provident fund reports are sub divided into the monthly and annual based on the period as listed below: 

Monthly: 

 Form 5 

 Form 10 

 Form 12A 

 Monthly Statement 

 E-Challan Return (ECR) 

Annual: 

 Form 3A 

 Form 6A 

 E-Return 

The Employee Provident Fund Scheme- Monthly Statement appears as shown in figure 3.3.31 

 

Figure 3.3.31 PF- Monthly Statement 
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Activity: View all the other reports falling under Provident Fund  

Employee State Insurance Reports 

The Employee State Insurance reports is sub divided into the Monthly and Annual on the period as listed 
below: 

Monthly 

 ESI Form 3 

 Monthly Statement 

 E-Return 

Annual 

 Form 5 

 Form 6 

Activity: View all the reports falling under Employee State Insurance  

Professional Tax Reports 

To view the Professional Tax reports, 

Go to Gateway of Tally > Display > Payroll Reports > Statutory Reports > Professional Tax 

The Professional Tax Report is further sub-divided into two types of reports: 

 Computation Report 

 Statement 

Activity: View the reports falling under Professional Tax  

Income Tax Reports  

To view the Income Tax Reports, 

Go to Gateway of Tally > Display > Payroll Reports > Statutory Reports > Income Tax 

The following Income Tax reports are provided in Tally: 

 Computation 

 Salary Projection 

 Challan Reconciliation 

 Returns 

 E-Return 

 Exception Reports 
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The Computation Report displays the employee-wise income tax computation details in the Form 16 format. 
Along with the total tax payable, it also displays the balance tax payable, tax already paid and tax amount to be 
deducted in the subsequent month. To view the Income Tax Computation report, 

1. Go to Gateway of Tally > Display > Payroll Reports > Statutory Reports > Income Tax > 
Computation 

2. Select Rajesh Jain and press Enter 

The Income Tax Computation screen appears as shown in the figure 3.3.32: 

 

Figure 3.3.32 Income Tax Computation 

The above report displays the Employee details on the top of the screen, on the right-hand top corner it gives 
the overall Tax deduction snapshot. In the remaining report each Income Tax Component value is displayed.  

To know the income tax slab and the calculation method in Tally, From Income Tax computation screen, 
select Serial Number 10>Tax on Total Income > Press Enter. 

The Tax on Total Income appears as shown in the figure 3.3.33: 
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Figure 3.3.33 Tax on Total Income 

Tax on Total income for employee Rajesh Jain displays as shown in the figure 3.3.34:  

 

Figure 3.3.34 Tax on Total Income with PAN 

The above calculation i.e. based on income tax slab is done based on PAN. 

Salary Projection 

The Salary Projection report provides the details of the Earnings and Deduction pay head values which are 
considered for income tax for selected employees. It provides the projection for twelve months and displays the 
actuals if payroll is already processed for any given month. To display the salary projection report, 

1. Go to Gateway of Tally > Display > Payroll Reports > Statutory Reports > Income Tax > Salary 
Projection 

2. Select Rajesh and press Enter to view Salary Projection 

Challan Reconciliation 

All the Income Tax Payment Challan details can be reconciled from one single menu known as challan 
reconciliation. To reconcile challan details, 
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1. Go to Gateway of Tally > Display > Payroll Reports > Statutory Reports > Income Tax >Challan 
Reconciliation 

2. Press F5 for Challan Reconcile and set/alter the required challan details 

Returns 

The following Income Tax returns can be generated from Tally: 

Monthly 

 Form 24Q 

 Annexure I to 24Q 

 Annexure II to 24Q 

Annual 

 Form 16 

 Form 12BA 

 ITR-1 

Form 16 

Form 16 is the certificate issued for tax deducted at source from income chargeable under the head salaries. 
To view the Form 16, 

1. Go to Gateway of Tally > Display > Payroll Reports > Statutory Reports > Income Tax >Returns > 
Form 16 

2. Select Rajesh Jain from the List of Employees and press Enter 

E- Return 

The following income tax E-returns can be generated from Tally: 

 E-24Q 

 Print Form 27A 

Conclusion 

The Payroll and Income Tax feature in Tally enables recording payroll related transactions of employees and 
facilitates instant generation of Payroll and Statutory MIS Reports with transaction details. You will be able to 
determine the salary payable, salary paid to employee with deductions and the management can easily track 
the payments made to employees and statutory payments made to respective departments which aids in 
decision making and growth of a company. 
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Self-Evaluation Section 
1. To bring the interest receivable amount in the books of accounts which of the following entry is recorded? 

a. Credit Note 

b. Sales Voucher 

c. Purchase Voucher 

d. Debit Note 

2. Adjustment of Forex Gain/Loss is recommended to be done using________. 

a. With Voucher Class in Journal  

b. Without Voucher Class in Journal Voucher  

c. Credit Note Voucher  

d. Debit Note Voucher  

3. In Tally, we can check the details of home currency and foreign currency from Balance Sheet report. 

a. True 

b. False 

4. In Tally, from _______________register we can check the details of finished goods and raw materials. 

a. Material Movement Register 

b. Job work out order 

c. Material In Register 

d. Material Out Register 

5. Which of the following two options gets activated automatically after enabling Job Order Processing in 
Tally? 

a. Godowns & Cost Tracking 

b. Godowns & Material In / Out 

c. Sales Order & Purchase Order 

d. Godown & Purchase Order 

6. In Tally.ERP 9, you can create new price list but cannot revise the existing price list. 

a. True 

b. False 

7. Multiple Price Levels can be maintained in Tally ________. 

a. True 
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b. False 

8. We can see user-wise report in Tally Audit. 

a. True 

b. False 

9. In Tally, the shortcut key to connect company for remote login is ________. 

a. F5 

b. Alt+F4 

c. F6 

d. F4 

10. ___________is the quarterly return for deduction of tax in respect of payments (other than salary) made 
to residents.  

a. Form 26Q 

b. Form 27Q 

c. Form 16 

d. Form 24Q 

11. In Tally, once after reconciling the TDS payment voucher the entry will reflect under Included 
Transaction. 

a. True 

b. False 

12. As per the Income Tax Act, 1961, every corporate and government entity responsible for collection of tax 
at source should furnish ______ returns. 

a. TDS 

b. TCS 

c. GST 

d. Customs 

13. What is gross earnings limit for ESI calculation? 

a. 10,000  

b. 21,000 

c. 15,000  

d. 20,000 
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14. Form 16 is used as________. 

a. PF challan 

b. TDS Challan 

c. TDS Certificate 

d. ESI Challan 

15.  What is the rate of percentage for PF Calculation? 

a. 12% 

b. 12.5% 

c. 15% 

d. 15.5% 

16. the Computation Report of Income Tax displays the employee-wise income tax computation details in 
the Form 16 format. 

a. True 

b. False 

17. ESI Rate for Employee’s contribution is_________. 

a. 4.83% 

b. 0.75% 

c. 2.50% 

d. 1.73% 

18. Sec 80D is related with________. 

a. Income Tax 

b. ESI 

c. Gratuity 

d. NPS 

Keys Answers 

Question 
No 

Fundamentals of Accounting Answer 

1 To bring the interest receivable amount in the books of accounts 
which of the following entry is recorded? 

Debit Note 

2 Adjustment of Forex Gain/Loss is recommended to be done 
using________. 

With Voucher Class in 
Journal 
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3 In Tally, we can check the details of home currency and foreign 
currency from Balance Sheet report. 

True 

4 In Tally, from _______________register we can check the details 
of finished goods and raw materials 

Material Movement 
Register 

5 Which of the following two options get activated automatically 
after enabling Job Order Processing in Tally? 

Godowns & Material In / 
Out 

6 In Tally.ERP 9, you can create new price list but cannot revise the 
existing price list. 

True 

7 Multiple Price Levels can be maintained in Tally ________. True 

8 We can see user-wise report in Tally Audit. True 

9 In Tally, the shortcut key to connect company for remote login is 
________. 

F4 

10 ___________is the quarterly return for deduction of tax in respect 
of payments (other than salary) made to residents. 

Form 26Q 

11 In Tally, once after reconciling the TDS payment voucher the entry 
will reflect under Included Transaction. 

True 

12 As per the Income Tax Act, 1961, every corporate and 
government entity responsible for collection of tax at source 
should furnish ______ returns. 

TCS 

13 What is gross earnings limit for ESI calculation? 21,000 

14 Form 16 is used as________. TDS Certificate 

15 What is the rate of percentage for PF Calculation? 12% 

16 In Tally.ERP 9, the Computation Report of Income Tax displays 
the employee-wise income tax computation details in the Form 16 
format. 

True 

17 ESI Rate for Employee’s contribution is_________. 0.75% 

18 Sec 80D is related with________. Income Tax 
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UNIT-3 : ADVANCE DATABASE CONCEPTS 

CHAPTER 1 : ADVANCE SQL QUERIES 

Exercise 1.1: Sub Queries 

Rohit is an Accountant in Apex Ltd. At the closing of the quarter, he has to check the Invoices for which the 

payments are made in Quarter-I of year 2008. 

Solution 

Student is requested to create a query to retrieve all records from Invoices table for which the Payment Date in 

Payments table lies in Quarter-I i.e. between 1/1/2008 and 4/30/2008. Since we do not require any details from the 

Payments table, we use the table in a sub-query. 

For Result please refer to Page No 4 of Study Module – II. 

Exercise 1.2: Unmatched Queries  

Ankur Mathur, Sales Head of Apex Ltd. wishes to reduce the production of few products. To analyse which products 

should not be produced further, he needs to find out the products which have not been ordered so far. 

Solution 

For the purpose of finding the unmatched products in Sales Item Description, students are requested to use 

Unmatched Query Wizard and find out products from Inventory table which do not have a matching Item Number in 

Sales Item Description table. 

For Result please refer to Page No 10 of Study Module – II. 

Exercise 1.3: Duplicate Queries  

Varun Gupta, a Chartered Accountant in Apex Ltd., is required to audit the invoices and the payments. While tracking 

the payments he noticed that multiple invoices have been created for a single sales order. To sort out the things, he 

wishes to check all the sales order having duplicate invoices. 

Solution 

For above requirement, student are requested to use Find Duplicates Query wizard for table Invoices based on the 

field Sales Order Number so that it displays all the duplicate invoices created for a single sales order. 

For Result please refer to Page No 15 of Study Module – II. 

Exercise 1.4: Grouping & Summarising Records using criteria  

The Country Head in Apex Ltd. wishes to compute the sales volume of its products. He also would like to see the 

number of orders placed for each product, so that they can focus on products with greater sales volume. 
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Solution 

Here students use a Total query that calculates the count of orders placed for each product and arrange them in 

descending order of the counts so as to find the products which are sold more. 

For Result please refer to Page No 18 of Study Module – II. 

Exercise 1.5: Grouping & Summarising Records using a Crosstab Query 

The company Apex Ltd. wishes to revise the credit limit of its customers. For this purpose, Ashish, the PRO needs a 

summary report that indicates the count of orders placed by each customer in every month of last financial year i.e. 

2011-2012. 

Solution 

To obtain the desired summary report, students are requested to create a Crosstab query on table Sales Order with 

month of Sales Date as row heading, Customer Number as column heading and count of Sales Order Number as 

values. 

For Result please refer to Page No 29 of Study Module – II. 

Exercise 1.6: PivotTable and PivotChart  

The Head of Sales Department in Apex Ltd. has demanded a Sales Summary report for review. The following are the 

desired requirements: the sales of the products can be viewed in terms of Year, Quarters and Months; the report 

should enable the user to view the products filtered by Category. 

Solution 

To create this Summary report, students are requested first to create a query that displays the Products and their 

Category, Sales amount of each product, also the date on which they were sold. Then to create summary sheet, 

create a PivotTable view of the query having 

a) Category field as a filter b) Product field on row c) Year, Quarter and Month on columns and Total Sales (which is 

computed as Quantity sold into Product cost) displayed as values 

For Result please refer to Page No 35 of Study Module – II. 

Exercise 1.7: Joining Tables in Queries  

The Operations Regional Head of Apex Ltd. is required to produce a report giving the details of the payments 

received. 

For this purpose, two reports are required to be prepared: 

• First report indicating the Invoices for which payments have been made, including the invoice and payments 

detail. 

• Second report displaying a list of all the sales order, their invoices and details of payments, including those 

invoices for which payments have not been received. 
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Solution 

To get the desired result, student is requested to create two queries as a) First query to fulfil the requirement using 

inner join between tables Invoice and Payments and b) Second query to achieve the second requirement which 

includes Sales Order, Invoice and Payments tables with a left outer join between Invoice and Payments tables. 

For Result please refer to Page No 53 of Study Module – II. 

Exercise 1.8: Calculated Fields  

Ramit, an executive in Apex Ltd. is required to produce a report displaying all the sales orders which contains the 

field Total Amount Paid as a sum of Tax, Freight and Other Charges. 

Solution 

Here students are requested to create a query on table Sales Order with a calculated column Total Amount Paid 

computed as a sum of Tax, Freight and Other Charges. 

For Result please refer to Page No 60 of Study Module – II. 

CHAPTER 2 : DESIGNING FORMS & REPORTS 

Exercise 2.1: Form - Adding Unbound Control  

The database Apex Inventory Shipment has a form frmOrders, based on table Sales Order which keeps track of all 

the orders placed. The Sales Manager wishes to add a current date on the form, so that it becomes easy for the user 

to keep track of dates. 

Solution 

Here students are required to add an unbounded control, a label to the form and sets its property to store the current 

date. 

For Result please refer to Page No 70 of Study Module – II. 

Exercise 2.2: Adding Graphics to Form  

The Database Developer wants to make a form frmOrders more presentable and thought of adding a picture to the 

background of this form. 

Solution 

Here students are required to set the picture as form background using the image control. Select the picture to be 

added, draw the image control and adjust its properties to make image as a background. 

For Result please refer to Page No 73 of Study Module – II. 

Exercise 2.3: Adding Unbound Control (Text Box)  

The Manager wishes to add another date in a form frm Orders, which may indicate when the order will reach 

customers. 
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This date can be computed as 15 days after the date of shipment. 

Solution 

Here students are required to add a textbox to the form. This textbox contains calculated value, which is computed as 

15 days + date of shipment. 

For Result please refer to Page No 77 of Study Module – II. 

Exercise 2.4: Adding Unbound Control (Combo box) 

The executives are making many mistakes while typing the reference of the customer to which orders are sold. The 

Sales Manager asked the Database Developer to find the solution to this problem. 

Solution 

The Database Developer thought that it will be a good way to add a combo box for the customers. Users will have an 

option to choose the value from the list or type a new value if required, thereby decreasing the typing mistakes. 

For Result please refer to Page No 79 of Study Module – II. 

Exercise 2.5: Adding Unbound Control (Calendar)  

Database Designer of Apex Ltd. has designed the frmOrders form to be used for Sales Orders table. The Supervisor 

of the Customer Service Group informs the designer that people taking orders often need to refer to a calendar to 

answer customer questions, such as when they will receive a shipment. A calendar is necessary so that customer 

service employees can take weekends & holidays into account when they make an estimate as to when orders will 

be shipped. 

Solution 

Here students are required to add a Calendar control to all the date fields to make the form convenient for the users. 

A calendar control can be added for Sales Date and Ship Date for users to pick up date graphically. 

For Result please refer to Page No 85 of Study Module – II. 

Exercise 2.6: Form Design  

The Sales Manager asks the Information Analyst to store the information of the customer which could be displayed in 

a friendly manner, such that the customer’s personal details and company details can be viewed separately. 

Solution 

Here students are advised to divide the information into separate tab in a form. One tab in the form should contain 

customer contact detail, while the other can contain customer’s company details, and third tab can contain 

customer’s terms with the company. 

For Result please refer to Page No 90 of Study Module – II. 
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Exercise 2.7: Displaying Summary Data in a Form 

The Sales Manager wishes to see the summarized data of sales. He requests the Database Developer to create a 

form in such a manner, that it should display the summarized data in terms of cost of Item Sold per year, per country. 

For example, he needs a report displaying summary of the items sold country wise and state wise in year 2008 

Quarter-2. 

Solution 

Here students are advised to create a query based on table Sales Order, Customers, Sales Item Description, and 

Inventory and fetches the required data from it. Once query is created, then a form using pivot table option is created 

over the query. 

For Result please refer to Page No 94 of Study Module – II. 

Exercise 2.8: Advanced Reports – Creating Customized Header & Footer  

The Database Developer has prepared a report rpt Customers to display all the details of the customers. The Zonal 

Sales Head requires the report to be customized; each page of the report must contain the Report Title at the top and 

date & time at bottom. 

Solution 

Here students are advised to add a Page Header & Footer to the report and customizes the Page Header to hold a 

label with Report Title, and Page Footer to contain the date & Time using Date Time control. 

For Result please refer to Page No 99 of Study Module – II. 

Exercise 2.9: Advanced Reports – Adding Calculated Values 

The Sales Head wishes the customer name should be displayed as a complete name, not as first name and last 

name. 

He requests the Database Developer to implement the change. 

Solution 

Here students are required to add calculated value that concatenates first name and last name in the report 

rptCustomers and replaces the First Name and Last Name textboxes. 

For Result please refer to Page No 103 of Study Module – II. 

Exercise 2.10: Advanced Reports – Sub Report 

The Regional Head notices that the database users face a big problem while tracing the orders placed by each 

customer. He asks the Database Developer to create a user-friendly object which can display both the customer’s 

details and orders placed by the customer. 
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Solution 

Here students are required to add a sub report to the report rptCustomers which include details of the orders placed 

by the customers. For this purpose, the table Sales Order is used and the fields Sale to Customer from Sales Order 

and Customer Number from Customers are mapped. 

For Result please refer to Page No 106 of Study Module – II. 

Exercise 2.11: Advanced Reports – Adding Chart 

The Sales Head wishes to create a summary report. The report should show the quarterly total sales for each 

category. 

The Sales Head requests the Information Analyst to show a diagrammatic representation of the report. 

Solution 

Here the best way to display the summary report is to create charts to represent the data. The charts can be included 

in a report, and based on a query sales data to show its diagrammatic representation. 

For Result please refer to Page No 109 of Study Module – II. 

CHAPTER 3 : BUILDING CRITERIA EXPRESSIONS 

Exercise 3.1: Using Functions 

Apex Ltd. is launching a new production unit in “California”, which will also focus on some new products. To promote 

these products a detailed list of all existing customers from “California” (state code CA) is required. 

Solution 

Here students are required to create a query that displaying Name, Contact Info and Address of the customers is 

required. To get only the customers from “California” the value CA in the criteria for the state field needs to be 

specified. Here, CA is a literal operand and is typed direct in query criteria. 

For Result please refer to Page No 125 of Study Module – II. 

Exercise 3.2: Using Compound Criteria 

At the end of a quarter, Country Head of Apex Ltd. wishes to review the following data: 

• A report displaying all sales orders placed in from January to March 2008. 

• All inventory details from the “Car”, “Snowmobile”, and “Boat” categories along with the details of the order 

placed for them. 

• A list of all the products that were sold with a quantity greater than 5 or the price greater than 1000. 

• A contact list for all Customers whose first name starts with A, B or C. 
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Solution 

For creating the query containing the report of Sales Order, the query will be created on the Sales Order table, using 

“Between” and “And” operator in query criteria. 

The inventory details query will contain the Inventory table and Sales Item Description. The query criteria will be 

based on the IN operator. 

For obtaining the list of products, query needs to be based on Inventory and Sales Item Description containing 

compound criteria. 

To retrieve the contact list of Customers, query will be based on the Customers table and the criteria for the first 

name will contain the LIKE operator. 

For Result please refer to Page No 135 of Study Module – II. 

CHAPTER 4 : MACROS AND SWITCHBOARDS 

Exercise 4.1: Creating Macro  

Kanika Mathur, a sales executive in Apex Ltd. is required to send a detailed report of all the orders that have been 

placed today to the Sales Head every evening in a form of an Excel sheet, also the same sheet also has to be 

uploaded in a shared folder for delivery to check. She thought to automate the process of transferring records so as 

to save the efforts required. 

Solution 

Here students are required to create a macro that transfers the table Orders into Excel and stores it in a shared folder 

using the Transfer Spread Sheet Action. Then, use Send Object Action to mail it to the Sales Head. 

For Result please refer to Page No 164 of Study Module – II. 

Exercise 4.2: Attaching Macro 

Based on the above problem scenario in the Orders form add a button that enables the user to export and mail the 

table. 

Solution 

Here students are required to add a button on the form and attach a macro to the click event of the button. 

For Result please refer to Page No 168 of Study Module – II. 

Exercise 4.3: Restricted Macro using Where Condition  

In the Database Apex Inventory Shipment, as an enhancement to the Orders form, the Manager wishes to see the 

details of the Customer who has placed the order. 
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Solution 

Here students are required to add a command button to the form. On the click event of the command, a macro will be 

created that displays the Customers form restricted to the Customer Number for the order. 

For Result please refer to Page No 173 of Study Module – II. 

Exercise 4.4: Validating Data using a Macro 

In the frmOrders form Rahul Sharma, the database developer in Apex Ltd. is asked to place a check on the Item 

Number field. It is to be ensured that Item Number should not be left blank. 

Solution 

Here students are required to add a macro that will be embedded on the Click event property of the Save Command 

Button. This macro will check if the Item Number is blank and will display a message accordingly. 

For Result please refer to Page No 182 of Study Module – II. 

Exercise 4.5: Automating Data Entry using a Macro  

In the frmOrders form, the Operational Manager wishes to see the total cost of the order, which would be computed 

as Quantity ordered * price of an Item. 

Solution 

Here students are required to add a text box as Total Order Cost to the form and a macro is created on the Exit event 

of price to compute the total cost of an order. This macro first checks the value of Quantity is not null and then 

computes Total Cost. 

For Result please refer to Page No 187 of Study Module – II. 

Exercise 4.6: Creating a Database Switchboard 

Employees of Apex Ltd. need to keep updating the company database frequently for various reasons. However, 

employees are confused over the interface that appears when the application is started. The application developer 

wishes to resolve this confusion by providing a clear and concise environment in which users can reduce the amount 

of time spent figuring out how to obtain the information they are looking for. 

Solution 

Here students are required to create a Switchboard form that contains buttons to open the Customers and Inventory 

tables and the frmOrders form needs to be created. Since switchboard is not capable of opening the tables directly 

through the Command button, so students must create macros to open the Customers and Inventory tables named 

as Macro Cust and Macro Invent respectively. 

For Result please refer to Page No 194 of Study Module – II. 
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Exercise 4.7: Modifying Database Switchboard  

The developer noticed that the switchboard created in earlier example is not giving a professional look. He wishes to 

add the company logo to the switchboard. In addition, he wants to add a new button to the switchboard which will 

help the user to create an excel copy of data and mail it to the manager. 

Solution 

Here students are required to add a company logo to the switchboard by modifying the switchboard in the Design 

view. To add a new button to the switchboard, use the Edit option in Switchboard Manager. Also create a command 

button to execute the macro Mail Current Orders which was created in earlier example. 

For Result please refer to Page No 203 of Study Module – II. 

UNIT-4 : ADVANCED ERP CONCEPTS 

CHAPTER1: SIMPLIFYING ADVANCED TRANSACTIONS IN TALLY 

Exercise 1.1  

Illustration 1: Configuration of interest in advance parameters and recording of sales transaction refer Page 218 

Exercise 1.2  

Illustration 2: Checking of Interest payable amount and bringing the same in the books of accounts refer Page 

222 

Exercise 1.3  

Illustration 3: Recording of payment voucher along with interest amount refer Page 224 

Exercise 1.4  

Illustration 4: Calculating interest based on compound interest formula. refer Page 226 

Exercise 1.5  

Illustration 1: Recording sales voucher with dollar currency and corresponding receipt transaction. refer Page 

232 

Exercise 1.6  

Illustration 2: Recording of journal voucher in order to write-off the forex gain/loss to the profit/loss account 

refer Page 234 

Exercise 1.7  

Illustration 3: Recording of sales transactions with different rate of exchange refer Page 236 
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Exercise 1.8 Multiple Currency  

Create currency 

Currency Name Shortcut Keys 

Pounds Sterling Alt+156=£  

Yen symbol Alt+0165=¥  

Euro symbol Alt+0128=€  

Dollar  $ 

Entry using foreign currency  

Q.A.  01/04/2017 sold 100 nos of digital watch to Prism times @$25/nos (invoice no  export/1). The rate of 

exchange on that date is Rs.64/$. Pass the entry.  

Q.B.  On 02/04/2017, prism time paid $2,500 (ch. No-754210). The bank charges of $50 were incurred and the 

rate of exchange on that date is Rs.66/$. Display the forex gain/loss from balance sheet and pass an 

adjustment entry for forex gain of prism time.  

Q.C.  On 01/04/2017 the following goods were purchase from 123 systems Invoice no123/045/17-18. The rate 

of exchange is Rs.85/£. Pass the necessary entry.  

Q.D.  On 02/04/2017 the company paid £110 to 123 systems against invoice no123/045/17 -18. The rate of 

exchange is Rs.82/£. The bank charges incurred were Rs.500 (corporation bank ch. No-781972).Display 

the forex gain/loss from balance sheet and pass an adjustment entry for forex gain/loss of 123 system.  

Exercise 1.9  

Illustration 1: Listing of Components using Bill of Materials in Finished goods. refer Page 240 

Exercise 1.10  

Illustration 2: Record purchase of raw materials and manufacturing the finished product. refer Page 242 

Exercise 1.11  

Illustration 3: Recording of manufacturing journal for converting raw materials in to finished goods refer Page 

243 

Exercise 1.12  

Illustration 4: Recording Stock Journal voucher to transfer materials from one location to  refer Page 245 

Exercise 1.13 Create BOM  

BOM example. 

A readymade manufacturer manufacturing a Shirt with Following Components : 
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Raw materials ( Components) Quantity 

Cloth 2 Meter 

Buttons 8 Nos 

Thread 1 Roll 

In tally there are three kinds of BOM available based on the usability  

Single BOM:- Follow Above Steps 

Multiple BOM:- By Using Above Single BOM, Create Shirt 40 Modern BOM with Unit of Manufacture 1 PC 

BOM with Item:- Cut piece of the cloth is used to make kerchief create the same. 

Exercise 1.14  

Emerald-Shine Makers has placed a job work out order for manufacturing electronic cookers to Madan 

Manufacturing Co. The raw materials for manufacturing electronic cookers are purchased by Emerald-Shine 

Makers. and are transferred to Madan Manufacturing Co. refer Page 250 

Exercise 1.15  

Illustration 2: Handling job work in order processing in Tally refer Page 262 

Exercise 1.16 ASSIGNMENT ON JOB WORK OUT ORDER PROCESSING 

Company placed an order to XYZ INDUSTRIES for manufacturing 20no.s of Laptops. To manufacture 20no.s of 

laptops following raw materials will be supplied by our company. Raw Materials – Each Item Opening Balance 

is 40pcs. (Order No: Job out / xyz / 001) 

S.NO NAME OF THE ITEM QUANTITY RATE 

1 Mother Board 20pcs 1500 

2 CPU 20pcs 3000 

3 RAM 6GB 20pcs 2000 

4 Monitor 20pcs 3000 

5 i8 processor 20pcs 4000 

B. Company transferred the raw materials to XYZ Industries against JOB WORK Order no : Job out / xyz / 001. 

(Challan no: Ch/XYZ/01) 

C. Our company received the following finished goods against the job work out order job out / xyz/ 001 from 

XYZ Industries. 

D. Our company received job work invoice from XYZ Industries (Challan Number : Ch/ XYZ / 001) Job work 

charge – 50,000 ) . Invoice no: Pur/XYZ/001 

E. Our company paid amount to XYZ Industries in cheque of SBI against the ref no: Pur / XYZ / 001. 
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Exercise 1.17  

Illustration 1: Defining price levels for different buyers refer Page 267 

Exercise 1.18  

Illustration 2: Defining price list for different stock items of the company in Tally refer Page 268 

Exercise 1.19  

Illustration 3: Recording Sale Voucher refer Page 271 

Exercise 1.20  

Illustration 4: Revising of price list in Tally refer Page 272 

Exercise 1.21  

Illustration 5: Recording sales voucher with revised price list in Tally refer Page 274 

Exercise 1.22 PRICE LIST 

Parker Company purchased 500 pieces of parker pen for Rs. 15 each. The company sold 427 pieces of pen on 

following conditions:- 

• Less than 10 pieces for Rs. 18. 

• More than 10 pieces and less than 50 pieces for Rs. 17 on 1% discount.  

• More than 50 pieces and less than 100 pieces for Rs. 16 on 2% discount.  

Exercise 1.23  

Illustration 1: Recording of transaction with different user levels refer Page 278 

Exercise 1.24 Security Control 

Create Security Levels as given below. 

Sr. 

No. 

Name of 

Security Level 

 

Back 

Dated 

Access 

Type of Access  

Masters Accounts Inventory Transactions 

1 Manager  Create, Alter, Display Create, Alter, Display Create, Alter, Display, 

Print 

2 Accountant 7 Create Create Create, Display, Print 

3 Operator 1 Display Only Display Only Create Only 

4 Auditor 0 Display Only Display Only Display Only 

5 Remote 

Manager 

30 Create, Alter, Display Create, Alter, Display Create, Alter, Display, 

Print 

6 Remote Auditor 0 Display Only Display Only Display Only 
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Create User IDs and allocate security levels as under 

Sr. No. Name of User User ID Security Level 

1 Pankaj Deshpande Pankaj Manager 

2 Swapnil Ghate Swapnil Manager 

3 Amit Shirwas Amit Accountant 

4 Mayura Rahane Mayura Operator 

5 Nivedita Dighe Nivedita Auditor 

6 Sumeet Thawri Sumeet Auditor 

7 You <Use your actual email ID> Remote Manager 

9 Your Auditor <Use one more actual email ID> Remote Auditor 

Exercise 1.25 Security control  

1. Create a company named as Security control and Enable Security Control option for a Company 

(Administrator Login). 
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2. Create Security Levels for Manager, Sales exe. and Auditor. Go to Gateway of Tally > Alt+F3 > Security 

Control > Types of security. 

 

3. Set the Manager profile as shown below: 
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4.  Set the Sales ex. profile as shown below:  

 

5. In Auditor Profile do as following:  

 a. Set “use the basic facilities of”  > Auditor  

 b. Set “Days Allowed for Back Dated Vouchers” > 0  

 c. Set “Cut-off date for Backdated vouchers”  > Blank  

 d. Set “Set Rules for Print Before Save”  > No  

 e. Set “Allow to Connect Company” > No  

 f. Set “Use Tally.NET Authentication”  > No  

 g. Set “Disallow the Following Facilities”  > List all report with full access Type  

 h. Set “Allow the following Facilities”  > List all report with display/print Type  
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6. Create User ID and allocate security level as under:  

Name of user  User ID  Security level  

Krishan  Krishan  Manager  

Pinki  Pinki  Manager  

Saleem  Saleem  Sales ex.  

Deepak  Deepak  Sales ex.  

Honey  Honey  Auditor  

A.K Bansal  A.K Bansal  Auditor  

 

CHAPTER3: E-FILING 

Exercise 3.1:  

Illustration 1: Booking of rental expenses on equipment’s, which attracts TDS refer Page 306 

Exercise 3.2:  

Illustration 2: Recording of purchase of software transaction which attracts TDS refer Page 309 

Exercise 3.3:  

Illustration: 3 Booking expenses on Commission Expenses refer Page 312 

Exercise 3.4:  

Illustration 4: Recording of TDS payment to government and printing of challan ITNS 281. refer Page 316 
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Exercise 3.5: TDS 1 

Type of Deductor: - Partnership Firm (Non-Government)  TAN of Head Office: N.A.   

 TAN: -  TRKD53565N  Ward: - Ward (1)  

Following are the details of payments made during 2010-11 

       
Name 

  
Deductee 

     
Reason for 

  
TDS Nature 

  
TDS 

  Total       Net  
 

 

Sr 
  

Date 
      

PAN 
        

Expendit 
  

TDS 
  

Paymen 
 

 

     

of Party 
  

Status 
     

payment 
  

of payment 
  

Rate 
       

 

                     
ure 

      
t 

 
 

                                   
 

       
S. 

       
For execution 

 Payment to               
 

               

contractor 
              

 

       

Gandhi 
 

Company- 
 

RFTCS7657 
 

of painting 
               

 

1 
 

01.04.14 
      

(other than 2% 75,000 
 

1,500 
 

73,500  

   
Controls 

 
Resident 

 
G 

 
contract for 

   
 

           
advertisement 

              
 

       
Ltd. 

       
office building 

               
 

              

) 
                

 

                                    
 

                
For execution 

 Payment to               
 

       

S. 
        

contractor 
              

 

        
Company- 

 
HTYCV545 

 
of painting 

               
 

2 
 

02.04.14 
  

Pawar 
    

(other than 2% 50,000 
 

1,000 
 

49,000  

    

Resident 
 

4D 
 

contract for 
   

 

       
Pvt. Ltd. 

    
advertisement 

              
 

              
office building 

               
 

                
) 

                
 

                                    
 

                
For execution 

 Payment to               
 

                 

contractor 
              

 

       
Man 

 
Individual- 

 
AGIPM0879 

 
of plumbing 

               
 

3 
 

02.04.14 
      

(other than 1% 25,000 
 

250 
 

24,750  

   

Mohan 
 

Resident 
 

N 
 

contract for 
   

 

           

advertisement 
              

 

                
office building 

               
 

                
) 

                
 

                                    
 

                Certification  
Fees for 

              
 

          

Partnershi 
 

AAEFP7381 
 

of Cash & 
        

10,00 
     

 

4 
 

01.05.14 
  

PWC 
     

professional 10% 1,00,000 
  

90,000  

    
p Firm 

 
C 

 
Bank 

    
0 

 
 

               
services 

             
 

                
Balance 

                   
 

                                    
 

          
Individual 

 
AGUPG398 

 Rent for                   
 

5 
 

02.05.14 
  

Nitin G. 
   

office 
   

Rent 
  

10% 40,000 
 

4,000 
 

36,000  

    
Resident 

 
9K 

        
 

            
premises 

                    
 

                                    
 

       C.C.  
Individual 

 
ARGPC443 

 Rent for  
Rent for office 

              
 

6 
 

02.05.14 
  

Enterpri 
   

office 
   

10% 25,000 
 

2,500 
 

22,500 
 

    
Resident 

 
4L 

    
premises 

    
 

       
ses 

   
premises 

                   
 

                                  
 

       
Pranav 

 
Individual 

 
POHPM231 

 Interest on  Interest other               
 

7 
 

01.06.14 
     

unsecured 
   

than   interest 10% 15,000 
 

1,500 
 

13,500  

   
M. 

 
Resident 

 
2B 

      
 

          
loan 

   
on securities 
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Exercise 3.6: TDS 2 

Following are the transactions entered into with Image India Inc. 

Name of Expenses: Advertisement Expenses Party Image India Inc. 

Deductee Status: Individual / HUF Resident PAN of Deductee: ABCDT1234J 

Nature of Payment: Payment to Contractors (Advertisement) 

 

Date 

  Voucher   Voucher   

Particulars 

  

Billing 

  

TDS 

  Net   

   

No. 

  

Type 

        

Payment 

  

                   

01-05-14 P01  Payment  Advance given Rs. 1,00,000    1,000 99,000  

02-05-14 J01  Journal  Bill received for services 2,00,000 1,000     

03-05-14 P02  Payment  

Amount demanded by Party Rs. 

3,00,000    2,010 2,97,990  

04-05-14 J02  Journal  Bill received for services 4,00,000 1,990     

05-05-14 P03  Payment  

Amount demanded by Party Rs. 

3,00,000    1,030 2,98,970  

06-05-14 J03  Journal  Bill received for services 1,00,000 -     

07-05-14 J04  Journal  Bill received for services 50,000 470     

08-05-14  P04  Payment  

Amount demanded by Party Rs. 

5,00,000    4,535 4,95,465  

09-05-14  J05  Journal  Bill received for services 6,00,000 1,465     

10-05-14  P05  Payment  Final payment    - 1,45,075  

          Total 13,50,000 13,500 13,36,500  

               

 

Exercise 3.7:  

Illustration 1: Recording Sales Transaction with TCS refer Page 326 

Exercise 3.8:  

Illustration 2: Accounting sale of TCS goods at lower rate refer Page 329 

Exercise 3.9:  

Illustration 3: Recording of TCS transaction at Nil Rate. refer Page 331 

Exercise 3.10:  

Illustration 4: Recording payment of TCS collected to the department. refer Page 332 
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Exercise 3.11: Payroll Exercise 

Create the following Employee Masters 

Employee 

Name Department 

Date of 

Joining 

Ajay Administration  1-4-2016  

Vijay Sales  1-5-2016  

Manish Purchase  1-5-2016  

Ashu Research and Development  1-6-2016  

Gagan Purchase  1-4-2016  

Murari Sales  1-6-2016  

Note: - Fill the General Info, Payment Detail and Statutory Detail of overall Employees . 

Create the following Units 

Name Type Symbol 

Hour Simple Hrs 

Minutes Simple Mins 

Hrs of 60 Mins Compound Hrs of 60 mins 

Create the following Attendance Types 

Name Under 

Attendance/ Production 

Type Period Type 

Present Primary Attendance/ Leave with pay Days 

Absent Primary Leave without pay Days 

Overtime Primary Production 

Hrs of 60 

Mins 
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Create the following Pay Heads:- 

          
Affect 

  
Name to 

        Calculation  
 

 

Pay Head 
  

Pay Head 
         

Use for 
  

Calculation 
  

Period/ 
 

 

     
Under 

  
Net 

  
Appear in Pay 

       
 

 

Name 
  

Type 
        

Gratuity 
  

Type 
  

Production 
 

 

        
Salary 

  
Slip 

       
 

                    
Type 

 
 

                       
 

Basic Pay 
 Earnings for  Indirect  

Yes 
 

Basic 
 
Yes 

 On  
Months  

 

Employees 
 

Expenses 
    

Attendance 
 

 

                  
 

DA 
 Earnings for  Indirect  

Yes 
 

DA 
 
No 

 As Computed  Current earning 
 

 

Employees 
 

Expenses 
    

Value 
 

Total 
 

                
 

House Rent  Earnings for  Indirect  
Yes 

 
HRA 

 
No 

 As Computed  on Specified 
 

Allowance 
 

Employees 
 

Expenses 
    

Value 
 

formula  

             
 

Conveyance 
 Earnings for  Indirect  

Yes 
 

Conveyance 
 
No 

 
Flat Rate 

 
Months  

 

Employees 
 

Expenses 
     

 

                    
 

Overtime Pay 
 Earnings for  Indirect  

Yes 
 

Overtime 
 
No 

 On  
Overtime  

 

Employees 
 

Expenses 
    

Production 
 

 

                  
 

Variable Pay 
 Earnings for  Indirect  

Yes 
 

Variable Pay 
 
No 

 As User 
--------- 

 
 

 

Employees 
 

Expenses 
    

Defined Value 
 

 

                  
 

Employees PF  Employees  
Current 

          
As Computed 

 
on Specified  

Contribution 
 

Statutory 
  

Yes 
 

EPF @ 12% ---------- 
   

 

  
Liabilities 

    
Value 

 
formula  

@12% 
  

Deductions 
            

 

                    
 

Hint:- 

• Basic pay is Based on Present 

• DA is under Normal Rounding Method & Based on Current earning Total & the percentage of DA is 10%  

• HRD is under Normal Rounding Method & based on Specified formula & i.e.:-Basic + DA and percentage 

is 8% 

• PF should be as per the below picture. 
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Create the following Salary Detail:- 

Employee Name Pay Head Rate Effective Date 

Ajay Basic 1000 1-4-2016 

Vijay Basic 2000 1-5-2016 

Manish Basic 1500 1-5-2016 

Ashu Basic 3000 1-6-2016 

Gagan Basic 1200 1-4-2016 

Murari Basic 1000 1-6-2016 

Note: - Also enter the Details of Pay Head in a Salary Detail of all employees.  

After completing the Payroll Info now we are doing the entries in Payroll Master which are given below:- 

Attendance/ Production 

Types 

Vijay  Ajay Ashu Murari 

Present Days  26 22 15 17 

Attendance/ Production 

Types 

Vijay Ajay Ashu Murari 

Overtime hours 

900 Min (15hr x 

60min) 

 720 Min (12hr x 

60min) 

 

Note:- 

• Overtime Rate 100 Rs/- per Hour. 

• Above attendance/ production table is only for first month, rest month and employees are present for 30 

days. 

• Enter the entries in Payroll Master of overall employees through Auto Fill.  

• Find the output till 31 July 2016 of all the employees. 

Output: 

  Basic Pay:-454000 DA:45400 HRA:39952 Overtime:2700 PF:4800 
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